1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Jan 21, 2010 #1781 of 10411
    txporter

    txporter One sec, almost done

    666
    0
    Sep 17, 2006
    Austin, TX
    Nice work!
     
  2. Jan 21, 2010 #1782 of 10411
    janry

    janry New Member

    17,688
    0
    Jan 2, 2003
    Nashville, TN
    This is probably one of those questions that'll make me slap my forehead when it is answered, but I have tried to find how to set some of the Global settings in the program and cannot find it. I see the setting for how often to check the TiVo for new programs but cannot for the life of me find the Global Setting to only process KUID recordings...please, please give me a clue.
     
  3. Jan 21, 2010 #1783 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    Auto Transfers->Configure... Under GLOBAL SETTINGS there is a Only process KUID recordings setting.

    Also as documented in auto_transfer Wiki you can set things up to auto transfer everything and then enabled this KUID only filter. i.e. The relevant portions of the Wiki page:
    If you still want that setup but want to run everything from GUI you can still setup Auto Transfers as described above and then execute Auto Transfers->Run in GUI
     
  4. Jan 21, 2010 #1784 of 10411
    janry

    janry New Member

    17,688
    0
    Jan 2, 2003
    Nashville, TN
    I think you've nailed exactly what I would like to do: transfer everything that is KUID. My issue is I can't find how to change the KUID Global setting. It does not appear in the configuation screen for Auto Transfers (at least, I can't find it).
     
  5. Jan 21, 2010 #1785 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    You are probably on an older version. The KUID filter was added in version 7e and current version is 7g.
     
  6. Jan 21, 2010 #1786 of 10411
    janry

    janry New Member

    17,688
    0
    Jan 2, 2003
    Nashville, TN
    I'll have to check when I get home, but I think it is 7e that I'm using. I know I upgraded once after I installed and 7e's release date seems appropriate for when I do that. Regardless, I need upgrade to the latest and maybe I'll see it then. Thanks for the help.
     
  7. Jan 21, 2010 #1787 of 10411
    VideoGrabber

    VideoGrabber New Member

    114
    0
    Sep 11, 2003
    Occasionally, a kmttg download will fail, for no apparent reason. When it does, the file contains an error, like:

    <h2>Bad Request</h2>
    Unable to initialize videomgr pipeline: err 0x1d0012

    Retrying the offending file later, and things are usually fine. Any idea why this happens, and how to avoid it?

    - Tim
     
  8. Jan 22, 2010 #1788 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    I think sometimes when TiVo gets too loaded the web server fails. If you search this thread there have been a few posts about that same error, and also a few posts in TiVo forums of people getting that error when attempting to download:
    http://tivocommunity.com/tivo-vb/showthread.php?p=4602094#post4602094
    http://rcbullock.blogspot.com/2009_08_16_archive.html
    http://archive2.tivocommunity.com/tivo-vb/showthread.php?p=2530276&&#post2530276
    etc.

    If you start getting it too often probably a TiVo reboot is in order.
     
  9. Jan 22, 2010 #1789 of 10411
    Morocco Mole

    Morocco Mole Tivo Rodent

    54
    0
    Jul 11, 2002
    Redwood...
    Hello.

    Great program. I had it working for a while but it stopped tonight. The download will begin, not make any progress then stop

    I did a search but similar problems had "server busy", which I do not see in my log.

    Any suggestions would be appreciated. Thanks in advance.

    This is what I see in my log

    >> DOWNLOADING E:\KMTTG\Greys Anatomy - I Like You So Much Better When Youre Naked - I Like You So Much Better When Youre Naked.TiVo ...
    "C:\Program Files\KMTTG\curl\curl.exe" --retry 3 --anyauth --user tivo:MAK --insecure --cookie-jar C:\DOCUME~1\CHRIST~1\LOCALS~1\Temp\cookie8988072208479910099.tmp --url http://192.168.2.8:80/download/Grey's Anatomy.TiVo?Container=/NowPlaying&id=921282 --output "E:\KMTTG\Greys Anatomy - I Like You So Much Better When Youre Naked - I Like You So Much Better When Youre Naked.TiVo"
    E:\KMTTG\Greys Anatomy - I Like You So Much Better When Youre Naked - I Like You So Much Better When Youre Naked.TiVosize=0.00 MB elapsed=00:00:07 (0.00 Mbps)
    Download failed to file: E:\KMTTG\Greys Anatomy - I Like You So Much Better When Youre Naked - I Like You So Much Better When Youre Naked.TiVo
    Exit code: 0
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed

    0 31 0 31 0 0 283 0 --:--:-- --:--:-- --:--:-- 283
    0 31 0 31 0 0 283 0 --:--:-- --:--:-- --:--:-- 0
    0 51 0 51 0 0 217 0 --:--:-- --:--:-- --:--:-- 217
    Warning: Transient problem: HTTP error Will retry in 1 seconds. 3 retries
    Warning: left.
    Throwing away 51 bytes

    0 51 0 51 0 0 544 0 --:--:-- --:--:-- --:--:-- 544
    0 51 0 51 0 0 544 0 --:--:-- --:--:-- --:--:-- 0
    Warning: Transient problem: HTTP error Will retry in 2 seconds. 2 retries
    Warning: left.
    Throwing away 51 bytes

    0 51 0 51 0 0 466 0 --:--:-- --:--:-- --:--:-- 466
    0 51 0 51 0 0 466 0 --:--:-- --:--:-- --:--:-- 0
    Warning: Transient problem: HTTP error Will retry in 4 seconds. 1 retries
    Warning: left.
    Throwing away 51 bytes

    0 51 0 51 0 0 652 0 --:--:-- --:--:-- --:--:-- 652
    0 51 0 51 0 0 652 0 --:--:-- --:--:-- --:--:-- 0
     
  10. Jan 22, 2010 #1790 of 10411
    Morocco Mole

    Morocco Mole Tivo Rodent

    54
    0
    Jul 11, 2002
    Redwood...
    Rebooting the Tivos fixed it. I'm downloading again. :)
     
  11. Jan 22, 2010 #1791 of 10411
    VideoGrabber

    VideoGrabber New Member

    114
    0
    Sep 11, 2003
    Morroco Mole,

    I managed to get my TiVo into the same state with kmttg, and once there nothing short of a TiVo reboot would fix it. Neither kmttg, nor the DesktopLite, nor the Tivo Desktop would communicate with the TiVo any more.

    This happened when I started 4 jobs, then realized I already had two of them, but had moved them out of the Import folder already. So instead of doing the logical thing, which would have been to select them both and Cancel, I Cancelled the first, then the second started, then I Cancelled that in rapid succession. At that point I heard a bunch of beeps, I got the same Transient warnings as you did, and both of the 2 remaining jobs failed, as did every program I tried afterwards.

    I put that on my "don't do that" list. :) Though I don't really know if the rapid sequential cancellations really had anything to do with it. It WAS working just fine prior to that, though.

    - Tim
     
  12. Jan 23, 2010 #1792 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    I was planning on "upgrading" to newer ffmpeg for next release but I have discovered that the the "aac" codec in the newer ffmpeg builds is buggy/flawed. I noticed playing back encodings with aac on my portable player had a lot of pops and some screeches. Playing back on my PC I also noticed the same. If I switch back to older ffmpeg with "libfaac" codec and encode with same specs there are no such problems. So I conclude that "aac" has a flaw. I tried about 6 different builds from the latest to the earliest ones released with the newer aac codec and all suffered from same problem.

    The previous "libfaac" codec (which is what is used in current kmttg release) is much better but ffmpeg folks were forced to remove it since it does not meet GPL standards.

    So at this point I do not consider the newer ffmpeg to be an "upgrade" given this problem and so at this point I don't think it's a good idea to have a release with it.
     
  13. Jan 23, 2010 #1793 of 10411
    neo_sapien

    neo_sapien New Member

    31
    0
    Dec 14, 2009
    I'm using kmttg to transfer Caprica from my TiVo HD to my PC, and after adding in t2extract, it seems that my closed captions come out disconnected and fragmented, as though bits and pieces of them have been chopped out. Does the process of cutting out ads prior to extracting closed captions somehow ruin the closed captions?
     
  14. Jan 23, 2010 #1794 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    I don't think so. It's likely if you run t2extract on original .TiVo file it will have same problem. Unfortunately sometimes TiVo clobbers captions during transfer and/or the recording has issues that t2extract can't read from properly. See this thread for example. You might want to try ccextractor on the .mpg file but I haven't had much luck with ccextractor myself.
     
  15. Jan 23, 2010 #1795 of 10411
    neo_sapien

    neo_sapien New Member

    31
    0
    Dec 14, 2009
    Genius! CCExtractor produces a perfect closed caption file, be it in the cut or uncut mpg file. t2extract was producing garbled closed captions in the cut and uncut mpg files.
     
  16. Jan 24, 2010 #1796 of 10411
    jmemmott

    jmemmott New Member

    393
    0
    Jul 12, 2003
    Santa Cruz, CA
    I am glad you were able to get your captions using ccextractor but I would also like to see if I can resolve the issue with t2extract as well.

    To ensure we are on the same page, it might be best to double check the version. The latest version is 3.0.0069 and it contains fixes for a similar problem which is why I think we should check. Running t2extract without any arguments will display the help information which includes the version.

    I also intend to record Caprica to see if I have similar problems but have discovered that it is on three different networks : USA, BRAVO and SYFY. The network feeds are not always identical so I need more information about the network and format you recorded.

    Finally if you have access to VideoReDo or a similar editor, it would simplify everything to get a 1-2 minute clip from you that has the problem. If you do not have a place for uploading, PM me and I can give you a place and instructions.

    Anyway, if you have the time and inclination to help, it would be appreciated.
     
  17. Jan 24, 2010 #1797 of 10411
    neo_sapien

    neo_sapien New Member

    31
    0
    Dec 14, 2009
    The t2extract version is 3.2.0069

    The episode of Caprica I recorded aired on Syfy at 9pm EST Friday 1/22, in 1080i.

    Sample @ Megaupload (140MB)

    Here's the closed captions produced by CCextractor on that sample mpg:



    and the closed captions produced by t2extract:



     
  18. Jan 25, 2010 #1798 of 10411
    sender_name

    sender_name I remember XM 202!

    227
    0
    Feb 11, 2005
    Northboro Ma
    Using kmtttg i Just had a sort of weird buggy prob...I was encoding something to .mkv from a mpg2 file and transferring a show from my tivo to the same pc that was doing the encoding (it's fine on power, quad core with 4gb of ram) and my tivo started pixelating on the show I was watching and the transferred file was full of hiccups...I tried tuning null channels and whatnot still kept getting the video/audio skips....So i restarted the tivo and now i am doing the same thing and the errors went away...just weird...the tivo also hung on the acquiring channel info screen for like 5 min on the restart...it had me scared
     
  19. Jan 25, 2010 #1799 of 10411
    stujac

    stujac Member

    2,343
    0
    Jan 26, 2002
    I had 2 straight failures last night trying to transfer Conan's last show to my Ipod Touch.
    The download went fine (using version c); no errors. The decrypt and encrypt went fine; no error messages. I used both ipod high and low res. Added the file (in each case) to itunes just fine. It plays on the computer with or without using itunes. It downloaded to my touch just fine. It won't play at all on my touch. Older shows that went through the same process play fine on the touch.After the high res didn't work I deleted everything but the downloaded file from Tivo and re-did it in low res and it brings a pop up that says file can't be played. Any ideas?

    Thanks,

    Stu
     
  20. Jan 25, 2010 #1800 of 10411
    Stormspace

    Stormspace Electrocuted by TiVo

    5,171
    0
    Apr 13, 2004
    Hartsville, SC
    Does the latest version allow you to automatically schedule downloads from the TiVo's? I know that version I'm using is supposed to do it, but it doesn't.
     

Share This Page