1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Oct 12, 2009 #1381 of 10413
    h00ligan

    h00ligan New Member

    85
    0
    Nov 29, 2007
    Is there currently a way to only transfer and decode certain information. I have, on occasion, to extract part of a newscast... it's a bummer right now to transfer 30-60 mins of HD video just to edit out 3 mins from the first 6... maybe the functionality is there, but i don't see it.. Cheers for the hard work!
     
  2. Oct 12, 2009 #1382 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    There is no way to intentionally download just part of a program AFAIK. However you can employ a couple of tricks:
    * If it's the start of a program that you want, wait until percent download is enough to cover what you want and then cancel download job in kmttg. The other jobs after download will run and complete. The decode job will spit out an error but resulting mpeg is still fine.
    * If you have have 2 Series 3 units then you can use MRV to partially transfer the section of video you want. Watch to starting point on original unit, then MRV transfer from resume point and cancel transfer at end point such that you get the clip you want on MRV destination TiVo and then transfer that clip via kmttg.
     
  3. Oct 12, 2009 #1383 of 10413
    cburbs

    cburbs New Member

    158
    0
    Jan 29, 2009
    OK I updated to kmttg v0p7b and now the only thing not working is the push. I get custom job completed: 00:00:00 exit code: 0....but nothing pushes.

    If I go to my video share and manually push that file it works.
     
  4. Oct 12, 2009 #1384 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    You have to look at pyTivo console to see why push is not working. Exit code of 0 means executing the push.py python script is succeeding, but something on the pyTivo side is going wrong. I would guess it's likely a video share related issue. You have to have a video share setup in pyTivo matching where kmttg deposits the video file and also matching the name in the push.py script as detailed in the Wiki page.
     
  5. Oct 12, 2009 #1385 of 10413
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    Should the command generated by kmttg be able to execute from a Windows Command Prompt? I'm having the same trouble with push, checked and rechecked pyTivo's settings. I resolved one issue by replacing [mpegfile_cut] with just [mpegfile] in kmttg. Although thinking [mpegfile_cut] would be the appropriate choice since the set just prior to custom is Ad Cut, this argument appended an additional "_cut" to the filename. I'm using the name kmttg in pyTivo, which does point to the same directory specified in kmttg's .mpeg Cut Dir.
     
  6. Oct 14, 2009 #1386 of 10413
    Dan S

    Dan S New Member

    29
    0
    Aug 8, 2007
    Hi there everyone, I am hoping someone might be able to shed some light on an issue I am having with kttmg. Thanks to the author, by the way, for such a wonderful program!

    I have a large archive of hi-def .tivo files that I have transferred to my vista machine using Tivo Desktop. They all play on the computer fine when I open the transferred .tivo file and it plays through Windows Media Player.

    Recently I bought a Western Digital "WDTV" to use sometimes in my condo building's theater room, this box is capable of playing 1080i mpeg files.

    I installed kttmg, installed it, and proceeded to use only the "decrypt" function to convert the .tivo file to an unprotected, standard .mpeg 2 file, with no extra encoding. The process seemed to work and went very quickly, just 2-3 minutes.

    However, while the resulting .mpg video file looks identical to the original file (as it should), the new file has sound issues not present in the original .tivo file, specifically:

    -When I play back the new .mpg file in Windows Media Player or VLC, there are are frequent sound dropouts

    -When I try to play the .mpeg file on the WDTV box, the soundtrack is completely silent (the video looks fine)

    Anyone have any idea what could be causing this? I tried converting two different movies and the problem occurred on both.

    Thanks!
     
  7. Oct 14, 2009 #1387 of 10413
    sirfergy

    sirfergy New Member

    288
    0
    May 18, 2002
    Is there a way to not auto-transfer a series if the episode title is empty? I currently have my filename format as this:
    [mainTitle][/]["" EpisodeNumber " - "][episodeTitle]

    So show's that don't have a title end up just being ".TiVo" in the folder of the series.
     
  8. Oct 14, 2009 #1388 of 10413
    cburbs

    cburbs New Member

    158
    0
    Jan 29, 2009
    I had to put that code back in the push.py file that you had me change --

    file = urllib2.quote(os.path.basename(sys.argv[1]))
     
  9. Oct 14, 2009 #1389 of 10413
    sirfergy

    sirfergy New Member

    288
    0
    May 18, 2002
    Is there a way to add a new keyword for file naming? I'd love to be able to add something like "HD" to prevent the non-HD version of a show overwriting the HD version for autotransfers.
     
  10. Oct 14, 2009 #1390 of 10413
    cburbs

    cburbs New Member

    158
    0
    Jan 29, 2009
    OK I can't seem to get this the following to work.

    I would like to take my two CSI shows which show up on my tivo in the same folder as
    CSI\CSI: Crime Investigation - Ghost Town
    CSI\CIS: Crime-Investigation - Working Stiffs

    Cut the commercials and send them back and be under one folder. They seem to show up as seperate items.
     
  11. Oct 14, 2009 #1391 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    You can always use the already available [channel] or [channelNum] keywords to prevent something like that.
     
  12. Oct 14, 2009 #1392 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Ask what the grouping rules are in the pyTivo forum. wmcbrine can tell you exactly how the grouping works for pushes. I think if both shows have same seriesId in metadata files they should end up grouped in 1 folder following a pyTivo push.
    NOTE: Currently kmttg metadata generator has a bug where a show without episode number ends up as episodeNumber without a value in metadata file which screws up pyTivo metadata parser. So you should check your metadata files and remove such lines if you see them. (That bug is fixed in the now soon to be released next version of kmttg).
     
  13. Oct 14, 2009 #1393 of 10413
    sirfergy

    sirfergy New Member

    288
    0
    May 18, 2002
    That is what I did, but I'd rather just get HD in the title. :)
     
  14. Oct 14, 2009 #1394 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    For next release kmttg will now check to see if the base file name built from File Naming template is empty and will not proceed to process such cases (and spits out an error indicating why).
     
  15. Oct 14, 2009 #1395 of 10413
    DougSW

    DougSW New Member

    2
    0
    Oct 12, 2009
    Dan S,

    I'm having the same issue with my WDTV, I haven't tried anything else for playback yet. I can decode SD programs fine but the HD programs off my TivoHD have no audio. I wonder if there is some setting we need to change in kmttg. I just installed it and clicked the decode box.

    Nonetheless, thank you for all your work on kmttg moyekj.

    Doug
     
  16. Oct 14, 2009 #1396 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    The decoding step which uses tivodecode does nothing to affect quality/encoding of the recording and there are no settings to tweak. It simply strips out metadata and encryption (which is why it runs so fast). You can verify that by using pyTivo (or TiVo Desktop) to transfer the decrypted mpeg back to your TiVo - it should look and sound same as original recording when playing back on your TiVo. If that's not the case then that would certainly point to something wrong with decryption process which would be news to me as I have never experienced that myself.

    When you play back mpeg on your computer check Job Monitor to see if you are stressing the system in any way.

    Don't know anything about WDTV so can't help you there...
     
  17. Oct 15, 2009 #1397 of 10413
    cburbs

    cburbs New Member

    158
    0
    Jan 29, 2009
    Ok so now I have another question -

    I tried doing adcuts on 3 different shows -

    CSI: NY - created a 2 minute clip of the show w/no ads
    CSI - only creates a 50mg file
    Til Death - 1/2 hour show and worked fine with no ads.

    I tried the CSI 3 times and each time it does the same thing.

    I am using comskip and comcut.

    >> Running comcut on F:\kmmtg\Tivo\CSI NY - LAT 40 Degrees 47 Minutes N_Long 73 Degrees 58 Minutes W Oct 07.mpg ...
    C:\tivo\mencoder\mencoder.exe "F:\kmmtg\Tivo\CSI NY - LAT 40 Degrees 47 Minutes N_Long 73 Degrees 58 Minutes W Oct 07.mpg" -edl "F:\kmmtg\Tivo\CSI NY - LAT 40 Degrees 47 Minutes N_Long 73 Degrees 58 Minutes W Oct 07.edl" -oac copy -ovc copy -of mpeg -vf harddup -o "F:\kmmtg\Tivo AdCut\CSI NY - LAT 40 Degrees 47 Minutes N_Long 73 Degrees 58 Minutes W Oct 07_cut.mpg"
    comcut failed (exit code: -1073741819 ) - check command: C:\tivo\mencoder\mencoder.exe "F:\kmmtg\Tivo\CSI NY - LAT 40 Degrees 47 Minutes N_Long 73 Degrees 58 Minutes W Oct 07.mpg" -edl "F:\kmmtg\Tivo\CSI NY - LAT 40 Degrees 47 Minutes N_Long 73 Degrees 58 Minutes W Oct 07.edl" -oac copy -ovc copy -of mpeg -vf harddup -o "F:\kmmtg\Tivo AdCut\CSI NY - LAT 40 Degrees 47 Minutes N_Long 73 Degrees 58 Minutes W Oct 07_cut.mpg"


    ERROR: scr 390.416, dts 0.000, pts 380.748

    continious Error:

    Skipping frame!

    Skipping frame!

    Skipping frame!

    Skipping frame!

    Skipping frame!

    Skipping frame!
    Couldn't realloc frame buffer(idx), abort


    PARSE_MPEG12: add_frames(81983) failed, exit
     
  18. Oct 15, 2009 #1398 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    New version just released with a lot of changes/enhancements and some fixes. Note that the magnitude of changes probably merits a major version bump but I'm releasing as v0p7c anyway.

    See release_notes wiki entry for all the details.

    Thanks for those that gave some great suggestions and helped out a lot with testing of these new features and enhancements. Hopefully nothing major is broken with all these changes...
     
  19. Oct 15, 2009 #1399 of 10413
    spocko

    spocko TiVo HD

    433
    1
    Feb 4, 2009
    On your PC, the difference is probably due to different codecs being used for .MPG files than for .TIVO files. In your case, it appears that the audio codec being used for .TIVO files is doing a better job than the one being used for .MPG files.

    To manage the codecs used for .TIVO files, see here:
    http://www.tivocommunity.com/tivo-vb/showthread.php?t=395047

    Managing the codecs used for MPG files in WMP is more complicated. You can use Graphedit to see what codecs will be used.
    Read about it here:
    http://msdn.microsoft.com/en-us/library/dd390950(VS.85).aspx
    Google it to find a download.
    You can use Directshow Filter Manager to manage which codecs get used.
    http://www.softella.com/dsfm/index.en.htm

    VLC supplies it's own codecs, so there there is nothing to configure with it.
     
  20. Oct 15, 2009 #1400 of 10413
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    Thanks!
     

Share This Page