1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Sep 11, 2009 #1281 of 10413
    mchief

    mchief Morey

    334
    1
    Sep 10, 2005
    Alexandria, VA
    I have not been able to get kmttg.jar (6k) to run on my VistaHP SP2. Java 6.16 is installed, but when I double click the .jar file I get a flash of a command window and nothing.

    I am running a dual boot with Windows7 RC with kmttg installed and that runs fine.

    Not sure what is going on. Looking for a .log file that might help explain the error.
     
  2. Sep 11, 2009 #1282 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Bring up a "cmd" window and execute the following:
    java -jar "<path>\kmttg.jar"
    (replace <path> with the full path to your kmttg installation directory)
    That way you can see any error messages that result.
     
  3. Sep 11, 2009 #1283 of 10413
    mchief

    mchief Morey

    334
    1
    Sep 10, 2005
    Alexandria, VA
    Had problem executing from the directory where kmttg was installed. Moved it to C:\temp and a firewall block came up, unblocked and all is well. Thanks.

    Edit: Wrong, only runs from the command prompt. When I execute the .jar file from C:\temp I am back to the flash command window and nothing.
     
  4. Sep 11, 2009 #1284 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Most likely your windows installation is missing or has wrong file association for .jar files. It should be setup to execute javaw.exe when double-clicking on .jar files. You should either try removing and re-installing Java Runtime Environment (JRE) so that it can fix the association or fix it yourself.
    As an example on a Windows XP installation my association has .jar files set to run the following:
    "C:\Program Files\Java\jre6\bin\javaw.exe" -jar "&#37;1" %*
     
  5. Sep 11, 2009 #1285 of 10413
    mchief

    mchief Morey

    334
    1
    Sep 10, 2005
    Alexandria, VA
    I had an two directories under the jre6 directory. Apparently .jar was trying to execute from the wrong older version directory. Once I deleted the older directory, working fine. Thanks again.
     
  6. Sep 11, 2009 #1286 of 10413
    robbroy

    robbroy New Member

    26
    0
    Feb 21, 2002
    Today when I ran kmttg, nothing happened. When I opened auto.log, here is what I found.

    "ERROR: No auto keywords setup" repeats a few hundred times and stops.

    I am not sure what happened. I tried setting up the program in another directory and got no response.

    And tivo desktop works fine.

    Please help.
     
  7. Sep 11, 2009 #1287 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Are you out of disk space by any chance? Sounds like one or more kmttg files with saved settings may have got corrupted. General/main settings are in config.ini which lives in same directory as kmttg.jar. The auto downloads config is saved to auto.ini file also in that same directory. Finally there is also a .kmttg_settings file which saves GUI related settings which goes under your Users directory (search for it in windows to find it since it varies depending on what windows installation you are using). If you rename all 3 of those files then that's like starting kmttg from scratch and you should have no problems doing that.
     
  8. Sep 11, 2009 #1288 of 10413
    robbroy

    robbroy New Member

    26
    0
    Feb 21, 2002
    Thanks! No space problem. When I renamed the .kmttg_settings file the program launched without a hitch.
     
  9. Sep 11, 2009 #1289 of 10413
    ellinj

    ellinj Seems Very Friendly TCF Club

    12,361
    8
    Feb 26, 2002
    RI
    not working &#37;100, I transfered some programs overnight and the tags came out messed up, will need to look into it further.
     

    Attached Files:

  10. Sep 12, 2009 #1290 of 10413
    jsjames

    jsjames Member

    47
    0
    Sep 25, 2007
    Chicago Area
    Great tool,

    But I have not seen a commercial cutting software that matches ShowAnalyzer, have you thought of having a way to utilize it? It works a lot better than VR and is 100&#37; accurate so far. Although It creates a VideoReDo file.

    Or maybe I can use it and provide a link to the program to cut commercials?
     
  11. Sep 12, 2009 #1291 of 10413
    emor20

    emor20 New Member

    1
    0
    Sep 10, 2009
    Clearwater, FL
    Non-technical person here who loves this application to download Tivo files to my IPod Touch. Have one Tivo account for two Tivos, one in my home, one in my daughters home. Same MAK. Works fine in my house (XP). Kmttg downloaded fine on daughter's laptop (Vista), but doesn't recognize her Tivo. Entered manually, still won't find playlist. Tivo support says that having the same MAK shouldn't cause the problem. Any ideas what to try next?
     
  12. Sep 12, 2009 #1292 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    You need to establish at very basic level if you have proper network connectivity to the Tivo. Try the following in a browser:
    http://<tivoip>
    (Obviously replace <tivoip> with the proper Tivo IP). This should give you a Congratulations screen.

    To get playlist from Tivo kmttg does the following, so if above works you can also check if this works:
    https://<tivoip>/TiVoConnect?Command=QueryContainer&Container=/NowPlaying&Recurse=Yes&AnchorOffset=0
    login=tivo
    password=MAK

    If above do work then it's likely a firewall issue preventing curl and/or Java from using networking functions on your PC. To determine if that's the case you can temporarily turn off firewall and then see if kmttg works. If it then works then you just have to add curl and/or java to firewall exceptions (which normally the PC prompts you the first time they are run).
     
  13. Sep 12, 2009 #1293 of 10413
    ellinj

    ellinj Seems Very Friendly TCF Club

    12,361
    8
    Feb 26, 2002
    RI
    How does kmttg decide to run atomic parsely? I am running into an issue where it doesn't always run despite using the same encoding profile. It seems if I queue up one program it will encode and then run AP, but If I encode several it does not.
     
  14. Sep 13, 2009 #1294 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    The decision to run AP is made right when encoding finishes successfully and will only run if exact same file name exists but ending in .txt exists (the pyTivo metadata file). It reads that .txt file to get information to pass on to AP.
    Also, it will only process .mp4 or .m4v files.
    i.e. as an example if you have sampleFile.mp4 & accompanying sampleFile.mp4.txt pyTivo metadata file then the job will run.

    The relevant section of the code is here lines 227-239.
     
  15. Sep 13, 2009 #1295 of 10413
    ellinj

    ellinj Seems Very Friendly TCF Club

    12,361
    8
    Feb 26, 2002
    RI
    It seems that the AP job is put into the queue, so even though the encoding is done I can't take the m4v and copy it to iTunes. Since the job isn't added to the queue list there is no indication if it is safe to copy the file without scrolling the output log.

    Also, I was confused by my test show as it didn't even have the episode ID in the metadata (oops). No wonder when I was trying to encode short clips for testing everything seemed to be working, but when I went to encode this particular hour long show I wasn't getting episode id.

    I am trying another test now, but I think it will be good, and if you want you can incorporate the code I posted above.
     
  16. Sep 13, 2009 #1296 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Probably easiest thing to do is use "custom" job to copy/move the file to iTunes to automate the whole process. The custom job is always last to run and hence will run after the AP job when it is safe to copy/move the file.
     
  17. Sep 13, 2009 #1297 of 10413
    ellinj

    ellinj Seems Very Friendly TCF Club

    12,361
    8
    Feb 26, 2002
    RI
    I am fooling around with seeing if I can create a custom job that will automatically import into iTunes. its kind of frustrating because the transcode job takes so long that you may need to wait for a second transcode to finish before AP and the custom job complete.
     
  18. Sep 13, 2009 #1298 of 10413
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    Are you doing this on a Mac, or on a PeeeCeee?
     
  19. Sep 13, 2009 #1299 of 10413
    ellinj

    ellinj Seems Very Friendly TCF Club

    12,361
    8
    Feb 26, 2002
    RI
    Will the existing Atomic job run after the custom job or before?
     
  20. Sep 13, 2009 #1300 of 10413
    ellinj

    ellinj Seems Very Friendly TCF Club

    12,361
    8
    Feb 26, 2002
    RI
    pc, windows 7 to be exact.
     

Share This Page