1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Jul 30, 2009 #1161 of 10413
    moyekj

    moyekj Well-Known Member

    11,143
    31
    Jan 23, 2006
    Mission...
    I don't see any temp files being created using ff_tivo_hd profile (or any of the profiles for that matter). So not sure what your issue could be...
     
  2. Jul 31, 2009 #1162 of 10413
    innocentfreak

    innocentfreak Active Member

    8,950
    3
    Aug 25, 2001
    Florida
    I don't know if this would be possible to do, but I noticed tonight I have a couple shows I record on both Tivo HDs. I selected Run in GUI and noticed that it queued all files from one Tivo instead of taking advantage of the second Tivo. I am guessing this is because it queues shows one Tivo at a time and maybe adds the shows to the history when it is queued versus completing the transfer.

    I may be the only one who sets duplicate recordings but I didn't know if there was a way to add an option that if the first Tivo is busy transferring that the program would check the second Tivo for a possible transfer even if it is already queued from the another Tivo. Well that or the option to not queue files and only transfer the oldest file first on each check assuming it isn't in the history since you can set how often KMTTG checks the Tivos.
     
  3. Aug 1, 2009 #1163 of 10413
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    Hmmm....
    With "Auto Transfers", I've noticed that it pulls from both TiVo's simultaneously. (1 show per TiVo at a time) I would wonder what version of KMTTG you are using, because this was even improved with one of the recent releases.

    Have you tried re-starting your TiVos, and re-starting your computer that is running kmttg? Sometimes I find that I need to do this when I have mysterious problems like you're seeing.
     
  4. Aug 1, 2009 #1164 of 10413
    innocentfreak

    innocentfreak Active Member

    8,950
    3
    Aug 25, 2001
    Florida
    I am using the latest version and it usually pulls one show per Tivo. I think because it is the same show it is automatically kicking one out since it is a duplicate.

    For example, I have Mental and Eureka which recorded tonight. I have both episodes on both Tivos. When I run KMTTG, it pulls the Now Playing List and queues both shows in the bedroom but kicks out the Living Room. I am guessing it is because both shows are either now in the history or already in the GUI list. As a result it is only pulling one show at a time instead of pulling Mental from the Bedroom Tivo and Eureka from the Living Room Tivo.

    When the shows are different, I don't have a problem except for the occasional errors on exit from decode.
     
  5. Aug 1, 2009 #1165 of 10413
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    If BOTH shows are on BOTH TiVo's, it should pull one from each. This was a bug in one of the beta's, but was fixed in the release. I would suggest taking those two shows out of the history, and then re-start kmttg and use Auto Transfers.
     
  6. Aug 2, 2009 #1166 of 10413
    innocentfreak

    innocentfreak Active Member

    8,950
    3
    Aug 25, 2001
    Florida
    Thanks I will try that.

    Also just in case no one else has reported it. I got this error earlier. The top show looked like it was selected but it wasn't so when I tried to add selected shows this happened. I don't know if this is helpful at all.

    No rows selected
    No shows currently selected for processing
    java.lang.ArrayIndexOutOfBoundsException: 26
    at org.jdesktop.swingx.decorator.ShuttleSorter.mapTowardModel(Unknown Source)
    at org.jdesktop.swingx.decorator.Filter.convertRowIndexToModel(Unknown Source)
    at org.jdesktop.swingx.decorator.FilterPipeline.convertRowIndexToModel(Unknown Source)
    at org.jdesktop.swingx.decorator.SelectionMapper.convertToModel(Unknown Source)
    at org.jdesktop.swingx.decorator.SelectionMapper.updateFromViewSelectionChanged(Unknown Source)
    at org.jdesktop.swingx.decorator.SelectionMapper$2.valueChanged(Unknown Source)
    at javax.swing.DefaultListSelectionModel.fireValueChanged(Unknown Source)
    at javax.swing.DefaultListSelectionModel.fireValueChanged(Unknown Source)
    at javax.swing.DefaultListSelectionModel.setValueIsAdjusting(Unknown Source)
    at javax.swing.plaf.basic.BasicTableUI$Handler.setValueIsAdjusting(Unknown Source)
    at javax.swing.plaf.basic.BasicTableUI$Handler.mouseReleased(Unknown Source)
    at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
    at java.awt.Component.processMouseEvent(Unknown Source)
    at javax.swing.JComponent.processMouseEvent(Unknown Source)
    at java.awt.Component.processEvent(Unknown Source)
    at java.awt.Container.processEvent(Unknown Source)
    at java.awt.Component.dispatchEventImpl(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Window.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)
     
  7. Aug 2, 2009 #1167 of 10413
    seplant

    seplant New Member

    8
    0
    Aug 2, 2009
    I'm new to Tivo, and I'm trying to get kmttg to run, but I keep getting an error that reads "Could not find the main class: C:\kmttg\kmttg.jar" when I try to run the jar file. My PC is running Vista, and I have installed the latest Java runtime. The only way I can get kmttg to run is if I go to a command prompt and type in "java -jar kmttg.jar", but that's a pain. Any suggestions?
     
  8. Aug 3, 2009 #1168 of 10413
    eman31

    eman31 New Member

    14
    0
    Apr 17, 2009
    I'm having some problems getting VideoReDo working properly lately. I have been using it for a while with no problems but the last week it has been giving me fits after the quick fix. It will run that fine and dump the .mpg file but when it goes to do the adscan it gives a message saying the .mpg file can't be found and then it leaves behind both the .qsfix file as well as a corrupted .mpg file. It's not running at all in autotransfer. I tried the settings on the wiki page and think I have those right and it will actually run fine if I do it manually from my files. Like I said, it worked fine before but haven't been running it for a few weeks and now it seems messed up.

    Here is the message that it gives me when trying to run the ad scan after quick fix.

    >> Running qsfix on I:\Videos\MPG\30 Rock - Hard Ball_Thu_Jul_23.mpg ...
    C:\Windows\system32\cscript.exe //nologo "C:\Program Files\VideoReDoTVSuite\vp.vbs" "I:\Videos\MPG\30 Rock - Hard Ball_Thu_Jul_23.mpg" "I:\Videos\MPG\30 Rock - Hard Ball_Thu_Jul_23.mpg.qsfix" /t1 /d /q /na
    qsfix job completed: 00:01:01
    ---DONE---
    (Renamed I:\Videos\MPG\30 Rock - Hard Ball_Thu_Jul_23.mpg.qsfix to I:\Videos\MPG\30 Rock - Hard Ball_Thu_Jul_23.mpg)
    mpeg file not found: I:\Videos\MPG\30 Rock - Hard Ball_Thu_Jul_23.mpg

    It's driving me crazy so any help would be appreciated.
     
  9. Aug 3, 2009 #1169 of 10413
    Airhead315

    Airhead315 New Member

    106
    0
    Jun 11, 2009
    I found a bug that doesnt affect most people.

    I setup an auto-transfer for all items on my TiVo. I had set this up previously and ran it without the encoding portion and it downloaded an entire tivo file at which point I stopped kmttg. I reconfigured the auto download and started it again.

    As it should the program noticed that the show had already been downloaded so it skipped the downloading step and moved onto decrypt and etc..At the same time the software started downloading a different show.

    However, When kmttg got through and finished encoding the first show it stopped the service. This ended the download in process(which had been running for quite some time). It almost appears as though the service is setup to auto-stop when it has finished encoding. But it should not do this when another program is currently downloading.

    I will add the contents of the auto.log below:
     
  10. Aug 3, 2009 #1170 of 10413
    moyekj

    moyekj Well-Known Member

    11,143
    31
    Jan 23, 2006
    Mission...
    The java installer should have setup a file association with .jar files to launch java when you double-click on a jar file, but looks like that didn't get done in your case. One easy way around the problem is simply create a shortcut that executes:
    javaw -jar C:\kmttg\kmttg.jar
     
  11. Aug 3, 2009 #1171 of 10413
    moyekj

    moyekj Well-Known Member

    11,143
    31
    Jan 23, 2006
    Mission...
    It appears that the rename of .mpg.qsfix to .mpg is failing. Note that the file rename is done with native Java code, so perhaps it's somehow related to Java not having proper permissions to access I: drive when in service mode. Is that a network mount or just an external drive? There's been discussions here before about network drives not being properly accessible in service mode. I assume it runs OK in GUI mode? Also if you have videos on internal drive (C: drive for example) then I assume auto mode works fine? i.e. Try to isolate if the problem is related to I: drive file permissions.
     
  12. Aug 3, 2009 #1172 of 10413
    zzgulu

    zzgulu New Member

    9
    0
    Mar 5, 2009
    I am new to kmttg. I installed it on Mac and it seems it does all the jobs without error. VRD QS fix is grayed out though. All other options like metadata, decrypt, ad detect, add cut and encode are checked. The output file_cut.mpg of a 2.5Gb original file is a 130 Mb file that is not playable in Mac and when I play it on PC it shows a slow motion of the first 15-20 seconds of the original file. Is there any setup I need to do to fix this?
    Tnx for the help
     
  13. Aug 3, 2009 #1173 of 10413
    moyekj

    moyekj Well-Known Member

    11,143
    31
    Jan 23, 2006
    Mission...
    There are only 2 ways that kmttg will exit itself out of auto transfers mode:
    1. An uncaught exception of some sort. This is usually accompanied with a stack trace of some sort which I don't see in your log so is probably not it.
    2. auto.log file does not exist or is deleted while kmttg is running. I don't remember why exactly that piece of code is in there and perhaps should not.
    Short of the above two I don't see another way of kmttg exiting short of windows stopping the service.
    By any chance were you editing/renaming auto.log file while service was running when it stopped?
     
  14. Aug 3, 2009 #1174 of 10413
    Airhead315

    Airhead315 New Member

    106
    0
    Jun 11, 2009
    No. I should mention that the first file was never able to be added to the history file.

    I downloaded a bunch of shows and forgot to check the metadata option in kmttg when I put them back on the tivo they could be viewed just fine but they all said they were copywrited and didnt have any info. For some reason this particular one didnt say it was copywrited but it didnt have any info either.

    The first thing I did when setting up the auto transfer was I selected almost everything in kmttg and selected "Add to Selected files to history" I checked the auto.history file and it worked for everything except that show. I had to let the auto kmttg do its thing on that file first...so I was anxiously awaiting that to finish when I ran across this problem.

    I have since deleted that item from the Tivo and currently kmttg is running great! I love this program. I just wanted to make sure you were aware that it stopped when it finished encoding. However, It could easily have been related to the fact that the file that finished encoding was from the program I mentioned above that I had uploaded using pyTivo without metadata...
     
  15. Aug 3, 2009 #1175 of 10413
    moyekj

    moyekj Well-Known Member

    11,143
    31
    Jan 23, 2006
    Mission...
    NOTE: If you use pyTivo "push" method (transfers initiated from PC) to put shows back on TiVo they will always come out copy protected. If you use the traditional "pull" method (transfers initiated from TiVo) then they do not come out copy protected.
     
  16. Aug 3, 2009 #1176 of 10413
    moyekj

    moyekj Well-Known Member

    11,143
    31
    Jan 23, 2006
    Mission...
    There is no VideoRedo for Mac platform (though I believe it is in the pipeline for a future release) so VRD QS fix option will not be available to you on Mac. Does the original .mpg file (before Ad Cut) play OK and is it full length? If so then either comskip is doing a very poor job of detecting commercials which you can check by looking at the .edl file or perhaps mencoder is not cutting the file properly to generate the _cut.mpg file.
    I'm not sure what programs there are for editing mpeg2 files manually on Mac platform to remove commercials, but one possibility if you don't have access to an editor is to manually/visually identify the cut points you want and generate your own .edl file and then start kmttg in FILES mode and the "Ad Cut" step.
     
  17. Aug 3, 2009 #1177 of 10413
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    On a Mac, use VLC (free) to play an MPG file. (These will not play in Quicktime)
     
  18. Aug 3, 2009 #1178 of 10413
    eman31

    eman31 New Member

    14
    0
    Apr 17, 2009
    The I: drive is an internal local drive. I did check the permissions and reset them so I have full access to it and tried rerunning it and also tried downloading a program and having it run on the C: drive but had the same issue. One thing I did notice when playing around is that the .mpg file that is being output after the qsfix is locked and I can't access it or delete it until I delete the .qsfix file. After that it ends up deleting itself. Maybe the fact that it is locked is causing it to show that it is not there? Still scratching my head.
     
  19. Aug 3, 2009 #1179 of 10413
    Icarus

    Icarus New Member

    360
    0
    Jun 15, 2002
    Upcountry...
    That is a good clue. When that happens next time, see if the video redo is still running. Sounds like it didn't finish and close the files, but kmttg thinks it did?

    If you are using the tv suite (it looks like you are from the log in your earlier post), you really don't need the suite. You only need video redo plus for this. You might want to try that instead of the suite.

    -David
     
  20. Aug 4, 2009 #1180 of 10413
    eman31

    eman31 New Member

    14
    0
    Apr 17, 2009
    Videoredo runs in the system tray when it does the work and the best I can tell it is shutting down in between but still getting the errors. If I pull up the task manager it doesn't show it as running at all. I tried running it without the qsfix and it works ok so maybe I will just remove that step until I can figure something else out.
     

Share This Page