1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Mar 5, 2017 #10621 of 10673
    cbpowers

    cbpowers New Member

    9
    0
    Feb 28, 2013
    Hi, Maybe this is just due to the shows I'm working with, but here we go:

    I'm running 2.2q and I'm trying to convert my TiVo library over to M4V and use the ad detect & ad cut options to reduce file size even more.

    For the most part, things are going OK, however, see some shows that just get hung up doing the comskip step, if I let it, it'll run for 10+ hours and never seem to finish or die.

    Is this normal? For example, a tv series like Wheeler Dealers, I may have 50 shows to convert. Maybe 10 will get hung up and the other 40 convert fine. For the ones that get hung up, I just need to re-convert without the ad detect & ad cut options and they'll convert fine.

    Ideas, suggestions? I'm guessing I've got a few hundred left to convert and hoping to have it be something I can kick off daily and it just "works".

    Thanks,
    Chris
     
  2. Mar 5, 2017 #10622 of 10673
    moyekj

    moyekj Well-Known Member

    11,302
    100
    Jan 23, 2006
    Mission...
    Free version of "comskip" included with kmttg cannot process H.264 videos, so if your provider has H.264 channels that is the problem. There's a pay version of comskip which supposedly works for H.264, but it just makes more sense not to encode those since they are already H.264 anyway. If you use VideoRedo then it works on either mpeg2 or H.264 so is another possibility.
     
  3. Mar 7, 2017 #10623 of 10673
    tluxon

    tluxon Member

    287
    2
    Feb 28, 2002
    Kirkland, WA
    I used to be able to delete shows via kmttg after transferring them. However, ever since I had to uncheck "Use RPC to get NPL when possible" under program options in order to load my Premiere's NPL, I have been unable to delete any shows from within kmttg. Is there a reason for that and what would I have to do to get it to work again while retaining the ability to load the NPL?
     
  4. Mar 7, 2017 #10624 of 10673
    reneg

    reneg Member

    720
    3
    Jun 19, 2002
    In the configuration Tivos tab, for your premiere, make sure that the "enable rpc style communications with this Tivo" is checked
     
  5. Mar 7, 2017 #10625 of 10673
    elprice7345

    elprice7345 Member TCF Club

    147
    0
    Sep 28, 2009
    Houston, TX
    @moyekj How easy would it be to add more Thumbs functionality to kmttg?

    I would like be to be able to right-click on a show in the NPL and have the ability to display, add, or change the thumbs rating that displays in the Thumbs tab.

    If that's too difficult, could you add the ability to add a show in the Thumbs tab?
     
  6. Mar 7, 2017 #10626 of 10673
    tluxon

    tluxon Member

    287
    2
    Feb 28, 2002
    Kirkland, WA
    What's interesting is that box seems to be checked for this TiVo automagically. When I uncheck it and restart kmttg, I go to that setting and see that the box is checked again. The same kind of behavior is true of my TiVoHDs, except it automagically shows an unchecked status when I look at it. Do you know if there is some other setting that controls whether that option is set automatically by detected attributes of each TiVo?
     
  7. Mar 7, 2017 #10627 of 10673
    lpwcomp

    lpwcomp Well-Known Member

    8,382
    56
    May 6, 2002
    John's...
    There's also a global "Enable RPC style delete task" setting.
     
  8. Mar 8, 2017 #10628 of 10673
    moyekj

    moyekj Well-Known Member

    11,302
    100
    Jan 23, 2006
    Mission...
    You need to get RPC for NPL working - works for my series 4 units.
     
  9. Mar 8, 2017 #10629 of 10673
    tluxon

    tluxon Member

    287
    2
    Feb 28, 2002
    Kirkland, WA
    Yeah - I mentioned that RPC seemed to break back in post #10604, but setlled on a workaround just to get the NPL to display. Any ideas of what kind of issues or conditions could break RPC for NPL?

    I'm not sure that there are any clues therein, but I've attached a file containing the error message returned when trying to receive the NPL using RPC. FWIW, this particular TiVo has a 2TB drive in it with 291 recordings on it - most of them sporting events.
     

    Attached Files:

    Last edited: Mar 8, 2017
  10. Mar 8, 2017 #10630 of 10673
    moyekj

    moyekj Well-Known Member

    11,302
    100
    Jan 23, 2006
    Mission...
    Looks like RPC connection to that TiVo is not working at all. My guess is Android and iOS apps also can't access that TiVo in current state. To try to fix it toggle network remote access off, then on again, then reboot the TiVo as described in this post:
    #10458
     
  11. Mar 8, 2017 #10631 of 10673
    tluxon

    tluxon Member

    287
    2
    Feb 28, 2002
    Kirkland, WA
    Thanks Kevin - That was it!
    Prior to this I had been on the phone with support because that TiVo was losing all its guide data almost weekly. It was suggested that I do one of those delete-everything-except-recorded-shows and start all over routines to clear out any residual information that may have been causing those guide data losses. Apparently, what I failed to realize is that the Network Remote Access had defaulted to OFF when I finally had a spare hour or so to do it. Turning it back on and restarting the TiVo restored RPC and kmttg is now using it for the NPL.
    Thanks!
     
  12. Mar 10, 2017 #10632 of 10673
    reneg

    reneg Member

    720
    3
    Jun 19, 2002
    In the last few days, I've noticed that my skip icons in the kmttg NPL list are showing up much later than I remember them showing up. When I've checked the Tivo, it has skip icons for shows and when I go back to kmttg and refresh the NPL, they don't come up. If I exit kmttg and restart it, and refresh the NPL, the skip icons appear. If I don't exit kmttg and wait until the next morning, the skip icons appear. I think this behavior may have started after my Tivo updated to 2.7.1, but I'm not sure.

    Just wondering if anyone else is seeing skip icons taking longer to show up in kmttg NPL than before or am I just being impatient?
     
  13. Mar 10, 2017 #10633 of 10673
    moyekj

    moyekj Well-Known Member

    11,302
    100
    Jan 23, 2006
    Mission...
    Haven't seen that. Fact you mentioned that you see SKIP icon on TiVo and refresh kmttg NPL and don't see it until you restart kmttg doesn't sound like normal behavior though...
     
  14. Mar 10, 2017 #10634 of 10673
    reneg

    reneg Member

    720
    3
    Jun 19, 2002
    I rebooted my Tivo and my PC and now it's working like I'd expect it too. Not sure what was going on, but it sure didn't look normal.
     
  15. Mar 12, 2017 #10635 of 10673
    dcbarry

    dcbarry Member

    83
    1
    May 21, 2002
    I'm embarrassed to ask, but I need help in pushing unprocessed TIVO files (with the metadata) back to my Roamio. (Or in having my device "see" kmttg as a device to "pull" from.). I'm trying to parse this information from the kmttg wiki, and searched for terms like push, pull, transfer, server, etc. to no avail. I'm feeling quite the fool. walked a bit through the thread, but 10,000+ posts!

    I used kmttg about 18 months ago, and I could swear there was a way to have it's offloaded files be seen as a network device by the tiro, so I could pull them back in. I'm using v2.2q, and trying to find that option in File / configure.

    If there's an existing doc I am stupidly missing, just point me to it please. And accept my apologies!
     
  16. Mar 12, 2017 #10636 of 10673
    moyekj

    moyekj Well-Known Member

    11,302
    100
    Jan 23, 2006
    Mission...
    TiVo broke push permanently, so push functionality has been removed from pyTivo and kmttg.
     
  17. Mar 12, 2017 #10637 of 10673
    dcbarry

    dcbarry Member

    83
    1
    May 21, 2002
    Darn! IS there currently a way to "pull" files back in?
     
    Last edited: Mar 12, 2017
  18. Mar 12, 2017 #10638 of 10673
    moyekj

    moyekj Well-Known Member

    11,302
    100
    Jan 23, 2006
    Mission...
    Sure, pull works just fine with pyTivo.
     
  19. Mar 12, 2017 #10639 of 10673
    webminster

    webminster Member TCF Club

    33
    1
    Dec 12, 2016
    Have a problem with kmttg, 2.2q and a previous version as well (I upgraded fresh to 2.2q to see if it would fix problem). Have a recording of the last-aired "Big Bang Theory", trying to download it from my Bolt+ running 20.7.1RC2. kmttg is set for using RPC, use transport stream, use tivolibre.

    Episode downloads, but video is "blank" (shows in Explorer as a gray thumbnail, shows as just a stream of green in videoredo). Tried a few other recordings, they seem to be OK, I haven't duplicated the same issue on the other recordings. The recording plays fine on the Bolt+.

    It shouldn't be copy protected, and kmttg doesn't indicate it is... the MAK looks OK in kmttg config as well, works for others.

    How can I figure out what's gone wrong with the transfer? I get no errors, just a non-working copy. Thanks in advance.
    -Alan

    EDIT: I found another - a "Hells Kitchen" episode, that does the same thing. Both are MPEG2 channels on Comcast (e.g., local CBS and FOX affiliates). Also, note running on Windows 7 Home x64, and current versions of Java (64 and 32 bit) installed.
     
    Last edited: Mar 12, 2017
  20. Mar 12, 2017 #10640 of 10673
    moyekj

    moyekj Well-Known Member

    11,302
    100
    Jan 23, 2006
    Mission...
    If they are mpeg2 then PS downloads for them may yield a better result. There's some apparent bugs on TiVo side associated with TS downloads.
     

Share This Page