1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Feb 17, 2017 #10601 of 10916
    moelleref

    moelleref New Member

    7
    0
    Jan 27, 2016
    Volume E: is actually a local Windows storage pool. However, I had a similar thought, and I had previously changed the output dir for encoded to my local C: ssd volume and I've seen the 1K issue there as well. It doesn't seem to matter what drive I use as the output directory.

    It seems to happen randomly. There were 3 files auto transferred last night and this was the only 1 had the 1K encoding issue.
     
  2. Feb 17, 2017 #10602 of 10916
    moyekj

    moyekj Well-Known Member

    11,375
    125
    Jan 23, 2006
    Mission...
    Perhaps Handbrake is not running reliably in service mode. If you are getting this consistenly with Handbrake perhaps try ffmpeg encoding profile instead of Handbrake to see if issue goes away.
     
  3. Feb 17, 2017 #10603 of 10916
    moelleref

    moelleref New Member

    7
    0
    Jan 27, 2016
    Thanks. I'm pretty sure I've tried using an ffmpeg profile as well, and seen it there also. However, I guess I need to do some formal testing to see if I can figure out a pattern or cause.
     
  4. Feb 18, 2017 #10604 of 10916
    tluxon

    tluxon Member

    311
    4
    Feb 28, 2002
    Kirkland, WA
    In the last few days, kmttg suddenly stopped displaying any data at all (other than its name and IP address) for my TiVo Premiere. Meanwhile, it's been displaying my two TiVoHDs as it always has. I've restarted my PC several times, rebooted the router a couple times, and Reset (deleting everything but My Shows and the One Pass Manager) and Restarted the TiVo Premiere a couple times. Kmttg (v2.2o) is still not showing anything but an error message when trying to connect to the Premiere. Meanwhile, I've done several downloads with TiVo Desktop with no issues, but this is not a preferred method.

    Any suggestions as I continue to try to troubleshoot this issue?
    Thanks!

    Update: Unchecking "Use RPC to get NPL when possible" in the Program Options tab of the Configuration menu solved that issue. Not sure why that stopped working.
     
    Last edited: Feb 18, 2017
  5. Feb 19, 2017 #10605 of 10916
    murgatroyd

    murgatroyd Don't stop believin'

    25,399
    1
    Jan 5, 2002
    Berkeley CA
    I've installed v2.2o and I'm seeing some problems with kttmg and my Roamio (my desktop is still on Win8.1). I'll list the two trivial problems first and the big one last.

    1) (this one has been going on for a while) Shows marked as KUID show with the yellow-bang icon in the NPL in kmttg

    2) using "About" gives me the error "Can't determine installed and/or available versions" (I see v2.o in the title of the Window itself)

    3) When I attempt to delete a show using kmttg, the entry in kmttg's NPL used to go away, too. Now the listing persists, and if I attempt to do anything like try the delete again, kmttg gives me the message "recordingId not available for this entry".

    I also have a phantom episode of a show on the Roamio where the Roamio gives me a message that there isn't a recording because the Roamio didn't have a video signal at the time. I can't delete this show with kmttg *or* on the Roamio itself. It's just lingering in MyShows like a bad disease.

    Suggestions?
     
  6. Feb 20, 2017 #10606 of 10916
    moyekj

    moyekj Well-Known Member

    11,375
    125
    Jan 23, 2006
    Mission...
    1. I get green for KUID (using RPC for NPL)
    2. sourceforge svn is completely borked at the moment which is why that's happening and why I haven't been able to do any source code update/check in for several days now. Presumably will work if/when sourceforge site management clowns every get their act together
    3. Don't see that. Post message window details when you try deleting a show.
     
  7. Feb 20, 2017 #10607 of 10916
    moyekj

    moyekj Well-Known Member

    11,375
    125
    Jan 23, 2006
    Mission...
    sourceforge finally fixed the web site issue this morning so Help menu items in kmttg are now working again.
     
  8. Feb 20, 2017 #10608 of 10916
    moyekj

    moyekj Well-Known Member

    11,375
    125
    Jan 23, 2006
    Mission...
  9. Feb 22, 2017 #10609 of 10916
    murgatroyd

    murgatroyd Don't stop believin'

    25,399
    1
    Jan 5, 2002
    Berkeley CA
    0. I installed v2.2p and while I was doing so, rebooted the Roamio
    1. The yellow-bang icons show up when using RPC for NPL is unchecked (I had it unchecked because I have both a Roamio and TiVoHD.) Checking the box to use RPC for NPL fixed everything. I'll play around with the config files. Thanks.
    2. I was able to download and install the new version so presumably stuff is fixed.
    3. Rebooting the Roamio seems to have gotten rid of my phantom show. It no longer appears on MyShows or in kmttg. If it happens again, I'll grab the message and post the messages I get.

    Thanks very much!
     
  10. Feb 23, 2017 #10610 of 10916
    ej42137

    ej42137 Well-Known Member

    2,322
    37
    Feb 15, 2014
    Los Angeles
    This morning I turned on my TV to discover one of my TiVos in a loop running "AutoSkip from SkipMode - ALL"; I had to cancel the scheduled task to recover. I started the process from an interactive session of kmttg and reproduced the problem; I have attached the log. Please let me know if there is any other diagnostic information you would like me to gather.
     

    Attached Files:

  11. Feb 23, 2017 #10611 of 10916
    moyekj

    moyekj Well-Known Member

    11,375
    125
    Jan 23, 2006
    Mission...
    Thanks for the logs. Looks like the issue is related to the "try again" feature I added in latest release. When it fails (as is the case for your Tonight Show) it's re-processing the whole stack of shows again instead of just the one that failed. So I need to fix code to just try re-doing the one that failed.
     
  12. Feb 23, 2017 #10612 of 10916
    Lurker1

    Lurker1 Active Member

    400
    88
    Jun 4, 2004
    And only retry it once. Do not get stuck in a loop.
     
  13. Feb 23, 2017 #10613 of 10916
    moyekj

    moyekj Well-Known Member

    11,375
    125
    Jan 23, 2006
    Mission...
    I have a patch for this issue I'd like you to try. Replace your current kmttg.jar with the one contained in this zip file to see if it fixes the problem:
    kmttg_v2.2q_beta1.zip

    Thanks.
     
  14. Feb 24, 2017 #10614 of 10916
    ej42137

    ej42137 Well-Known Member

    2,322
    37
    Feb 15, 2014
    Los Angeles
    Success. I ran the old version to make sure it would still loop, then shut it down and substituted your beta; the beta tried a couple of times and gave up, as it should.

    Thanks!
     

    Attached Files:

    moyekj likes this.
  15. Feb 24, 2017 #10615 of 10916
    moyekj

    moyekj Well-Known Member

    11,375
    125
    Jan 23, 2006
    Mission...
    Lurker1 likes this.
  16. Mar 3, 2017 #10616 of 10916
    az1097

    az1097 Member

    83
    0
    Apr 3, 2013
    I haven't used kmttg on my xp machine for a few months and when tried to open it from the desktop recently, it would not open. Any tips as of how to fix this issue? Thanks.
     
  17. Mar 3, 2017 #10617 of 10916
    kpeters59

    kpeters59 Member

    175
    18
    Jun 19, 2007
    You probably need to (manually) download the latest version and update Java to the latest version that will run on XP.

    -KP
     
  18. Mar 3, 2017 #10618 of 10916
    moyekj

    moyekj Well-Known Member

    11,375
    125
    Jan 23, 2006
    Mission...
    JavaFX used by kmttg 2.x is not officially supported on Win XP and I don't have any XP machines to run it on, so can't help other than advise to install kmttg on a machine with OS later than XP.
     
  19. Mar 4, 2017 #10619 of 10916
    godsey1

    godsey1 Member

    71
    1
    Jan 23, 2014
    Crossville, TN
    Hi all. I tried to use this to get all that i could off my Tivo before i swapped hard drives, but I could not figure it out. I downloaded the latest files, unzipped them into a folder that i made for it on the desktop, clicked on the kmttg.jar file and it opened the zip file up, just shows the files that's in it. I then went and downloaded the Java 121. It does the same thing. An ideas? Thanks for any help,

    Tony
     
    Last edited: Mar 4, 2017
  20. Mar 4, 2017 #10620 of 10916
    moyekj

    moyekj Well-Known Member

    11,375
    125
    Jan 23, 2006
    Mission...

Share This Page