1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Jun 25, 2009 #941 of 10413
    oViTynoT

    oViTynoT Obvious Forum Lurker

    342
    0
    May 18, 2007
    Plano, TX
    You read the instructions HERE.
     
  2. Jun 25, 2009 #942 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    Follow instructions given in linux_installation wiki page.
    NOTE: For linux there is no zip file with pre-compiled 3rd party tool binaries so you have to build them yourself if you don't already have them installed.

    If you just want to download from your Tivos then no additional tools are needed, but if you want to decrypt files then you need tivodecode. If you want to encode you will need ffmpeg or handbrake, etc. Links to the various 3rd party tools are provided in the main kmttg web page.
     
  3. Jun 25, 2009 #943 of 10413
    cones

    cones New Member

    3
    0
    Apr 20, 2009
    I did all of that but i still can't get it to work. What file do i open, do i need to extract the .jar file?
     
  4. Jun 25, 2009 #944 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    No. There is a script called kmttg that you run from command line to launch kmttg. The script has some fancier options but essentially or that is needed to launch from command line is:
    java -jar kmttg.jar
     
  5. Jun 25, 2009 #945 of 10413
    cones

    cones New Member

    3
    0
    Apr 20, 2009
    When i enter that code i get "unable to access jarfile kmttg.jar"
     
  6. Jun 25, 2009 #946 of 10413
    krar4

    krar4 New Member

    57
    0
    Dec 21, 2002
    IL
    To all:

    Now that I have KMTTG working so well, I am looking to find a way to increase the volume on the .mp4 files that it creates. I travel a bit, so I'd like to make the video files louder to make them easier to hear when I have to fly. Is there a way either within KMTTG or with another piece of software to easily do this?

    I appreciate any assistance.

    Thanks,
    Rick
     
  7. Jun 25, 2009 #947 of 10413
    dlfl

    dlfl Cranky old novice

    6,998
    18
    Jul 6, 2006
    Near...
    VideoReDo can adjust both audio sync and level (volume). This occurs in an mpeg2 file of course but the change would be carried through transcoding to MP4.
     
  8. Jun 25, 2009 #948 of 10413
    krar4

    krar4 New Member

    57
    0
    Dec 21, 2002
    IL
    Since I'm converting from .tivo to .mp4 automatically with KMTTG, is there any way to increase the volume on the audio on the .mp4 file? I would prefer not to have to transcode twice if I don't have to ( transcode .tivo to .mp2, increase the volume of .mp2, then transcode .mp2 to .mp4).

    Thanks!

    Rick
     
  9. Jun 25, 2009 #949 of 10413
    dlfl

    dlfl Cranky old novice

    6,998
    18
    Jul 6, 2006
    Near...
    You're never transcoding from .tivo to .mp2 whether you're using kmttg, VideoReDo or TivoDecode. The .tivo files are actually .mp2 files that must be freed from their TiVo wrapper -- much faster than transcoding. This is always part of any process that starts with .TiVo files, whether visible as a separate process step or not.

    As the author of TVAP (see signature) I know how easy this would be to do with the semi-automatic mode of TVAP operation in which you manually review/edit the automatic commercial cuts in VRD. You could adjust the audio volume in about one second during the this manual review process. I'm not aware of a completely automatic way of doing this with VRD or kmttg.

    Perhaps a kmttg expert (not me) will provide you a solution.
     
  10. Jun 25, 2009 #950 of 10413
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    Which encoder are you using?
     
  11. Jun 25, 2009 #951 of 10413
    krar4

    krar4 New Member

    57
    0
    Dec 21, 2002
    IL
    dlfl,

    Thanks for the feedback. Sorry for all the newbie questions.

    So in my situation, I need to run the .tivo file through KMTTG to download from my TiVo and also decrypt it to an .mp2 file. Then load it into Video Redo to increase the volume. Then transcode from an .mp2 to an .mp4 file. Is that the correct process?

    Audio Nutz - I'm not at my home computer at the moment, but I know for sure that I don't have the "encode" box checked. I just download, decrypt, comskip, and comcut with KMTTG. Is that leaving it as an .mp2 file then? If so, then following dlfl's instructions is easier than I realized.

    Thanks,
    Rick
     
  12. Jun 25, 2009 #952 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    You have to be in the same directory as kmttg.jar file to run the command that way. Otherwise you need to execute:
    java -jar <path>/kmttg.jar
    (substitute <path> for the real full path)

    But the proper way to do is simply to execute the following:
    <path>/kmttg &
    (again substitute <path> for the real full path to kmttg file)

    NOTE: It sounds like you are not very familiar with Linux and using Linux shell so depending what your goal is this may prove too hard for you to run under Linux.
     
  13. Jun 25, 2009 #953 of 10413
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    Hmmm... You're able to view these .mpg files on an airplane then, without encoding them? What kind of device are you watching them on?
     
  14. Jun 25, 2009 #954 of 10413
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    By the way, if you were using the ffmpeg encoders to actually go to .mp4 like your original question stated, then you could use -vol ??? as part of your encoding argument.

    From the ffmpeg -h help docs...
    -vol volume change audio volume (256=normal)
     
  15. Jun 25, 2009 #955 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    You can automate the whole process still using kmttg. You just need to add option to the encoder to tell it to boost the volume.
    For ffmpeg the option is -vol . Normal volume level is 256, so higher numbers mean higher volume. So for example adding -vol 333 option should boost the audio. You probably need to experiment a little to determine the right number - setting it too high you will get distortion and/or noise.

    For handbrake the option is -D with a 1.5-2.5 useful range. i.e. something like -D 2.0

    In either case easiest thing to do is make a copy of existing encoding profile (name.enc file in encode folder), give it a new name ending in .enc and add in the option given above.
    Then in kmttg just pick that encoding profile as your encoder and use kmttg as normal.
     
  16. Jun 25, 2009 #956 of 10413
    krar4

    krar4 New Member

    57
    0
    Dec 21, 2002
    IL
    AudioNutz,

    I'm watching the resulting .mp4 files on my Archos 5 Internet Media Tablet. I have never put a check mark by the "encode" button in KMTTG, so I don't think I'm encoding anything. The files I load say something like "Gary Unmarried_052609_cut.mp4". I realize the filename properties aren't exactly correct (from memory), but I know it ends in "..._cut.mp4", and the "encode" box is not checked.

    It sounds like you're saying I can encode using "ffmpeg -vol 300", where 256 is normal, so 300 is louder. If that's the process, where do I input the "-vol 300" information in the encoding instructions? It may be very obvious, but I'm not at my home PC at the moment, so I don't know.

    Thanks to all!

    Rick

    P.S. When I finished this post, I saw that KMoye had added another post regarding -vol 333. I'll give that a try.

    Thanks again!
     
  17. Jun 25, 2009 #957 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    krar4, you can't end up with .mp4 file without having encode enabled. If you are not enabling "encode" step in GUI then you probably are using "Auto Transfers" in which case you must have "encode" enabled in the auto transfer setup. In that case if you follow my instructions you will need to update the "Auto Transfers" setup to use the new encoding profile that you generate with the volume option added.
     
  18. Jun 26, 2009 #958 of 10413
    krar4

    krar4 New Member

    57
    0
    Dec 21, 2002
    IL
  19. Jun 26, 2009 #959 of 10413
    krar4

    krar4 New Member

    57
    0
    Dec 21, 2002
    IL
    KJ -

    I checked once I got home, and my resulting filenames are like "Gary Unmarried_052609_cut.mpg", not "xxx.mp4", as I originally thought.

    I don't want to say something that is incorrect. What is the filetype that is output if all I do is download, decrypt, comskip, and comcut? I don't have the "encode" option checked, and I'm not using Auto Transfers. Is my filetype an .mp2 filetype then?

    I opened the ff_h264_high_rate.enc file in WordPad and added the -vol 333 information. What filetype do I save it as with Wordpad? I can't get it to save as the correct filetype such that KMTTG recognizes it.

    Thanks,
    Rick
     
  20. Jun 26, 2009 #960 of 10413
    bkdtv

    bkdtv New Member

    7,902
    0
    Jan 9, 2003
    DC Metro Area
    MPG. MPG is the most common container (and extension) for MPEG-2 video. MP2 is almost never used.

    Output will always be MPG (MPEG-2) unless you select encode, in which case you will get M4V or MP4 (MPEG-4) depending on what encoding profile you select.

    Edit the .enc files in notepad or an enhanced text editor like Notepad++.

    Save the modified profile, then select File | Refresh Encoding Profiles in kmttg.
     

Share This Page