1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Jan 20, 2014 #6321 of 10413
    dearing

    dearing New Member

    23
    0
    Jan 31, 2007
    Thanks. Turning off Java downloads works, and I can now download (using cURL)/decrypt/encode shows again. All the items on the "Remote" tab still give this error, but are not critical for what I need now.

    I'll consider downgrading Java if necessary, but I figured it would just need a modification somewhere in Java's security config to get the latest Java version working with kmttg.
     
  2. Jan 20, 2014 #6322 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    I updated 3 different Windows machines (XP, Vista, Win 7) to latest JRE (1.7.0_51-b13) and none had the problem you posted. Java downloads work as do RPC functions. So I would recommend you run Java update again as looks like you don't have latest version and perhaps one you have didn't install properly.
     
  3. Jan 20, 2014 #6323 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Can't reproduce following above steps on either Windows or Linux (I do have an Elite whose very 1st item in NPL is a folder). Don't have a Mac to test.
     
  4. Jan 20, 2014 #6324 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    I'm seeing the same error when doing as mattack documented.

    This is on Win 8.1

    Code:
    >java -version
    java version "1.7.0_45"
    Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
    Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)
     
  5. Jan 20, 2014 #6325 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Can't reproduce on XP, Vista, Win7 or Linux here. My steps to test are:
    * Refresh Now Playing list for an Elite with "Show Folders" turned on
    * Click on top item in the table which is a folder
    * Click on top item inside folder

    Is above right sequence to try and reproduce?
    Does the stack trace contain any kmttg code references? Please post the full stack trace and also possibly your config.ini with MAK, passwords and anything else you don't want others seeing redacted.
     
  6. Jan 20, 2014 #6326 of 10413
    dearing

    dearing New Member

    23
    0
    Jan 31, 2007
    Yup. Updated to JRE 1.7.0_51-b13 and all is working again. Thanks as always!
     
  7. Jan 21, 2014 #6327 of 10413
    mattack

    mattack Active Member

    20,750
    4
    Apr 9, 2001
    sunnyvale
    Actually, it seems to be only on my Roamio.. and you can sort by different columns to force a folder to be at the top, and it still reproduces (on the Roamio).

    No, no stack traces are shown, or else I would have posted them.

    Even if I save the messages to a file and look there, there's no extra info shown (I thought that might have extra debug info).
     
  8. Jan 21, 2014 #6328 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Happens on both my Roamio and my Premiere. Does not happen on the THD. Can't check on the TiVo 2 as I can't get a folder to sort to the top.
     
  9. Jan 21, 2014 #6329 of 10413
    nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
    I tried rolling back to the older java, but the new security rules stayed-put. I re-installed the new version, set the security level to the lowest, and still have to click my way through triplicate warnings and "I'm OK with running this" type messages on websites with any java content embedded, with any browser.

    Since I tried the lower-level java security settings, before I rolled-back, and nothing would work at all, due to being "blocked" due to security reasons, I figure it working now, on the same new java release, and the same low-security setting, is a sign that the original install didn't work correctly.

    I didn't try kmttg before I had my browsers back. I checked after all that, and all seems well with kmttg.

    Yes, I did remove all other java versions present with each and every install, at completion of each installation.
     
  10. Jan 21, 2014 #6330 of 10413
    mattack

    mattack Active Member

    20,750
    4
    Apr 9, 2001
    sunnyvale
    Actually, I also seemed to run into the same error if I *delete* the first item in a folder, and the selection automatically goes back to the first item.. (no stack trace this time either).

    Is there any way I can make it give more info, and/or can you provide me with a build with more logging info?


    As a SEPARATE issue, it would be GREAT if the list scrolled to the currently selected item when you delete the 2nd item in a folder, and now the only item left is selected, but scrolled way out of view..
     
  11. Jan 22, 2014 #6331 of 10413
    Joe Siegler

    Joe Siegler New Member

    780
    0
    May 10, 2000
    Garland, TX
    Tried using KMTTG to create metadata files for episodes I've copied over from my TiVo to my computer already. These are .tivo files.

    However, it never wants to create a metadata file if the file is already on my computer. It works fine if I'm copying from my TiVo itself. I'd really like to create some metadata files for the programs I already have, but it seems to not want to work.

    I could probably do it by hand with info out there on the net, but that's an epicly huge pain in the backside.

    Am I doing something wrong, or does it not create metadata files for files you add via the "files" tab"? Below is what I see error wise, but I don't think it's a lot of use..

    Code:
    >> CREATING J:\TiVo\Brooklyn Nine-Nine - Old School (Recorded Nov 12, 2013, KDFWDT)_cut.mpg.txt ...
    C:\Users\Joe\Documents\kmttg\tivodecode\tivodecode.exe --mak MAK -D -x "J:\TiVo\Brooklyn Nine-Nine\Brooklyn Nine-Nine - Old School (Recorded Nov 12, 2013, KDFWDT).TiVo" 
    Failed to generate metadata file: J:\TiVo\Brooklyn Nine-Nine - Old School (Recorded Nov 12, 2013, KDFWDT)_cut.mpg.txt
    Exit code: 0
    Encryption by QUALCOMM ;)
    
     
  12. Jan 22, 2014 #6332 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Yes it's supposed to work and is usually very fast. Below is an example.
    Check write permissions under J:\TiVo or temporarily try a different location under C: volume to see if it's permissions problem.
    Code:
    >> CREATING C:\home\dvd\The Americans - (s01e01) Pilot Three-Minute Replay_ts.TiVo.txt ...
    "C:\home\kmttg java testing\tivodecode\tivodecode.exe" --mak MAK -D -x "C:\home\dvd\The Americans - (s01e01) Pilot Three-Minute Replay_ts.TiVo" 
    metadata job completed: 0:00:00
    ---DONE--- job=metadataTivo output=C:\home\dvd\The Americans - (s01e01) Pilot Three-Minute Replay_ts.TiVo.txt
    
    You can also cut and paste the tivodecode call in a "cmd" window to perhaps get a better clue about what's going wrong.
     
  13. Jan 22, 2014 #6333 of 10413
    mattack

    mattack Active Member

    20,750
    4
    Apr 9, 2001
    sunnyvale
    I didn't realize you could make a metadata file after the fact (I had thought it was pulled from the tivo). But since you're creating it before I actually download the file, I guess you're getting it a different way.

    Still interested in getting to the root of that java error.
     
  14. Jan 22, 2014 #6334 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    I'm unable to reproduce the error for any of the posted scenarios thus far. There may be certain settings I don't have set causing the problem which is why I asked for a config.ini (redacted of sensitive info or perhaps as a PM).
     
  15. Jan 23, 2014 #6335 of 10413
    Joe Siegler

    Joe Siegler New Member

    780
    0
    May 10, 2000
    Garland, TX
    J:\TiVo is my primary TiVo drive. It copies all my episodes to that directory before i manually move them elsewhere. I doubt it's a permission issue since all my transfers end up there.

    Additionally, if I do anything else like decrypt or adcut, kmttg can write those files there. Just not the metadata.

    Also, it can write the metadata file to the same directory if it's pulling from an actual TiVo at the same time. Just not via a locally added one.
     
  16. Jan 23, 2014 #6336 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Did you try running following from a cmd window (replace MAK with your actual 10 digit MAK)?
    Code:
    C:\Users\Joe\Documents\kmttg\tivodecode\tivodecode.exe --mak MAK -D -x "J:\TiVo\Brooklyn Nine-Nine\Brooklyn Nine-Nine - Old School (Recorded Nov 12, 2013, KDFWDT).TiVo" 
    It should produce a couple of xml files.
     
  17. Jan 23, 2014 #6337 of 10413
    Joe Siegler

    Joe Siegler New Member

    780
    0
    May 10, 2000
    Garland, TX
    Oops. Forgot. I'll go do that now.

    Edit: It left two files in my j:\Tivo directory (I ran the command from there). They are:

    chunk-01-0001.xml
    chunk-02-0002.xml

    Looking at the contents, the info in the second one would be in a resultant metadata file is in there, but the file format is not a metadata file. Probably not the right file(s) - or so it seems to me. Let me know if you want me to send those over.
     
  18. Jan 23, 2014 #6338 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    After xml files are generated kmttg parses 2nd one to generate metadata file. Zip them up so I can take a look. If xml generation is working I doubt there's an xml parsing issue, but never know...
     
  19. Jan 23, 2014 #6339 of 10413
    Joe Siegler

    Joe Siegler New Member

    780
    0
    May 10, 2000
    Garland, TX
    From looking inside the files, I kind of figured it grabbed info out of the second, as the first wasn't really readable.

    See attached for zip file.
     

    Attached Files:

  20. Jan 23, 2014 #6340 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    Open up a blank browser window and drag the xml file into it. It should be readable that way.
     

Share This Page