1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Nov 29, 2013 #6101 of 10413
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,736
    8
    Apr 6, 2000
    SF Bay Area
    Here's a few suggestions to add in to KMTTG:

    Add F5 for refreshing NPLs.
    Add .VPrj extension to the ADD files open window section.
     
  2. Nov 30, 2013 #6102 of 10413
    chicagobrownblue

    chicagobrownblue Active Member

    2,284
    7
    May 29, 2008
    Chicago, IL
    I successfully downloaded an episode of "The Big Bang Theory" using kmttg - clever program thanks. Lost in a commercial skip area is about 10 seconds at the end of the program followed by more commercials and another episode. When I use comskip review, it takes a minute or two to advance one frame. When I left click into the black area, it takes 2-3+ minutes to get the red line to the new position. Am I doing something wrong? Can I edit a file to start guessing at where the missing program end is?

    Quad core i7 (12-13% CPU utilization when comskip is not responding), 3 GB of memory less than 50% in use, Windows 7. Thanks.
     
  3. Nov 30, 2013 #6103 of 10413
    steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    I have one S2 and two Tivo HDs.

    How do I "restart" kmttg? I don't leave it running, I start it up when I need it.
    Do I need to kill something in Task Manager?
     
  4. Nov 30, 2013 #6104 of 10413
    christheman

    christheman New Member

    166
    0
    Feb 20, 2013
    Hi, I just wanted to say "Thanks" to everyone and Happy Holidays to all this season.

    moyekj, KMTTG has been working well for me. There is one thing though that I wanted to mention. I use Control-C rather heavily from within KMTTG to copy movie descriptions over to a text field in another program. Occasionally I accidentally hit Control-X, which exits KMTTG. Would there be any way for the KMTTG user to circumvent or disable this?

    Thanks
    Chris
     
  5. Nov 30, 2013 #6105 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    See the remote_control Wiki. For series 3 units you need to supply your tivo.com login + password in order to gain limited Remote functionality. Full Remote capability is only for series 4 or later units.
     
  6. Nov 30, 2013 #6106 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Deletion of metadata file is expected since in normal kmttg flow there should be _cut.mpg.txt metadata file. The .mpg.VPrj file naming seems strange and I don't think came from kmttg flow. Don't know exactly what you are doing but doesn't appear to be entire kmttg based flow.
     
  7. Nov 30, 2013 #6107 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Before using comskip did you run the .mpg through QS Fix step?
     
  8. Nov 30, 2013 #6108 of 10413
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,736
    8
    Apr 6, 2000
    SF Bay Area
    I use the .mpg.VPrj name scheme for ease of naming after I had done the VRD cutting process and then use the .mpg.txt filename since I have long filenaming schemes. I let KMTTG do the actual adcut and don't have to wait for VRD to do it when done one by one. The resulting file after adcut was .mpg_cut.mpg. I would then just delete the end after the first .mpg.
     
  9. Nov 30, 2013 #6109 of 10413
    chicagobrownblue

    chicagobrownblue Active Member

    2,284
    7
    May 29, 2008
    Chicago, IL
    I think I did but I deleted all the files and started from scratch running the QSFix step for sure. Getting the same behavior again. It might be a little faster but I am eating dinner and checking the program so maybe not. Thanks.



    kmttg v1p0j

    and

    "You have the recommended Java installed (Version 7 Update 45)"
     
  10. Nov 30, 2013 #6110 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Perhaps try a different version of comskip which from this thread seemed to have helped somebody else having issues with it:
    http://www.tivocommunity.com/tivo-vb/showthread.php?t=506062
     
  11. Dec 1, 2013 #6111 of 10413
    steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    I just now saw another post about this elsewhere and came to report that I got it working.
    I figured it had to be something easy...

    Thanks again. :up:
     
  12. Dec 1, 2013 #6112 of 10413
    chicagobrownblue

    chicagobrownblue Active Member

    2,284
    7
    May 29, 2008
    Chicago, IL
    Thanks. I finally found the 10 second spot in Big Bang Theory and cleared out most of the surrounding commercials. When I started on a SNL episode, the red line moved immediately to the new spot on my first click and then things slowed to a crawl. I am only archiving 4 shows so this works well for me.
     
  13. Dec 1, 2013 #6113 of 10413
    Kamakzie

    Kamakzie Are you serious bro?

    4,998
    0
    Jan 7, 2004
    MI
    Hey guys, just discovered kmttg with my Sling 350. Works great. However under video resolutions I have 1920x1080 or 640x480. Is there anyway to add 1280x720? Thanks!
     
  14. Dec 1, 2013 #6114 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Nope. I was unable to find that capture resolution for the 350 using the Perl script.
     
  15. Dec 1, 2013 #6115 of 10413
    Kamakzie

    Kamakzie Are you serious bro?

    4,998
    0
    Jan 7, 2004
    MI
    Darn, do you know of a good way to re-encode into 720p?

    Thanks.
     
  16. Dec 2, 2013 #6116 of 10413
    SoldierOfFortran

    SoldierOfFortran New Member

    1
    0
    Dec 2, 2013
    This is a great application, thank you for your work on it.

    I am experiencing an excessive number of read timeouts while downloading from the device. It occurs with both the java downloader and with curl.

    This manifests itself as the download 'stalling' partially into a transfer. Things will be ticking along at 90Mb/sec, then simply stop. Eventually it times out and retries. Sometimes the retry will work, but sometimes it will stall again.
    The size of the item doesn't seem to predict if it will stall. Larger items are harder to get downloaded, as they seemingly have more opportunity to stall. Large files (12GB+) I cannot download successfully.

    This weekend I will acquire a wireshark capture. Any tips on things to try, or things to look for?

    I have a roamio plus, OSX 10.8, JDK 1.6.0_65. The computer and tivo are on the same 1000Mbit switch.

    Code:
    htt p://10.0.1.4:80/download/---.TiVo?Container=%2FNowPlaying&id=4771: Read timed out
    /TiVo/dotTiVo/---.TiVo: size=1741.45 MB elapsed=0:07:53 (30.88 Mbps)
    Download failed to file: /TiVo/dotTiVo/---.TiVo
    
     
  17. Dec 2, 2013 #6117 of 10413
    chicagobrownblue

    chicagobrownblue Active Member

    2,284
    7
    May 29, 2008
    Chicago, IL
    I downloaded the O p r a h W i n f r e y 24-th season opener from my TiVo Premiere. I did run QSFix. The resulting mpg file has a few seconds of commercial with audio and video before the show starts. The show starts with both audio and video. The audio is some mechanically produced low tones. Then the audio drops out completely for the rest of the show, including commercials. The show plays with both video and audio on my TiVo. Is there a log file to possibly debug what is going wrong? Thanks.
     
  18. Dec 2, 2013 #6118 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Is your QS Fix step using ProjectX or VideoRedo?
     
  19. Dec 2, 2013 #6119 of 10413
    chicagobrownblue

    chicagobrownblue Active Member

    2,284
    7
    May 29, 2008
    Chicago, IL
    Projectx. Thanks.
     
  20. Dec 2, 2013 #6120 of 10413
    moyekj

    moyekj Well-Known Member

    11,148
    33
    Jan 23, 2006
    Mission...
    Not much can be done then if that's the case. My guess is ProjectX is probably not selecting the right audio track when remuxing. You may want to try and see if you can get away with skipping QS Fix for this problem title.
     

Share This Page