1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Oct 27, 2013 #5961 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    That only happens when the target dir is determined not to be available. So triple check the path and the read/write permissions along with AV and/or firewall settings which may have been affected if you changed Java versions. Also make sure things work properly via GUI first since service mode can be more problematic.
     
  2. Oct 27, 2013 #5962 of 10410
    Revolutionary

    Revolutionary Too sleepy for TV...

    575
    0
    Dec 1, 2004
    Virginia
    Permissions. That was it. I had shared the target folder on the network recently and it reverted the admin privileges over it. Thanks!
     
  3. Oct 28, 2013 #5963 of 10410
    bwperez

    bwperez New Member

    29
    0
    Jan 3, 2005
    I can't imagine my Tivo's without KMTTG. Thank you for such an amazing program. I do have two questions

    I'm running KMTTG on an ESXI server running Windows Server Essentials 2012 and my media storage isn't the fastest. I've added a SSD to do all the downloading, encoding and converting with great success with the final output to media storage. The problem is it performs the encode process to a tmp file and once it copies that tmp file to the .mp4 it runs atomic parsley. Is there any way around this? I don't see the config

    The second question is related to processing .tivo files that have been downloaded in the past. I'm currently running those through my new process and converting them to H264 MP4. Unfortunately it isn't enforcing the new filename string I've configured even though it does download and create the metadata files. Also, the file path ends up at the root of encoding output directory rather than under the tv program directory.

    Brian
     
  4. Oct 28, 2013 #5964 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    What encoding profile? Sounds like encoder doing that. I know, for example, some VRD and Handbrake profiles do that. I have no control over that.

    File naming template only applies starting with a download. If you start with an existing file then that current file name will be used as basis for all subsequent files. So rename the .TiVo files appropriately before starting processing with kmttg. That still won't help create sub-folders you may have defined as part of naming template though.
     
  5. Oct 28, 2013 #5965 of 10410
    bwperez

    bwperez New Member

    29
    0
    Jan 3, 2005
    I'm using VRD h.264 mp4 profile. I'll post the question to VRD.

    I was afraid of that. I'll go research tools for renaming things. I've been doing it manually and that isn't an efficient way of doing it.

    Thanks for the quick reply and the great program.

    Brian
     
  6. Oct 28, 2013 #5966 of 10410
    mlippert

    mlippert New Member

    59
    0
    Apr 2, 2010
    Massachusetts
    Brian,
    I found pfrank to be a pretty good tool for renaming things on Windows if you're comfortable w/ regular expressions.
    http://www3.telus.net/pfrank/

    Mike
     
  7. Oct 28, 2013 #5967 of 10410
    alan2k

    alan2k New Member

    5
    0
    Feb 28, 2007
    This evening both of my Premiere's have decided to start giving me 503 errors. I upgraded KMTTG to the current release, v1p0i, verified I'm on Java 1.7u45. I have a Roamio that is working fine. Problem is related to the Premerie's only. The only thing I can see is that they both got the Fall 2013 update tonight when I rebooted them.

    The exact message from KMTTG is :

    ERROR: http IO exception for: hxtxtp://192.168.1.240:80/download/Kitchen%20Crashers.TiVo?Container=%2FNowPlaying&id=1950030[
    Server returned HTTP response code: 503 for URL: hxtxtp://192.168.1.240:80/download/Kitchen%20Crashers.TiVo?Container=%2FNowPlaying&id=1950030]​

    <Note: I manually changed http to hxtxtp to get the message to post!>

    I even tried it off another box using both v1poh and v1poi and both are giving the same issue.

    Anybody got any suggestions?

    Thanks,
    Alan
     
  8. Oct 29, 2013 #5968 of 10410
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,717
    7
    Apr 6, 2000
    SF Bay Area
    You might try getting them to connect to Tivo Service again.
     
  9. Oct 29, 2013 #5969 of 10410
    alan2k

    alan2k New Member

    5
    0
    Feb 28, 2007
    Well, I just rechecked them and now they are working again. I hate when that happens. (You don't know what may have fixed them, but that is a good suggestion for next time!)

    Thanks!
     
  10. Oct 29, 2013 #5970 of 10410
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,717
    7
    Apr 6, 2000
    SF Bay Area
    What I think is that service updates have a higher priority so it gets downloaded and installed before even guide data updates and transfer permissions. The next time it connects, those get updated.
     
  11. Oct 29, 2013 #5971 of 10410
    keenanSR

    keenanSR Member TCF Club

    909
    2
    Oct 12, 2004
    Santa Rosa CA
    I've decided to get a Roamio basic and was wondering if the lack of 1Ghz(10/100 only) ethernet will be an issue? I don't imagine it would matter, but thought I would check to be sure.

    Thanks
     
  12. Oct 29, 2013 #5972 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    I don't really understand the question. Without Gigabit ethernet transfers may be a little slower than they could possibly be, but the difference is not worth sweating about since transfers are plenty fast enough with Roamio compared to previous generations of TiVo hardware.
     
  13. Oct 29, 2013 #5973 of 10410
    keenanSR

    keenanSR Member TCF Club

    909
    2
    Oct 12, 2004
    Santa Rosa CA
    Right, since they have gotten faster from the days of Series 3 transfer speeds I just wondered if it would make a difference being limited to 100Mbps vs 1Ghz. The transfer speed has never really been an issue to me with my Series 3 and HD(not as fast) but I thought I'd ask as when posted I was debating on which Roamio model to purchase - I have since already picked up the Basic model and just waiting on the larger HDD.

    Thanks for your response!
     
  14. Oct 31, 2013 #5974 of 10410
    truegalbklyn

    truegalbklyn Member

    43
    0
    Aug 8, 2012
    Hey All :)

    I need some help. I am trying desperately to get kmttg to work on my new Windows 8 surface tablet. I have both versions of java installed. I installed the program correctly, it downloaded all the tools and I entered my MAK. It correctly pulled up my playlist but when I attempted to download, I got the following error messages.

    1. This was attempting a download via the normal (curl) method. I got this error message.

    [​IMG]
    [​IMG]

    2. So then I attempted to download via java only and got this error message.

    [​IMG]

    Can anyone help me to get this to work?

    ETA: I should add that each time (both curl and java), the download does begin and sometimes gets all the way to about 25 percent before those errors messages show up.
     
  15. Oct 31, 2013 #5975 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
  16. Oct 31, 2013 #5976 of 10410
    truegalbklyn

    truegalbklyn Member

    43
    0
    Aug 8, 2012
    I tried that too. It goes for about 5 minutes and then tells me the network failed or something.

    Mind you, I have kmttg working on my laptop with no issues and it is the same network.
     
  17. Oct 31, 2013 #5977 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    Different wireless adapter though. Don't know if the Surface has an ethernet port but if it does you may want to try going wired to your router just to see if that works.
     
  18. Oct 31, 2013 #5978 of 10410
    truegalbklyn

    truegalbklyn Member

    43
    0
    Aug 8, 2012
    Quick question, does AV software always need to be turned off when doing downloads or is it just some software companies (example- Kapersky) that brings issues? I ask because my laptop (where I have NO problems) has Avast and the surface uses Kapersky.
     
  19. Oct 31, 2013 #5979 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    Kasperksy is troublesome. It's been causing trouble with downloads ever since I can remember. Don't use it or make exceptions in it so that curl & java are not interfered with.
     
  20. Nov 1, 2013 #5980 of 10410
    bwperez

    bwperez New Member

    29
    0
    Jan 3, 2005
    Thanks for the suggestion. I took a look at it and RAN! I work with Oracle and every time a developer asks me for help with regular expressions I cringe. This would be a tool I use 2 times a year which means I'd have to re-learn it every time I needed it :) The good news is I found a solution. I used VAP to just rename the files and it does metadata lookups on its own. I'm all set and wish I had thought of VAP sooner.
     

Share This Page