1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Oct 19, 2013 #5921 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    1. OK, fixed the problem with entries older than current time. Also returned results are sorted by Date by default.
    2. Yes this will happen for searches without keywords since kmttg uses collectionSearch instead of offerSearch for those and that's a side effect of different search type.
    3. Yes it's always been that way and tooltip mentions that. These RPC searches don't allow more than 1 year as a filter.
    Latest beta version with above fixes:
    https://docs.google.com/file/d/0B0SMFC97ymdENHNJWnpGa0swRjA/edit?usp=sharing

    (Thanks for help testing BTW).

    EDIT. For issue 2 I figured out now how to include multiple airings in the results so it behaves like offerSearch now. With this type of search the final count of results can be now be > Initial Match count displayed by job table.
     
  2. Oct 19, 2013 #5922 of 10413
    jimpmc

    jimpmc New Member

    72
    0
    Oct 31, 2001
    First off, thanks for the great program and continual new features. Recently, I tried using the qsfix (projectx version) on an mpg file (that was created from a dvd rip). The original mpg was an entire movie, but just showed the wrong time when playing. When I used qsfix, it completed, but the resulting file is cutoff around halfway. The original file is 5.71GB and the qsfix one is only around 2.8GB. This happened before when I tried another file, so I figured I'd see if it was a setting, known issue, or a limitation of the filesizes.
     
  3. Oct 19, 2013 #5923 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    There are 2 steps to the ProjectX qsfix:
    1. projectx demux
    2. ffmpeg remux

    While demux is running double click on the job in the table to get stdout/stderr window and see if there are error messages showing up during or towards the end of the run. If the problem is happening on this one then it's a projectx issue with likely no solution.
    While remux is happening double click on the job again and look for errors.
    If the problem is happening during the ffmpeg remux phase it's possible that a different/new version of ffmpeg may help.
     
  4. Oct 19, 2013 #5924 of 10413
    jimpmc

    jimpmc New Member

    72
    0
    Oct 31, 2001
    It is definitely happening on the demux. The .m2v file is half the size and the elapsed time shown is also about half of what it should be.
     
  5. Oct 19, 2013 #5925 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Then not much to be done. There's no later version than what kmttg distributes. If you really are motivated you may want to download the latest CVS source code to build latest binary to see if it fixes the issue, but it's a long shot and unlikely to help.

    VideoRedo is a better solution for qsfix if you haven't considered that.
     
  6. Oct 19, 2013 #5926 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Beta version of kmttg.jar with multiple airings included for collectionSearch type searches:
    https://docs.google.com/file/d/0B0SMFC97ymdEdGsySE9pd1k2bTA/edit?usp=sharing
     
  7. Oct 19, 2013 #5927 of 10413
    Hyrax

    Hyrax New Member

    112
    0
    Sep 1, 2007
    I've searched and cannot find if anyone else has a problem with captions being out of sync by a few seconds. I discovered this by transferring a show with captions to my PC and running handbreak in a separate step. About half of the time the captions are perfect, the rest of the time they are off - sometimes slightly, some times it is so bad as to make them useless.

    Digging deeper into the problem, I have tried using kmttg to extract the captions as .SRT files and then using MKVMerge to mux them into the program. I still have the same problem. (I'm using ccextractorwin.exe for this).

    I believe that the problem may somehow be in the code that converts the .TIVO container to a .MPG container.

    Has anyone else seen this problem? Is it possible that some key timing information is being lost in transferring from the Tivo? If no one else has seen the problem, I'll explore it further. I guess once I find a new show with this problem and test to try to find the source of the problem. I want to see if the problem is in the original material (possible), see if Tivo Desktop has the problem, see if pushing the show back to the Tivo eliminates the problem, and so on.

    Thanks in advance
     
  8. Oct 19, 2013 #5928 of 10413
    Hyrax

    Hyrax New Member

    112
    0
    Sep 1, 2007
    BTW, this caption sync problem was happening on a Premiere XL. I just got a Roamio and don't know if it has this issue or not.
     
  9. Oct 20, 2013 #5929 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Today I also added "Minimum rating" to Advanced Search so that when searching for movies you can set how many stars minimum to restrict matches to. Since Advanced Search is now much better than current official release I'll probably be releasing another update soon.

    I still can't believe how badly TiVo crippled Wishlists screens when "upgrading" to HDUI. They even removed capability of setting up advanced wishlists with boolean logic along with introducing several issues.
     
  10. Oct 20, 2013 #5930 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    v1p0i version is now released. Improvements to the Advanced Search capability are included. See the release_notes Wiki for details.
    As usual, if using v1p0b version or later you can update automatically using Help->Update kmttg...
     
  11. Oct 20, 2013 #5931 of 10413
    mglutz

    mglutz New Member

    33
    0
    Jan 13, 2011
    In the now playing table the icons have a hierarchy that has the copy protection icon on top. That hides the expiration icon. Looks like that is all the Tivo supplies looking at show information. Does the RPC function provide the additional needed to be able to show expiration information for all shows?
     
  12. Oct 20, 2013 #5932 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    There's some relevant parameters. Here's a blurb on it:

    All my expectedDeletion dates are in the year 2038, but my Roamio Pro is only 10% full.
    Looking at my Premiere with 40% full disk there are some "expectedDeletion" dates that are dated a few months ago.
     
  13. Oct 20, 2013 #5933 of 10413
    nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
    Just a thought, out of the blue, from somebody who has been annoyed by inaccurate deletion date flagging:

    If you reboot the Premiere, and check the dates on the ones scheduled for past dates, do they update to the future? I can eliminate the yellow exclamation points, for about a week, by simply rebooting the unit.

    I've found that any time I run a DIY unsanctioned upgraded HDD TiVo, past ~30% of the upgraded capacity, it will flag programs for deletion, as if it was running the stock drive and/or it seems the TiVo calculates based on all to-do programs being in full HD, while many of them aren't and/or calculates all programs, even if they are duplicates/not new, and the SPs are set to new-only, thus they won't actually record.

    It's something I'm hoping that the new program from the author of DVRBARS may find a way to address, in his future software. Maybe I should bother to mention it the next time I chat with him, since I've just realized I've never asked him about it...
     
  14. Oct 21, 2013 #5934 of 10413
    Eyedoctor2

    Eyedoctor2 New Member

    9
    0
    Feb 11, 2005
    Just a FYI, I am getting 1920 x 544 resolution using Slingbox Pro HD and your slingbox capture setup.

    Thanks for the great work!
     
  15. Oct 21, 2013 #5935 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Indeed, rebooting my Premiere and checking again all the "expectedDeletion" dates got changed to year 2038. So looks like the scheduler resets that property on reboot for each recording not set to KUID, at least for 20.3.1 Premiere software.
     
  16. Oct 21, 2013 #5936 of 10413
    mglutz

    mglutz New Member

    33
    0
    Jan 13, 2011
    Can the play list in kmttg be updated to show both the deletion policy AND the copy protection. So that for both copy protected and non protected shows you could see at a glance if a show is likely to get deleted?
     
  17. Oct 21, 2013 #5937 of 10413
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Well, there can't be 2 icons in 1 table cell, so that would mean either having to add another column or not using copy protect icon for copy protected shows. At 1 point I was using just the different background color to indicate copy protected shows and the normal expiration icons, but I seem to recall some color blind related complaints about that.
     
  18. Oct 21, 2013 #5938 of 10413
    nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
    Glad I could contribute something. That behavior has been going on for so far back that I can't say for sure if it was always that way, or was introduced by a particular update. I have hundreds of SD recording set to KUID, which exacerbates the problem happening. Now, it would just be nice to know the exact reason for the behavior, as opposed to all my speculation on the why.

    It's been that way for my HD units as well (all my TiVos are 2TB upgrades), but I did notice when viewing the NPL of a HD from a Premiere, that the HD units would display yellow ! for all recordings, while a direct check at the HD unit would not display them for all. This behavior DID begin a few Premiere updates back, and has remained since it was introduced.
     
  19. Oct 22, 2013 #5939 of 10413
    mglutz

    mglutz New Member

    33
    0
    Jan 13, 2011
    Since the green and yellow seem to be acceptable colors, can you create new icons that add the copy protected 'slash' across the existing yellow and green icons.
     
  20. Oct 22, 2013 #5940 of 10413
    BH9244

    BH9244 Member

    119
    0
    Feb 10, 2009
    Upgraded to v1p0a still get the same error msg ?
     

Share This Page