1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Oct 12, 2013 #5881 of 10412
    moyekj

    moyekj Well-Known Member

    11,140
    31
    Jan 23, 2006
    Mission...
    You have kmttg installed under "c:\Program Files" dir which is not recommended with Windows Vista or later that impose restrictions on that folder. Also looks like you may be trying to decrypt a .TiVo file downloaded with TiVo Desktop which may have "Fast Transfers" option enabled and hence it could be a TS .TiVo file which tivodecode can't handle. You can run mediainfo on the .TiVo file to check for sure.
     
  2. Oct 12, 2013 #5882 of 10412
    ajayabb

    ajayabb Member

    429
    0
    Jan 11, 2007
    Moorestown NJ
    Reinstalled to new directory and made sure fast transfers in Tivo Desktop was unchecked and still getting same error.
     
  3. Oct 12, 2013 #5883 of 10412
    moyekj

    moyekj Well-Known Member

    11,140
    31
    Jan 23, 2006
    Mission...
    Did you check the .TiVo file you were trying to encrypt with mediainfo? If it's mpeg TS container then tivodecode won't work and you'll have to re-download with "fast transfers" disabled.
     
  4. Oct 12, 2013 #5884 of 10412
    wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    "G:\My Tivo Recordings\" would seem to be the problem directory, in terms of permissions, unless it's the permissions of the .TiVo file itself. (Why this should be so, I don't know.)
     
  5. Oct 12, 2013 #5885 of 10412
    moyekj

    moyekj Well-Known Member

    11,140
    31
    Jan 23, 2006
    Mission...
    Yes, good point. By error message it appears to be file read permission problem, but then I'm not sure how he was able to include the file in FILES list to begin with...
     
  6. Oct 12, 2013 #5886 of 10412
    ajayabb

    ajayabb Member

    429
    0
    Jan 11, 2007
    Moorestown NJ
    Ran Mediainfo and it isn't in a .ts container. Turns out some there were some restrictions on my external (G:) drive so I added permissions and reran kttmg and things seem to be working.
     
  7. Oct 12, 2013 #5887 of 10412
    markp99

    markp99 TakoKichi TCF Club

    11,129
    16
    Mar 21, 2002
    Nashua, NH
    Quick question, I hope:

    1. pyTivo installed and functional, sees TiVo and push/pull no issue
    2. kmttg installed - can PULL programs, but PUSH option is GREYED
    3. pyTivo is properly configured in kmttg to point to pytivo.conf
    4. TiVo can see the local files in their prescribed locations

    When I select a CUT file to send back to TiVo, PUSH is not enabled.

    Any suggestions to enable?
     
  8. Oct 12, 2013 #5888 of 10412
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,724
    8
    Apr 6, 2000
    SF Bay Area
    [​IMG]

    Is it setup similar to this? You may also need to run auto_push.jar.
     

    Attached Files:

  9. Oct 12, 2013 #5889 of 10412
    markp99

    markp99 TakoKichi TCF Club

    11,129
    16
    Mar 21, 2002
    Nashua, NH
    Added "pytivo.conf" to the path. I could have sworn I had it there previously, but caused issues elsewhere.

    Anyway, PUSH is now enabled.

    Thanks!
     
  10. Oct 16, 2013 #5890 of 10412
    az1097

    az1097 New Member

    82
    0
    Apr 3, 2013
    I have shows on my PC which I had transfered with kmttg and now I'd like to push some .tivo files with closed captioning back to my Premiere but I'm unable to, not sure what I'm doing wrong. Do I need the tivo metadata files for this process? Thanks.
     
  11. Oct 16, 2013 #5891 of 10412
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,724
    8
    Apr 6, 2000
    SF Bay Area
    KMTTG does not do pushes, instead, it uses PyTivo for that action.
     
  12. Oct 16, 2013 #5892 of 10412
    moyekj

    moyekj Well-Known Member

    11,140
    31
    Jan 23, 2006
    Mission...
    Unless they are TS container .TiVo files, if you want captions preserved they need to be returned to TiVo in TS container for captions to work for series 4 or later units (TiVo bug). Suggested way to do this:
    1. From kmttg FILES tab add the .TiVo files and enable "metadata" & "decrypt" tasks and run.
    2. Make sure you are using recent version of wmcbrine pyTivo and have ts=on in pyTivo.conf [server] section.
    3. With pyTivo running now when you pull the decrypted shows pyTivo will remux to TS container and captions will be preserved.

    I don't think PS .TiVo files with ts=on get remuxed to TS container by pyTivo but I'm not sure about that and haven't tried it. I'm assuming .TiVo files are left alone which is why I suggest decrypting to .mpg.
     
  13. Oct 16, 2013 #5893 of 10412
    az1097

    az1097 New Member

    82
    0
    Apr 3, 2013
    How would I use PyTivo within KMTTG to push those files?
     
  14. Oct 16, 2013 #5894 of 10412
    moyekj

    moyekj Well-Known Member

    11,140
    31
    Jan 23, 2006
    Mission...
  15. Oct 16, 2013 #5895 of 10412
    az1097

    az1097 New Member

    82
    0
    Apr 3, 2013
  16. Oct 16, 2013 #5896 of 10412
    lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    What happens when you try to use the pyTiVo Browser interface to push?
     
  17. Oct 16, 2013 #5897 of 10412
    moyekj

    moyekj Well-Known Member

    11,140
    31
    Jan 23, 2006
    Mission...
    If you are attempting to push .TiVo files you need to configure pyTivo to tell it where tivodecode is since .TiVo files can't be pushed directly.
     
  18. Oct 16, 2013 #5898 of 10412
    az1097

    az1097 New Member

    82
    0
    Apr 3, 2013
    KMTTG completes push
    but pyTivo.py first shows "WARNING: pyTivo.config:tdcat not found" then sends an empty file to the Tivo.
     
  19. Oct 16, 2013 #5899 of 10412
    az1097

    az1097 New Member

    82
    0
    Apr 3, 2013
    How would I do this?
     
  20. Oct 16, 2013 #5900 of 10412
    lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    It's under "Global Server Settings" in pyTivo settings. Or you can just put a copy of tivodecode in the "bin" subdirectory of the pyTivo install location.
     

Share This Page