1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Jul 29, 2013 #5481 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    I can tell you it does run on Vista 64 as that is what my main laptop is still running and I use all the time. Probably easiest way try running it and see any error messages is doing the following:
    From Start menu choose "Run..." and then type "cmd" (without the quotes) to get a command prompt, then execute the following 2 commands:
    cd c:\kmttg
    java -jar kmttg.jar

    I would expect you should see some kind of error printed to the screen at which point please cut and paste the error here if it's not clear what the problem is.
     
  2. Jul 29, 2013 #5482 of 10413
    buckaroos

    buckaroos New Member

    3
    0
    Dec 17, 2009
    Thank you for the prompt reply! Following is a copy of the cmd session and error message:

    ==========

    c:\kmttg>java -jar kmttg.jar
    'java' is not recognized as an internal or external command,
    operable program or batch file.

    ========

    It seems that "java" is somehow not known as a command in the DOS environment. I'm googling this issue, but maybe you have the answer?

    Best regards!
     
  3. Jul 29, 2013 #5483 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    For "normal" JRE installations it normally takes care of associating jar files to javaw.exe as well as adding java to your path, so sounds like you may not have a "normal" Java install. You will need to substitute "java" in the command above with full path to "java.exe" or "javaw.exe" in your installation. i.e. something like:
    "c:\Program Files (x86)\Java\jre7\bin\java.exe" -jar kmttg.jar
     
  4. Jul 29, 2013 #5484 of 10413
    buckaroos

    buckaroos New Member

    3
    0
    Dec 17, 2009
    That did the trick! It is initiating and giving me the GUI now. Thank you so much for your excellent and timely support!

    Best regards!!!
     
  5. Jul 29, 2013 #5485 of 10413
    IPbUnSJ5njOL

    IPbUnSJ5njOL New Member

    16
    0
    Feb 19, 2005
    0.4.4? Odd. Are you sure you're not thinking of 0.3pre6 from March?

    I've had no graphics problems at all. I've had sound screw up on 4 out of dozens and dozens of shows, but haven't figured out a pattern or tried to test to see if turning TS off would help those.
     
  6. Jul 29, 2013 #5486 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    Yes, it's 0.4.4 (the C++ version) I'm talking about.
     
  7. Jul 30, 2013 #5487 of 10413
    mattack

    mattack Active Member

    20,750
    4
    Apr 9, 2001
    sunnyvale
    This is a VERY VERY VERY minor issue, and not even really a bug.. But I do notice it.

    Since downloads from Premiere 4s are "so fast" (compared to my TivoHD, they are), the "go into second by second countdown when it is under 5 minutes to go" actually means it's doing second by second countdown the MAJORITY of the time, since an hour long SD show (yeah, I record virtually all SD) takes about 7-8 minutes to download.

    So maybe it should switch to second by second in the last 10% or something (I know the % isn't really accurate, and somewhere near the end, it just finishes without actually getting to 100%).
     
  8. Jul 30, 2013 #5488 of 10413
    scandia101

    scandia101 Just the facts ma'am

    10,520
    0
    Oct 20, 2007
    MN, greater...
    I'm completely new to kmttg.
    I put kmttg on my Mac and was checking out it's features for a few minutes and then I left that and picked up my peanut remote to check something on my Premiere and it didn't work. The Tivo was reset to remote code 0 and then an entire folder of 31 recordings was deleted.
    Is kmttg to blame or is it just coincidence?
     
  9. Jul 30, 2013 #5489 of 10413
    mattack

    mattack Active Member

    20,750
    4
    Apr 9, 2001
    sunnyvale
    ABSOLUTELY a coincidence.
     
  10. Jul 30, 2013 #5490 of 10413
    wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    Maybe not a coincidence. I had a similar report of the IR remote mode being reset to zero from someone who used my network remote to enter, I think, the system information screen. To which I could only advise, "Don't do that." It's a TiVo bug, not something the network remote does.

    No idea about the deleted folder though.
     
  11. Jul 30, 2013 #5491 of 10413
    mattack

    mattack Active Member

    20,750
    4
    Apr 9, 2001
    sunnyvale
    OK, maybe I misspoke.. I have no idea how kmttg could do that though!
     
  12. Jul 30, 2013 #5492 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    When you are on the system information screen, the remote code will get set to whatever it "sees". I just used the remote in the TiVo app to navigate to the "System Information" screen and, as I suspected, the remote code got changed to 0, so it would appear that a network remote has remote code of 0, which makes sense. I immediately exited from the remote app and used the physical remote to set it back to the correct value.
     
  13. Jul 31, 2013 #5493 of 10413
    scandia101

    scandia101 Just the facts ma'am

    10,520
    0
    Oct 20, 2007
    MN, greater...
    Thanks. It's not likely to happen again.
     
  14. Aug 1, 2013 #5494 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    I have an RFE: The ability to create an Auto Transfer entry from a ToDo list entry.
     
  15. Aug 2, 2013 #5495 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    For next release "Auto Transfers->Add selected titles" now works for Remote tables with show titles in addition to NPL tables.
     
  16. Aug 2, 2013 #5496 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    My thanks for the quick response.

    Edit: Works great!
     
  17. Aug 3, 2013 #5497 of 10413
    Hyrax

    Hyrax New Member

    112
    0
    Sep 1, 2007
    I just thought I'd thank you for KMTTG. It is a wonderful program and a joy to use.

    Thanks!
     
  18. Aug 3, 2013 #5498 of 10413
    murgatroyd

    murgatroyd Don't stop believin'

    25,395
    0
    Jan 5, 2002
    Berkeley CA
    I have a new computer (Win8), so I'm starting over with a fresh new install of kmttg.

    I'm not sure I grok how the FILES mode is supposed to work.

    Let's assume I have some TiVo recordings which I've transferred by other means (e.g. TiVo Desktop). Would I point the FILES directory in the kmttg configuration to the My TiVo Recordings folder, in order to make those visible?

    From the FILES tab, would I schedule a job from there, to have either tivodecode or VideoReDo decrypt the already-transferred file?

    Sorry to post such a stupid question, but my old computer has been down for so long, I've forgotten most of what I had learned from before.

    For Win8, where's the most logical place to put a My TiVo Recordings folder? IIRC under WinXP it was a separate folder on the same level as My Videos (not a subfolder under videos).
     
  19. Aug 3, 2013 #5499 of 10413
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,739
    9
    Apr 6, 2000
    SF Bay Area
    Under the Files tab, click on ADD and it will open a dialog window to navigate to where your videos are located. The options are ALL, Video, etc. You can then select which files to add to the Files tab, Holding CTRL and clicking will let you select multiple files, also you can also press CTRL-A to select all the files in that folder.
     
  20. Aug 3, 2013 #5500 of 10413
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    Question for anyone with series 3 tivos using kmttg.
    Are you able to schedule Season Passes and/or individual recordings with kmttg remote anymore? It's something that used to work but I just plugged in my S3 OLED unit to try it because of a recent reported problem and can't seem to get it to work anymore. If indeed it does no longer work then I will grey out the appropriate Remote buttons for next release.
     

Share This Page