1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. May 23, 2013 #5261 of 10413
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,726
    8
    Apr 6, 2000
    SF Bay Area
    Make Tivo connection, it might need a reboot after all its processing. The Tivo name is listed in the System Information screen.
     
  2. May 24, 2013 #5262 of 10413
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,726
    8
    Apr 6, 2000
    SF Bay Area
    When I have "Allow only 1 download at a time" checked, shouldn't it be for just 1 download at a time and allows other jobs such as decrypt, QSFix, encode to execute?

    I find it will do 1 job (decrypt, or qsfix, etc.) then a downloads starts and afterwards, it will not do another job until the download completes.
     
  3. May 24, 2013 #5263 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Yes looking at the code I see that if you have more than 1 download queued up and have that option turned on that all queued up jobs are prevented from starting until current download completes which is behavior you are seeing. I'll have to modify the logic to apply it to download jobs only as it should be.
     
  4. May 25, 2013 #5264 of 10413
    az1097

    az1097 New Member

    82
    0
    Apr 3, 2013
    I have rebooted the Tivo after the name change by the Tivo menu, it also rebooted just two days ago after receiving the new update and still both names appear. Would a reboot by unplugging make a difference?
     
  5. May 25, 2013 #5265 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    When you login to your tivo.com account does it show the same name new name you changed it to? There must still be 2 different MDNS broadcasts with different names & same IP happening on your network. Maybe under kmttg config-Tivos tab try enabling "Detect with TiVo Beacon instead of Bonjour" instead to see what happens. Or if you have static IP settings for you TiVos you can just disable "Look for Tivos on the network" completely for now so you don't have to deal with it.
     
  6. May 25, 2013 #5266 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    v1p0a version just released.

    Note that starting with this version you can now update kmttg installation directly from kmttg using Help->Update kmttg... menu entry.

    For Windows and Mac platforms you can also install the latest tools zip file from kmttg using Help->Update tools... menu entry.

    In addition to the ability to self update there are a few bug fixes and changes included in this version.

    NOTE: I'm transitioning kmttg from googlecode to sourceforge since Google Downloads are scheduled to be shut down for any new downloads. So in the future please use the new kmttg home to look for information & files:
    http://sourceforge.net/projects/kmttg/

    SourceForge Download link: kmttg_v1p0a.zip

    Consult release_notes Wiki for all the details.

    I've updated Google site also to contain this version for the benefit of those that don't know about the sourceforge site yet and so they can get this new version of kmttg with self updating capabilities to make it easy to get new versions going forwards.
     
  7. May 27, 2013 #5267 of 10413
    cherry ghost

    cherry ghost Active Member

    5,277
    5
    Sep 13, 2005
    Chicago
    Did something change with Atomic Parsley? --TVEpisode and --TVEpisodeNum used to have the same value. This is from a recent encode


    --TVEpisode 424 --TVEpisodeNum 24 --tracknum 424 --TVSeasonNum 4


    In the past, --TVEpisodeNum would also be 424
     
  8. May 27, 2013 #5268 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Yes. By request from AppleTV users (plus logically matching what that atom represents). From release notes:
    "Updated AtomicParsley run such that --TVEpisodeNum argument is just the episode # without season # for correct display by AppleTV and the like."
     
  9. May 27, 2013 #5269 of 10413
    cherry ghost

    cherry ghost Active Member

    5,277
    5
    Sep 13, 2005
    Chicago
    Ugh, now I have to rerun AP on everything I've encoded so that it sorts properly in iTunes
     
  10. May 29, 2013 #5270 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    It's a nasty bug for series 4 TiVos since not only do transfers not work, but it puts TiVo http server in "server busy" mode perpetually until rebooted. Since it's badly broken with 20.3.1 software I've updated code for next release to just ignore 'Resume Downloads' option for series 4 units (with a warning to that effect). Still useful to have for those with series 3 units which is why I didn't remove the option completely.
     
  11. May 29, 2013 #5271 of 10413
    mattack

    mattack Active Member

    20,743
    4
    Apr 9, 2001
    sunnyvale
    No, I was saying that transferring *FROM* my Premiere TO my TivoHD with transfer from paused point was broken.

    (Sorry, haven't fully kept up with the thread, if this was clarified later, sorry.. I will probably check this thread out again later today.)
     
  12. May 29, 2013 #5272 of 10413
    mattack

    mattack Active Member

    20,743
    4
    Apr 9, 2001
    sunnyvale
    Actually, I'm not sure about that server busy issue.. That it's perpetual that is.

    My P4 rebooted last night (after getting into a weird 'hung' situation a few times.. it would keep recording of course, and DID at least once eventually go back into Live TV.. then would react to some remote presses -- but eventually got back into hung mode -- and like many Tivos, if you hit enough remote keys when it's hung, it eventually reboots).. But ANYWAY.. Before that, I'm *almost* positive that over a few days, I was able to transfer a few things from my P4 *on the same boot* as trying resume from paused point in kmttg. I'd say I'm even MORE sure that it was the same boot as trying to resume from paused point from my TivoHD too.

    Though I also remember that I *did* get some kind of error shown in kmttg (maybe it was server busy).. the kind that you THINK will just keep repeating.. But on the retry, it started downloading fine.
     
  13. May 29, 2013 #5273 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    When I tested yesterday with my 2 tuner Premiere with 20.3.1 software I tried both Java and Curl modes and could no longer download anything after attempting Resume Downloads. After multiple reboots and tries without any luck I concluded it's best to turn off that feature for series 4 units since even if it does not kill the http server it doesn't work anyway.
    From my experiments it looks like MRV resume between series 4 units still works OK and MRS resume I use all the time and know it works fine. I don't have a series 3 unit plugged in anymore to test with.
     
  14. May 29, 2013 #5274 of 10413
    mlippert

    mlippert New Member

    59
    0
    Apr 2, 2010
    Massachusetts
    Yeah, that sounds wise. I wonder if this is an issue for TivoDesktop as well since I *think* it also supported transfer from pause point.

    I guess it'll be worth testing again to see if it's fixed after the next update to the Premiere, whenever that happens.
     
  15. May 29, 2013 #5275 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    I'm pretty sure TiVo Desktop never supported this, at least not the times that I explored it.
     
  16. May 29, 2013 #5276 of 10413
    species8472jj

    species8472jj New Member

    56
    0
    Dec 23, 2009
    Unfortunately, I had a computer crash, and I nearly have everything back up and running.

    I really like the KMTTG software, and I especially love the auto transfers feature which is why I need help getting it up and running.

    I am using Windows 7 and have version v1p0a of KMTTG.

    The program is downloading the program fine off my TiVo but it seems to crash when it moves on to the next step (decrypt).

    Below is an except from the log file which I hope is helpful. If anyone can offer any insight, it would be greatly appreciated.

    2013_05_28_09:14:46 ERROR: qsfix failed (exit code: 0 ) - check command: C:\Windows\system32\cscript.exe //nologo C:\KMTTG\VRDscripts\qsfix.vbs "C:\Users\Jim\Videos\Mega Disasters - Oil Apocalypse (05_29_2013).TiVo" "C:\Users\Jim\Videos\Mega Disasters - Oil Apocalypse (05_29_2013).ts.qsfix" /l:C:\KMTTG\VRDLock4304613647741015657.tmp /c:mpegts /v:mpeg2video /x:1280 /y:720
    2013_05_28_09:14:46 ERROR: C:\KMTTG\VRDscripts\qsfix.vbs(61, 4) WScript.CreateObject: Could not create object named "VideoReDo.VideoReDoSilent".
     
  17. May 29, 2013 #5277 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Take a look at VideoRedo_configuration Wiki page.
    2 important things:
    1. Make sure kmttg service is running using your account, not default Windows account
    2. Make sure you bring up the VideoRedo GUI at least once using same account (with Admin privileges) so it registers itself so WScript can find it.
     
  18. May 29, 2013 #5278 of 10413
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,726
    8
    Apr 6, 2000
    SF Bay Area
    What I was thinking was, his KMTTG wasn't setup properly for VRD.
     
  19. May 29, 2013 #5279 of 10413
    christheman

    christheman New Member

    166
    0
    Feb 20, 2013
    I was just wondering if you or anyone else have actually downloaded a "partial" file since the 20.3.1 upgrade. Does the Tivo still have this glitch, or might that have been corrected at the source?

    I know, I'm feeling optimistic this evening.
     
  20. May 29, 2013 #5280 of 10413
    mattack

    mattack Active Member

    20,743
    4
    Apr 9, 2001
    sunnyvale
    ????

    It sounds like you're talking about exactly what I and others have been talking about -- resume download is BROKEN.
     

Share This Page