1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Feb 26, 2013 #4861 of 10410
    christheman

    christheman New Member

    166
    0
    Feb 20, 2013
    I just loaded and tried the update. Good to see you were able to get the IMDB part in, it makes a big difference and opens things up.

    One other thing I had thought about, under the GUIDE sub-tab: Would there be any way to allow the user the option to just scroll through the entire list of show entries, without requiring them to use the pulldown menu, or are there too many entries to poll this information in one shot?
     
  2. Feb 26, 2013 #4862 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    It's intentionally structured to be 12 hours of data for 1 channel at a time to minimize the overhead time of collecting the data. Would be way too slow to try and do that for all channels at a time.
     
  3. Feb 26, 2013 #4863 of 10410
    dianebrat

    dianebrat I refuse to accept your reality TCF Club

    10,112
    73
    Jul 6, 2002
    boston'ish
    Dumb speed question since I'm using kmttg this week to off-load the shows from my S3 OLED to replace the drives.

    I'm only getting 14 Mbps type speeds, so HD items are effectively transferring at real time, am I right in thinking this is because the bottleneck is the S3 itself?
     
  4. Feb 26, 2013 #4864 of 10410
    wmcbrine

    wmcbrine Ziphead

    10,363
    22
    Aug 2, 2003
    Yes.
     
  5. Feb 26, 2013 #4865 of 10410
    Fofer

    Fofer XenForo Rocks! TCF Club

    82,086
    286
    Oct 29, 2000
    I've tried this. I see the web query address appear in kmttg's bottom pane. But it doesn't open a web page or even switch to my default browser. Should it? I'm on a Mac OS X 10.8.2 system, by the way.
     
  6. Feb 26, 2013 #4866 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    Theoretically, yes, but I don't have a Mac to test on. Looking at code for Mac it tries to execute the following system call:
    open "<url>"

    So for opening this thread for example it would be:
    open "http://www.tivocommunity.com/tivo-vb/forumdisplay.php?f=35"

    For linux platform by default it will call an actual browser by name if available based on list of popular browsers for linux, but there's also linux only option in kmttg config Visual tab to specify what to use for browser executable. Sounds like Mac may benefit from having that option available as well since the above apparently doesn't work.
     
  7. Feb 26, 2013 #4867 of 10410
    ccrider2

    ccrider2 New Member

    100
    0
    Nov 1, 2007
    If I change both tuners to a channel I don't get, My speed jumps up to about 20. (takes a burden off the CPU...not having to record the 2 buffers while transferring) If that don't help, try rebooting the TiVo...sometimes helps.

    Good Luck,
    Cheers
     
  8. Feb 26, 2013 #4868 of 10410
    dianebrat

    dianebrat I refuse to accept your reality TCF Club

    10,112
    73
    Jul 6, 2002
    boston'ish
    I can wait it out, just wanted to be sure I didn't have another issue. :)
     
  9. Feb 26, 2013 #4869 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    Quick bug fix version v0p9n just released to fix a couple of issues:

    * Fix to auto transfers mode to prevent double processing for mind-enabled series 3 units when retrieving NPL.
    * Web browser call on Mac platform now uses same method as for Linux and the web browser executable can be explicitly set under "Visual" tab option "web browser binary".
     
  10. Feb 26, 2013 #4870 of 10410
    Fofer

    Fofer XenForo Rocks! TCF Club

    82,086
    286
    Oct 29, 2000
    Thank you very much!

    I downloaded and am trying the new version. What is the syntax for entering this? I have tried:

    /Applications/Safari.app
    \Applications\Safari.app
    Macintosh HD:Applications:Safari.app
    file://localhost/Applications/Safari.app

    and all sorts of other variations... and none seem to work.
     
  11. Feb 26, 2013 #4871 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    Perhaps try something as in this thread:
    http://stackoverflow.com/questions/5721528/terminal-command-to-open-safari

    /usr/bin/open -a Safari

    According to that thread what I had in place in last release should have worked as well:
    open <url>

    If that still doesn't work then perhaps try:
    sh -c /usr/bin/open -a Safari

    Or it could be as simple as:
    Safari

    Hopefully one of those will work...
     
  12. Feb 27, 2013 #4872 of 10410
    Fofer

    Fofer XenForo Rocks! TCF Club

    82,086
    286
    Oct 29, 2000
    I hate to be the bearer of bad news but none of those worked.
     
  13. Feb 27, 2013 #4873 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    Go to the command line and try things from there. In Linux it's trivial. As long as the executable is somewhere in your PATH you can run without specifying full path. So for example on my Linux box I just put "firefox". I don't know anything about Mac OS to help you further but maybe someone else more familiar with Mac can help out.
     
  14. Feb 27, 2013 #4874 of 10410
    christheman

    christheman New Member

    166
    0
    Feb 20, 2013
    Here is something I found in a quick search. I am including this as it appears to offer something new and is dated fairly recently from October 20, 2012:
    http://alvinalexander.com/java/mac-java-open-url-browser-osascript

    In particular, I see this bit being used:
    Code:
    String[] args = { "osascript", "-e", "open location \"" + url + "\"" };
    the backslash escape characters and syntax double quotes removed might look something like:
    Code:
    open location {url}
    The use of the word "location" as a command line argument seems to not have been mentioned yet. Give that a try.

    Also, moyekj might want to verify use of "osascript" and "-e" as used in this particular situation.

    EDIT: another [open location "url"] example:
    http://forums.macrumors.com/showthread.php?t=916578
     
  15. Feb 27, 2013 #4875 of 10410
    Fofer

    Fofer XenForo Rocks! TCF Club

    82,086
    286
    Oct 29, 2000
    Okay. I will try.
    Code:
    open /Applications/Safari.app
    ...works in Terminal.

    But not in KMTTG. :(

    Hopefully other Mac users out there can try.
     
  16. Feb 27, 2013 #4876 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    Does this work from Terminal?
    open "http://www.tivocommunity.com/tivo-vb/forumdisplay.php?f=35"

    If so try just "open" as the command in kmttg. The way it's being called there can't be any spaces in the executable name called from kmttg.
     
  17. Feb 27, 2013 #4877 of 10410
    Fofer

    Fofer XenForo Rocks! TCF Club

    82,086
    286
    Oct 29, 2000
    Ha! Yes! That did it. Simply typing "open" under "Visual" tab option "web browser binary" did the trick! :D :up:
     
  18. Feb 27, 2013 #4878 of 10410
    howards

    howards New Member

    76
    0
    Oct 31, 2007
    kmttg vop9n (and earlier versions) are giving me a message on one of my two Series 2 Tivos that says:

    -----------
    Can't determine bodyId for TiVo: <name redacted>
    RemoteInit - (IP=middlemind.tivo.com, port=443): null
    -----------

    Still, it seems to work fine. Is this something that should concern me, and is there an easy fix?

    If the number that can't be found is the device number starting with 649 for a series 2, I checked that my account on tivo.com shows it, but I don't know anything about middlemind.tivo.com.
     
  19. Feb 27, 2013 #4879 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    Strange that the original implementation in last release didn't work for you then because it did just that... (though I think I had quotes around url which may have screwed it up).
     
  20. Feb 27, 2013 #4880 of 10410
    moyekj

    moyekj Well-Known Member

    11,132
    27
    Jan 23, 2006
    Mission...
    kmttg needs the TSN # to determine if machine is mind enabled, and if it can't get the TSN from Bonjour then it tries to get it from middlemind.tivo.com if you have TiVo username & password specified. If you login to this page do you see your S2 TiVo listed as one of the options?
    https://www3.tivo.com/tivo-tco/go.do?def=tco.todo.page
    If not then that's probably why.

    I'm not sure if S2 TiVos used Bonjour to advertise themselves or not. Perhaps if you let kmttg use TiVo Beacon to detect TiVos for a few minutes your S2 TSN should be found: Configure-Tivos-Detect with TiVo Beacon instead of Bonjour (and make sure "Look for Tivos on network" is enabled). Once the TSN is found it's saved for next session so then those error messages should go away.
     

Share This Page