1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Feb 17, 2013 #4781 of 10413
    morac

    morac Cat God

    8,946
    22
    Mar 14, 2003
    NJ
    I found a very simple set and forget work around for TiVo Desktop.
    See this post for details.

    Basically you need to add cookie = "sid=abc" to the curl configuration file that TiVo Desktop uses.
     
  2. Feb 17, 2013 #4782 of 10413
    twdix

    twdix New Member

    8
    0
    Feb 27, 2007
    "edit the "sid" cookie to expire at a later date"

    Can you explain how to do this?

    Disregard my question... The fix described in the post 30 of the "Sudden file transfer failure: kmttg and Tivo Desktop" thread works perfectly.
     
  3. Feb 17, 2013 #4783 of 10413
    pesto126

    pesto126 New Member

    16
    0
    Dec 15, 2007
    Just ran into a strange issue that I am hopeful you all can help with.. so, once I got the whole Jave vs Curl thing figured out and can download programs again (Whohoo)... I noticed that my episode numbers appear to be off by one in the metadata files.

    For example - here is a dump from a file I downloaded off my TIvo premier this afternoon:

    title : Too Cute!
    seriesTitle : Too Cute!
    description : A Shar-Pei keeps his toys away from his siblings; a young cairn terrier sets off on an adventure; a tiny boxer's grandfather steers him toward glory.
    time : 2013-02-09T21:00:00Z
    isEpisode : true
    iso_duration : PT59M58S
    originalAirDate : 2012-12-22T00:00:00Z
    episodeTitle : Puppy Love
    isEpisodic : true
    showingBits : 4611
    tvRating : x3
    episodeNumber : 207
    displayMajorNumber : 630
    callsign : APLHD
    seriesId : SH01391049
    programId : EP013910490014
    vProgramGenre :
    vSeriesGenre :
    vSeriesGenre :

    Episode Title shows as Puppy Love and episode number a 207 - when I look this up on TVDB - Puppy Love shows as episode 208.. The program really is Puppy Love.. but the number appears wrong.

    I tried it again on a Tivo HD machine using How It's Made... same issue:

    title : How It's Made
    seriesTitle : How It's Made
    description : Iron bathtubs; hopi kachina dolls; mine truck engine.
    time : 2013-02-16T09:30:00Z
    isEpisode : true
    iso_duration : PT30M
    originalAirDate : 2012-12-04T00:00:00Z
    isEpisodic : true
    showingBits : 4611
    tvRating : x3
    episodeNumber : 2010
    displayMajorNumber : 622
    callsign : SCIHD
    seriesId : SH415402
    programId : EP4154020545
    vProgramGenre : Documentary
    vProgramGenre : Science
    vSeriesGenre : Documentary
    vSeriesGenre : Science
    vSeriesGenre : Documentary
    vSeriesGenre : Science and Nature
    vHost : Adams|Lynne

    The show is about Iron Bathtubs.. but should be listed as 2011 (season 20, episode 11).

    Has anyone else noticed this? I typically wouldn't care except I'm also using a Plex server which is crazy particular about episode naming or it doesn't work properly...

    Thx!!
     
  4. Feb 17, 2013 #4784 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    pesto126, the problem is the local TiVo guide database does not always have accurate episode information, and in many cases doesn't have episode information at all. For series 4 units kmttg uses alternate sources to supplement the metadata which typically is more accurate and complete. Technically something similar could be done for series 3 units (getting additional info from middlemind.tivo.com) but that is not currently implemented in kmttg.
     
  5. Feb 17, 2013 #4785 of 10413
    pesto126

    pesto126 New Member

    16
    0
    Dec 15, 2007
    Thanks Moyekj - thought it was something like that. Oh well.. in the end, its not that important.. just wish this was more accurate or could be intercepted by kmttg and updated using TVDB to generate the episode number.
     
  6. Feb 17, 2013 #4786 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    The information available from thetvdb.com isn't always accurate either. You have to remember, it is mostly entered by users.

    Data for those two series on zap2it is very confusing. "Too Cute!" has no season & episodes numbers at all and is listed by year.

    Information for "How It's Made" is even more confusing. Neither zapt2it nor the TiVo admit to the existence of a season 20, while both IMDB and thetvdb agree there is one but disagree on which episode is which. The only source that has information about an episode whose OAD is 12/04/2012 is zap2it, and that is only if you look at the page for that particular programId (http://tvlistings.zap2it.com/tv/how-its-made/EP004154020545?aid=zap2it)
     
  7. Feb 17, 2013 #4787 of 10413
    andrew1883

    andrew1883 New Member

    45
    0
    Apr 25, 2008
    I ran into this problem and was advised (in another thread here) to look at the latest kmttg and other options. Downloaded v0p9l (was using v0p7m) and it's transferring fine!

    I'll add my thanks to the others' for the quick response (and add my contempt for TiVo's response quoted above).

    =aw
     
  8. Feb 17, 2013 #4788 of 10413
    gtstephenson

    gtstephenson New Member

    7
    0
    Jan 12, 2009
    I tried to install kmttg_v0p91l but find the jar file (having been properly associated) will not properly open the application.

    Yes, I did uninstall my 64 bit java and install the latest 32 bit flavor. I did manually associate the javaw.exe file with kmttg.jar and when I look at running services the app is running but nothing is presented on the screen.

    One more clue:
    assoc .jar=jarfile gives me "Access is denied" response. Had to associate the file with right click on the kmttg.jar and point to java.

    Ideas anyone?

    Tom S
     
  9. Feb 17, 2013 #4789 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Read the Wiki page:
    http://code.google.com/p/kmttg/wiki/windows_installation

    If you don't have proper association then follow instructions given in the Wiki with administrator account. You probably need to set the jarFile association from Administrator cmd prompt with something like (adjust to proper full path to your javaw.exe):
    ftype jarfile="C:\Program Files (x86)\Java\jre6\bin\javaw.exe" -jar "%1" %*
    (Java installer typically takes care of this for you so not sure why it's not the case for you).
     
  10. Feb 17, 2013 #4790 of 10413
    AlMejias

    AlMejias New Member

    4
    0
    Feb 17, 2013
    Thanks for the tip! So far, it seems to be working! I'll know for sure in a day or two.

    In my case there was no curl.conf file in my Tivo Desktop install or config folders so I created a file in the suggested folder and added that line to it. It worked! Until there is a permanent fix that will work with the browser download method as well, this will do.
     
  11. Feb 18, 2013 #4791 of 10413
    SixString

    SixString New Member

    22
    0
    Jan 7, 2003
    My ReadyNAS will automatically back up all KUID files. As of yesterday, it fails with the same error message (Session ID missing). Unfortunately, I can't reset the time on my NAS!

    Hopefully, Tivo will push out a fix, but I wonder if they'll bother with older HD units (like mine).
     
  12. Feb 18, 2013 #4792 of 10413
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,726
    8
    Apr 6, 2000
    SF Bay Area
    If you are using KMTTG, update it.
     
  13. Feb 18, 2013 #4793 of 10413
    degobahjunk

    degobahjunk New Member

    48
    0
    Jan 10, 2009
    I've been googling, uninstalling, re-installing, re-booting, using the TiVoDesktopCleaner, clearing my cache, moving files, system restore.... on & on. :mad: I could not figure out why the last day my files transferred was 2/15/13. I have a laptop running XP Pro SP3. I use Desktop 2.5.1 & I kept getting, "An internal error has occurred." I just recovered last week from a complete hard drive failure and subsequent replacement, and have been slowly getting all my programs up & running, codecs figured out, etc. Just when I thought I got TiVo Desktop 2.5.1 working great, it show all my programs on my TiVo HD but then just wouldn't transfer them for the last few days. Thank you to notting :) for posting this crazy simple "fix." I hope TiVo fixes this for real soon, because I can't keep the date wrong on my computer all the time..... :(
     
  14. Feb 18, 2013 #4794 of 10413
    unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    morac's already figured out the fix for TiVo Desktop (though I wonder why you're running an older version of it)

    http://www.tivocommunity.com/tivo-vb/showthread.php?p=9527463#post9527463

    Basically you add a line of text to the curl.conf file in your TiVo Desktop installation, or just overwrite it with the one he provides.

    I've already done it and it works great, like there was never a problem in the first place.
     
  15. Feb 18, 2013 #4795 of 10413
    jcthorne

    jcthorne Active Member

    2,721
    3
    Jan 28, 2002
    Houston
    Thanks for the quick update. Yes the new version works fine using either java or curl to download.

    Now I have a question. Is there any reason to use one method or the other when both work? I see no difference in trasfer speed.
     
  16. Feb 18, 2013 #4796 of 10413
    degobahjunk

    degobahjunk New Member

    48
    0
    Jan 10, 2009
    I had a lot of problems when I upgraded a few years ago.... so I downgraded voluntarily. I can't seem to get Morac's curl.conf solution to work.

    I downloaded the curl.conf file right into my TiVo Downloads folder (since I didn't have one at all, I think I deleted it yesterday in my hours & hours of trying everything I could think of or read about with the "An internal error occurred" issue I was having until I finally found a few threads on here that actually addressed the real problem) but as soon as I changed my computer's calendar date to the actual date, the transfers failed again.

    Thinking I need to reboot... again....
     
  17. Feb 18, 2013 #4797 of 10413
    unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    For the edification of future readers, I quote myself again:

    " To quote myself from another thread

    "You may be looking for it in the wrong place.

    Desktop install in Program Files, but also sticks some stuff, including curl.conf, in the user profile section.

    That morac post I link to shows how to find it for XP and Vista and up. "

    For instance, here's where mine is on an XP machine

    C:\Documents and Settings\unitron\Local Settings\Application Data\TiVo Desktop "
     
  18. Feb 18, 2013 #4798 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Not really. Years ago some had issues getting curl downloads to work reliably for whatever reason so pure java-based alternative was created.
     
  19. Feb 18, 2013 #4799 of 10413
    cautionespn

    cautionespn Grand PooBah

    53
    0
    Feb 21, 2003
    Salem,MA
    Here is an easier workaround for this.
    1. Go to /Applications
    2. Find iTivo, right click and choose "Duplicate"
    3. Right click on the newly created iTivo Copy and choose "Show Package Contents"
    4. Navigate to Contents > Resources and find http-fetcher.pl
    5. Edit this in your favorite text editor
    6. On the line with:

      Code:
      $shellScript = "curl -q \'http://$tivoip\:80/download/$showNAME\.TiVo?Container=%2FNowPlaying&id=$showID\' -c /tmp/cookies.txt --retry 12 --retry-delay 10 --digest -u tivo:$MAK -o $target --stderr $TivoDir/iTiVoDL";
    7. Change to:

      Code:
      $shellScript = "curl --cookie sid=abc -q \'http://$tivoip\:80/download/$showNAME\.TiVo?Container=%2FNowPlaying&id=$showID\' -c /tmp/cookies.txt --retry 12 --retry-delay 10 --digest -u tivo:$MAK -o $target --stderr $TivoDir/iTiVoDL";
    8. Save and launch. Problem gone.
     
  20. Feb 18, 2013 #4800 of 10413
    MHunter1

    MHunter1 TiVo Bug Hunter

    286
    0
    Oct 11, 2007
    Silicon Valley
    For those of us who prefer transferring shows using TiVoPlayList (rather than KMTTG, pyTiVo, or Desktop), is there any solution other than changing the clock back?
     

Share This Page