1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Jun 24, 2012 #4121 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    If the picture is not distorted when you watch it on the TiVo, I assume that these are movies that are wider than 16:9. I also assume that the TiVo and the DVD player are on two different TVs.

    While this doesn't directly address your question, have you tried changing the settings on the DVD player or the display mode of the TV?
     
  2. Jun 24, 2012 #4122 of 10413
    catfan64

    catfan64 Member

    219
    0
    Mar 6, 2002
    Louisville KY
    I just noticed that in the program info for the show on the Tivo, it notes "letterbox". And if i am viewing it from my tivo, on my HD 16:9 TV, set at "normal", it has black bars all the way around. On "normal", the tivo menus have black bars on the left and right, so I keep it set at "wide", so the tivo menus fill the screen. I guess the recordings are actually being stretched to the left and right. Also note, that these are NOT HD recordings. This is a series 2 Tivo, and I am hooked up to cable, and do NOT have a HD cable converter box, so I assume everything I recieve is in standard definition/format.

    Yes, the TiVo and the DVD player are on two different TVs. The TV with the DVD palyer is also a 16:9 HD tv.

    I have tried using the ZOOM setting on the tv with the dvd player, and while it fills the screen, it also crops it in a way, that you loose some of the picture, and it degrades the picture quality noticably.

    I'm sure this is probably getting real confusing to you now. It's confusing me!!!!




    __________________
     
  3. Jun 24, 2012 #4123 of 10413
    catfan64

    catfan64 Member

    219
    0
    Mar 6, 2002
    Louisville KY
    Another thing i just realized. My Series 2 tivo is is hooked up to my HD TV using RCA composite cable (red, white, and yellow), as the Series 2 Tivo does not have HDMI or component outputs. In the TIVO settings for TV Aspect Ratio, I have it set on "Widescreen 16:9, but with the TV set to normal, the tivo menus have a black bars on the left and right. I would think that since the TIVO output is set to Widescreen 16:9, then it would fill the whole screen. Also, I have tried changing the Tivo TV Aspect Ratio to 4:3, and it does not change how it shows on the TV.
     
  4. Jun 24, 2012 #4124 of 10413
    warehouse

    warehouse New Member

    34
    0
    Aug 31, 2003
    Sorry if this has been asked before but I've searched through this whole thread and can't seem to find the answer. I would like to use kmttg to automatically transfer and encode HD files from my Tivo to a format which I can burn to a DVD. My understanding is that they need to be MPEG-2 in either mpg or avi containers for me to use something like "Windows DVD maker" to author the DVD. Unfortunately none of the installed encoder profiles I've seen in kmttg support this mode. Do I need to somehow create a new profile to support this? Is there an existing profile somewhere I can just add to the profiles directory?
     
  5. Jun 24, 2012 #4125 of 10413
    droedl

    droedl New Member

    2
    0
    May 29, 2008
    I was unable to find a similar question in search.

    I am getting the following when I try to launch kmttg.jar. "The Jave file kmttg.jar could not be launched. Check the Console for details." This is on a machine that I have used the program on before. I did transfer data from one hard disk to another recently, to an SSD. I have a similar configuration running on the same network on a Mac Mini with no issues.

    Any tech interpreters out there who can read the tea leaves and explain what the console log is pointing to?


    6/24/12 4:14:56.886 PM [0x0-0xfa0fa].com.apple.JarLauncher: Exception
    6/24/12 4:14:56.887 PM [0x0-0xfa0fa].com.apple.JarLauncher: in thread "main"
    6/24/12 4:14:56.888 PM [0x0-0xfa0fa].com.apple.JarLauncher: java.lang.NoClassDefFoundError: com/tivo/kmttg/main/kmttg
    6/24/12 4:14:56.889 PM [0x0-0xfa0fa].com.apple.JarLauncher: Caused by: java.lang.ClassNotFoundException: com.tivo.kmttg.main.kmttg
    6/24/12 4:14:56.890 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    6/24/12 4:14:56.890 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.security.AccessController.doPrivileged(Native Method)
    6/24/12 4:14:56.895 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    6/24/12 4:14:56.896 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    6/24/12 4:14:56.896 PM [0x0-0xfa0fa].com.apple.JarLauncher: at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    6/24/12 4:14:56.897 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.lang.ClassLoader.loadClass(ClassLoader.java:247)



    Things I have tried:
    Downloading and installing a fresh copy.
    Making sure java is active and working.
    Repairing disk permissions.

    Platform: Mac OS X 10.7
    MacBook Pro mid 2009
     
  6. Jun 24, 2012 #4126 of 10413
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,726
    8
    Apr 6, 2000
    SF Bay Area
    Use the Decrypt option in KMTTG, that will make them .mpg. You can then use VideoReDo TVSuite (windows only) to edit out commercials and burn to DVD. Its not free but it works.
     
  7. Jun 24, 2012 #4127 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    On a Mac you should launch "kmttg" script not "kmttg.jar". If there is a permissions problem then first do the following from command prompt:
    chmod +x kmttg
    ./kmttg
     
  8. Jun 24, 2012 #4128 of 10413
    droedl

    droedl New Member

    2
    0
    May 29, 2008
    Well I have been using the .jar file for the past couple years and for some reason it worked, still works on the mini. However, I just used your method and now kmttg is working on the affected machine. I appreciate it. I'm looking forward to doing some decrypting and encoding with the new SSD on the MBPro and seeing what it can do. Thanks!
     
  9. Jun 24, 2012 #4129 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    I don't remember and can't currently access my TiVo 2 (also connected to a 16:9 screen) but that is probably normal to avoid distorting the picture. You might try playing with various combinations of TiVo "Aspect Correction Mode" using the "Zoom" or "Window" button on the TiVo remote (if it works on a TiVo 2) and the TV's picture size.

    The behavior of the DVD player sounds like the same problem I had when playing back a 16:9 SD recording on Premiere connected to a 16:9 TV. I used to record things like Law&Order from the SD channel on my THD since they would normally be viewed on a 4:3 TV and they are letterboxed. It was so annoying when I ended up watching on my Premiere that I switched to the HD channel. Again though, you might try various combinations of DVD player settings and TV picture size.

    Hopefully someone else has encountered your problem and can answer your original question about an encoding profile.
     
  10. Jul 1, 2012 #4130 of 10413
    range rat

    range rat New Member

    9
    0
    Mar 7, 2007
    Hi, newbie here. I've been encoding some .tivo files to .mp4's and can't seem to get the voice to sync. I'm using the ff_ipad profile and I'm not resorting to taking out commercials just yet. I just need to get 'em off the Premiere's hard disk to make room, but would like to enjoy the vids elsewhere. What am I doin' wrong?

    Jon
     
  11. Jul 1, 2012 #4131 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    You need to run the QS Fix step either using VideoRedo if you have it else ProjectX.
     
  12. Jul 1, 2012 #4132 of 10413
    range rat

    range rat New Member

    9
    0
    Mar 7, 2007
    Thanks, just dug that up. Doin' it now.

    Jon
     
  13. Jul 1, 2012 #4133 of 10413
    lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    Hey moyekj,

    I just noticed something. Running a previous version of kmttg under Linux, the CPU usage was very low, except when it was running a demux/decrypt or comskip operation. I recently upgraded to the most recent version of kmttg, and now whenever kmttg is running, java pegs both CPU meters. Do you have any idea what might be the issue? I cannot categorically state it has happened ever since the upgrade, but the upgrade was done only a few days ago, and I noticed the pegged CPUs just the day before yesterday. Looking at it last night and today, top shows java eating up more than 130% of a full CPU load, and the usage meters drop right off when I stop kmttg.
     
  14. Jul 2, 2012 #4134 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Not sure, but obviously that's not normal. The whole program runs a master loop with msecs between operations thus keeping CPU consumption to a minimum for Java stuff. Perhaps in your upgrade you upgraded Java version to 7 or something newer than you had before? Also you should try both in GUI and background/batch modes to see if there is any difference.
     
  15. Jul 2, 2012 #4135 of 10413
    range rat

    range rat New Member

    9
    0
    Mar 7, 2007
    Hi,

    My computer was merrily grinding away at its tasks when it had a hiccup and shut down (I know why; it's old). Restarting kmttg let it resume where it had left off (I had "Automatically restore job queue between sessions" on) and it continues, writing over the last interrupted outputs as expected. However, I can't find the job queue displayed anywhere; it used to be in the middle listbox showing status. Any idea how to bring that up -- I like watching the colored bar get bigger as it goes?

    :p

    Thanks,

    Jon
     
  16. Jul 2, 2012 #4136 of 10413
    lpwcomp

    lpwcomp Active Member

    8,081
    2
    May 6, 2002
    John's...
    2 related RFEs.

    1. Add "pyTivo Push destination" to specific Auto-transfer settings.

    2. Add support for push to remote TiVos.

    Plus a question: does the communication interface enable the creation of a manual recording?
     
  17. Jul 2, 2012 #4137 of 10413
    range rat

    range rat New Member

    9
    0
    Mar 7, 2007
    And another question: If I quit the app while it's working on something, will it resume where it left off in the output files, or will it just restart that task again?
     
  18. Jul 2, 2012 #4138 of 10413
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,726
    8
    Apr 6, 2000
    SF Bay Area
    Auto-Resume is not supported on the Tivo, it would just start over again.

    An alternative is to use the 'Transfer from paused point' option, but you would have separate files, and duplicate filenames, and if you have overwrite files on, with overwrite off, it would not transfer at all.

    I have used the 'paused point' transfer method, and simply used the commercial break, to find and join the files using VideoReDo.
     
  19. Jul 2, 2012 #4139 of 10413
    lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    Nope. The only thing I upgraded ws kmttg. I downloaded the newest version.

    Code:
    RAID-Server:~# java -version
    java version "1.6.0_18"
    OpenJDK Runtime Environment (IcedTea6 1.8.3) (6b18-1.8.3-2)
    OpenJDK 64-Bit Server VM (build 16.0-b13, mixed mode)
    

    You mean the -a and -b switch? They don't run, but then I don't have any batches or automatic transfers set up:

    Code:
    RAID-Server:~# kmttg -a
    RAID-Server:~# ERROR: Address already in use
    STARTING AUTO TRANSFERS
    ERROR: No auto keywords setup
    ERROR: No keywords defined in /usr/share/kmttg/auto.ini... aborting
    EXITING BATCH MODE
    SHUTTING DOWN
    RAID-Server:~# kmttg -b
    RAID-Server:~# ERROR: Address already in use
    STARTING BATCH MODE SINGLE LOOP TRANSFERS
    ERROR: No auto keywords setup
    ERROR: No keywords defined in /usr/share/kmttg/auto.ini... aborting
    EXITING BATCH MODE
    SHUTTING DOWN
    
    The "Address already in use" messages are odd, though.
     
  20. Jul 3, 2012 #4140 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    I run kmttg on a Linux system with CentOS 5.4 (Kernel Version 2.6.18-164.el5) and monitor using htop and java CPU is 0% when just sitting in GUI doing nothing.

    /usr/bin/java -version
    java version "1.6.0"
    OpenJDK Runtime Environment (build 1.6.0-b09)
    OpenJDK 64-Bit Server VM (build 1.6.0-b09, mixed mode)

    Don't know if it has anything to do with problem but perhaps try turning off "Look for Tivos on network" under config-Tivos tab to see if that changes anything.
     

Share This Page