1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Sep 16, 2011 #3281 of 10921
    moyekj

    moyekj Well-Known Member

    11,377
    126
    Jan 23, 2006
    Mission...
    If you have a hacked series 3 with TWP then you can turn on "Enable TivoWebPlus Delete task" under kmttg config->Program Options. Then OK the form and re-start kmttg. Now after you populate NPL you can use the "delete" key to remove programs.
     
  2. Sep 19, 2011 #3282 of 10921
    LarryYBH

    LarryYBH New Member

    12
    0
    Nov 2, 2002
    Pittsburgh PA
    I'm new to kmttg, and if someone's already asked this question, I haven't been able to find it. I've used the program to do two things at this point: first, take a file from my TiVo and bring it over to my iMac; and second, take a file that's already on my iMac (transferred using iTivo) and create an output file from it that's playable on my iMac.

    The problem is volume -- neither of the two video files have any volume. The one on my TiVo has sound when played on my TV, and the one that's already on my iMac has sound when I play it through Windows.

    Is there something that I've missed in the use of kmttg? Am I doing something wrong, that causes the files to have no sound?

    Thanks!

    Larry
     
  3. Sep 19, 2011 #3283 of 10921
    txporter

    txporter One sec, almost done

    666
    0
    Sep 17, 2006
    Austin, TX
    I am not very familiar with macs, but it sounds like a codec problem. Did you transcode the video to a mp4 file with AC3 sound? Can macs play mp4 (H.264 + AC3)? That would be my guess.
     
  4. Sep 19, 2011 #3284 of 10921
    LarryYBH

    LarryYBH New Member

    12
    0
    Nov 2, 2002
    Pittsburgh PA
    I've played other mp4's, and if I understand correctly, Perian (which I have installed) handles AC3.
     
  5. Sep 19, 2011 #3285 of 10921
    moyekj

    moyekj Well-Known Member

    11,377
    126
    Jan 23, 2006
    Mission...
    Examine the video with mediainfo. If that reports there is an audio stream then the problem is whatever software/codec you are using for playback. Note that as mentioned AC3 audio stream in mp4 container is a relatively new spec that not many players support. VideoLAN VLC for example can, so you can try that.
     
  6. Sep 20, 2011 #3286 of 10921
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    I use "-vol 900" in my ffmpeg encoding profiles to boost up the volume a bit.
     
  7. Sep 24, 2011 #3287 of 10921
    moyekj

    moyekj Well-Known Member

    11,377
    126
    Jan 23, 2006
    Mission...
    v0p8h version just released with some minor enhancements. See release_notes for details.
     
  8. Sep 24, 2011 #3288 of 10921
    Soapm

    Soapm Active Member

    1,572
    1
    May 9, 2007
    So close,...
    Thanks for this program. I just started using it to get the shows off my S2DT and it's moving right along. I am getting much higher speeds than I was getting using PyTivo. At this rate I can retrieve all the shows in the next week or so.

    PS... Superpatch was run on my Tivo, do I still need to decrypt?
    I don't mind leaving the files as .tivo since I will more than likely move them to my new Tivo. Any reason for me to convert the to .mpg? Any advatage in using .mpg or .tivo?
     
  9. Sep 24, 2011 #3289 of 10921
    moyekj

    moyekj Well-Known Member

    11,377
    126
    Jan 23, 2006
    Mission...
    If you're going to move them to another TiVo then best thing to do IMO is just leave them as .tivo. If you change your mind later on it's easy to start from .tivo files and decrypt them if necessary.
     
  10. Sep 24, 2011 #3290 of 10921
    Soapm

    Soapm Active Member

    1,572
    1
    May 9, 2007
    So close,...
    Cool, that should cut down the time per file slightly but it will add up over the 1TB of stuff I have.

    Thanks again for the great program...

    PS... Anyway to tell my average download speed? I notice I can click on the file and see the speed of parts but I was wondering overall how is it doing? Also, not that I'm complaining but any way to speed it up?
     
  11. Sep 25, 2011 #3291 of 10921
    wmcbrine

    wmcbrine Ziphead

    10,450
    60
    Aug 2, 2003
    I have to question if you're seeing this correctly. There should be no difference.
     
  12. Sep 25, 2011 #3292 of 10921
    cweb

    cweb Member

    106
    0
    May 29, 2004
    How many days out does kmttg look for season premiers? It appears that I only get 5-7 days out.
     
  13. Sep 25, 2011 #3293 of 10921
    moyekj

    moyekj Well-Known Member

    11,377
    126
    Jan 23, 2006
    Mission...
    12 days ahead which is usually the max available from TiVo listings. Of course since it uses your TiVo it depends how many are available from your TiVo guide listings. Right now with restricted channels I ran a search and my last match is 10 days ahead (House: 10/03 on Fox). You can sort by date once search completes to see listings in date order rather than channel order.
     
  14. Sep 25, 2011 #3294 of 10921
    Soapm

    Soapm Active Member

    1,572
    1
    May 9, 2007
    So close,...
    I understand that and can't explain the difference but I am still humming along with this software but py was snailing...

    I'm going to try your fork when I get a break in my action but for now I'm keeping the queue loaded and the files moving...
     
  15. Sep 26, 2011 #3295 of 10921
    cburbs

    cburbs New Member

    158
    0
    Jan 29, 2009
    I am getting this error with a show for my kids - The encode file works fine on other files from the tivo. I can put this file in handbrake and it encodes fine.

    Encoding failed (exit code: 0 ) - check command: C:\Tivo\kmttg_v0p8g\handbrake\HandBrakeCLI.exe -i "E:\converted files\KMTTG\MPGCut\09_ 23_2011 Tazzy Chris.mpg" --cpu 4 -e x264 -q 22.0 -a 1,1 -E faac,copy:ac3 -B 160,160 -6 dpl2,auto -R Auto,Auto -D 0.0,0.0 -f mkv --detelecine --decomb --loose-anamorphic -m-x b-adapt=2:rc-lookahead=50 -o "\\msi-nas\files\movies\TVShows\09_ 23_2011 Tazzy Chris.mkv"
    [09:25:11] hb_init: checking cpu count
    [09:25:11] hb_init: starting libhb thread
    HandBrake 0.9.4 (2009112300) - MinGW i386 - http://handbrake.fr
    4 CPUs detected
    Forcing 4 CPUs
    Opening E:\converted files\KMTTG\MPGCut\09_ 23_2011 Tazzy Chris.mpg...
    [09:25:11] hb_scan: path=E:\converted files\KMTTG\MPGCut\09_ 23_2011 Tazzy Chris.mpg, title_index=1
    [09:25:11] scan: trying to open with libdvdread
    libdvdnav: Using dvdnav version 4.1.3
    libdvdread: Encrypted DVD support unavailable.
    libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
    libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
    libdvdread: Can't open file VIDEO_TS.IFO.
    libdvdnav: vm: failed to read VIDEO_TS.IFO
    [09:25:11] dvd: not a dvd - trying as a stream/file instead
    [09:25:11] file is MPEG DVD Program Stream
    [09:25:12] hb_demux_ps: not a PS packet (000001be)
    [09:25:12] hb_demux_ps: not a PS packet (000001be)
    [09:25:12] hb_demux_ps: not a PS packet (000001be)
    [09:25:12] hb_demux_ps: not a PS packet (000001be)
    [09:25:12] add_audio_to_title: added AC3 audio stream 0x80bd
    [09:25:12] scan: decoding previews for title 1
    [09:25:12] scan: audio 0x80bd: AC-3, rate=48000Hz, bitrate=384000 Unknown (AC3) (2.0 ch)
    Scanning title 1...
    [09:25:12] scan: could not get a decoded picture
    [09:25:12] scan: could not get a decoded picture
    [09:25:12] scan: could not get a decoded picture
    [09:25:12] scan: could not get a decoded picture
    Scanning title 1...
    [09:25:12] scan: could not get a decoded picture
    [09:25:12] scan: could not get a decoded picture
    [09:25:12] scan: could not get a decoded picture
    Scanning title 1...
    [09:25:13] scan: could not get a decoded picture
    [09:25:13] hb_demux_ps: not a PS packet (000001be)
    [09:25:13] Warning: Could not read data for preview 9, skipped
    [09:25:13] hb_demux_ps: not a PS packet (000001be)
    [09:25:13] Warning: Could not read data for preview 10, skipped
    [09:25:13] libhb: scan thread found 0 valid title(s)
    No title found.
    HandBrake has exited.
     
  16. Sep 26, 2011 #3296 of 10921
    txporter

    txporter One sec, almost done

    666
    0
    Sep 17, 2006
    Austin, TX
    Do you own VideoRedo? Has this file been processed with QuickStream Fix? Looks like a timestamp issue.
     
  17. Sep 26, 2011 #3297 of 10921
    moyekj

    moyekj Well-Known Member

    11,377
    126
    Jan 23, 2006
    Mission...
    Agree that qsfix is a must if you are not running that. However if it works with your installation of Handbrake then consider pointing kmttg config to HandBrakeCLI.exe where that is installed.
     
  18. Sep 26, 2011 #3298 of 10921
    Soapm

    Soapm Active Member

    1,572
    1
    May 9, 2007
    So close,...
    I blue screened last night which gave me an opportunity to use your fork. I like the slight changes to the web interface and it seems to be a little more consistent so far. I am humming along using it now and what I like about it is that I can add to the queue while it is downloading thereby I can keep it running continuously.

    I may just have this backed up by the weekend...

    I also like the check box for the meta data. Don't know what it looks like yet but that is a real plus since I plan to return most of these to my new Tivo. Nice touch...

    Thanks...
     
  19. Sep 30, 2011 #3299 of 10921
    lpwcomp

    lpwcomp Well-Known Member

    8,732
    117
    May 6, 2002
    John's...
    Just installed kmttg on a Win2k system and tivodecode fails. The downloaded .tivo file is handled fine by direct show dump utility. Here is the relevant part of the log:


    >> DOWNLOADING F:\Video\FOX and Friends (09_30_2011).TiVo ...
    C:\kmttg\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\DOCUME~1\JAMESS~1\LOCALS~1\Temp\cookie5327047853826621861.tmp --url http://192.168.1.102:80/download/FO...Playing&id=388260&Format=video/x-tivo-mpeg-ts --output "F:\Video\FOX and Friends (09_30_2011).TiVo"
    F:\Video\FOX and Friends (09_30_2011).TiVo: size=374.00 MB elapsed=0:01:38 (32.01 Mbps)
    ---DONE--- job=download output=F:\Video\FOX and Friends (09_30_2011).TiVo
    OVERWRITING EXISTING FILE: G:\kmttgmpegs\FOX and Friends (09_30_2011).mpg
    >> DECRYPTING F:\Video\FOX and Friends (09_30_2011).TiVo ...
    C:\kmttg\tivodecode\tivodecode.exe --mak MAK --no-verify --out "G:\kmttgmpegs\FOX and Friends (09_30_2011).mpg" "F:\Video\FOX and Friends (09_30_2011).TiVo"
    tivodecode failed (exit code: 10 ) - check command: C:\kmttg\tivodecode\tivodecode.exe --mak MAK --no-verify --out "G:\kmttgmpegs\FOX and Friends (09_30_2011).mpg" "F:\Video\FOX and Friends (09_30_2011).TiVo"
    TiVo Private Data : Unmatched Stream ID: No error
    ts_handle_tivo_private_data failed: No error
    processing frame: No error
    Encryption by QUALCOMM ;)
     
  20. Sep 30, 2011 #3300 of 10921
    ThAbtO

    ThAbtO TiVoholic by the bay

    7,280
    59
    Apr 6, 2000
    SF Bay Area
    I assume this is transferring from the Premiere, it looks like you are transferring .ts instead of .ps stream.
     

Share This Page