1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Nov 29, 2010 #2881 of 10411
    Berone

    Berone New Member

    108
    0
    Feb 14, 2005
    Kevin,
    Hard to believe it's been over 2 1/2 years since you wrote this. Come a long way! I just started playing with the latest version on my MacBook. All of my .tivo files are downloaded to a MacMini external drive. When I select files I can only see drives connected to my machine. Is there any way to access files across the network?

    Thanks!
    Anthony
     
  2. Nov 29, 2010 #2882 of 10411
    tknman0700

    tknman0700 New Member

    8
    0
    Nov 24, 2010
    My biggest problem is that it seems I have audio sync issues... very bad when using ffmpeg and when I use handbrake after abotu 30 mins seems there is a sync issue.

    Any ideas?
     
  3. Nov 29, 2010 #2883 of 10411
    tknman0700

    tknman0700 New Member

    8
    0
    Nov 24, 2010
    and handbrake seems to take FOREVER - 1.5hrs on a 30 min show using this:

    C:\tivoStuff\handbrake\HandBrakeCLI.exe -i C:\tivoStuff\test.mpg --cpu 4 -f mp4 --large-file --decomb --detelecine -O --encoder x264 -w 1280 -b 2500 -r 29.97 -a 1 --aencoder faac --ab 256 --mixdown dpl12 --arate 48 --drc 0.0 --x264opts ref=2:bframes=2:subq=6:mixed-refs=0:weightb=0:8x8dct=0:trellis=0 -v -o C:\tivoStuff\test.m4v
     
  4. Nov 29, 2010 #2884 of 10411
    tknman0700

    tknman0700 New Member

    8
    0
    Nov 24, 2010
    The machine it is running on is dual core 2.5 with 8GB Ram - Win7/64
     
  5. Nov 29, 2010 #2885 of 10411
    BigT4187

    BigT4187 WDW Nut

    146
    0
    Jul 24, 2006
    GSP Exit 17
    Does anyone have any suggestions?
     
  6. Nov 29, 2010 #2886 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    Not familiar with Mac OS but if it's anything like linux/unix NFS mounts then they are all available starting from the root directory "/".
     
  7. Nov 29, 2010 #2887 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    What are you playing back on? If you try a different device or application for playback is the problem still there? (i.e. If only 1 device has issue then it's decoder issue for that device).
     
  8. Nov 30, 2010 #2888 of 10411
    AudioNutz

    AudioNutz New Member

    318
    0
    Nov 9, 2008
    On a Mac, back all the way out to your Hard Drive, then scroll down to "Volumes". All connected volumes will show. When utilizing these volumes in a config to place files, use:

    /Volumes/name_of_share
     
  9. Nov 30, 2010 #2889 of 10411
    BigT4187

    BigT4187 WDW Nut

    146
    0
    Jul 24, 2006
    GSP Exit 17
    I thought the same thing so I've tried VLC and Media Player Classic - Home Cinema on two different PCs. I've also tried different profiles. Still having the same issue.
     
  10. Nov 30, 2010 #2890 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    Then it's likely an issue with the source recording that needs to be fixed before encoding. Only good solution I know for fixing issues with source recording is VideoRedo QSFix which of course is Windows only. (The fact you mentioned encoding with ffmpeg results in A/V sync issues also points to timestamp problems in the source).
     
  11. Nov 30, 2010 #2891 of 10411
    BigT4187

    BigT4187 WDW Nut

    146
    0
    Jul 24, 2006
    GSP Exit 17
    So that means I have to purchase VideoReDo? If so, which product?

    Thanks.
     
  12. Nov 30, 2010 #2892 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    They have fully functional trial versions to see if it can actually help you before you commit to purchase. The $50 VideoRedo Plus is sufficient for QS Fix purposes. If you do try it out be sure to complete the free trial registration before using to get a fully functional copy.
    http://www.videoredo.com/en/ProductPlus.htm
    If you try it within kmttg make sure you run VideoRedo GUI at least once as administrator so that it registers proper components in registry needed to run in batch/COM mode that kmttg uses.
     
  13. Nov 30, 2010 #2893 of 10411
    BigT4187

    BigT4187 WDW Nut

    146
    0
    Jul 24, 2006
    GSP Exit 17
    I'll give that a shot. Are there any special settings I need to apply in VideoRedo for this to work?

    Thanks again!
     
  14. Nov 30, 2010 #2894 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    No. You can run QS Fix manually in VRD GUI from Tools pulldown menu or you can run via kmttg QS Fix task. As I mentioned if running via kmttg you should first bring up the VRD GUI at least once as administrator (use "run as administrator") to make sure the registry is updated appropriately.
     
  15. Dec 1, 2010 #2895 of 10411
    tknman0700

    tknman0700 New Member

    8
    0
    Nov 24, 2010
    I have playback sync issues regardless of the device. QT, VLC, Roku, etc.
    The unencrypted mpg is fine but when I convert to H.264 there are sync issues.
     
  16. Dec 1, 2010 #2896 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    See posts above about VideoRedo QS Fix for (non-free) solution.
     
  17. Dec 8, 2010 #2897 of 10411
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,719
    7
    Apr 6, 2000
    SF Bay Area
    I recently been transferring some .MP4 to my THD, about 450megs each. When I pulled from the Tivo, it takes a long while and end up with the show info showing the size around 2gb. Then, I pushed with Kmttg and the Tivo shows it as 450 megs as the original file.
     
  18. Dec 8, 2010 #2898 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    That's because pull operations only support mpeg2 program stream format, so mp4 files have to be transcoded to mpeg2 on the fly during transfer which slows things down and makes file pushed to TiVo bigger. On the other hand compatible mp4 files pushed to TiVos are just transferred as is without transcoding. i.e. The key to remember is pull always requires mpeg2, push can transfer certain encodings natively.
     
  19. Dec 11, 2010 #2899 of 10411
    innocentfreak

    innocentfreak Active Member

    8,950
    3
    Aug 25, 2001
    Florida
    Not sure if it would be possible, but it would be nice if you could add by folder for files. This way you could select your default directory and it would add any MPG and TiVo file.
     
  20. Dec 11, 2010 #2900 of 10411
    philt56

    philt56 Member

    165
    0
    Aug 21, 2008
    I'm trying to decode a tivo file on my PC with kmttg and get the following errors almost immediately.

    Late Night With Jimmy Fallon - Paul McCartney; Nick Cannon
    Recorded Thu 12/09/2010 11:37 PM on 188=WMAQDT, Duration = 63 mins
    Musician Paul McCartney; radio personality Nick Cannon.
    >> DECRYPTING F:\My TiVo Recordings\Late Night With Jimmy Fallon - ''Robert Plant; Nick Cannon; Robert Plant'' (Recorded Dec 9, 2010, WMAQDT).TiVo ...
    C:\kmttg\tivodecode\tivodecode.exe --mak MAK --out "C:\kmttg\Late Night With Jimmy Fallon - ''Robert Plant; Nick Cannon; Robert Plant'' (Recorded Dec 9, 2010, WMAQDT).mpg" "F:\My TiVo Recordings\Late Night With Jimmy Fallon - ''Robert Plant; Nick Cannon; Robert Plant'' (Recorded Dec 9, 2010, WMAQDT).TiVo"
    tivodecode failed (exit code: 10 ) - check command: C:\kmttg\tivodecode\tivodecode.exe --mak MAK --out "C:\kmttg\Late Night With Jimmy Fallon - ''Robert Plant; Nick Cannon; Robert Plant'' (Recorded Dec 9, 2010, WMAQDT).mpg" "F:\My TiVo Recordings\Late Night With Jimmy Fallon - ''Robert Plant; Nick Cannon; Robert Plant'' (Recorded Dec 9, 2010, WMAQDT).TiVo"
    TiVo Private Data : Unmatched Stream ID: No error
    ts_handle_tivo_private_data failed: No error
    processing frame: No error
    Encryption by QUALCOMM

    I used it fine on some files from my HD XL but this seems to be new with the file from my Premiere. I even xferred the file from my Premiere to the XL and then from the XL and got the same error. (had read something about a diff xfer protocol on the Premiere?)

    I also tried another file on my Premiere and same thing. I did install the latest Tivo desktop but not sure that matters.

    Anybody have any ideas?
     

Share This Page