1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Sep 12, 2010 #2621 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    v0p7o version just posted with Java download timeouts changed to 2 minutes instead of 10 secs (so that bigger playlist retrieval doesn't time out). Thanks to ferror for pointing it out.
     
  2. Sep 13, 2010 #2622 of 10411
    ferror

    ferror New Member

    66
    0
    May 3, 2005
    Austin, TX
    Thank you. I tried it and the 2 minute timeout solves the problem I was having. When that was solved, I started having another problem but I haven't been able to put my finger on it. Not sure if it was autotune, my TiVos, or something else, but I was getting errors with my downloads part of the time. I'll report if I narrow anything down.
     
  3. Sep 14, 2010 #2623 of 10411
    tivowiz

    tivowiz New Member

    60
    0
    Aug 3, 2002
    did you happen to tune something in the v0p7o version that makes the initial download of the playlist go faster? Before this, my playlist downloads were taking a very long time (using curl on ubuntu 10.04), I just grabbed the latest release and it grabbed my playlist in seconds.

    I have to say that this program is great - it allows me to share my Tivo's with other systems painlessly. Combined with pyTivo and streambaby my fileserver is actually a media server (as it should be).
    Thanks!
     
  4. Sep 14, 2010 #2624 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    No. The TiVo web server can only return up to 128 entries at a time, so if you have more than 128 recordings it can take multiple calls to grab them all which can take a while. The only intended change was kmttg now reports how many total entries there are to process after the 1st call so you get status updates as playing list is retrieved, but the download using curl is same as always.
    (I hope the reason it's faster is not because somehow kmttg is not actually getting all the shows you have recorded due to some bug introduced).
     
  5. Sep 16, 2010 #2625 of 10411
    Eamus Catuli

    Eamus Catuli Member

    77
    0
    Aug 8, 2010
    Toronto ON...
    Folks, I need some help to sort out an audio sync problem I'm having.

    First, a little history. When I first started using kmttg, I tried using Ad detect/Ad cut and the resulting file had audio sync issues. So I removed Ad detect/Ad cut and everything was fine (well, it was a bit of a pain to try and skip over commercials on my iPod touch).

    In the past few days, I've added VideoReDo to my environment hoping to get sync-problem-free files and make my iPod touch viewing more enjoyable.

    Yesterday, I got kmttg set up to use VideoReDo, enabled VRD QS fix, then re-enabled Ad detect/Ad cut, and tried to convert my first TiVo recording. I played it this morning and the audio sync issue I had before has returned. It seemed better than before but that's my subjective view. While the conversion was running it sure looked like VideoReDo was invoked.

    So my question is - what might I be missing that is causing the synch issue? Do I need to configure anything on VideoReDo itself? Or maybe I need to change something on kmttg? (maybe I should have kept the log :rolleyes: ) Is there something I should watch for to prove that VideoReDo is actually being used to remove the commercials?

    I'm using:

    Windows 7 x64
    encoding with hb_iphone.enc

    Thanks for any advice! ... Mike
     
  6. Sep 16, 2010 #2626 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    Some things to try:
    1. Play back the recording in iTunes on your PC to check if it is also out of sync there. I've seen cases when PC playback was fine and in sync but playback on iPod touch was slightly out of sync - not much can really be done about that as it's likely iPod decoder issue.
    2. Check the .mpg file that is being used as source for encoding by playing it back on your computer to see if it's in sync. That file has supposedly been run through VRD QS Fix if you have that enabled. If that file is out of sync then that's the problem, though I highly doubt that's the case if it has been run through VRD QS Fix.
    3. Try ff_iphone encoding profile instead of hb_iphone to see if that works any better.

    It should be fairly obvious from kmttg message window if VRD QS Fix is being run or not. Most likely if VRD QS Fix task is enabled then it is being run. You can save messages to a file using File->Save messages to file or just copy/paste directly from message window.
     
  7. Sep 16, 2010 #2627 of 10411
    tivowiz

    tivowiz New Member

    60
    0
    Aug 3, 2002
    Ahh - that all makes sense - After transferring many shows to my server I removed them from the Tivo, which dropped the total count down to under 128 (actually its at 92 now). Don't worry, I still see all the shows.
    Thanks
     
  8. Sep 16, 2010 #2628 of 10411
    Eamus Catuli

    Eamus Catuli Member

    77
    0
    Aug 8, 2010
    Toronto ON...
    Thanks moyekj! :) I tried your suggestions above and even a few more things that isolated the fault to the encoding stage. It looks like the ffmpeg encoder works much better than handbrake, at least for me.
     
  9. Sep 17, 2010 #2629 of 10411
    Eamus Catuli

    Eamus Catuli Member

    77
    0
    Aug 8, 2010
    Toronto ON...
    update to post 2628. It's still not perfect (but seems better using ffmpeg over handbrake). I also noticed that not all commercials were skipped. This is starting to sound more like a VideoReDo issue?? Does it matter what version I use? My research on the web found there is a TVSuite version 4. Would that work better than version 3 (I'm using 3.1.5-564) or the Plus version??
     
  10. Sep 17, 2010 #2630 of 10411
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,719
    7
    Apr 6, 2000
    SF Bay Area
    The version is current for VRD TVSuite. V4 is in beta.
     
  11. Sep 17, 2010 #2631 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    If you're using auto commercial detection then it will never be perfect. For different shows you can tweak various settings and use custom comskip.ini files but I don't bother. If I want perfect commercial editing I find it quicker and easier to do it manually using VideoRedo, so I use the "Bring up VideoRedo GUI to make manual cuts" option in kmttg so that when "Ad Cut" task is enabled kmttg will bring up VideoRedo GUI for you to edit the show for that task and won't continue with subsequent tasks for that show until you exit the GUI. You can also leave Ad Detect step enabled and use the "Use VideoRedo GUI to review detected commercials" option, but personally I find to correct incorrectly detected commercials takes longer than just finding and defining the cut points correctly in the first place myself. To get latest versions of VideoRedo you need to visit the beta forums and download latest beta from there:
    http://www.videoredo.net/msgBoard/forumdisplay.php?f=4
    VideoRedo hasn't released "official" (non-beta) updates in a long time I think for any of the versions so the latest beta is what you need to get for most up to date.
     
  12. Sep 17, 2010 #2632 of 10411
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    Hmmm... Could the global option "Bring up VideoRedo GUI to make manual cuts" be made local in the auto-config process? Say you have some series' that comskip reliably detects all the commercial breaks, but yet have a couple of series that are ALWAYS wrong (mostly due to station identification logos being present during commercials). If there were a local override in auto-config (similar to the metadata/decrypt/qsfix/comskip/etc. options per entry), those specific errant series could be dealt with manually, while the majority(?) of other shows could go along their own merry way. I've not used "Bring up VideoRedo GUI to make manual cuts", so I don't know how the job queue behaves when that option is enabled...
     
  13. Sep 17, 2010 #2633 of 10411
    Eamus Catuli

    Eamus Catuli Member

    77
    0
    Aug 8, 2010
    Toronto ON...
    Thanks for your help (and the great program too :D ). Since the stuff I put on my iPod touch is of the play-once-and-delete variety, it will be easier to just live with the commercials (which already provided me with perfect audio sync with handbrake when I unclicked Ad detect/Ad cut) than spend time manually editing them.

    Out of curiosity, I ran the stuff I was having problems with into VideoReDo and I noticed some awful commercial cuts. I found a frame that had the commercial and the program (remnants of each) in the same frame! :eek: (not the usual fade to black). That may have sent the autodetect program into a bad spin. :confused:

    Maybe I'll try it with a better source and see how it does.
     
  14. Sep 18, 2010 #2634 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    I think that could be confusing because for service mode (non graphical) auto transfers mode obviously this graphical VRD option does not apply/cannot be run. As far as how it affects the queue any task for a show following the "Ad Cut" step is on hold until VRD GUI is closed for that show.
     
  15. Sep 18, 2010 #2635 of 10411
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    Yeah, I use the hybrid loop-in-GUI option. :up:

    I guess a more appropriate question would be how the VRD GUI effects the Active Job limit. Is kmttg "active" while the VRD GUI is in play? If the Active Job limit were set to two, is it possible to have two instances of the VRD GUI? Would all other jobs just get queued?
     
  16. Sep 18, 2010 #2636 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    VRD GUI jobs are NOT considered "active" and don't count against the Active Job limit.
     
  17. Sep 18, 2010 #2637 of 10411
    srosen2004

    srosen2004 New Member

    3
    0
    Sep 18, 2010
    Just downloaded your program...

    What is this error?
    MAK not specified or not correct

    The first time you bring up this window you will need to set the proper value for Total Disk Space (GB) field at the top of the window.

    What is the size in GB? I have the TiVo that is 45 hours (not the larger 120 hours)

    Thanks!

    Still reading your release notes & how to use the software - what encoding is best for dvd with audio sync being ok?

    I had been trying in vain to use Creator 10 that crashes all the time...
     
  18. Sep 18, 2010 #2638 of 10411
    keenanSR

    keenanSR Member TCF Club

    909
    2
    Oct 12, 2004
    Santa Rosa CA
    I just tried to setup Autotune for my 2 TiVos(S3 and HD) and when I press the 'Test' button it returns 'telnet - Failed to connect to host: 192.168/.0.110, telnet - connect timed out' for both machines. Am I doing something wrong? The 'tune to' box is checked for each machine. It seems to me this worked for me on the previous version(j and m?).

    Also, when I click on 'Ok' it shows 1 error, proceed....?

    Version being used is 'v0p7o'

    Thanks
     
  19. Sep 18, 2010 #2639 of 10411
    srosen2004

    srosen2004 New Member

    3
    0
    Sep 18, 2010
    Some shows work, some don't...
    Reason?

    Below is the journal for one that worked and one that did not work...

    OK

    >> CREATING H:\Programs\Louie - ''Dr. BenNick'' (Recorded Jul 6, 2010, FXHD)_cut.mpg.txt ...
    H:\Programs\tivodecode\tivodecode.exe --mak MAK -D -x "H:\TV Shows\Louie\Louie - ''Dr. BenNick'' (Recorded Jul 6, 2010, FXHD).TiVo"
    metadata job completed: 0:00:00
    ---DONE--- job=metadataTivo output=H:\Programs\Louie - ''Dr. BenNick'' (Recorded Jul 6, 2010, FXHD)_cut.mpg.txt
    >> DECRYPTING H:\TV Shows\Louie\Louie - ''Dr. BenNick'' (Recorded Jul 6, 2010, FXHD).TiVo ...
    H:\Programs\tivodecode\tivodecode.exe --mak MAK --out "H:\Programs\Louie - ''Dr. BenNick'' (Recorded Jul 6, 2010, FXHD).mpg" "H:\TV Shows\Louie\Louie - ''Dr. BenNick'' (Recorded Jul 6, 2010, FXHD).TiVo"
    tivodecode job completed: 0:03:46
    ---DONE--- job=decrypt output=H:\Programs\Louie - ''Dr. BenNick'' (Recorded Jul 6, 2010, FXHD).mpg
    >> Running comskip on H:\Programs\Louie - ''Dr. BenNick'' (Recorded Jul 6, 2010, FXHD).mpg ...
    H:\Programs\comskip\comskip.exe --ini H:\Programs\comskip\comskip.ini "H:\Programs\Louie - ''Dr. BenNick'' (Recorded Jul 6, 2010, FXHD).mpg"

    not OK

    >> CREATING H:\Programs\Louie - ''DentistTarese'' (Recorded Aug 24, 2010, FXHD)_cut.mpg.txt ...
    H:\Programs\tivodecode\tivodecode.exe --mak MAK -D -x "H:\TV Shows\Louie\Louie - ''DentistTarese'' (Recorded Aug 24, 2010, FXHD).TiVo"
    metadata job completed: 0:00:00
    ---DONE--- job=metadataTivo output=H:\Programs\Louie - ''DentistTarese'' (Recorded Aug 24, 2010, FXHD)_cut.mpg.txt
    >> DECRYPTING H:\TV Shows\Louie\Louie - ''DentistTarese'' (Recorded Aug 24, 2010, FXHD).TiVo ...
    H:\Programs\tivodecode\tivodecode.exe --mak MAK --out "H:\Programs\Louie - ''DentistTarese'' (Recorded Aug 24, 2010, FXHD).mpg" "H:\TV Shows\Louie\Louie - ''DentistTarese'' (Recorded Aug 24, 2010, FXHD).TiVo"
    tivodecode failed (exit code: 10 ) - check command: H:\Programs\tivodecode\tivodecode.exe --mak MAK --out "H:\Programs\Louie - ''DentistTarese'' (Recorded Aug 24, 2010, FXHD).mpg" "H:\TV Shows\Louie\Louie - ''DentistTarese'' (Recorded Aug 24, 2010, FXHD).TiVo"
    TiVo Private Data : Unmatched Stream ID: No error
    ts_handle_tivo_private_data failed: No error
    processing frame: No error
    Encryption by QUALCOMM ;)
     
  20. Sep 18, 2010 #2640 of 10411
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    If you go to File > Config > TiVos tab, do all the IPs look correct in the dropdown?
     

Share This Page