1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. May 15, 2010 #2321 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    epstewart, TS downloads are only possible with "Premiere" or Australia/NZ TiVo units. For Series 3 USA units the specification for TS download format has no effect and you end up with PS mpeg2 files same as always. That info is in kmttg documentation & the tooltip that pops up when you put mouse over the kmttg config option.
    In any case it appears like TS downloads at least from Premiere units are still buggy so best avoided. Premiere units even for PS format are supposedly faster for downloading/uploading compared to S3 units (especially if you stick to SD interface) so may accomplish what you want.

    One more thing to keep in mind about Streambaby uploads:
    There is still a 1.1GB TiVo imposed buffer limit after which the stream must be re-started (to clear the buffer). Streambaby can do this fine for unencrypted mpeg2 & H.264 formats but for .TiVo format it will simply stop & restart from beginning - i.e. You shouldn't use .TiVo formats for files > 1.1GB with streambaby.
     
  2. May 15, 2010 #2322 of 10413
    epstewart

    epstewart Member

    648
    0
    Mar 1, 2003
    Ok, thanks, I missed the tooltip, but it's clear now that I didn't really get a TS download, and why.

    The problem is with the Premiere software, right, not kmttg?

    Yes, I'm definitely looking into the Premiere, and have downloaded bkdtv's Premiere tech review, which I'm about to read. I notice that he (she?) put a lot of information in it concerning time considerations for downloading recorded files and computer video transfers.

    Yes, I've run into the 1.1 GB buffer limit on non-.TiVo files, as I've been using such decoded files, not the originals. I'll keep what you said in mind if I ever try to use StreamBaby for .TiVo files.

    Thanks for your help and for the excellent kmttg program.
     
  3. May 15, 2010 #2323 of 10413
    SoBayJake

    SoBayJake New Member

    407
    0
    Feb 6, 2002
    Los Angeles, CA
    I think only the Premiere and Tivos in Australia/New Zealand can output transport streams.

    If you are in the U.S. with TiVo HDs and S3s, you are going to get Program Streams regardless of the preference in kmttg. The TiVo won't send out Transport Streams, so when kmttg requests a TS, the TiVo ignores the flag, and sends out a PS.

    EDIT: Nevermind, I was late to the party! epstewart's message was the last on the page, and I didn't realize I wasn't at the end of the thread!
     
  4. May 15, 2010 #2324 of 10413
    wireman121

    wireman121 Member

    126
    0
    Nov 8, 2008
    Now all I need to figure out is how to make pytivo delete the mpg and txt file after the push and its all set haha
     
  5. May 15, 2010 #2325 of 10413
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    Check out this post discussing the hack of plugins/video/video.py, in the pyTivo forum: http://pytivo.sourceforge.net/forum/log-of-video-transfers-t131.html

    I log all my transfers to a text file using that hack, then as part of the kmttg "custom command" that can run after each set of jobs, I parse that text and delete any successfully transferred files, using "IF EXIST" logic in the custom command .bat file I wrote.
     
  6. May 15, 2010 #2326 of 10413
    jk5598224

    jk5598224 New Member

    312
    0
    Jan 28, 2003
    Bay Area, CA
    I was using this program for transfers fine, but from some reason the audio now sounds like the chipmunks sqeeking. Is this the wrong encoding profile being used?

    I am transfering from Tivo HD AND Sony SVR3000 to a Lenovo Thinkpad. Any tips appreciated.
     
  7. May 16, 2010 #2327 of 10413
    epstewart

    epstewart Member

    648
    0
    Mar 1, 2003
    SoBayJake,

    Thanks, anyway!
     
  8. May 16, 2010 #2328 of 10413
    richklein

    richklein New Member

    98
    0
    Feb 9, 2001
    I am having an issue. I am in the middle of a project that is keeping me away from watching TV due to being to busy. So i am trying to move some shows so i can watch them later.

    Anyway, I have the options set as: Metadata, Decrypt, QS Fix

    If I que up more than two shows at a time to download, it crashes the second show.

    If I only pick two at a time, it seems to work.

    Thanks,
    Rich

    Code:
    H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
    <h2>Resource Not Found</h2>
    Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
    Exit code: 0
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    
      0    47    0    47    0     0    198      0 --:--:-- --:--:-- --:--:--   198
      0    47    0    47    0     0    198      0 --:--:-- --:--:-- --:--:--     0
    Hook (05_04_2010).TiVo: Download attempt # 2 scheduled in 10 seconds.
    >> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
    C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie7862338643140377077.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
    H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
    <h2>Resource Not Found</h2>
    Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
    Exit code: 0
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    
      0    47    0    47    0     0   1174      0 --:--:-- --:--:-- --:--:--  1174
      0    47    0    47    0     0   1174      0 --:--:-- --:--:-- --:--:--     0
    Hook (05_04_2010).TiVo: Download attempt # 3 scheduled in 10 seconds.
    >> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
    C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie8991614487978055852.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
    H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
    <h2>Resource Not Found</h2>
    Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
    Exit code: 0
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    
      0    47    0    47    0     0   1021      0 --:--:-- --:--:-- --:--:--  1021
      0    47    0    47    0     0   1021      0 --:--:-- --:--:-- --:--:--     0
    Hook (05_04_2010).TiVo: Download attempt # 4 scheduled in 10 seconds.
    >> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
    C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie2898269932603719347.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
    H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
    <h2>Resource Not Found</h2>
    Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
    Exit code: 0
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    
      0    47    0    47    0     0    959      0 --:--:-- --:--:-- --:--:--   959
      0    47    0    47    0     0    959      0 --:--:-- --:--:-- --:--:--     0
    Hook (05_04_2010).TiVo: Download attempt # 5 scheduled in 10 seconds.
    >> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
    C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie1950304797418644820.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
    H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
    <h2>Resource Not Found</h2>
    Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
    Exit code: 0
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    
      0    47    0    47    0     0   1382      0 --:--:-- --:--:-- --:--:--  1382
      0    47    0    47    0     0   1382      0 --:--:-- --:--:-- --:--:--     0
    Hook (05_04_2010).TiVo: Too many failed downloads, GIVING UP!!
    tivodecode job completed: 00:06:39
    
     
  9. May 16, 2010 #2329 of 10413
    AgtScully

    AgtScully New Member

    10
    0
    May 26, 2009
    I'm having a problem installing the kmttg service onto the Windows 7 32-bit Ultimate version.
    When I select "Service" then "Install", the GUI just hangs.
    I first tried v0p7j(since it worked well in XP SP3) but it would never install.
    The task manager will list it as "running" but no response from the GUI.
    So I tried v0p7k but it also will not install.
    But I have no problem running the "Loop in GUI" option.

    I'm still learning the ropes of Windows 7 so I would greatly appreciate anyone's help in solving this problem.

    Thanks.
     
  10. May 16, 2010 #2330 of 10413
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    That "<h2>Resource Not Found</h2>" error occurred last evening for me. I have changed my download retry wait time (found in program options) from 10 seconds to 3600, which may be a bit extreme, but the error only occurred once. The next attempt an hour later was successful, and kmttg didn't have to give up.
     
  11. May 16, 2010 #2331 of 10413
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    You may want to try running "\kmttg\service\win32\install-kmttg-service.bat" manually as administrator. I don't know if that will help or not, but it may do it.
     
  12. May 16, 2010 #2332 of 10413
    AgtScully

    AgtScully New Member

    10
    0
    May 26, 2009
    UGH!! So simple, a cavewoman could do it:)

    Thank you orangeboy!!
     
  13. May 16, 2010 #2333 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Most likely a codec and/or player issue on Thinkpad. What encoding profile are you using? If it's one with H.264 with AC3 audio there aren't too many players that can handle playback of that properly, but VLC media player can.
     
  14. May 16, 2010 #2334 of 10413
    jk5598224

    jk5598224 New Member

    312
    0
    Jan 28, 2003
    Bay Area, CA
    I only click the decrypt button, not sure if I need to click encode as well. Seems more of a problem with WinDVD 5.x. I am discovering that it works with Msft Player. Of course it used with work with WinDVD 5.x, so I am trying to figure out 'what changed' :)
     
  15. May 17, 2010 #2335 of 10413
    abnersnell

    abnersnell New Member

    18
    0
    Mar 3, 2002
    I was curious if anyone is handling interlaced content transferred from TiVo in a "custom" manner?

    I have cobbled together a "custom" script after the transfer, decode, streamfix, ad detect, and ad cut steps. I skip encode and handle 1920x1080@29.97 interlaced HDTV with avisynth(deinterlace, resize) and x264.exe for encoding.

    Anyone else doing anything special with interlaced content? Or just compressing interlaced straight away with FFMEG?

    Abner
     
  16. May 18, 2010 #2336 of 10413
    NYHeel

    NYHeel Active Member

    1,906
    12
    Oct 7, 2003
    I've run kmttg twice with metadata, decrypt, ad detect, ad cut, and push all checked. Eventually I'll want to have this encoding for my ipod but I was just testing the commercial skip feature for now. Everything seems to run great (including the push, really cool by the way) except the Ad cut part gets all of these errors and eventually quits. It leaves a file that's about 20 minutes long and doesn't quite work right. Unfortunately I closed kmttg before saving out the log. Does anyone have any ideas what the problem could be? The ad detect ran fine but the ad cut part bombed. Is there another program I need?

    Thanks for the help and again really cool program, especially with the pytivo push integration.
     
  17. May 18, 2010 #2337 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    VideoRedo is really a necessary addition if you see those kinds of problems. VRD QuickStream Fix cleans up glitches in the original recordings and will also be used to make the cuts instead of mencoder if you have it configured in kmttg and those kinds of problems go away. The $50 Plus version is really all you need if you don't care about VRD encoding, H.264 editing & DVD burning capabilities. It's also useful to be able to review detected commercials with VRD and clean up the cut points if necessary. There is a fully functional trial version if you wish to try it out before buying. Of course it only runs on Windows currently which is an issue for some.
     
  18. May 18, 2010 #2338 of 10413
    janry

    janry New Member

    17,688
    0
    Jan 2, 2003
    Nashville, TN
    I have installed kmttg on two previous computers (XP & Vista) with limited issues. I recently installed it on a Windows 7 computer and for love nor money, I cannot get auto transfers to work. It's like it never even attempts to transfer. And yes, I do have the transfer "enabled" under the latest verson.

    Manual tranfers work great.

    Any ideas of what I've done wrong?
     
  19. May 18, 2010 #2339 of 10413
    moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    It's probably a service permissions issue. First make sure you get the transfers working properly via GUI. In latest version there's both "Run Once in GUI" and "Loop in GUI" options. It's also useful to use the "Dry Run Mode" option to test your auto transfers setup without having kmttg actually initiate downloads. If/once you get that working then focus on getting service mode to work. Consult the Wiki page:
    http://code.google.com/p/kmttg/wiki/auto_transfers
    Pay particular attention to the section entitled "RUNNING THE AUTO TRANSFERS PROGRAM AS A SERVICE IN WINDOWS". Ultimately it boils down to permissions issues where you need to use same account you use to run GUI when running the service.
     
  20. May 18, 2010 #2340 of 10413
    NYHeel

    NYHeel Active Member

    1,906
    12
    Oct 7, 2003
    Thanks for the recomendation. I'll give it a try. Do you think the VRD commercial cuts are "better" than the comskip/comcut that kmttg uses (assuming the quickstream fix part runs first)?
     

Share This Page