1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New program for 1 step TTG downloads, decryption, encoding - kmttg

Discussion in 'TiVo Home Media Features & TiVoToGo' started by moyekj, Mar 15, 2008.

  1. Apr 29, 2010 #2261 of 10411
    JohnL88

    JohnL88 New Member

    9
    0
    Oct 7, 2006
    Thanks for the replies moyekj and Stormspace. I appreciate it.

    I only have one HD Tivo box, the drive is ntfs, and the video will likely never be on again (football game). It is that stupid 2-second video glitch that is creating the problem. I wish there was a way to tell the transfer program to ignore the glitch and keep going. But it sounds like that is not possible. I was looking for anything: MRV to PC transfer; then some type of conversion program, etc. etc.

    If anyone thinks of anything creative or any software that can help, please let me know. Thanks again.
     
  2. Apr 29, 2010 #2262 of 10411
    txporter

    txporter One sec, almost done

    666
    0
    Sep 17, 2006
    Austin, TX
    Does Tivo Desktop let you transfer from paused point like you can do with MRV?
     
  3. Apr 29, 2010 #2263 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    No.
     
  4. Apr 29, 2010 #2264 of 10411
    waynomo

    waynomo My One Time TCF Club

    12,049
    36
    Nov 9, 2002
    Seven...
    I had this same problem on a few videos over a year ago. (Glitch in program caused transfer to cease at that point.) I kept trying and eventually they transferred. (I don't know if all did, but I know most did.) It took at least three or four tries so keep trying.

    You might try tuning to your TiVo to two channels that don't receive a signal. This should speed up the transfer process and might be enough to get past the glitch. Also, if wireless you might want to try using a wired connection which is a bit faster also. Seems like it is something you really want so would be worth the effort.

    Do you have any friends with a TiVo HD? Bring your TiVo there and do the partial transfer as someone suggested. Or perhaps purchase a used one (eBay, Craigslist, forum on TCF), to do what you need to do and then sell it. Someone might even be willing to rent it to you for $20 or something like that.

    Just out of curiosity, what football game?
     
  5. Apr 29, 2010 #2265 of 10411
    SoBayJake

    SoBayJake New Member

    407
    0
    Feb 6, 2002
    Los Angeles, CA
    But you can only do MRV between TiVos on the same account, so they have the same MAK correct? If you put another TiVo on the network, they will see each other, but they will say there are no recordings when selected.
     
  6. Apr 29, 2010 #2266 of 10411
    waynomo

    waynomo My One Time TCF Club

    12,049
    36
    Nov 9, 2002
    Seven...
    Ah, that could be. . . . Has to be on the same account . . . I don't know.

    I thought each TiVo had its own MAC.

    If they have to be on the same account then it gets more complicated.
     
  7. Apr 29, 2010 #2267 of 10411
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    MAC - Yes.
    MAK - No.
     
  8. Apr 29, 2010 #2268 of 10411
    videojanitor

    videojanitor New Member

    678
    0
    Dec 21, 2001
    The same thing happened to me once and it was incredibly frustrating, so I feel your pain. I ended up transferring the video off using an external HD capture device (the Hauppauge HD PVR) -- the quality went down a notch, but it was the only way to do it. If somebody knows of another way, I'm all ears too ...
     
  9. Apr 29, 2010 #2269 of 10411
    Phantom Gremlin

    Phantom Gremlin New Member

    1,555
    0
    Jun 20, 2002
    Tualatin,...
    Okay, you sound desperate. First try the other suggestions people gave you, such as tuning to channels you don't receive, etc.

    Here's my idea. Maybe the glitch isn't in the video as you received it, maybe it corresponds to a bad sector on your disk. So, get a 2nd drive the same size (check the FAQ for drives that work), remove the bad drive from the TiVo, use dd in Linux to make a bit for bit copy, then put the new drive into your TiVo. Then try the transfer again.

    You will need to use options to dd, that's out of the scope for this response since I use OS X and not Linux. But you will need something like

    conv=noerror​

    to keep from hanging up on the bad sector(s). And you will need something like

    bs=1m​

    or your copy will take forever.

    Edit: I have a DVD recorder, I used to use it quite a bit with the TiVo HD before I got into the TTG stuff. You can always play back the game via S-video to a DVD recorder. I've done that in the past and the results were by no means HD, but weren't bad at all. My DVD recorder happily recorded S-video that played back fine in 16:9 ratio when my TV was set to "full" mode. But YMMV with all that. If it were me, I'd go the DVD recorder route. HD is over-rated anyway.
     
  10. Apr 29, 2010 #2270 of 10411
    waynomo

    waynomo My One Time TCF Club

    12,049
    36
    Nov 9, 2002
    Seven...
    Oops. I meant MAK. So if I get a second TiVo it will have the same MAK as my first? I.e. one MAK per account.
     
  11. Apr 29, 2010 #2271 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    Yes. You can't use Multi Room Viewing (MRV) between units unless that is the case.
     
  12. Apr 29, 2010 #2272 of 10411
    JohnL88

    JohnL88 New Member

    9
    0
    Oct 7, 2006
    Thanks for all the suggestions everyone. I'll let you know how it turns out.

    And to the person that asked .... it was the Cowboys beating of the Eagles in the playoffs! Great game.
     
  13. Apr 30, 2010 #2273 of 10411
    Test

    Test Active Member

    3,724
    0
    Dec 8, 2004
    Started using this program tonight and now I have a question. The download was fast, but the decrypt took 4 hours for a 1.5 hour show (8.2gb); is that normal? I'm using a mac and was previously using iTiVo, which downloaded slower, but I was completely done within 3 hours for the same type of file. I'm thinking that 4 hours can't be right, because I also have a pc running directshow dump and that is almost instant. Any settings I should verify? Change?
     
  14. Apr 30, 2010 #2274 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    No, that's not at all normal at all - decrypt should only take a few minutes. Make sure to turn off TS mode downloads if you haven't already: File->Configure->Program Options and disable Download TiVo files in Transport Stream format
    There are just too many issues being reported for TS downloads and/or decryption. Next version that option will default to off again. Of course that means you'll have to download the show again if it was previously downloaded in TS format.
    If that doesn't solve your decrypt slowness then monitor memory use and make sure you're not low on RAM.
     
  15. Apr 30, 2010 #2275 of 10411
    shiffrin

    shiffrin Member

    215
    0
    Aug 23, 2000
    Lancaster, PA
    The auto.log gets big pretty quickly. Did I miss an option somewhere to limit its size? I've been manually editing it each day to chop off the first few hundred lines, but that is getting to be a pain.
     
  16. Apr 30, 2010 #2276 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    There is no option right now. It's probably a good idea to have one. Next version (unreleased) already has a new menu entry in GUI to empty out auto.log file which is more convenient than doing it manually, but probably a user specified file size or line limit would be a useful addition. I'll look into it for next release.
     
  17. Apr 30, 2010 #2277 of 10411
    Test

    Test Active Member

    3,724
    0
    Dec 8, 2004
    That did it, thanks.
     
  18. Apr 30, 2010 #2278 of 10411
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,719
    7
    Apr 6, 2000
    SF Bay Area
    The semicolon (;) and apostrophe (') should be allowed to be used in file names on Kmttg. The double quotes (") can't be used but instead double apostrophe ('') is allowed.
     
  19. Apr 30, 2010 #2279 of 10411
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    Maybe for Windows yes. kmttg is encompassing multiple OS's including Linux and Mac so it's dealing with superset of potentially troublesome characters, and I don't want to try dealing with OS-specific exceptions. There are system calls being made for the helper programs so characters like apostrophes and semicolons cause issues.
     
  20. Apr 30, 2010 #2280 of 10411
    orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    FWIW, I use the following with Windows Task Scheduler twice a day at noon and midnight to create 3 sets of logs (full log, error log, and success log), all limited to 180 files (~30 days worth of logs):

    Code:
    REM Clearlog.bat
    @ECHO OFF
    SETLOCAL ENABLEDELAYEDEXPANSION
    
    ::------------------::
    :: Define Variables ::
    ::------------------::
    SET   year=%DATE:~-4%
    SET  month=0%DATE:~4,2%
    SET    day=0%DATE:~7,2%
    SET  month=%month:~-2%
    SET    day=%day:~-2%
    SET   hour=0%TIME:~0,2%
    SET   hour=%hour: =%
    SET   hour=%hour:~-2%
    SET minute=0%TIME:~3,2%
    SET minute=%minute:~-2%
    SET second=%TIME:~6,2%
    SET second=%second:~-2%
    SET   name=%year%.%month%.%day%.%hour%.%minute%
    
    ::----------------------------------::
    :: Copy current log to archive log, ::
    :: then seed the new auto.log       ::
    ::----------------------------------::
    CD /D "C:\Program Files\kmttg\logs\auto\"
    TYPE "C:\Program Files\kmttg\auto.log" >>auto.%name%.log
    ECHO %year%_%month%_%day%_%hour%:%minute%:%second% Beginning of new log file > "C:\Program Files\kmttg\auto.log"
    
    ::-----------------------------------::
    :: Select specific records to create ::
    :: an abbreviated log, showing only  ::
    :: "successful" messages             ::
    ::-----------------------------------::
    FINDSTR /I /V /P "Filter NPL Skipping curl sleeping programid getting match error ---" auto.%name%.log >>tmp.log
    FOR /F "tokens=1-3*" %%a IN ('TYPE tmp.log') DO (
    	IF "%%c" NEQ "" (
    		ECHO %%a %%b %%c %%d >> auto.%name%.s.log
    	)
    )
    DEL tmp.log
    
    ::-----------------------------------::
    :: Select specific records to create ::
    :: an abbreviated log, showing only  ::
    :: "Error" messages                  ::
    ::-----------------------------------::
    
    FINDSTR /P "ERROR:" auto.%name%.log >>tmp.log
    FOR /F "tokens=1-3*" %%a IN ('TYPE tmp.log') DO (
    	IF "%%c" NEQ "" (
    		ECHO %%a %%b %%c %%d >> auto.%name%.e.log
    	)
    )
    DEL tmp.log
    
    ::---------------------------::
    :: Save only 180 logs:       :: 
    :: 2 full logs,              ::
    :: 2 error logs, and         ::
    :: 2 abbreviated logs =      ::
    :: 6 logs per day x 30 days. ::
    ::---------------------------::
    SET /A counter=0
    FOR /F "delims=" %%i in ('dir /b "*.log"^|SORT /R') DO (
    	SET /A counter+=1
    	IF !counter! GTR 180 (
    		DEL "%%i"
    	)
    )
    
    EXIT /B
    
    Expectations: \kmttg\logs\auto directory has been created. My \kmttg\logs\auto directory is populated with filenames like this:

    Code:
    auto.2010.04.30.12.00.e.log
    auto.2010.04.30.12.00.s.log
    auto.2010.04.30.12.00.log
    auto.2010.04.30.00.00.e.log
    auto.2010.04.30.00.00.s.log
    auto.2010.04.30.00.00.log
    auto.2010.04.29.12.00.e.log
    auto.2010.04.29.12.00.s.log
    auto.2010.04.29.12.00.log
    auto.2010.04.29.00.00.e.log
    auto.2010.04.29.00.00.s.log
    auto.2010.04.29.00.00.log
    auto.2010.04.28.12.00.e.log
    auto.2010.04.28.12.00.s.log
    auto.2010.04.28.12.00.log
    
    Edit: It's bad that I have any *.e.logs. Too many problems with the Transport Stream and TiVoDecode! :(
     

Share This Page