1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New Netflix Won't Load?

Discussion in 'TiVo Help Center' started by ginginlala, May 11, 2012.

  1. ginginlala

    ginginlala New Member

    38
    0
    Jul 15, 2011
    Received the new software update today and applied it.

    Whenever I try to load Netflix, I get an error that reads:

    "An expected error has occurred, either the Netflix service is inaccessible, or there was a network error. Please try accessing Netflix again. If you are still having trouble, go to www.tivo.com/support for help."

    I've tried re-accessing it, rebooting the TiVo...same result every time. The error message appears to be rendered in what looks like the OLD Netflix interface, interestingly.

    Anybody else having this?
     
  2. ginginlala

    ginginlala New Member

    38
    0
    Jul 15, 2011
    I also note that the YouTube interface also still appears to be old.

    Seems like something went awry with my update?
     
  3. ginginlala

    ginginlala New Member

    38
    0
    Jul 15, 2011
    TiVo support was able to help me out. In case anybody has this problem, here's how to fix it. If you've updated but are still seeing the old YouTube interface and Netflix won't load, go to the Video Provider list, de-select both Netflix and YouTube, go back to TiVo Central, press Thumbs Down, Thumbs Up, Play, Play on your remote, it'll do a soft restart, then go back to Video Provider list, re-enable Netflix and YouTube, and voila.
     
  4. Solosmooth

    Solosmooth New Member

    87
    0
    Dec 20, 2003
    Got the new update on both my devices and my netflix app is broken on my tivo elite. network error. tried what you suggested and didn't work for me. netflix is working on my other tivo premiere.
     
  5. AMike

    AMike Member

    42
    0
    Oct 22, 2004
    Metro Atlanta
    I was having the same problem, but followed those steps. It works fine now.

    Thank you!
     
  6. ndirish2001

    ndirish2001 New Member

    2
    0
    Jan 5, 2011
    I tried that. I even tried a full restart (as opposed to the soft restart) but neither worked. I get the network error every time I try to load up Netflix. I can't believe that Tivo botched this update.
     

Share This Page