1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Netflix and Premiere

Discussion in 'TiVo Premiere DVRs' started by hybucket, Jan 20, 2013.

  1. hybucket

    hybucket Member

    558
    6
    Nov 26, 2004
    I notice several threads about Netflix streaming here and on the HD forum, but nothing recent. I just got the Premiere...it is on the latest software. I connect OK to Netflix, but when I start running a movie, it will load and start running, but within a couple of minutes, the video will go black while the audio keeps running. The only way out of it (that I know) is to go back to live TV, try TiVO again, but the same thing happens. I'm connecting with a G adapter with an N router, if that matters (TiVO told me that would not be a problem, and I have had no problems connecting to the TiVO service with that setup, and also streams Comcast OnDemand fine). I may try calling TiVO tom'w, but wonder if it's a Netflix problem.
     
  2. lujan

    lujan Member

    418
    0
    May 24, 2010
    Go to "Settings" and then "Video" and the "Video Output Format" and set it to "1080i" only. Leave the others unchecked and this problem will stop. This is assuming you have an HD TV?
     
  3. hybucket

    hybucket Member

    558
    6
    Nov 26, 2004
    Thanks - that sounds too easy! I have mine currently set at 1080p, I believe. I will try it after the Patriots game.
    Yes, I do have an HD TV, albeit a few years old (Samsung).
    As I said, I have no problem streaming YouTube or OnDemand. This was my first attempt at streaming Netflix, which always worked just fine on my TiVO HD.
     
  4. rainwater

    rainwater Active Member

    7,057
    1
    Sep 21, 2004
    Most likely your tv can't handle Netflix's 1080p output format so when Netflix starts playing it you get a black screen.
     
  5. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,522
    182
    Apr 17, 2000
    Nevada
    I had this problem once. Turned out that my TV was not establishing a secure HDCP connection with the TiVo. If you go to the system information screen you can see if the TiVo has a valid HDCP connection. If it doesn't then Netflix will only show a black screen.

    Dan
     
  6. hybucket

    hybucket Member

    558
    6
    Nov 26, 2004
    Thanks to you all. The problem was the 1080i selection. It now plays fine.
    I do have another TiVO/Netflix question, as long as I'm here.
    Is there any "guide" to how to navigate thru the Netflix app? I can't for the life of me figure a way out of a movie/program without just hitting the LIVE TV button. How do I just get back to the Netflix main screen? It was so much easier on the TiVO HD.
     
  7. jrtroo

    jrtroo User

    4,065
    6
    Feb 4, 2008
    Up on the remote will drop out of a program, then left to the icons.

    There is a thread out there where these are listed- I believe it was under the large "new" netflix thread. Sorry, but you'll need to flip pages. The lack of a user guide is in there as a complaint.
     
  8. hybucket

    hybucket Member

    558
    6
    Nov 26, 2004
    Thanks, I found that thread. Lots of complaints there, some legit (IMHO), and some just foolish. But I did find the "guide," for what it's worth.
     
  9. Ziggy86

    Ziggy86 Member

    857
    0
    Jun 22, 2004
    This worked for me. Thank you!!!!!!!!!!!!!!!!!!!!!
     
  10. Ziggy86

    Ziggy86 Member

    857
    0
    Jun 22, 2004
    Can someone please let me know what the buttons on our Tivo remotes do when using netflix?
     
  11. hybucket

    hybucket Member

    558
    6
    Nov 26, 2004
    If you read the above posts (there aren't that many...), the answer is there. It will involve some searching in the forums, but the answers are there. I had a similar question (as you'll see above). Not a perfect solution, but better than braving the cold at Redbox.
     

Share This Page