1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need power supply for TCD130 Series 2

Discussion in 'TiVo Help Center' started by aaronkn, Jul 25, 2012.

  1. aaronkn

    aaronkn New Member

    33
    0
    Nov 8, 2002
    Have a Series 2 TCD130 (AT&T brand TiVo) which appears to have died. No reaction whatsoever when I plug it in, so it seems like the power supply. Does anyone have one for this model for a cheap price? I've seen many go for under $20 on eBay, but just not for this model. Not willing to pay the $70 weaknees is asking given the overall value of this model tivo. But given that I have lifetime service on it, I'd be willing to try and get some more life out of it for little investment.

    (In case anyone from TiVo is reading this -- I'd of course be willing to buy an XL4 if TiVo would allow me to transfer the lifetime sub.:D)

    Thanks.
     
  2. lillevig

    lillevig Hot in West Texas

    1,769
    0
    Dec 6, 2010
    San Angelo, TX
    If you are handy with a soldering iron you might be able to just replace the capacitors and get it going. See if eBay or Craigslist has the same model without lifetime. Those usually go pretty cheap. If all else fails, another lifetime S2 is not that much. As for transferring the lifetime to a newer model - ain't gonna happen.
     
  3. unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    I wouldn't be surprised if the problem was "capacitor plague", but if you know how to use an ohmmeter, check to make sure the AC input jack is still connected, and doesn't just look that way.

    Also, you could ask Weaknees if they'll give you anything as a trade-in or core charge on the old supply.
     

Share This Page