1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need an image? Don't PM me. :)

Discussion in 'TiVo Upgrade Center' started by rcobourn, Mar 25, 2008.

  1. wbd

    wbd New Member

    12
    0
    Feb 24, 2009
    I tried doing a restore from WinMFS and it seems to go ok, but right at the end it crashes with a message about trying to expand the drive. After that I cannot even select that drive in WinMFS without it crashing. The only way I could get WinMFS to be able to select the drive again was to create a Windows partition on it. Tried restarting the computer, unplugging the drive, etc. Thanks.
     
  2. unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    What brand and model is that 320GB drive?

    Do you have a bootable copy of the MFS Live cd v1.4?

    Do you have a bootable copy of the Ultimate Boot cd?

    We need to run the manufacturer's own diagnostics on that 320, and then, in a situation where we know that we are doing it to that drive and only that drive, overwrite it with zeros (erase it, so to speak), at least for the first few thousand sectors.


    WinMFS should only bring up the question of expanding after a successful restoration, and only then by telling you that you have extra space and offering to expand.

    You should turn down that offer, by the way, because sometimes it doesn't work, even if it seems it did.

    Once you verify the restoration, you can go back and do the expansion as a separate step.
     
  3. wbd

    wbd New Member

    12
    0
    Feb 24, 2009
    Here is the info on the drive: WD Caviar SE WD3200JB. It was an external drive I had lying around and has been working fine. I do not have a bootable copy of MFS Live cd v1.4 but I guess I could download one and make it? Same for the Ultimate Boot cd? I didn't really want to buy a new disk for this TiVo as it is tough to find PATA drives and this thing is now reaching it's 12th year of service! But since it has a lifetime on it, figured why not try to extend it a bit more if I can. I do have 3 other newer TiVo's in my home also. Thank you for your help!
     
  4. unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    You might want to read through all of the SATA/IDE adapter thread

    http://www.tivocommunity.com/tivo-vb/showthread.php?t=416883

    As for testing and zeroing the drive, go to the bottom of this page:

    http://www.ultimatebootcd.com/download.html

    where it says Mirror Sites, and over on the left where it says ISO, click on one of the drive icons (they're really old icons from the early days of drives) to download the .iso file which is an image of the UBCD.

    Then you have to burn it to cd-r "as an image", so that the right parts are on the cd in the right places for you to be able to boot the PC from it.

    It's got lots and lots of stuff on it, including the WD diagnostic software.

    You should run the long test on the drive before putting it into service, and I'm pretty sure there's a "write zeros to the drive" option as well in that WD software.

    If not, post back after the drive passes the long test and I'll tell you how to do it the dangerous way from the command line with the

    dd

    utility, or maybe the more sophisticated

    ddrescue

    utility.
     
  5. jbluemke

    jbluemke New Member

    12
    0
    Sep 22, 2013
    Can anyone please send me a TCD240140 Image??

    My TiVo has been dead for quite some time and I am trying to make a backup of the tivo drive but I keep getting HD errors. :(

    Thank you SO much for any help!
     
  6. jbluemke

    jbluemke New Member

    12
    0
    Sep 22, 2013
    anyone? .....Please?? :(
     
  7. lessd

    lessd Active Member

    7,695
    5
    Jan 23, 2005
    CT
    I have the image but no convent way to get it to you, I guess you could set up a Drop box account and let me load the image into your drop box account, are you near CT.
     
  8. ThAbtO

    ThAbtO TiVoholic by the bay

    6,724
    8
    Apr 6, 2000
    SF Bay Area
    PM sent for a 24008a, think it should work.
     
  9. unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    Have you tried the search tool to search this thread?


    Anyway, these are from a 240080 (or 24008A) and will restore onto a drive with an LBA number of 160086528 or higher.

    Which means bigger than the non-Maxtor 80GB drives of 10 years ago.


    For use with the MFS Live cd v1.4:

    https://dl.dropboxusercontent.com/u/49887720/240_gset.bak


    For use with WinMFS:

    https://dl.dropboxusercontent.com/u/49887720/240_GSet.tbk




    The most recent version of the S2 software is 9.3.2c-01-2-xxx but these are 9.3.2b, because I could never get my 240 to update (which is to say I could never get the TiVo servers to update it).


    If you use TiVo Desktop and you've already patched it because of the expired cookie thing from last February, then even if your 240 never updates to "c" this image should work just fine.



    Just remember, do the expansion afterwards as a separate step after testing the drive.


    If using the command line

    restore

    do not use the

    -x

    option, go back later and use

    mfsadd



    Or in WinMFS when it finishes and offers to expand, tell it no, and then go back and do it by clicking on

    mfsadd

    later, after that target drive has become the selected drive.



    All of the above assumes you have a good drive upon which to put the image.

    I get to assume that, you do not.

    You need to run the manufacturer's own diagnostic software long test on whatever drive you propose to use before putting it into service or back into service.
     
  10. ThAbtO

    ThAbtO TiVoholic by the bay

    6,724
    8
    Apr 6, 2000
    SF Bay Area
    Beat you to it by about 3 hrs. :D
     
  11. unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    Hey, I gotta sleep sometime!

    :rolleyes:
     
  12. Jan 1, 2014 #1672 of 2373
    jbluemke

    jbluemke New Member

    12
    0
    Sep 22, 2013
    Thank you guy SO MUCH!! I will give it a shot later today!
     
  13. Jan 1, 2014 #1673 of 2373
    supz

    supz New Member

    1
    0
    Jan 1, 2014
    Hey ggieseke, could you please help me out with getting the image to TCD746320?

    I'm in the same boat as others on this thread. TiVo drive has failed entirely, refuses to even spin up to allow ddrescue to work, and I prefer to not pay for lifetime subscription again.

    Thanks!
     
  14. Jan 1, 2014 #1674 of 2373
    ggieseke

    ggieseke Active Member

    4,020
    11
    May 30, 2008
    PM sent.
     
  15. Jan 2, 2014 #1675 of 2373
    jbluemke

    jbluemke New Member

    12
    0
    Sep 22, 2013
    I just wanted to thank you guys for your help!! Works perfectly! :)
     
  16. Jan 2, 2014 #1676 of 2373
    Gangreen

    Gangreen New Member

    1
    0
    Jan 2, 2014
    Also looking for a series 2 TiVo backup image. Model TCD130040. It is a nice venerable 11 years old at this point. My lifetime subscription has served me well. :)

    This TiVo was behaving strangely with random crashes or freezes, and so I ordered a new drive. When it got here my existing drive wouldn't spin up so I couldn't pull a backup from it.

    Any help would be appreciated. Thanks.
     
  17. Jan 2, 2014 #1677 of 2373
    wbd

    wbd New Member

    12
    0
    Feb 24, 2009
    Hi unitron, it is starting to look like my backup is bad. I did everything you said above. I used MFSLive and ran the full test on the target drive and no errors. Then I zeroed the entire drive. All was fine. Then when I went to restore the backup to that drive it went as follows:

    Restoring 747 of 812 MB
    Cleaning up after restore. Please wait a moment.
    Restore: Premature end of backup data.

    I went back and tried recreating the backup. All seems to go well, but when I attempt the restore, same thing. Tried with another target drive that tested out perfectly and the same exact results. So I believe it all points to my source drive is corrupt and not capable of getting a backup from it.

    So it sound like my only hope is if someone can make available an original image for TCD130040?

    Thanks!,
    -Bill
     
  18. Jan 2, 2014 #1678 of 2373
    unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    Although I'm fixing to PM somebody who had a 130 at one time to see if they can help, I don't right now know of a source for a 130/230 image other than finding a working machine at Goodwill or on Craigslist or paying weaKnees/DVRupgrade for the Instant Cake version.

    If you could borrow a 1TB (or larger) drive from someone, you could try using

    dd_rescue

    or

    ddrescue

    to do a long slow copy of the current 1TB internal and see if you can get that working in the TiVo and then backup from it.

    One thing to consider, obviously you're using an adapter to run that 1TB in an S2 (or you have the only IDE 1TB drive ever made).

    Maybe the adapter is going bad and is part of the problem.
     
  19. Jan 2, 2014 #1679 of 2373
    sierra299

    sierra299 New Member

    2
    0
    Jan 2, 2014
    I also need the TCD746320 image as my original drive will not spin up. Looks like ggieseke has kindly provided a link to numerous people. Could someone send it to me? Thanks!
     
  20. Jan 3, 2014 #1680 of 2373
    wbd

    wbd New Member

    12
    0
    Feb 24, 2009
    I apologize, the drive in there was only 160GB and no adapter just stock PATA. As mentioned earlier, I have 4 TiVo's in my home all that I have upgraded over time and I thought they all had 1TB drives. I was mistaken, this one only had 160GB. So I guess the good news is that I should be able to try a ddrescue from the failing 160GB to my working 320GB? You mention dd_rescue or ddrescue. Which should I use and do you have any advice on options (I have not used these before)? Thank you again for all your help with this.
     

Share This Page