1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

my tweaks for gotomydvr service

Discussion in 'TiVo Underground' started by SteveT, Sep 5, 2007.

  1. Sep 5, 2007 #1 of 20
    SteveT

    SteveT Just a member

    102
    0
    Oct 23, 2002
    Easley, SC
    I've been using the excellent (and free!) gotomydvr service to access tivowebplus over the internet and would like to share a couple of techniques I've used to improve my usage. (See tcf thread for background.) My internet connection drops regularly, so 1 & 2 may not be needed by everyone. #3 should be helpful to anyone using gotomydvr, however.

    1. I replaced the dbclient program with a newer (0.50.1) version provided by supernaut. (attached) This eliminated the high CPU usage I was seeing when running gotomydvr. It also provided a couple of additional flags used in #2.
    2. I modified the watchdog.sh and rc.gotomydvr scripts to increase the timeouts and ignore some warnings. (attached)
    3. I overcame the extremely small window size by the following technique:
    a) open the gotomydvr site and select your tivo as normal.
    b) once the tivo is connected, I open a new page linked to https://gotomydvr.com/ This page opens without the frame, giving full-screen access to tivowebplus.
    c) I created 2 quick links on my toolbar to https://gotomydvr.com/select.php and https://gotomydvr.com/. The first lets me select which of my tivos to connect to (and asks for signon if first time), the second opens the full-screen version.

    These tweaks have kept my 3 tivos available for a couple of weeks now.

    Please use at your own risk. If you have difficulties, just reinstall from the gotomydvr site.
     

    Attached Files:

  2. Sep 5, 2007 #2 of 20
    mtcbuilder

    mtcbuilder New Member

    41
    0
    Nov 9, 2006
    To get a full screen, just right click on the frame, select frames> then click "show only this frame".
     
  3. Sep 6, 2007 #3 of 20
    SteveT

    SteveT Just a member

    102
    0
    Oct 23, 2002
    Easley, SC
    An excellent tip for those using FireFox. Thanks.
     
  4. Francesco

    Francesco Summum Pontificem

    18,365
    0
    Oct 4, 1999
    Maricopa...
    A little trouble getting it going with my humble way of doing things (I'm really un-savvy), but I finally switched the dbclient and it indeed dropped my CPU usage on the 540 from 85-90% down to 2-7%. One thing I notice though is that top now updates every three seconds or so and dbclient has a new PID every time.

    But well done!
     
  5. goofeyfoot

    goofeyfoot New Member

    33
    0
    Nov 16, 2005
    Don't know whether this is the correct place to post but here goes.

    SVR2000. Have Turbo Net Card.

    Telnet seems to work real good. But can't seem to properly install the gotomydvr application (whatever it is called)


    Here is the error I got when I did this. It's a direct quotation off the Telnet session:

    "TiVo: {/var/tmp} % /gotomydvr/bin/dbclient: TCP forward failed: Error listening:
    Address already in use
    /gotomydvr/bin/dbclient: Failed local port forward 7:127.0.0.1:7"

    Anyone know how to fix this?

    Thanks in advance

    Michael
     
  6. SteveT

    SteveT Just a member

    102
    0
    Oct 23, 2002
    Easley, SC
    Michael, I would suggest posting in the gotomydvr thread for install problems like this.
     
  7. Dec 4, 2007 #7 of 20
    Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    I decided to give this version a try since the service was usually not running when I wanted to remote in. I get this error when it starts;

    WARNING: Ignoring unknown argument '-y'

    Any thoughts? S2 649DT OS 9.1
     
  8. Dec 4, 2007 #8 of 20
    SteveT

    SteveT Just a member

    102
    0
    Oct 23, 2002
    Easley, SC
    My first guess would be that the replacement dbclient is not installed, or your script is finding another one, because the -y argument is one of the items added in the new version.
     
  9. Dec 4, 2007 #9 of 20
    Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    Thanks, I'll give it another try this evening but will run dos2unix on each file first
     
  10. tony4pres

    tony4pres New Member

    4
    0
    Dec 9, 2007
    Hello everyone. My first post here. I'm trying to set up gotomydvr program and for some reason I can't write anything in the telnet box once connected. it won't allow me to type at all. I've tried another program called ttpro313 to try to write to my tivo with no luck. Please forgive me for being so dumb but I've been reading everything I can for the last 6 hours and haven't gotten any closer to making anything work.I'm so freaking confused.LOL


    I have a series two dual tuner 80 hour tivo. It's hard wired to the network and I've used tivo desktop to pull videos from my tivo. What I'm hoping to accomplish is remotely accessing my tivo while on business trips. Is that possible or should I buy a sling box?

    Please don't beat me down for this post. I'm going to apologize in advance if I've broken any rules.

    Please help a brother out.LOL
     
  11. SteveT

    SteveT Just a member

    102
    0
    Oct 23, 2002
    Easley, SC
    I suggest you ask general setup questions over in the gotomydvr thread
     
  12. Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    Last two days my logs have been filled with these entries. Thoughts?

    Host '68.178.174.173' key accepted unconditionally.
    (fingerprint md5 7c:f1:17:0a:21:0f:7f:2f:90:3d:7d:08:4a:b7:9b:4d)
    /gotomydvr/bin/dbclient: Warning: failed creating //.ssh: Read-only file system
    Dec 12 11:41PM (none) kernel:
     
  13. SteveT

    SteveT Just a member

    102
    0
    Oct 23, 2002
    Easley, SC
    Afraid I have no suggestions. Perhaps someone with more dropbear knowledge will pitch in.

    My only suggestion would be to set the root to RW, let gotomydvr run a while, then set it back to RO and see if you still get the message. There might be something it needs to build only once.
     
  14. Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    No good, I got the same message except without the read only part.

    I put the original dbclient back in and those messages stopped. I prefer just getting the -y error to having my logs full of those entries. The service works both ways it is just a matter of logging.
     
  15. SteveT

    SteveT Just a member

    102
    0
    Oct 23, 2002
    Easley, SC
    Cool. You can eliminate the -y message by removing the -y from the command string at the bottom of rc.gotomydvr.
     
  16. Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    Now that worked, thanks...
     
  17. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    SteveT,

    Thanks for these contributions. I'm looking into things further and trying to integrate your changes, but so far have only had limited success. For some reason, I cannot automate the startup of dbclient with your script, but I can run it manually, but not in the background. I think it has something to do with id_rsa.db not being picked up by dbclient when it is run. Any thoughts on this?
     
  18. SteveT

    SteveT Just a member

    102
    0
    Oct 23, 2002
    Easley, SC
    Sorry for not noticing this question earlier, but the "noise" level on TCF is so high I don't attempt to keep up.
    Unfortunately, I have nothing to suggest, as I'm no longer using gotomydvr, and was never an expert at any of the ssh or dropbear stuff anyway.
     
  19. Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    Are you using something different? Care to share?
     
  20. SteveT

    SteveT Just a member

    102
    0
    Oct 23, 2002
    Easley, SC
    I finally got broadband, and configured a direct connection to/through my router.
     

Share This Page