1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My TiVos cant connect to new netgear router wifi

Discussion in 'TiVo Help Center' started by Alan_r, Oct 8, 2013.

  1. Alan_r

    Alan_r New Member

    33
    0
    Sep 13, 2013
    Hello all
    I posted this at the tivo support forums hoping to get some employee feedback, but figured I would give it a shot here as well.

    Im very well versed in networking (I do it for a living) and this one has me stumped!



    I have both a TiVo HD and Roamio Plus that cannot connect to my Netgear WNDR4300 router over WiFi.

    I just replaced my old router with this Netgear.
    The TiVos were working fine with the previous router.

    The new router has both 2.4g and 5g radios and the 5g SSID is different than my previous SSID.
    Both networks use WPA2-AES

    The Romaio is using the built in wireless
    The HD is using the TiVo G adapter.

    I tried joining the Roamio to the new 5g network and it never successfully connects.
    I either get the N02 (DHCP) or N07 (Router problem) errors. Or sometimes it says my password is wrong (which i triple checked and it isnt wrong)
    Same thing with the HD when I try to connect to the 2.4g network.
    Ive even tried specifying an IP manually, but it doesnt help.

    I have 5 other wireless devices in the house that can connect to both of the networks on the netgear.
    All use DHCP and connect without issue.

    The Netgear has options for network speed, depending on the radio selected I can choose "Up to 54, 130, 216, 300, 450"

    What Ive found is that if I set the 2.4g network to "Up to 54mbps" & WPA2-TKIP the Roamio will connect.
    (required restarting the Roomio though)
    I didnt try this with the 5g network.

    But connecting at 54mbps is far from ideal and would limit my other devices.

    Connecting to the router with a cable works fine.
    Unfortunately I was using a 30ft cable for testing - I dont have a jack close to either of the TiVos.

    So I dont actually think its a DHCP problem, even though thats the error I receive the most.
    (the router logs sometimes show an IP being assigned to the Roamio)

    I think its more of a negotiation problem when the networks are set to their highest speeds.

    I contacted Netgear but they were no help.
    My previous router was a DLink N router and the TiVos had no problem, except the signal was somewhat weak. (which is why i bought the netgear)

    So Im wondering if anyone else has come across a problem like this?
     
  2. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    Allow me to suggest that you give everything on the network that doesn't leave the house a fixed IP address and set the DHCP range to a set of numbers that the fixed addresses are not part of, and only big enough to accomodate the devices that do leave the house plus an additional 2 or 3.

    If your router is set to X.X.X.001, then start the fixed addresses at .002 and go up, and set the DHCP range from .254 downwards as much as necessary.

    In the future you can add either fixed addresses or DHCP address space without them running into each other until you've got something like 200 or more devices on that one network, at which point you'll already have hired someone to administer it for you.

    I can't guarantee that it will help, but it certainly won't hurt.
     
  3. Alan_r

    Alan_r New Member

    33
    0
    Sep 13, 2013
    I may as well just set the subnet to 255.255.255.248 or .240 and just limit the number of hosts that way...but I dont see what good that would do, since the TiVos dont get an IP and dont communicate on the network with a static IP.

    I can get them to connect every time as long as I limit the network to G speeds, which makes no sense to me.

    I did have some luck by changing the preamble to long instead of auto, which only enabled the TiVo to receive and IP, but it didnt actually help, they still had no network access.
    The network status says its on channel 0 during this time, so its definitely something with the wireless association.

    Im at the point where I may as well just return the router, its too much trouble now.
     
  4. GBL

    GBL covert opiniative

    1,740
    2
    Apr 20, 2000
    Twin Cities, MN
    Have you looked at the log files of your TiVos? Sometimes the logs give more information about the cause of the failed handshaking.

    You can access TiVo logs from the Account Information screen with the secret CCEE0 code.
     
  5. Alan_r

    Alan_r New Member

    33
    0
    Sep 13, 2013
    Ill take a look tonight.
    Does that code require backdoors to be enabled?
     
  6. GBL

    GBL covert opiniative

    1,740
    2
    Apr 20, 2000
    Twin Cities, MN
    No.
     

Share This Page