1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MFStools Boot CD - LBA48 Boot Disk for ALL TiVo Models

Discussion in 'TiVo Upgrade Center' started by tivoupgrade, Oct 4, 2004.

  1. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    No - but you shouldn't need to. Not sure about your MAC, but I've put used TiVo HD drives in PC's (running Windows XP) at one time or another and they work fine - remember you need to go into the admin tools to configure the new drive, its not going to show up automatically... That's a Windows issue, though...
     
  2. bengalfreak

    bengalfreak Active Member

    2,101
    0
    Oct 20, 2002
    Here are some ideas. I too only have 1 IDE channel on my system, and I had to pull the CDROM drive and jumper it as slave, while putting the hard drive I wanted to put in the Tivo on the master connector. It was the only way to get my system to recognize both drives. Secondly, I found that the folder names for the kernels have changed on the boot disk.

    Stick your boot disk in your CDROM drive, while booted in Windows, and see what the folder names are. Mine was in a folder called S1_KERNE instead of s1_Kernels. And the folders inside that folder were called KERNEL_X.X where X is the version number of the kernel you need.

    Hope this helps. I had some of the same problems recently.
     
  3. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    I think what you are seeing there is what windows does to compensate for FAT entries that are longer than 8 characters. The folder names haven't actually changed, though.

    The the OP; have you tried just using the "df" command after booting the CD-ROM to see what devices are seen?

    Not sure why you are having so much trouble - I've never tried using the CD with a drive on a single IDE system, but as long as you've got one drive configured as the master and the other as the slave, you shouldn't have a problem. You might also try disabling any SATA interfaces in case they may interfering.

    Lou
     
  4. smw6230

    smw6230 New Member

    21
    0
    Aug 24, 2009
    Thanks bengal, I got it fixed. There actually wasn't a problem with drive configuration. Everyting worked with CDROM master (hda) and the Tivo drive as slave (hdb). My real problem, posted in a non-sticky thread, was this was my first attempt at an upgrade and having gotten to the LBA48 kernal part I didn't want to screw up my new drive. So instead I was using a WD2500JB hard drive that was corrputed in another tivo as a test drive, if you will, to make sure that everything worked before I used my good drive.

    Once I figured out that the error stemmed from the inability of the boot CD to read/write onto the test drive, everything went smoothly after I switched the drives and used the good one as the target.

    Sucks that it took me two days to see that obvious problem, but........:eek:
     
  5. May 4, 2010 #545 of 572
    unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    If you've made it this far into the thread you're probably poor and desperate. : - )


    If you're desperate, but still have a couple of nickles to rub together left over after buying that big ol' upgrade hard drive, please consider one of the commercial offerings of the sponsors who pay to keep this forum online. If you haven't bought that big ol' hard drive yet, they can hook you up with that as well, and maybe even save you having to run "copykern" in the first place.


    The link (as of May 3rd, 2010) to the zip of the iso of the free 4.04 cd is

    http://www.dvrupgrade.com/dvr/stores/1/downloads/BOOTCD/ptvlba48-4.04.iso.zip

    and the way to mount it for the specific purpose of running "copykern" after booting it, but before running "copykern", is

    mount -t iso9660 /dev/hdx /cdrom

    where the "x" in hdx is

    "a" if your cd drive is primary (IDE 0) master

    "b" if your cd drive is primary (IDE 0) slave

    "c" if your cd drive is secondary (IDE 1) master

    "d" if your cd drive is secondary (IDE 1) slave

    The hyphen t flag/option (hyphens indicate that what immediately, i.e., no space in between, follows is a flag/option) tells the mount command that what follows the space after the "t" is the file system used by what it's supposed to mount, and iso9660 is the standard used by data cds.


    The /dev/hdx is the device you want to mount and the /cdrom is the directory you want to use as the mount point.

    When you boot the computer with this cd it creates the /cdrom directory, along with some others, as a mount point. Since it's already available, use it instead of creating your own with "mkdir".

    After you mount the cd drive on the mount point "cdrom", just type in "copykern" (without the quotation marks) and hit the Enter key. It will step you through the process.

    Do not "cd" (change directory) into "/cdrom" first.

    You can reach me by putting coastalnet.com after my username with the appropriate squiggly thing in between.
     
  6. sl8r1

    sl8r1 New Member

    8
    0
    Oct 16, 2003
    If you want a series 2 kernal, this disc is not free. $10 is trivial and not a big deal, but can we be honest?

    Burning the 'free' disc and booting to prompt, only to realize that there are Series 1 kernels on there is a bit of a hassle.
     
  7. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    It doesn't have Series 1 kernels, it has patches for the Series 1 kernel.

    If you have a Series 2, you already have LBA48 support.
     
  8. pcmodem

    pcmodem New Member

    1
    0
    Apr 10, 2011
    Thanks for the info!
     
  9. Mfusick

    Mfusick New Member

    10
    0
    Aug 25, 2011
    What do I need to install an upgraded hardrive in my HD tivo?

    I have the Tivo HD 2160 model. The original drive died. I have a 750 gig drive and torx drivers.

    What I don't have is the install CD, or any software. What software do I need ?

    Where can I get it? It is free?
     
  10. dwit

    dwit Active Member

    1,660
    0
    May 4, 2004
    Atlanta, GA
    If the hard drive is truly "dead", then you will need to obtain an "image" of the Tivo HD software, to load onto a new hard drive. You may be able to obtain an image from the "Need an Image?" begging thread, here in the Upgrade forum, or you can buy the "Instant Cake" image from dvrupgrade.com(downloaded, burned to cd image, or mailed cd). It is $40. Includes all the software you need to create a new Tivo HD hard drive.

    If you are able to obtain an image, then you can use the free tools(winmfs-easy, or the mfslive cd-more advanced) from mfslive.org to create a new hard drive. These tools can create a drive up to 1 TB in capacity. See the "Uprgrade" sticky thread in the S3HD Forum for instructions.

    If you decide to upgrade to 2 TB, you will need to use the free JMFS program. Instructions here in the Upgrade Forum, but first you will need to have a working Tivo hard drive to copy. It is basically a cloning program, so does not utilize an image, per se.

    Good luck.
     
  11. videobruce

    videobruce OTA is still alive

    348
    0
    Nov 30, 2012
    Buffalo NY
    If you can get it to work since it doesn't allow mounting SATA optical drives and their support forum is apparently dead!
    I wasted a half a day on that outdated program.
     
  12. ruckus816

    ruckus816 New Member

    9
    0
    Sep 18, 2013
    their site wouldn't even let me send in a question.
     
  13. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    So ask us the question instead.
     
  14. Darr247

    Darr247 New Member

    32
    0
    Mar 21, 2010
    Michigan
    Drive '1' is 1TB WD10EAVS (out of my S3 THX - I guess you guys call them OLED S3's) in a KingWin KF-1000 Trayless Rack.
    Drive '6' is a new/blank 2TB WD20EURS connected via SATA/PATA -> USB adapter (next computer I'll put 2 of those trayless docks in).
    Computer's OS is XP Pro SP3.

    Running WinMFS beta 9.3f... is this really all the settings I need to do, and click Start? [​IMG]
    (then Supersize drive '6' when it's done copying?)

    Am I missing something... I mean is it really that simple?
    Or have I been paying $30-$50 extra for larger drives just for this?

    Thanks for any info/warnings you can give me before I click Start. :)
     
  15. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    Okay, you've got version 11.0k of the TiVo operating system, so it can handle a 2TB drive (it was only with "k" or maybe the one before that this became possible).

    On the left you've got the correct drive selected as the "A" drive for the source.

    One the right, under Destination, change the "B" drive to none, and the "A" drive to the one to which you want to copy, which I assume is 6.


    If it were me, I'd increase the swap size, even though others haven't bothered to in the same circumstance and seem to be doing okay.

    To do that, check the Custom Linux Swap Size (MB) checkbox and put the number 1024 into the text box.

    Leave "No Optimized Partition Layout" UNchecked, because you DO want the optimized layout that's the way TiVo has been doing it since the Series 2s.

    Then click Start and prepare to wait a while.

    It may look like it's frozen up and isn't making any progress, but it is.


    When it finally finishes, it'll say you have extra space and ask if you want to expand.


    Tell it NO. Do not expand at this time.

    Click on File, click on select drive, and select the drive to which you just copied, the 2TB drive.

    Then click on the thing to the right of File, and click on mfsinfo, just to be sure it doesn't throw any error messages.

    You should have the same partition map as the 1TB, with a big Apple Free partition added on the end.

    Exit from that, and click file and then mfsadd.

    That will handle the expansion.

    It will expand the size of your 15th partition, which should be your 3rd MFS Media partition.

    If it says something about a single partition exceeding 1.2TB, tell it yes, that's what you meant to do.

    That should do it.

    You can check it again in mfsinfo to make sure everything looks kosher.

    If so, put it in the TiVo.
     
  16. Darr247

    Darr247 New Member

    32
    0
    Mar 21, 2010
    Michigan
    Good call... with the 'B' drive set on the right, clicking Start just told me "No Drive Selected!"


    I'm trying that on a second WD20EURS right now (got them on sale at newegg last week for $80 each)... though with only 128MB of RAM in the S3 THX (erp - OLED S3), I'm not sure much over 512MB of swap will be useful... but what the heck - the extra 512's only a half hour of SD time reduction.

    It took 28.5 minutes... but the 1TB was far from full. A few hours of downloaded SD podcasts and Stargate:Universe (HD)... but lots of Season Passes and manual record times, which is the main reason I wanted the full copy. I assume it would have been under 15 minutes with both drives on the SATA bus instead of the 2TB drive on a USB adapter.
    Result: 288 hours of HD; 2513 hours of SD.


    Can you tell me any problem in particular which can't be recovered by running the auto-MFSadd (answering Yes to the 'you have extra capacity... do you want to expand?' prompt), that can be recovered from by not trying MFSadd first?


    It made the 15th partition 1.6TB, for what that info's worth. :)

    MFSinfo pre-MFSadd[​IMG]
    MFSinfo post-MFSadd[​IMG]

    The first one's been happily working in the S3 for over 12 hours now, and those screen grabs above are from the second one, on which I'm also going to try an open-source alternative to WD's wdidle3 program.

    I wish I would have bought more of those drives, now. :-|

    Anyway... thanks for the quick reply and tips!
     
  17. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    A recently manufactured WD20EURS should not need wdidle3 the way actual Caviar Green drives do.

    The expansion has to be done as a separate step with WinMFS because just accepting the offer to expand after copying may appear to work, but actually doesn't.

    I don't know why.

    It would be interesting to know why, but since it can be done the other way, I can live with that.
     
  18. djtravis

    djtravis New Member

    46
    0
    Jan 23, 2003
    Lockport, IL
    I am trying to put a 1T drive in my S3 TiVo and I am not having any luck with winmfs beta 9.3f (running XP home SP3). I purchased 2 WD Black 1T drives and I have tried both and I get the same error on each. The backup worked just fine. The restore goes through the motion (maybe 30 seconds or less) and finishes with "Error writing media inode0". I ran diagnostics on the new drive and it tests ok. Any ideas?
     
  19. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    You should have gotten a WD20EURS, but the blacks should work.

    Are you copying the original 250GB (TCD648250--OLED S3) or 160GB (TCD652160--S3 HD) drive to to the black, or creating a truncated backup file (.tbk) from the original drive and then trying to restore to the 1TB from that file?

    Can you have your Windows drive, your original TiVo drive, and one of the 1TB Caviar Blacks all connected to the PC at the same time?
     
  20. djtravis

    djtravis New Member

    46
    0
    Jan 23, 2003
    Lockport, IL
    To try to answer your question (hopefully): I created a .tbk file from the (I think) working TiVo 500G drive. Then I tried to restore to the 1T drive. I gave up on winmfs & went back to mftools because I didn't really trust the winmfs backup image even if it had restored. History: When I got the S3, I removed the 250G drive immediately & made a backup using mftools, then I restored that backup onto a 500G drive and have been using that 500G drive for 7 years, it now broke. I purchased the Black drive & tried to restore that backup file onto the Black (1T) drive. The backup file is a version 8 software. I had the XP system set up as hda=TiVo drive (Black), hdb=backup image (FAT32), & hdc=CD/DVD drive. That restore failed on 2 different computers using 2 different 1T drives. I stayed up late last night & changed the drive hookup & set it up as hda=TiVo drive (Black), hdc=CD/DVD, & hdd=backup image (FAT32). I suceeded in making a copy and I now have that system working, after I forced an update to V11m software. I have 2 systems, I cannot get the image restored to the 2nd Black drive. I ran WD diagnostics on the 1T drives and it says all ok. I'm going to try the restore a couple more times this morning just for the fun of it. The restore (mfstools) worked w/o a hitch 7 years ago when I did them initially using the same computer as I'm using now. The computer has PATA interface & I have a PATA to SATA adapter that I use for the TiVo drive.
     

Share This Page