1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MFStools Boot CD - LBA48 Boot Disk for ALL TiVo Models

Discussion in 'TiVo Upgrade Center' started by tivoupgrade, Oct 4, 2004.

  1. Tim N.

    Tim N. New Member

    Apr 28, 2003
    I licensed the software for Sony SVR2000 and tried to build a 200GB Maxtor drive. This would be the second upgrade/replacement disk. I only have a single drive.

    When I ran the upgrade software it reported everything worked fine. When I replaced the new drive into the TIVO I olny get the black "TIVO is starting up" image and it never goes any further.

    Any suggestions?
  2. Tim N.

    Tim N. New Member

    Apr 28, 2003
    Forget the above post. I went to the right support place and probably found my answers.

    Next time, I'll look first and post second...
  3. Tim N.

    Tim N. New Member

    Apr 28, 2003
    I cannot get much of anything to behave the way the instructions tell me to expect...

    I try three different schemes to get PTV IC and PTVlba48 to work and nothing gets past the TIVO startup screen. PTV fails to answer any emails for support.

    I go back to 2.0 tools and start over. I'll live with 137GB of space out of 200GB on the drive.

    I perform mfsbackup to a FAT32 partitiion and it says "okay"
    I put the new disk in and msfrestore -s 127 -zpi /mnt/dos/tivo.bak /dev/hdb results in "/mnt/dos/tivo.bak: No such file or directory"

    Any suggestions?
  4. azitnay

    azitnay New Member

    Jan 20, 2003
    Is /mnt/dos/tivo.bak definitely the correct location of the backup image you created in the mfsbackup step?

    What happens when you type:

    ls -la /mnt/dos


  5. Tim N.

    Tim N. New Member

    Apr 28, 2003
    I'm linux illiterate. I don't know what commands to use for simple information gathering.

    I figured out that the restore didn't work because I didn't execute the two commands earlier for mkdir amd mount. When I did these, the restore worked and the disk booted up in the Sony TIVO.

    Then I tried to restore all of my old movie files and the restore operation failed on error 3.

    I'm going back to resore with expand and will live with no old recordings.

    Thank you for trying to help me.
  6. NardVa

    NardVa New Member

    Jul 15, 2006
    Does the free PTVupgrade LBA48 4.04 cd include a virgin 3.1.5 keneral?

    I know the PTVupgrade cd with enhancements includs the killhdinitrd 3.1.5 kernel, but I was reading where you can do the killhdinitrd process yourself on a virgin 3.1.5 kernel.
  7. tivoupgrade

    tivoupgrade Sponsor

    Sep 27, 2000
    Only Series1 kernels on the free CD...
  8. dsnook

    dsnook New Member

    Aug 24, 2006
    Hi Folks,

    Like most everyone else on this forum still owning a series 1 DirecTiVo unit , I've been reviewing all these threads and gleaning them for the necessary info to remedy my ailing TiVo unit. In spite of my efforts, I still cannot find a set of detailed instructions to upgrade the kernel.

    I have deduced that I need to use 'copykern' and 'killinitrd' (or is it killhdinitrd?), but I have found little in the way of how to use them. Could some kind soul on this thread please offer this data without telling me to look at some other obscure thread? I don't have the time to pick this out one post at a time; that's why I'm requesting it from you experts here on this forum.

    Here is my situation:

    I own a Sony SAT-T60 series 1 unit that had the HD upgraded recently (last Jan) using InstantCake app. I replaced the original 40 GB HD with a 160 GB HD following their instructions and was working fine until a few months ago when my Tivo unit froze on me. All I did was press the Tivo button on the remote and the Tivo menu overlaid my live TV display and would not go away regardless what buttons were pressed on either the remote or the unit . I was only able to reset the unit by cycling the power.

    I have over 40 hrs of recorded content that I dearly wish to recover. Will upgrading the kernel with 3.1.0+ allow me to retrieve this content afterwards or will it disappear?

    When I invoke the 'copykern' command to upgrade the kernel, do I have to use 'killhdinitrd' too? Is this only necessary for units that have additional networking functions? This unit has only had the HD upgraded and no other networking features were added. Do I still have to use 'killhdinitrd' anyways? Could someone please clarify this?

    Thanks for the help.

  9. kpfleming

    kpfleming New Member

    Dec 23, 2003
    In November of last year I bought two Maxtor 300G drives and InstantCake to use to upgrade my HR10-250 (which was brand new at the time). I tried multiple computers, multiple IDE cables, etc., but was never successful.

    A few weeks ago, I tried again, using yet another computer I had built since then. Wonder of wonders, this time InstantCake actually produced a usable Tivo drive, but the Tivo did not see the additional space on the second drive (even though the 'mfsadd' output during the InstantCake run did show it being added).

    I then started trying to manually use mfsadd to add the space myself, using the LBA48 boot CD I downloaded at the same time as InstantCake (as well as the recently updated 4.04 LBA48 boot CD). Each attempt failed, and trying to do is resulted in a series of 'drive busy' and 'drive write error' messages in the kernel message log. However, the drives are fine; they have been thoroughly tested by the Maxtor tools, and it doesn't matter which drive I make the A drive... the errors are always reported on the same sectors.

    Since I still had my original drive from the HR10-250, I decided to try the Weakness upgrade process instead (I was originally trying to avoid touching that drive, even just to read from it). I downloaded their CD yesterday, plugged all three drives into my computer, booted off the CD an ran the mfsbackup/mfsrestore piped process. Less than an hour later, I had a fully functional HR10-250 with 600GB of working space (77 hours HD, 515 hours SD). There were no kernel messages when the mfsrestore process ran; everything was clean.

    So, as best I can tell, the Linux kernel on the Weaknees CD is significantly better than the one on the PTVUpgrade LBA48 CD (and apparently on their other CDs as well, since my InstantCake CD had the same problem).

    Just thought I'd report this in case others are interested... I'm happy now that my Tivo is upgraded and working, and I'll write off the $20 InstantCake purchase as a learning experience :(
  10. jelboston

    jelboston New Member

    Sep 10, 2006
    Hi- newbie question here. I am trying to upgrade my TiVo 540040 with a Seagate 300GB drive. I downloaded the newest version of PTVupgrade LBA48 Boot Disk (version 4.04) and loaded it onto my computer. It is an old AMD K6 with 256MB ram running Windows 95- I borrowed it from the trash heap at our office.

    I have gone over the instructions on the PTVUpdate site and Weaknees numerous time. I have been planning on doing this for 2 months- today I took the plunge.

    I took apart my TiVo and put the drives in place. I have my c: drive recognized in the hda position, the Seagate is recognized in the hdb position and the CD Rom is recognized in the hdd position. In lieu of it saying hdc it says

    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx

    in another place it says

    spurious 8259A interrupy: IRQ7.

    I have moved the jumpers around a couple times to no avail.

    Any suggestions?

    Thanks for your help in advance.

    A newbie.
  11. steff3

    steff3 Member

    Sep 17, 2005
    Attempting to complete the upgrade using instant cake for my HR10-250 to a single new seagate 400gb hd. Everything fine until I get to .....................now we will begin baking..... then I receive:

    mount: medium not found

    /etc/rc.d.S: /cdrom/ .live/bin/ptvbake: No such file or directory

    What is happening? :confused: It looked as though everything was found as it should have. Problem with the download of instant cake?

  12. deek_man

    deek_man New Member

    Jul 26, 2002
    I hope this is the right place to post this.

    I have upgraded several different units for myself and a couple of friends. I now have a refurbished Hughes SD-DVR40 which I want to upgrade for a friend to two 200 GB hard drives. I've checked the machine and it seems to work properly but it has the 3.xxxxx software. My underestanding is that it has to have the 6.xxxx software in order to recognize the entire 400 GB due to the limits on the older software. I can't activate with DTV and force the new software upgrade since I'm upgrading this for a friend who lives on the other side of the country. My question is this: If I choose the option in the option list that I have less than the 6.2 software version in the weaknees interactive upgrade instructions, will the upgrade process do whatever is necessary to recognize the entire 400 GB? Or will the software have to be upgraded first. If it will not recognize the entire 400 GB, must I have the DTivo upgraded to the higher version software first and can I do that without sending the machine to my friend to activate and force the upgrade, then send it back to me to upgrade with the larger drives?

    Any help greatly appreciated.
  13. albrandwood

    albrandwood New Member

    Aug 12, 2002
    OK ... I'm not sure what your _ACTUAL_ problem is ... but you can ignore the "ide: Assuming 33MHz system bus speed for PIO modes; override with idebuss=xx" ... since that is just the system telling you that the linux kernel did not recognize the IDE controller, and so is unable to use DMA transfer ... the net result is slightly slow upgrades ...

    you have mentioned that:

    (a) your C: drive is showing as hda
    (b) your _new_ Tivo drive is showing as hdb
    (c) your CD Drive is showing as hdd

    are you saying that the CD is not recognizing your _old_ Tivo drive (as hdc)? Is it being seen by the BIOS during the initial POST ?

    Once the machine has booted to the CD, try typing "mount" ... what does it report?

  14. deek_man

    deek_man New Member

    Jul 26, 2002
    Can I use a drive from one DTivo (Hughes SD-DVR40) to replace a drive in an identical unit? It could solve the problem I mentioned above.

    Thanks in advance for any help.
  15. marsbarbabe

    marsbarbabe New Member

    Mar 1, 2003
    Hello everyone,

    This thread seems to be on the subject I need help on. i'm haveing a lil problem HERE

    to summerise..
    I have a UK spec series 1 single drive TiVo version 2.5.5. I used Hinsdales guide to upgrade it to a 250gb single drive. I need to make my TiVo see all 250gb and understand I need to change the kernel to lba48.

    This CD that this thread is based about.. does it cater for my needs on a UK (only ever series1) spec TiVo?

    Is there a guide on what/how to use copykern or this disc to help me out?

    I've read and read and found little tit bits on UK machines but no definitive answers.

    Any and ALL help is greatly appreciated.

    Many Many Thanks

  16. steff3

    steff3 Member

    Sep 17, 2005
    Oops, my bad, had the HD connected to the wrong IDE ribbon and forgot to disconnect the other two cd/dvd drives. Once I woke up and connected properly, all went smooth! :up:
  17. heatzeker

    heatzeker New Member

    Sep 18, 2006
    Has anyone tried the Knoppix Linux disk image?
  18. azitnay

    azitnay New Member

    Jan 20, 2003
    It should work fine, but you'd have to obtain the mfstool binary yourself... Much easier to just use this CD with mfstool built in.

  19. jbch

    jbch New Member

    Dec 16, 2005
    Does someone have a link to a 2.4.18 kernel thats been patched for lba 48 support. Need the old kernel for a 4.x software to monte to. Its preferred that it be pretty standard without other hacks, but I will try any that are provided.

  20. JerryZ

    JerryZ New Member

    Feb 5, 2003
    Attempting to do an upgrade. Is anyone available for some help? Either phone, email or PM?
    Many thanks

Share This Page