1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MFStools Boot CD - LBA48 Boot Disk for ALL TiVo Models

Discussion in 'TiVo Upgrade Center' started by tivoupgrade, Oct 4, 2004.

  1. lorenmcguire

    lorenmcguire New Member

    May 10, 2006
    OK. I have read almost all the postings in this area. Here is my system and problem.
    Phillips HDR212
    Original Drive - 22 gig - Toasted beyond recovery

    I have bought the PTVupgrade InstantCake CDROM for a Series 1 Standalone TiVo Unit.
    Code: ICAKE-S1SA
    Thought this would be the easy way to do this, I would not have to write the program, I would get a good restore CD and everything would be cool. NOT!!

    I have followed the instructions on the CDROM to the letter. The CDROM is on the Primary IDE controller and a slave on that contoller. There is no primary drive, as I have removed the drive (was a windows drive and wanted to make sure it did not get toasted). The drive to be upgraded is on the secondary controller as a slave drive. There is no other hard disk in the system. The new drive is a 60 gig Maxtor MX6L060J3. This is a drive I have had in a Windows system which I recently upgraded.

    During the "Baking" portion, it appears the scripts and so forth are copied into memory. The "Baking" occurs and says I now have good disk with like 47 hours available.

    Adding Pair /dev/hdc12-/dev/hdc13

    Your Cake has been successfully baked. Please shutdown your computer remove the drive and install it in your TiVo. Don't forget to clear and delete.

    Put the disk in the TiVo and the TiVo boots. It goes through a few cycles, asks me what my zipcode is, my phone number prefix, then dials. After dialing, the hard disk basicly is accessed for about 60 seconds or so, indicated by the hard disk red light going on and off. The screen then goes to the "Almost there. A few more seconds please" with the PTVupgrade logo on it. IT THEN REMAINS ON THIS SCREEN VIRTUALLY FOREVER.

    I have also tried this with the following command line:
    mfstool restore -r4 -b -x -p -s 300 -zi /cdrom/.images/000001

    Took me a bit to figure out that the program on the disk unmounted the cdrom after copying what it needed into memory. I remount the cdrom, go to the mfstools directory, then access the image on the cdrom directly.

    This above command line gets the same response at the end, stating a successful restore with 47 hours now available.

    I have seen a couple of errors at the end of some of my attempts stating:

    umount2: Device or resurce busy
    umount: /dev/hdb busy - remounted read-only

    I don't believe these errors are significant issues, as unmounting and mounting a file system with linux is not generally an issue. Hitting control-alt-delete sends a kill signal to all processes and will stop the machine.

    This only appears to happen when using the PTVbake method, so not sure what that is all about. It doesn't happen all the time.

    My questions are:
    1. Why does the bake not work all the way?
    2. Anyone ever seen the above 2 errors? (and are they significant)
    3. Why would it be successful (according the cdrom load) but hang after being put in the TiVo
    4. Is there a jumper setting that is specific to the TiVo hard drive? (does the drive have to be a Master, Slave, ????)

    As a side note, I have used both an AMD 2000+ on an ECS Motherboard and an Intel 866 Slot 1 on an Abit motherboard. The results are the same.

    As another side note, I have run the PTVupgrade cdrom in a Microsoft Virtual Machine with the same results on both the manual mfstool input and the run from the CDROM. I had to change the script on the CDROM a bit (and reburn it) because MVM does not put a hard disk on the secondary controller and the CDROM can only attach to the Secondary Controller. Other than that it worked fine.

    Any help on this would be appreciated. I just want my TiVo!!!
  2. tweekerz

    tweekerz New Member

    Oct 13, 2002
    I am in the same boat as you, but I have not successfully copied everything.

    I have S2 130 Series AT&Tivo which started with a 40gb, that was upgraded and expanded to a 160 GB 5400 rpm

    But now, the drive clicks when I have something on pause for more than 10 minutes.

    Now, I am trying to copy everything over to a new 200GB.

    I tried the PVxxx cd and instruc, and also the weaknees instruc. To no luck.

    I even tried the dd: command, and that didnt work either.

    What command lines did you use?

    Specifics would help.



  3. lorenmcguire

    lorenmcguire New Member

    May 10, 2006
    The command line I actually used to restore the PTV image to the hard drive was:

    mfstool restore -r4 -b -x -p -s 300 -zi /cdrom/.images/000001

    This also required the mount for the cdrom. Here are the steps:

    1. Boot from the PTV cdrom.
    2. Let it go through to the point where it asks you if this is going to be a 1 drive or 2 drive installation.
    3. Hit Control C - Ctrl key and C key at same time to abort the script
    4. Type - fdisk - l (this is a lower case L)

    The fdisk command will tell you what drives are connected and where they are mounted. The drive you want will be on hda, hdb, hdc, or hdd. The cdrom will also be on one of these. The mfstools-2 directory will be in the root partition. This actually is residing all in memory.

    Type - mount /dev/hdb /cdrom (this will most likely be your cdrom if you have it connected to the primary ide controler as instructions state.

    This should then allow you to run the mfstool restore command.

    Let me know if this works for you. The -x option in the mfstool restore is to expand the "image" to fit the drive and have access to all the space. The 300 option is for caching purposes. (300 megabytes). If you look in the /bin directory you will also find a BlessTivo executable which is supposed to restore the boot partition (first few tracks) and make the drive bootable in the TiVo.

    I have been programming for a number of years, including on Linux, HP, Windows and with a variety of programs including C, C++, Vis Basic, Basic, Shell Scripts and a lot of others, but this has got me stumped. Short of going over to a friends and sticking the hard drive on his PowerPC machine, I have about exhausted my options. At one point, I did a mfstools mfs /dev/hdc and I did get a listing from the drive of all the available partitions, but the thing still failed to completely work after putting it in the TiVo. Not sure if the TiVo has a problem, or I'm still doing something wrong.

    Any insight would be appreciated. I have also tried the above commands without the -x option just to see if a simple restore of the image to the disk would work. It didn't.

  4. claird

    claird New Member

    Dec 1, 2002
    I have read and read but am still confused. I am not a linux user (sorry). I downloaded the free PTV cd ISO for kernel 3.10+ and burned the CD. Booted on the CD with my broken (3.5) Directivo series 1 160GB drive as secondary master (hdc). typed copykern and followed the prompts. But I simply do not understand killinitrd!
    Is is a command: kill initrd ?
    Is it a program somewhere on the CD?
    Is it a program on the TIVO?
    Do I have to mount something or change to something and then type something?
    I see in the threads the utility program killhdinitrd which people vaguely state you can download and put onto a floppy or CD and then voila type killhdinitrd and Linux finds the media and utility somehow on its own, but where are the specific instructions on how to download a Linux utility and put it on a CD or floppy while using Windows XP?
    Thanks for any replies that can help me fix this problem.
    Craig Laird
  5. tweekerz

    tweekerz New Member

    Oct 13, 2002

    Well I got everything to copy over... but I am unable to expand using the
    mfsbackup -Tao - /dev/hdc | mfsrestore -s 127 -xzpi - /dev/hda COMMAND.

    I get Backup target not large enough for entire backup by itself.

    I used these commands to get it to copy EVERYTHING

    mkdir /mnt/dos
    mount /dev/hda1 /mnt/dos
    mfsbackup -f 9999 -6so /mnt/dos/tivo.bak /dev/hdc
    dd if=/dev/hdc of=/dev/hda
    umount -f -a -r

    Then tried to expand, but no luck
    I just want more hours... but can live withou em, the rive only costed $30 during Black Friday!
  6. azitnay

    azitnay New Member

    Jan 20, 2003
    This is often the case when attempting to expand a second time... Most likely, you'll need to start over without recordings if you want to use the full 200GB.

  7. LastPlace

    LastPlace New Member

    Feb 21, 2005
    I'm having some trouble, too, with my Sony SVR-2000.

    I tried to copy the image from the original 30GB to my new Seagate 7200.9 300GB hard drive but finally gave up and bought InstantCake.

    I've "baked" it twice and both times it just hung at the initial "Powering Up..." screen.

    Some more details:

    Went through and got a message about it being successful and to do a clear-and-delete.

    Put it in the TiVo and powered it up – it just stuck at Powering Up, just a minute...

    Unplugged it, powered it down and started it back up – let it sit for about 3 hours but never made it past that same Powering Up, just a minute… screen.

    Took the drive out, and figuring I missed something important the first time, I rebaked it. It seemed to go through fine and then said

    Uncompressed backup size: 816 megabytes
    Restoring 816 or 816 megabytes (100.00%) (83.78% compression)
    Cleaning up restore. Please wait a moment.
    Restore done!
    Adding pair /dev/hdc12-/dev/hdc13
    New estimated standalone size: 342 hours (312 more)

    CONGRATULATIONS! Software installed…

    Your cake is baked! You should now power down your PC and move your drives to the TiVo. Don’t forget to do a clear-and-delete everything once you’ve booted your unit for the first time with your new software.

    umount2: Device or resource busy
    umount: /dev/hda busy – remounted read-only

    After a while the last line changed to
    /# May 13 22:58:03 PTVupgrade syslog.info - - MARK - -

    So given that I felt like I was "giving up" by going to InstantCake, I'm feeling particularly stumped! I did see that the image I bought had been successfully tested on a drive as large as 250GB and mine is 300GB. Given that it recognized the larger amount during the baking, that's not the problem is it?

    Any help is most appreciated!
  8. LastPlace

    LastPlace New Member

    Feb 21, 2005
    I was concerned that the jumpers may be the problem...

    When I baked the new Seagate 300GB 7200.9 hard drive, I had the jumper in the Master position. I recall that was the correct placement but now I haven't been able to figure out where I read that and can refer back to for confirmation.

    I had started up the TiVo with the Seagate's jumper still in the Master position and it hung at "Powering Up..."

    To make sure it wasn't a jumper issue I've tried starting the TiVo with the jumper in each of the possible locations and got the same result each time; the unit just sits on the first "Powering Up..." screen.

    And I've confirmed that the TiVo unit is not the problem because I restarted it with the original drive that came with it - no problem with that (other than the hard drive size)

    So - what do I try next :confused:

    Please - help me climb my way out of this "easy" project I got myself in to!

    Thanx :eek:
  9. tivoupgrade

    tivoupgrade Sponsor

    Sep 27, 2000

    You are posting in the wrong thread. FirstPlace ;-) to start is with the instructions ; from your first post, because it sounds like you may not have connected your drives properly. You may also want to read this thread and if you continue to have problems, use the official support thread as another resource. Thx.
  10. LastPlace

    LastPlace New Member

    Feb 21, 2005
    OOPS :eek:

    I'm off to confirm I've read through the suggested links!
  11. Blitz68

    Blitz68 New Member

    May 11, 2006
    Here is what I want to do. I have an HR10-250 with the Super Bowl recorded. I want to make this DVR networkable without reimaging. I am going to have a full backup image before doing this. It is my understanding if I use Instant Cake I will erase all of my recording and settings...right?
  12. tivoupgrade

    tivoupgrade Sponsor

    Sep 27, 2000
    InstantCake is for reimaging drives, not networking; and yes, it will overwrite everything the drive used. We do not recommend using your original drive.

    You can use PTVnetHD for networking, however that is beyond the scope of this thread which is intended for DIY folks using the LBA48 CD.
  13. johnny*dangerous

    johnny*dangerous New Member

    May 19, 2006
    I have a t-60 with a 300g drive. This is what I did - tell me where I may have gone wrong....

    After receiving the 3.5 upgrade, many of my shows in the now playing list were not working, as well as my cachecard.

    I reinstalled the cachecard with /nic_install/nic_install cachecard (from the iso disc) It asked me if it could disable the initrd - I said yes.

    After the install was complete, I used the 4.04 LBA48 iso from PTV Upgrade.

    All I did was boot the disk and type "copykern" and followed instructions to ensure I had the correct hard drive.

    It said it was successful and I rebooted and hooked the t-60 back up. The cachecard is working but the shows still aren't working.

    Did I miss something in my process?

  14. Rhughes

    Rhughes New Member

    Jan 14, 2001
    With the 3.5 upgrade you can no longer use all of a large hard drive because the new kernel won't support it. I'm sure it won't be long before we have another kernel for large HD support with the Series 1 DirecTiVo's.
  15. tivoupgrade

    tivoupgrade Sponsor

    Sep 27, 2000
    Please take a look at the first post of this thread - there is already one available.
  16. johnny*dangerous

    johnny*dangerous New Member

    May 19, 2006
    :) I solved it - for some reason it wasn't copying the kernal properly, I had to mount the cd rom again and then copykern.

    Everything is up and running now.
  17. john_o

    john_o New Member

    Nov 27, 2000
    I am having trouble with the copykern utility -- I am not convinced it is actually copying the kernel over since when I put the drive back in my TiVo it still reboots during playback and many shows are not accessible.

    I have telnet and ftp back up -- can anyone give me the file path where the kernel lives? I remember seeing a reference from tivoupgrade but I can't find it for the life of me now. I presume I can just ftp the 3.1.0+ kernel image over from the cd and swap it out?

    Does the utility move the 3.1.0+ kernel to both the 3 and 6 partitions?

    Will the kernel rev # be reflected in the TiVo System Information screen?
  18. Rhughes

    Rhughes New Member

    Jan 14, 2001
    I guess that's what I get for reading the lastest posts instead of going back and starting from the beginning. :)
  19. john_o

    john_o New Member

    Nov 27, 2000
    Of those who have successfully upgraded to the LBA48 kernel, do you have issues with the video image not clearing when you get the 'keep/delete this episode prompt?' (i.e. you see the show you were just watching rather than the blue background?) This is what makes me wonder if I am actually at 3.1.0+ or not...
  20. PyroMan

    PyroMan New Member

    Jun 5, 2002
    I have a SAT-T60 that I forgot to pull the phone line from and it received the upgrade. The drive had recently been upgraded to 300GB and now upon boot it says "Cannot load kernel" or something to that effect. For now I have loaded the original HD back into the unit and pulled the upgraded drive.

    Most people on this site have stated that they can boot, but cannot view all of their shows. I would like to know if I should be able to use this CD, along with the one at SiliconDust forums and be able to get my unit working again with the upgraded HD? The unit in question is currently not networked, but I am considering doing this in the future.

    Second issue, I have another identical unit that I was able to stop from updating. Do I just follow the directions in the first post prior to allowing the unit to take the update and reboot or after?


Share This Page