1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MFSLive v1.4 and NTFS problem

Discussion in 'TiVo Upgrade Center' started by jerrymc, Feb 25, 2014.

  1. jerrymc

    jerrymc TiVo Tinker

    182
    0
    Sep 17, 2001
    Antioch, CA, US
    Having trouble with MFSLive boot CD version 1.4 and my NTFS Windows XP boot volume. According to the release notes, NTFS volumes are supported for r/w access now under the Linux kernel. However, the following command sequence doesn't work:

    mkdir /win
    mount -t ntfs -w /dev/hda1 /win
    backup -f 9999 -6so tivo.bak /dev/hde

    The last command gives the result:
    tivo.bak: Permission denied

    I've also tried using:
    mount -t ntfs -w -o rw /dev/hda1 /win
    with the same results.

    Am I doing something wrong, or is this a problem with MFSLive? Is there another MFS tools boot CD that supports NTFS for R/W??

    Thanks!
     
  2. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC

    It may be that it can write to NT partitions, but it doesn't have all the right permissions to write to that particular NT partition.

    Frankly, I wouldn't want it writing to my C: drive anyway, just in case.

    I'm assuming that hda1 is the first partition on your boot drive, and is the partition from which you boot when not booting from a cd.

    You can always write to a USB stick formatted FAT32

    (mount -t vfat )

    and then boot back into Windows and copy from it.

    How big is that drive which you are calling hda?

    How many partitions on it?

    And is there any chance that this is a newer computer and that the boot drive is a SATA and you should have been trying to mount and write to

    /dev/sda1

    ?

    And I usually mount the partition first and make sure I can read it before I go trying to tie it to a new virtual directory.
     
  3. jerrymc

    jerrymc TiVo Tinker

    182
    0
    Sep 17, 2001
    Antioch, CA, US
    Thanks for the reply. The PC is an old P4 that I've just brought out of retirement specifically for performing tasks that I don't want to risk running on my main system. (Used to use my ancient P3 which was all FAT32.) Running XP SP3 on the only ATA hard drive (hda1 = 250GB). Only the one partition.

    As for the permissions, I presumed that was what the "-w" and "-o rw" flags in the mount command were for.

    I'd rather not use a USB flash drive (too easily misplaced). I could repartition the hard drive and make the second partition FAT32, and I probably will do exactly that if I don't find a better solution. But I'm also doing this to learn, and if this CD should support NTFS read/write, I'd like to learn how.

    Not sure I get the distinction here. Are you suggesting that before mounting, I "cd /dev/hda1" and read to see that I have access? I already get a successful read-access mount with:

    mount -t ntfs /dev/hda1 /win
    (-w is supposed to be the default, BTW)

    This command gives no error or warning message, and I can cd to /win/* and at least list directory contents. The only time I get an error message is when I try the backup command.
     
  4. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    Okay, you can wipe the drive, repartition as FAT32 and re-install XP.

    If you have to have an NT partition you can probably use PartedMagic to shrink that partition, then create a FAT32 D: drive, which will show up as

    /dev/hda2

    or create an extended partition and create a FAT32 partition inside that, which will show up as the D: drive, and, I think,

    /dev/hda5

    because of the way the MFS Live cd (and other Linux stuff for all I know) deals with the 4 primary partition per drive limit, where it assumes, apparently, for some reason, that the presence of an extended partition means the presence, or eventual presence, of 3 other primary partitions, so any partitions inside the extended start at 5.

    I think you'd be better off with backup images and such not being on the boot partition anyway.

    I think there might be something about the Linux version used on the MFS Live cd v.1.4 (which ain't exactly brand new) not being able to overcome some settings that Windows puts on NT drives, like maybe it can't convince the drive that it has the right permissions to open it with write privileges or something.
     
  5. HomeUser

    HomeUser Active Member

    2,376
    1
    Jan 12, 2003
    A2 Michigan
    I am a little rusty on the command line. I interrupt the output location for "tivo.bak" defaulting to where the program is run from (the CD DRIVE?) have you tried pointing the output to the location that the previous command mounted the NTFS partition to /win/tivo.bak ?
     
  6. jerrymc

    jerrymc TiVo Tinker

    182
    0
    Sep 17, 2001
    Antioch, CA, US
    Actually, I left out a command. After the mount, and before the backup, I executed "cd /win". You're right though, if the commands had been entered as I originally typed them, the backup would target the CD root and fail.
     
  7. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC

    Have you considered leaving the directory change out and doing it this way:


    mkdir /win
    mount -t ntfs -w /dev/hda1 /win
    backup -f 9999 -6so /win/tivo.bak /dev/hde


    Also, before doing that, after booting with the cd, try

    pdisk - l /dev/hde

    and

    mfsinfo /dev/hde

    just to make sure the drive you're trying to backup is where you think it is and doesn't have any problems of a TiVo-related nature.


    Sometimes when an error message gets returned, it's whatever's available that's closest to what really needs saying, and not an absolutely accurate report of the actual problem.
     
  8. jerrymc

    jerrymc TiVo Tinker

    182
    0
    Sep 17, 2001
    Antioch, CA, US
    Yep, tried that. And I backed up the Tivo drive to a FAT32 drive and it all worked. Pretty sure it's just the NTFS partition issue.

    For anyone else following this thread, I also found this command from a Linux site, but it didn't work either:

    mount /dev/hda1 /win -t ntfs -o nls=utf8,umask=0222

    The umask is only for files that you create, and it doesn't control the permissions for the folder you are writing to. Don't know what the nls option is.

    Still looking for answers if anyone happens by with one...
     

Share This Page