1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

kmttg stopped working

Discussion in 'TiVo Home Media Features & TiVoToGo' started by NSPhillips, Sep 17, 2014.

  1. NSPhillips

    NSPhillips Member

    71
    0
    May 31, 2007
    I realize this is a vague problem, but there is no obvious solution at the moment.

    I was happily running kmttg on Windows 7 (not installed as a service) for a month or two. But it has recently stopped working. When I click on the .jar file I now get a quick flash of the interface screen, it disappears and then nothing.

    I tried downloading and installing it again, but I get the same issue. Should I be deleting the files or editing the registry to remove all traces before re-installing?
     
  2. moyekj

    moyekj Well-Known Member

    11,379
    126
    Jan 23, 2006
    Mission...
    Most likely a Java installation problem. Open a "cmd" window and go to folder where you installed kmttg. Then type kmttg.jar and see what happens. It could be problem such as missing program association with .jar files. By using "cmd" window any error messages that result will be visible. More details can be found in installation Wiki:
    https://sourceforge.net/p/kmttg/wiki/windows_installation/
     
  3. NSPhillips

    NSPhillips Member

    71
    0
    May 31, 2007
    Thanks for the advice. I tried the command line and got the same results. Re-installed kmttg and Java, again same results. Eventually I found this log file from the new installation:

    Code:
    2014_09_17_22:35:05 NOTE: 
    Auto Transfers Loop in GUI enabled
    2014_09_17_22:35:06 ERROR: No auto keywords setup
    2014_09_17_22:35:06 ERROR: No keywords defined in D:\kmttg\auto.ini... aborting
    2014_09_17_22:35:06 
    EXITING BATCH MODE
    

    So now I remember that it originally stopped working while I was trying to transfer and commercial-edit a group of shows. It seems like the interface is stuck in Auto Transfer mode? How can I delete whatever settings file controls that? Or, alternatively, can I populate the auto.ini file to force it to resume?
     
  4. moyekj

    moyekj Well-Known Member

    11,379
    126
    Jan 23, 2006
    Mission...
    Remove the following file:
    %userprofiles%\.kmttg_settings

    For Vista and above this will be c:\Users\<YourLoginName>\.kmttg_settings
     
  5. NSPhillips

    NSPhillips Member

    71
    0
    May 31, 2007
    That worked. Thanks!!
     
  6. satmaster

    satmaster Member

    80
    0
    Sep 11, 2004
    Louisiana
    I am having the same problem it worked fine for years suddenly stopped.
    when I use cmd I get nothing it just exits no error message.
    I erased the .kmttg_settings file.

    reinstalling from scratch doesn't solve it any other settings I need to erase to get a new install?
     
  7. moyekj

    moyekj Well-Known Member

    11,379
    126
    Jan 23, 2006
    Mission...
    For v2.x kmttg the settings file is now kmttg_settings_v2, so make sure you delete that one.
     

Share This Page