1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

KMTTG Audio Sync Problems

Discussion in 'TiVo Home Media Features & TiVoToGo' started by csm10495, Feb 28, 2013.

  1. csm10495

    csm10495 Badoop Badoop!

    117
    0
    Nov 15, 2008
    Whenever I get a recording from KMTTG, it decrypts using TivoDecode and then it is a nice mpg file that plays in VLC, windows media player, etc. I tried throwing the video into Adobe Premiere CS6 and the audio was out of sync; not just a second off but it was a worsening sync as time went on. I had KMTTG encode using handbreak and ffmpeg but the resulting videos had the same problem in Premiere CS6. I also tried converting the mpg manually to an avi using ffmpeg, but Premiere CS6 still had sync issues. The same problem happens with every show, regardless of channel HD/SD. Has anyone run into this problem? Any solutions? Thanks in advanced.

    PS... I always said CS6 after Premiere because that name can be rather confusing on this forum. :rolleyes:
     
  2. moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    You have to enable the kmttg "QS Fix" step to fix errors in the source video before encoding it, preferably using VideoRedo if you have it, else using ProjectX.
     
  3. Mar 1, 2013 #3 of 11
    csm10495

    csm10495 Badoop Badoop!

    117
    0
    Nov 15, 2008
    Thanks!
     
  4. Mar 3, 2013 #4 of 11
    csm10495

    csm10495 Badoop Badoop!

    117
    0
    Nov 15, 2008
    Alright so I tried ProjectX to fix a couple files and it didn't make actually fix the problem in Premiere, so I downloaded the trial of VideoRedo and it's QuickStream fix didn't fix the audio sync either. Are there any other tools, (or things that I could have easily done wrong)? Better yet is there a way to just make Premiere ignore the syncing problem? VLC plays back the video without a hitch.
     
  5. Mar 3, 2013 #5 of 11
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    What video are you transferring back to the Premiere and how are you transferring it back exactly? If you transfer back the decrypted mpeg2 to Premiere does it have audio sync issue?
     
  6. Mar 3, 2013 #6 of 11
    csm10495

    csm10495 Badoop Badoop!

    117
    0
    Nov 15, 2008
    Sorry for the confusion, I mean Adobe Premiere CS6, as in using the video editor on the mpeg2 on the computer.
     
  7. Mar 3, 2013 #7 of 11
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    Since you have the VideoRedo trial, how about its editor? Is it out of sync there? I would guess not.
     
  8. Mar 3, 2013 #8 of 11
    csm10495

    csm10495 Badoop Badoop!

    117
    0
    Nov 15, 2008
    It is in sync until it gets to a point (different in each video) where it says that it needs the quickstream fix. So after running the fix it works fine in VideoRedo for the entire video.
     
  9. Mar 3, 2013 #9 of 11
    moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    Yes, that's what I meant after QS Fix. I don't know anything about the Adobe encoder but I can vouch for VideoRedo TVSuite as being an excellent editor and encoder for videos coming from TiVo and is what many in TCF forums use.
     
  10. smello2

    smello2 New Member TCF Club

    27
    0
    Nov 14, 2014
    I had QS Fix on along with decrypt and encode to ff_mobile_1080p and I get a video that is not insync with the audio. It happened on both downloads I did today. I viewed them in mpg and had the same problem. Since I run on a Mac, I use ProjectX. VideoRedo doesn't have a Mac version. It isn't totally off but enough to be very annoying.
     
    Last edited: Oct 24, 2015
  11. fflewddur

    fflewddur R&D

    169
    0
    Jul 20, 2015
    Seattle, WA
    I've been working on a new tool for transferring recordings from a TiVo to a computer, and one of the main goals is to run just as well on a Mac as on a PC. It's still in testing, but I haven't found any audio sync issues yet. If you want to try it out, there's a preview release at https://github.com/fflewddur/archivo/releases; let me know if you have audio sync problems with it.
     

Share This Page