1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Kmttg and VideoRedo error for commercial cuts

Discussion in 'TiVo Home Media Features & TiVoToGo' started by eboydog, Jun 18, 2014.

  1. eboydog

    eboydog Just TiVo'ing.....

    904
    0
    Mar 23, 2006
    I finally broke down and bought VideoRedo suite, I'm trying to use VideoRedo for commercial cuts but I get a profile error in Kmttg after it downloads and trys to start the cuts. Is there a trick in setting this up?

    I point Kmttg to the videoredo directory C:\Program Files (x86)\VideoReDoTVSuite

    I don't recall the error, I just bought Videoredo and didn't have time when I first tried it. :D

    Anything off the top that I might be missing? As a typical user I didn't write the error down but I'm running a new download and will post it later.

    <Edit>

    How do you pull up kmttg log to copy paste the error? In the kmttg screen I can see the error but can't copy it to paste it.

    Error is something like: adscan failed (exitcode: 0) - check commend c:\windows\system32\csripts.exe /nologo (path to my kmttg directoy\VRDscripts\adscan.vbs (path to the file being scanned) and then the last part is "could not locate automation class name "VideoRedo.VideoReDoSilent"
     
  2. eboydog

    eboydog Just TiVo'ing.....

    904
    0
    Mar 23, 2006
    Ok, I fugured out the log file in kmttg, here's the message:

    I have kmttg installed in D:\kmttg_v1p0q

    The recording is "D:\kmttgContent\Dark Matters Twisted but True - 21 Grams, Missing Cosmonauts, Sound of Death (06_11_2014).mpg"

    D:\kmttg_v1p0q\VRDscripts appears to contain all the VRD VBS files....


     
  3. dlfl

    dlfl Cranky old novice

    6,996
    16
    Jul 6, 2006
    Near...
    Unless you've already done this once after your VRD install, right-click your VRD (not kmttg) shortcut and select "Run as administrator".
    After VRD starts up, shut it down and try your kmttg run again.
     
  4. moyekj

    moyekj Well-Known Member

    11,141
    31
    Jan 23, 2006
    Mission...
  5. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    I'm running Win 8.1 and I never could get VRD to run correctly when invoked by kmttg running as a "service". If I want to do auto transfers and use VRD, I have to use "Loop in Gui".
     
  6. moyekj

    moyekj Well-Known Member

    11,141
    31
    Jan 23, 2006
    Mission...
    Don't know about win 8, but for prior versions you have to set service to run using your account, not default service account. You may also try setting java.exe and/or javaw.exe to run as administrator in file properties.
     
  7. lpwcomp

    lpwcomp Active Member

    8,075
    2
    May 6, 2002
    John's...
    Did all of that and more and it simply refused to work. Finally just gave up. I don't actually use the auto transfer capability at all most of the time. I use VRD to detect and cut commercials but don't like kmttg forcing the unnecessary decrypt step.

    As far as the actual issue goes, based on my reading of similar reported problems, it appears that Win 8 will not let you start a child process in admin mode from a service even if the parent is running as an admin and the child process is set to run as admin.
     
  8. eboydog

    eboydog Just TiVo'ing.....

    904
    0
    Mar 23, 2006
    Thanks! that fixed it!
     

Share This Page