1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

KMTTG and Ports

Discussion in 'TiVo Home Media Features & TiVoToGo' started by JeffreyF, Sep 11, 2012.

  1. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    I have successfully used KMTTG to find my TiVos using an internal IP address. Even though the computer and TiVo are on different zones, there is no issue.

    I would like to be able to access a TiVo through port forwarding from the router and am wondering what port(s) I need to forward for KMTTG to see the TiVo.

    As an example, instead of me typing in the 192.168.X.X in the IP address within KMTTG, I would like to be able to use the DDNS capability for access externally and type MYDOMAIN.COM:pORT_NUMBER_HERE

    What port number does KMTTG use to find the TiVo?
     
  2. moyekj

    moyekj Well-Known Member

    11,144
    32
    Jan 23, 2006
    Mission...
    Under config-Tivos you specify the WAN side port numbers that you will be port forwarding in your router setup to port 80 (http) & 443 (https) on your TiVo. Optionally you can also use the iPad/Android RPC capability as well by port forwarding to port 1413. I use kmttg that way to access my TiVos outside my LAN all the time.
     
  3. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    Thank you. I will try port 1413

    Best,

    Jeffrey


     
  4. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    To confirm, should the settings be:

    MYDOMAIN.COM:1413 --> Port 1413 on the Tivo

    Or is it

    MYDOMAIN.COM:1413 ---> Port 80 on the Tivo

     
  5. moyekj

    moyekj Well-Known Member

    11,144
    32
    Jan 23, 2006
    Mission...
    No you misunderstand. There are 3 ports on a TiVo that kmttg can use:
    80 (http)
    443 (https)
    1413 (rpc/iPad/Android)

    So you will have to port forward to each of those. For example if your TiVo IP is 192.168.1.200 then you'd want something like:
    MYDOMAIN.COM:8080 -> 192.168.1.200:80
    MYDOMAIN.COM:8443 -> 192.168.1.200:443
    MYDOMAIN.COM:81413 -> 192.168.1.200:1413

    The rpc forwarding is only necessary if you want to use the rpc remote functions.

    Then in kmttg config you'd enter 8080, 8443, 81413 as the WAN ports when using kmttg via MYDOMAIN.COM.
     
  6. lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    Except I think I would avoid 8080 -> 80. Quite a few applications use 8080, and one might wind up with an issue down the line. Perhaps 8880 -> 80? Or not.
     
  7. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    Thanks for the clarification.

    Here is what I have done:

    Tivo name: MYDOMAIN.COM
    Enabled iPad stule communications with this TivO is checked off

    WAN HTTP: 9080
    WAN HTTPS: 9443
    WAN IPAD: 1413

    I have ports 9080, 9443 and 1413 with its own separate entry on my router all pointing to the TiVo ip address.

    When I go to get the list of recordings I get the error:

    Failed to retrieve Now Playing List
    Exit code: 7
    Check Your MAK & IP settings
    curl: (7) couldn't connect to host

    Any suggestions?

     
  8. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    Quick upadate. I had the incorrect ports on the router which I have now corrected and it is now seeing the TiVo and its recordings via an outside domain name!

    I am now able to transfer recordings which is great.

    One question I do have is if ther eis anything I can do to increase the speak of the Mbps. Right now it is between 2.5Mbps and 4.0Mbps even though the downlink is 80Mbps and the uplink is 10Mbps.

    Any suggestions?
     
  9. lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    Possibly, although probably not.

    1. What operating system are you using on the kmttg server?
    2. What is the round-trip latency between the TiVo and the server?

    If the latency is fairly high, you could try increasing the default maximum TCP Rx buffer size on the PC. The TiVo and the server negotiate the maximum Rx buffer size every time a TCP connection is established. The maximum throughput is directly related to the latency and the Tx buffer size. The higher the latency, the lower the throughput, but this can be offset by a larger Tx buffer. If the Tivo is already negotiating its highest maximum Tx buffer size, then setting the default higher on the server won't help.

    Another possibility is the MTU might be set too high for the link being transversed. If so, then the packets will get fragmented, significantly reducing the throughput. If so, then lowering the MTU size on the server should definitely help.

    Which way are the transfers going?
     
  10. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    Some great tips. Thank you!

    Jeffrey
     

Share This Page