1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

JMFS 1.04 and WD Expander - Fails

Discussion in 'TiVo Upgrade Center' started by philhu, Feb 11, 2013.

  1. philhu

    philhu User Since Day ONE!

    Apr 11, 2001
    Funcity, MA
    Ok, as you know, I expanded my Premiere 4 to 2tb, works good!

    I said I would get an expander. WD, certified for tivo.

    I plugged it in, it went throught its 'adding space' messages, and rebooted. Upon reboot, it went into the expand space message again

    So the conclusion is that you CANNOT add an expander to a JMFS 1.04 upgraded internal disk.

    I'm sure it is a partition thing.

    My thoughts...

    I think an 'Apple_free' partition (as partition 15) needs to be made to force a partition 16/17 pair as free. Which Tivo must use to add an expander.

    I think JMFS needs to figure out how to add a coalesced partition. IE, add the new expanded space into the other MFS region on the disk. Not adding a new MFS region. This might require using JMFS on a no-data disk.
  2. retiredqwest

    retiredqwest Member

    Sep 7, 2010
    Partitions and apple_free have nothing to do with it.

    When an expander is married to a stock TIVO drive it does not add a partition to the internal drive. Put the stock drive back in the 4 and marry
    the expander and then take a look at the internal drive again it will still have 14 partitions.

    Partition map of my XL4 using Mfslayout via JMFS before marrying the expander:

    1 : start= 1, size= 63 ( 31.50K), type='Apple_partition_map', name='Apple'
    2 : start=2148865904, size= 8 ( 4.00K), type='Image' , name='Bootstrap 1'
    3 : start=2148865912, size= 16384 ( 8.00M), type='Image' , name='Kernel 1'
    4 : start=2148882296, size= 524288 (256.00M), type='Ext2' , name='Root 1'
    5 : start=2149406584, size= 8 ( 4.00K), type='Image' , name='Bootstrap 2'
    6 : start=2149406592, size= 16384 ( 8.00M), type='Image' , name='Kernel 2'
    7 : start=2149422976, size= 524288 (256.00M), type='Ext2' , name='Root 2'
    8 : start=2149947264, size= 262144 (128.00M), type='Swap' , name='Linux swap'
    9 : start=2150209408, size= 1048576 (512.00M), type='Ext2' , name='/var'
    10: start=2157549440, size= 1638400 (800.00M), type='MFS' , name='MFS application region'
    11: start=2160826240, size=1746202928 (832.65G), type='MFS' , name='MFS media region'
    12: start=2159187840, size= 1638400 (800.00M), type='MFS' , name='MFS application region 2'
    13: start= 64, size=2148865840 ( 1.00T), type='MFS' , name='MFS media region 2'
    14: start=2151257984, size= 6291456 ( 3.00G), type='Ext2' , name='SQLite'

    Size of zones:
    Used: 2310049624 (1.08T)
    Free: 1588275496 (757.35G)
    Total: 3898325120 (1.82T)

    Recordable space reported by Tivo: 3898344448 (1.82T), approximately 287 HD hours

    After marrying the expander mfslayout will no longer read the stock drive.
    Had to use Pdisk from the mfslive cd:

    Partition map (with 512 byte blocks) on '/dev/sda'
    #: type name length base ( size )
    1: Apple_partition_map Apple 63 @ 1
    2: Image Bootstrap 1 8 @ 2148865904
    3: Image Kernel 1 16384 @ 2148865912 ( 8.0M)
    4: Ext2 Root 1 524288 @ 2148882296 (256.0M)
    5: Image Bootstrap 2 8 @ 2149406584
    6: Image Kernel 2 16384 @ 2149406592 ( 8.0M)
    7: Ext2 Root 2 524288 @ 2149422976 (256.0M)
    8: Swap Linux swap 262144 @ 2149947264 (128.0M)
    9: Ext2 /var 1048576 @ 2150209408 (512.0M)
    10: MFS MFS application region 1638400 @ 2157549440 (800.0M)
    11: MFS MFS media region 1746202928 @ 2160826240 (832.7G)
    12: MFS MFS application region 2 1638400 @ 2159187840 (800.0M)
    13: MFS MFS media region 2 2148865840 @ 64 ( 1.0T)
    14: Ext2 SQLite 6291456 @ 2151257984 ( 3.0G)

    Device block size=512, Number of Blocks=3907029168 (1.8T)
    DeviceType=0x0, DeviceId=0x0

    You'll notice this reduced the recording space on the stock drive by 890meg.

    So, no you cannot expand a stock drive and then add an expander and I would assume this goes for any Series 4 tivo and the Series 3 THD as well.

    Weaknees and Dvr-Dude have figured it out how to get around this ...... just no one on TCF.
  3. philhu

    philhu User Since Day ONE!

    Apr 11, 2001
    Funcity, MA

    So they must make some partition map change
    To the internal. Just not a new partition
  4. philhu

    philhu User Since Day ONE!

    Apr 11, 2001
    Funcity, MA
    Anyone still looking at this?

    I have an expander in the box waiting for a way to update!

    To remind, I also tried plugging it in to my 2tb upgraded premiere4

    It goes through 'I found the drive', does its format, reboots, and asks again to upgrade. Tried 4 times, never completes.

    So pulled out the external, during the reboot and everything works on the 2tb. No loss of programs.
  5. jrtroo

    jrtroo User

    Feb 4, 2008
    Not unless you are volunteering. :)

    comer was great in updating the community on his findings as he developed his tool. If someone else is working on it they are not posting here.
  6. philhu

    philhu User Since Day ONE!

    Apr 11, 2001
    Funcity, MA
    I was looking at it, but with a tivo dedicated to Young and the Restless for my wife, I can't keep it out of service too long :)

    I might bite the bullet and buy a 2+2tb Premiere from weaknees, then look at the two disks to see how they are laid out. It bugs me that it has been developed by multiple people and noone in the hack group has figured it out
  7. jrtroo

    jrtroo User

    Feb 4, 2008
    Many of us just move to a PC/server instead of dealing with extra on board storage.

    Obviously, not a solution for everyone, especially those who have cable systems with all of the CCI flags set.
  8. philhu

    philhu User Since Day ONE!

    Apr 11, 2001
    Funcity, MA
    BINGO! My other solution is rmv the CCI bit on an older TivoHD I have to do just as you say. I do have a 12TB NAS right now with 30,000+ old TV Shows on it

Share This Page