1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

iTiVo (TiVo -> mac -> iPhone)

Discussion in 'TiVo Home Media Features & TiVoToGo' started by Yoav, Nov 6, 2008.

  1. javabird

    javabird Active Member

    Oct 12, 2006
  2. Fofer

    Fofer Say what? TCF Club

    Oct 29, 2000
    WOO HOO!

    Awesome holiday surprise! (I've figured this app wouldn't be seeing any updates.) This is great news as I vastly prefer the UI of iTiVo over kmttg.

    iTiVo for my Mac and the TiVo app for iOS (working with TiVo Stream) for my iPad. I'm a happy camper.
  3. wmcbrine

    wmcbrine Ziphead

    Aug 2, 2003
    I'd figured Yoav was dead. :eek:
  4. tony1athome

    tony1athome New Member

    Aug 16, 2007
    Not dead. But he's given up. Some other folks are trying to pick up the slack.
  5. javabird

    javabird Active Member

    Oct 12, 2006
    It's still a beta, and has a few issues, but it seems to be working.
  6. stratton

    stratton New Member

    Nov 19, 2006
    Macbook Air Mountain Lion user here. Also use Toast solely to get shows onto my iphone/ipad. Came here looking for help because my Toast 10 stopped seeing my TiVos after we changed cable providers in a move, although two other apple computers in the house could still see the DVRs. Roxio customer support is useless. I've tried itivo in the past and it hasn't worked.

    happy to say that Toast and iTivo are now no longer needed, because TiVo Stream allows you to download directly to your iphone or ipad when you are on your home network - thus skipping the download to computer, conversion, and sync with itunes.

    It's very single purpose - but it's the purpose I needed and I am very happy to not need Toast anymore.

    I did try this release of itivo and it works sometimes. other times gets hung.
  7. javabird

    javabird Active Member

    Oct 12, 2006
    Glad it's working for you. However, the Tivo Stream only works with a Premiere, so those of us with other Tivos (I have a TivoHD) aren't able to use it.
  8. Marconi

    Marconi TiVo Junkie

    Sep 8, 2001
    I've been using iTiVo for years with minimal problems but suddenly, yesterday. it became impossible to download recordings. iTiVo is able to connect to any of my DVRs and get a listing of available recordings, but if I try to download anything, I get "Couldn't Download [name of recording]"

    I've double-checked the MAK and it's good. I've tried using iTiVo on four separate Macs and all do the same thing.

    In the past, I've encountered the same thing but rebooting my Ethernet switch always fixed it. This time, nothing fixes it. I shut down every TiVo, All WiFi routers, my MoCA adapters -- the entire network infrastructure, and then restarted everything but it did not solve the problem.

    I *can* transfer between DVRs with MRV, just not to a Mac using iTivo.

    I've tried iTiVo 1.7.7b3 and the newer beta of 2012-12-13 (which also claims to be 1.7.7b3).

    Below is the iTiVo log file. To keep it as short as possible but still include all relevant info, I set the tries per download to 1, queued up a show to transfer, quit iTiVo and restarted it (to empty the log file) then hit Run Queue without the need to connect. So, here's the entire log from this attempt. (I've changed my MAK in the log.)

    2013-02-16 10:03:54  =========== Starting ==========
    2013-02-16 10:03:54 mDNS -B _tivo-videos._tcp local | colrm 1 74| grep -v 'Instance Name' |sort | uniq & 
    sleep 2
    killall mDNS
    2013-02-16 10:03:56 read settings
    2013-02-16 10:03:56 growlisrun: 0
    2013-02-16 10:03:56 No Growl
    2013-02-16 10:03:56 Using Homer:Applications:TiVoStuff:iTiVo.app:Contents:Resources:formats.plist
    2013-02-16 10:03:56 Using format file : Homer:Applications:TiVoStuff:iTiVo.app:Contents:Resources:formats.plist
    2013-02-16 10:03:56 getFormatsNames
    2013-02-16 10:03:56 Format is Decrypt
    2013-02-16 10:03:56 using format : Decrypt
    2013-02-16 10:03:59 killed : 
    2013-02-16 10:04:14 starting queue download...
    2013-02-16 10:04:14 downloadItem called: 1,0
    2013-02-16 10:04:15 checkDL
    2013-02-16 10:04:15 perl /Applications/TiVoStuff/iTiVo.app/Contents/Resources/ParseDetail.pl 9999999999 6677038
    2013-02-16 10:04:15 rm /tmp/iTiVo-marconi/iTiVoDL{,2,3}
    2013-02-16 10:04:15 is download complete 0 / 0
    2013-02-16 10:04:16 killed : 
    2013-02-16 10:04:16 rm -f /tmp/iTiVo-marconi/iTiVoDLPipe* /tmp/iTiVo-marconi/iTiVoTDC* /tmp/iTiVo-marconi/iTiVoDLMeta*
    2013-02-16 10:04:16 mkfifo /tmp/iTiVo-marconi/iTiVoDLPipe /tmp/iTiVo-marconi/iTiVoDLPipe2.mpg
    2013-02-16 10:04:16 perl /Applications/TiVoStuff/iTiVo.app/Contents/Resources/http-fetcher.pl 6677038 Psych 9999999999 /tmp/iTiVo-marconi/iTiVoDLPipe >> ~/Library/Logs/iTiVo.log 2>&1 & echo $! ;exit 0
    curl '' -c /tmp/cookies.txt --retry 12 --retry-delay 10 --digest -u tivo:9999999999 -o /tmp/iTiVo-marconi/iTiVoDLPipe --stderr /tmp/iTiVo-marconi/iTiVoDL
    2013-02-16 10:04:16 perl /Applications/TiVoStuff/iTiVo.app/Contents/Resources/tivo-decoder.pl %2FApplications%2FTiVoStuff%2FiTiVo%2Eapp%2F 9999999999 >> ~/Library/Logs/iTiVo.log 2>&1 & echo $! ;exit 0
    /Applications/TiVoStuff/iTiVo.app/Contents/Resources/tivodecode -n -D -m 9999999999 -o /tmp/iTiVo-marconi/iTiVoDLPipe2.mpg /tmp/iTiVo-marconi/iTiVoDLPipe
    2013-02-16 10:04:16 perl /Applications/TiVoStuff/iTiVo.app/Contents/Resources/re-encoder.pl %2FApplications%2FTiVoStuff%2FiTiVo%2Eapp%2F %2FVolumes%2FLisa%2Fscratch%2Fincoming%2F Psych%5C%20%2D%5C%206677038.mpg 'cat' ' ' ' ' ' '  >> ~/Library/Logs/iTiVo.log 2>&1 & echo $! ;exit 0
    cat -u       /tmp/iTiVo-marconi/iTiVoDLPipe2.mpg > /Volumes/Lisa/scratch/incoming/Psych\ -\ 6677038.mpg
    2013-02-16 10:04:16 curl++ timeout: 0   currentFileSize: 0  fullFileSize:6648
    Encryption by QUALCOMM ;)
    read chunk data: Undefined error: 0
    mv: rename chunk-01-0001.xml to /tmp/iTiVo-marconi/iTiVoDLMeta.xml: No such file or directory
    2013-02-16 10:04:17 curl++ timeout: 1   currentFileSize: 0  fullFileSize:6648
    2013-02-16 10:04:17 Running : touch /tmp/iTiVo-marconi/iTiVoDLPipe3.mpg
    2013-02-16 10:04:18 is download complete 1 / 0
    2013-02-16 10:04:18 is download complete 1 / 0
    2013-02-16 10:04:18 Running : touch /tmp/iTiVo-marconi/iTiVoDLPipe3.mpg
    2013-02-16 10:04:18 is download complete 1 / 0
    2013-02-16 10:04:18 is download complete 1 / 0
    2013-02-16 10:04:18 Download completed
    2013-02-16 10:04:19 killed : 
    2013-02-16 10:04:19 is download complete 1 / 0
    2013-02-16 10:04:19 is download complete 1 / 0
    2013-02-16 10:04:19 Complete=false  , 85% fullfilesize=5650.8 ;  currentfilesize=3.71932983398438e-05
    2013-02-16 10:04:19 write_settings
    Can anyone tell me what the problem is?
  9. wmcbrine

    wmcbrine Ziphead

    Aug 2, 2003
  10. shack1108

    shack1108 New Member

    Feb 17, 2013
    Hey guys, I found a fix:

    First, open Terminal and type in this command: 'curl -c cookies.txt -d "tivo:MAK" http:/ /tivoip:80'
    (replace "MAK" with the Media Access Key and "tivoip" with the ip of your tivo) (and it won't let me post any "links" since it's my first post so remove the space between the first and second slash)
    Then cookies.txt will be placed in your home folder.
    Open it, and change the value 1360972800 to whatever you want (it's the number of seconds past January 1, 1970 that the cookie will expire). I just changed the first 1 to a 2.
    Then, save it to some folder out of the way (I just threw it in my Documents folder).
    Then, go to iTivo in the Applications folder, right-click, and click "Show Package Contents". Go to Contents, then Resources, then right-click on http-fetcher.pl, and open it in Text-Edit. Once there, change "-c /tmp/cookies.txt" to "-b /Users/'homefolder'/Documents/cookies.txt" (change 'homefolder' to the name of your user account). Then re-open iTivo and it should start working again!
  11. javabird

    javabird Active Member

    Oct 12, 2006
    Thank you for posting this. The fix is currently working for me.

    BTW, when Tivo gets around to posting a fix for the issue, does this need to be changed in any way?
  12. cautionespn

    cautionespn Grand PooBah

    Feb 21, 2003
    A different workaround:
    1. Go to /Applications
    2. Find iTivo, right click and choose "Duplicate"
    3. Right click on the newly created iTivo Copy and choose "Show Package Contents"
    4. Navigate to Contents > Resources and find http-fetcher.pl
    5. Edit this in your favorite text editor
    6. On the line with:

      $shellScript = "curl -q \'http://$tivoip\:80/download/$showNAME\.TiVo?Container=%2FNowPlaying&id=$showID\' -c /tmp/cookies.txt --retry 12 --retry-delay 10 --digest -u tivo:$MAK -o $target --stderr $TivoDir/iTiVoDL";
    7. Change to:

      $shellScript = "curl --cookie sid=abc -q \'http://$tivoip\:80/download/$showNAME\.TiVo?Container=%2FNowPlaying&id=$showID\' -c /tmp/cookies.txt --retry 12 --retry-delay 10 --digest -u tivo:$MAK -o $target --stderr $TivoDir/iTiVoDL";
    8. Save and launch. Problem gone.
  13. Graeber

    Graeber New Member

    Nov 22, 2000
    If I am using multiple tivos, do I run this set of steps once per tivo?
  14. Fofer

    Fofer Say what? TCF Club

    Oct 29, 2000

    Thanks for this. Seems to be working fine on my iTiVo now!
  15. Fofer

    Fofer Say what? TCF Club

    Oct 29, 2000
    No, not sure about shack1108's solution, but at least if you follow cautionespn's easy instructions above, you only have to do it once, on that install of iTiVo on your Mac.
  16. dcborn61

    dcborn61 New Member

    Dec 9, 2002
    I assume you then run the copy of iTivo and not the original application?
  17. Fofer

    Fofer Say what? TCF Club

    Oct 29, 2000
    Yeah, you're just working with the copy so in case something goes wrong you can revert to the original.

    After your (modified) copy is confirmed to work, you can trash the original. At least, that's what I did :)
  18. igirl

    igirl Tivo and EyeTV User

    Feb 5, 2011
    I've successfully enjoyed using iTivo to transfer many full HD shows in the past, but now I'm getting red circle © on everything from USA, TNT and TCM (probably others too).

    Same thing on KMTTG - "This show is copy protected - cannot process"

    We moved to another state and changed cable providers which may be partially the issue.

    Any workaround? We need to clear up space on the Tivo HDD but not lose the shows just yet. :-/
  19. bruiz

    bruiz New Member

    Dec 10, 2008
    Like everyone else, I've been struggling to keep iTiVo running...

    Recently, while searching for an answer to my iTiVo issues in Google, I came across another project on GoogleCode called "cTiVo" (code.google.com/p/ctivo).

    The landing page says: cTiVo is a Mac application to download shows from your TiVo Series 2, Series 3, TiVoHD, and Premiere device. Simple to set up and use, it will download shows to your mac, and convert them to many popular formats / devices. It is inspired by the great work done on iTivo, but written in Cocoa/Objective C for better performance / compatibility.

    I asked the development team to add an encoder, and I have to say that they have been 1) Responsive, 2) Interested, 3) Enthusiastic!

    They are in what they call "rapid development," and not all features are active, but I have to say that they have a working solution that is filling my iPad for my daily commute!

    I recommend that interested users take a look.

    R'grds - Ben.
  20. Fofer

    Fofer Say what? TCF Club

    Oct 29, 2000
    comskip doesn't work for me on iTiVo, it seems. The download/transfer just pauses.

    Here's a link to cTiVo, thanks for the heads up, bruiz!


Share This Page