1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issue with Xfinity on demand on Tivo Premiere

Discussion in 'TiVo Coffee House - TiVo Discussion' started by dbouchon, Apr 19, 2012.

  1. dbouchon

    dbouchon New Member

    Apr 19, 2012

    I am one of the lucky users who is in one of the right locations in the SF Bay and now have Xfinity on Demand on my Premiere Elite!

    It worked very well last week ... for a couple of days, until Saturday.

    Since Saturday (4/14), I can still access Xfinity on Demand, browse the shows / movies, see which are free or for a charge, and select one.
    But when I select "Watch now", I am getting a black screen and, a few seconds later, an error message saying I should try disconnecting and reconnecting the cable, and if that does not work, I should contact Comcast with error number: SRM-8001.

    I did the cable disconnect / reconnect - did not help.
    I restarted the tivo box a few times - did not help.
    I called Comcast, who had no idea what I was talking about (told me Tivo does not support on demand ...).

    I have a Comcast tech coming over on Saturday, but am wondering if he'll be able to help ... wondering if the issue is on the tivo end or comcast end...

    Frustrating, as it was working beautifully until Saturday....

    Any Suggestions?


  2. Xab

    Xab New Member

    May 21, 2004
    Columbus, Ohio
    Sorry to hear you are having problems. I would honestly scrap your service call, since the tech that comes out is most likely going to just be completely confused about your equipment situation, and/or just blame it on the Cablecard. I think your best bet might be to call TiVo support, they might have a department that is dealing with the issues that pop up with the new On Demand Comcast thing. But the majority of Comcast people are likely going to be in the dark about it.
  3. rhettf

    rhettf R3T1CAL

    Apr 5, 2012
    Oakland, CA
    theres been reports of needing to re do the cable card pairing.
  4. dbouchon

    dbouchon New Member

    Apr 19, 2012

    the tech comcast person came in today, and I have to say, solved the problem quickly.

    Apparently, when I added a few new channels last week, for some reason comcast removed on-demand from my cable card channel line up ... the guy corrected that configuration and now everything works beautifully...

    Good luck to all!

  5. rainwater

    rainwater Active Member

    Sep 21, 2004
    In other words, all he really did was pair the card properly.

Share This Page