1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is Comcast on Demand working for anybody?

Discussion in 'TiVo Mini' started by Gadfly, Mar 17, 2013.

  1. tivoboy

    tivoboy Member

    681
    1
    Jan 14, 2002
    SFO
    Well, I've discovered a way to at least get it working on the MINI. IF I have the problem on the mini, which is the one described above, all I need to do is head over to the XL4 and run ondemand from that device, and then the mini no longer has problems streaming ondemand.

    Now, that's not the way it's SUPPOSED to work and "Tivo" has "never heard" of this problem - at least their support reps haven't. But, if I have the problem, restarting ANY ondemand on the XL4 gets it working again on the mini.

    I'm pretty sure it's an authentication error. The mini gets it's authentication form the CableCard in the XL4 and maybe either that card hasn't authenticated recently, or the mini can't parse the XL4 authentication easily and so has to have it refreshed.

    Hopefully, they will get it sorted since it's ANNOYING.
     
  2. lessd

    lessd Active Member

    7,695
    5
    Jan 23, 2005
    CT
    I just tried OD (from Comcast) from my Mini (never used it before from the Mini) worked without problems for me.
     
  3. splintersam

    splintersam New Member

    13
    0
    May 1, 2013
    I haven't ever been able to get the On Demand to work on the Tivo in my area.
     
  4. hershey4

    hershey4 New Member

    179
    0
    May 31, 2006
    Red Sox Nation
    I got App not available V301 error on the Mini even though VOD was showing on the P4. After reading this thread, I tried again on the P4 and now (for the first time ever) I get the error message noted at the beginning of this thread on the P4.

    I have a feeling this is not going to go well :-(. It was all good pre-Mini and pre-Moca that I just did today. Will try again later.

    And yes, I allocated one tuner to the Mini. Maybe it needs 2? One for live buffering and one for dedicated VOD?
     
  5. Bigg

    Bigg Active Member

    5,425
    5
    Oct 30, 2003
    Hartford-...
    Mine was working for a while, and now it's not. I get the GSM4 error or something like that. I don't know why Comcast keeps messing it up...
     
  6. Shanezam203

    Shanezam203 New Member

    787
    0
    Jul 27, 2007
    What a Mess. I got the email from Tivo which was nice stating Comcast Xfinity on Demand is now supported on my Tivo Premiere. I was told I need to have Comcast refresh my Cable Card, so I called Comcast and they have NO CLUE about their Cable Cards.

    Another tech refreshed my services, still no On Demand.
    They said I need a new Cable Card, they have 10 available @ my local Comcast service center.
    I went there, they switched my working Cable Card with the SAME model, and she was clueless.

    Now I am back home and guy is directing me back to service center, A. they are now closed and B. they were useless there.

    any thoughts what I need to do to get Xfinity on Demand working on my Tivo Premier?
     
  7. jrtroo

    jrtroo User

    4,059
    5
    Feb 4, 2008
    It sounds like you are calling the normal 800 number. Don't do that.

    Call the cablecard hotline. Not the normal csrs.
     
  8. jmpage2

    jmpage2 New Member

    1,951
    0
    Jan 20, 2004
    Have you read the page of posts before yours? There is tons of info on what people have done to fix this.
     
  9. Shanezam203

    Shanezam203 New Member

    787
    0
    Jul 27, 2007
    What needs to be done, I just read through and still am unsure.
    I only have 1 Tivo Premier HD with a multi tuner cable card. Does Comcast need to do anything, when I go to channel 1 it says Xfinity on Demand on my Tivo, but no picture is loaded like in the past.
     
  10. jmpage2

    jmpage2 New Member

    1,951
    0
    Jan 20, 2004
    Have a look at this thread, towards the end, there are several people who had the problem you report and were able to resolve it. I got the two threads mixed up.

    http://www.tivocommunity.com/tivo-vb/showthread.php?t=508928&goto=newpost
     
  11. dlongnecker

    dlongnecker New Member

    24
    0
    Dec 30, 2006
    VOD is working fine on pro.

    On the mini, I go into comcast streaming, find a show, select it and it starts playing. At least I can hear the show, but not see it. After about 5 seconds a comcast error message shows up saying it was having problems streaming. I go to the pro and it streams fine.

    Comcast doesn't know anything about the mini....any thoughts about what might be wrong?
     
  12. Shanezam203

    Shanezam203 New Member

    787
    0
    Jul 27, 2007
    Got it working, thank you. The fix for me was to change the View from Tivo SD to Tivo HD and it now is available. wow, wonder why On Demand isnt available on Tivo SD display.
     
  13. dmk1974

    dmk1974 DA BEARS!!!

    549
    0
    Mar 7, 2002
    Cary, IL
    Very interesting...I'll have to check this when I get home from work tonight. I live in the Chicago suburbs and had basically figured they would never support the Xfinity app. I have 2 Premieres and 2 Minis. Will check on all of them and report back tonight.
     
  14. ncfoster

    ncfoster Member

    168
    0
    Jan 22, 2011
    Hopefully, they have smoothed out the process some. The only step that I needed to take was to reboot my Roamio Pro and Mini, and it has worked flawlessly for me on both. <knock on wood> I'm in Northwest Indiana.
     
  15. dmk1974

    dmk1974 DA BEARS!!!

    549
    0
    Mar 7, 2002
    Cary, IL
    I only wound up testing it on one of my TiVo Mini units last night and it worked without issue. Only tested playing a few videos on HBO and others. The HBO one ("The Heat") didn't appear to be in HD, but wasn't sure if it's supposed to be. Pretty basic folder interface, but at least it's better than nothing (finally)!
     
  16. jrtroo

    jrtroo User

    4,059
    5
    Feb 4, 2008
    The Tivo interface for this is much better than my experience on the Comcast box themselves.
     
  17. dmk1974

    dmk1974 DA BEARS!!!

    549
    0
    Mar 7, 2002
    Cary, IL
    Seems to be working well on all of my boxes! Tested a few shows on the various boxes. Rented "Wolf of Wallstreet" and played perfectly in HD as well.
     
  18. swak

    swak New Member

    22
    0
    Apr 7, 2014
    I am in NW IN and finally got it working last night on my Premieer after two weeks of calling in. I did an online chat and asked that my billing codes were correct, and got someone who said they were not. My account showed "Cablecard" and not "Tivo Cablecard". I was told that would fix it. Tried it and not fixed, so I called-in , at first last night the rep I got said it wasn't even possible to get ondemand with a tivo premieer she said it only works on roamios and also it was not available in area! I told her she needed to double check on both of her statements because she was wrong!

    After she checked she asked me if I had a comcast cable box! I said no this is a TIVO. then she said that at least one comcast cable box needs to be on the account and listed as the primary box to get any ondemand channels. She added a virtual cable box (no monthly cost, she said) as my primary box and now my TIVO ondemand is working.

    Hope this makes sense and helps someone...
     
  19. ncfoster

    ncfoster Member

    168
    0
    Jan 22, 2011
    Greetings fellow region rat! So thankful that I didn't have to do the billing code tango to get my on-demand to work. I have spoken enough with Comcast to last a lifetime.
     
  20. sandman55

    sandman55 New Member

    12
    0
    Aug 30, 2008
    I found out that you need to watch live TV first before going to OnDemand. Mini doesn't seem to take a tuner if you go straight to OnDemand.
     

Share This Page