1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internet and TiVO Service connection problems

Discussion in 'TiVo Roamio DVRs' started by ptr727, Sep 4, 2013.

  1. ptr727

    ptr727 New Member

    Dec 2, 2004
    Hi, have my Roamio Pro for about a week now.
    Ever since getting it, I've had problems with internet connectivity.

    When I press the TiVO button, or when I go to the what to watch now section, I'd see various messages about not connected to the internet , or not connected to the tivo service, or connected to the internet but some problem. Netflix also fails to connect.
    Errors: C501, C133, ui-133

    When the problem happens, I just need to wait a couple of seconds, then it resolves itself and the error goes away.

    If the error shows up, and I troubleshoot the network connection, it always works, no problems.

    My iOS TiVO apps also report the box has lost internet connectivity.

    It looks like the TiVo has some intermittent network problem.

    I contacted chat support, and I felt like the person could not get me of the line quick enough, did you reboot, no, have you rebooted, no, ok reboot, and then come back, bye.

    I've rebooted.
    I've swapped ethernet cables.
    I've swapped switch ports.
    Same problem.

    My internet connection is working just fine.
    I have many devices connected and none have any problems.
    I tried the same CAT6 cable that my working Roku uses for the TiVO, same problem.

    Searching I see old threads dating back to 2011 with similar symptoms.
    No resolution.

    My setup:
    Roamio Pro
    FiOS 75/35.
    Wired CAT6 ethernet.

    Any ideas?
  2. moyekj

    moyekj Active Member

    Jan 23, 2006
    I think I recall seeing posted in the TiVo Mini forums something about a problem with connecting to "Green" switches. Try bypassing switch and connecting directly to router if possible or use an alternate non-green switch to see if that helps just to see if that solves the problem.
  3. ptr727

    ptr727 New Member

    Dec 2, 2004
    I do use "green" switches, TrendNET TEG-S8g.
    But, no problems with any other devices.

    It is not possible to connect directly to the router.
    The router is in the distribution closet along with a HP ProCurve switch supplying the house, and then the 8 port switch in this AV closet for this TV.

    I called support again, they said the roamio is new and they are tracking some problems that may be updated, and that they do not recommend using a switch. When I explained how it is impossible to not use a switch, they suggested I switch to MoCA instead of wired ethernet.

    I switched to MoCA, and so far so good, hope it lasts.

    It would be really sad if they somehow do not support "green" switches.

  4. Devx

    Devx New Member

    Jun 1, 2006
    Atlanta, GA
    There's another thread or 2 on it but the Trendnet TEG-S80G is definitely one of the problem switches. It seems from your experience that the TEG-S8G should be on that list along with several other green switches. I was able to stream from an Elite to my Roamio tonight without issue on an S80G so it's an intermittent problem. It seems to affect some more than others.
  5. questors

    questors New Member

    Jun 4, 2009
    I'm having the same problems. I keep getting the C133 error. The Roamio can't see the TiVo Desktops, but the Desktops see the Roamio. When I try to transfer a show from our TiVo HD, it starts to transfer and then partway through the transfer it stops. When I look at the history, it says the show couldn't be found. I have a strong WiFi signal. When I run the run the network test it always connects successfuly. The TiVo HD is in the same location on the same network and it has no connection problems.

    I spent two hours on the phone with TiVo support yesterday and they couldn't resolve the problems. I'm about ready to return it.
  6. Initialvic

    Initialvic New Member

    Jun 16, 2012
    Wow, I thought I was the only one that was seeing this issue. Made me rethink the mini I purchased at the same time. I ended up putting an Apple airport I had laying around in between the tivo and the trendnet to stabilize the connection until I can try a few more gigabit switches. I am also using the TrendNet green switches.
  7. andrews777

    andrews777 New Member

    Aug 22, 2007
    I have noticed that some of my network errors clear up when I reboot all the switches in the network chain. It very well could be the swith, which is why a direct connection is the only way to know for sure. Have a really long ethernet cable you could string down the hall, etc. to test?
  8. TivoRoy

    TivoRoy New Member

    Feb 8, 2002
    Leesburg, VA
    I had the same problem with a green switch (D-Link DGS-1008G), replaced it with a Netgear GS108 and all is well.
  9. questors

    questors New Member

    Jun 4, 2009
    I talked to TiVo tech support today. They had me open incoming ports on the router firewall. That didn't help. We'll see what tomorrow brings.
  10. ptr727

    ptr727 New Member

    Dec 2, 2004
  11. Slamzee

    Slamzee New Member

    Aug 25, 2013
    Same issue here. Using a DLink Green switch. I moved to a Apple Time Capsule and have the same issues. I'm not sure if the time capsule has green features or not.

    Seems like the tivo software just needs to be a little more tolerant. It feels like it one tries once to connect and then times out. Make it retry a few times before giving up, and problem could be solved... Just a couple lines of code might solve it.
  12. questors

    questors New Member

    Jun 4, 2009
    Opening the ports didn't help. I removed my D-Link router and access point and got an Apple Airport Extreme. That didn't help either. Still getting C133s and unable to see the THD or PC Desktops. Problem has to be with the Roamio. I've eliminated all of the network variables. Not using a switch. Network status tests all run successfully. Tivo support doesn't get back to me.
  13. PHeadland

    PHeadland New Member

    Mar 29, 2005
    San Mateo, CA
    If you are using the Airport Extreme via a cable to your TiVo, it's still acting as a switch. And if you bought it recently, the ports are "green". So chances are this is the same problem the rest of us are experiencing.
  14. MScottC

    MScottC New Member

    Sep 11, 2004
    A note to this issue... you can have "green" switches in the path from one TiVo to another. They just can't be directly connected to the TiVos. So if you want to use your GigE green switches as central hubs between rooms, that's all and good. Just find a cheap (or not cheap) router, switch or otherwise to place between the "green" switch and TiVo.
  15. tvmaster2

    tvmaster2 New Member

    Sep 9, 2006
    I finally had this happen to my Premiere, which is connected to a non-green Netgear router, which is THEN connected to a new, TP-Link green-switch.
    There's not a single thing on the network, including my SageTV server, that balked at the green-switch.
    Are we just accepting the green-switch as the reason, as opposed to Tivo's software/hardware? I'm just not ready to blindly accept green-switches as the culprit...
    Will I miss recordings because of this?
  16. Dan203

    Dan203 Super Moderator TCF Club

    Apr 17, 2000
    Margret said they are looking into the problem with green switches. Obviously it's some sort of conflict between TiVo and the green switches and not entirely the green switches fault. Hopefully they can fix it via some sort of software update.
  17. Millionaire2K

    Millionaire2K New Member

    Jun 15, 2008
    I do Not have a green switch.

    I have been having Tivo service error message on both my Roamio boxes for a few days.

    However no problems on my Elite and Tivo HD.

    today they are all back to normal. I did nothing to fix it.
  18. Dan203

    Dan203 Super Moderator TCF Club

    Apr 17, 2000
    I've been seeing that too, late at night. I think they might actually be working on the system and taking it off line.
  19. HarperVision

    HarperVision TiVo's Italian Cuz!

    May 14, 2007
    That's my thought too.

Share This Page