1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Increase swap partition -w/o losing my recordings?

Discussion in 'TiVo Series3 HDTV DVRs' started by jlindema, Jan 31, 2013.

  1. jlindema

    jlindema New Member

    Feb 11, 2003
    San Jose, CA
    Hi TiVo Community-

    I screwed up.

    I have a TiVo HD (TCD652) with a WD drive that was manufactured in Sep. 2007. It was showing signs of slow failure
    for the past few years. So, having some time over the recent holidays, I tried copying the drive and adding capacity
    at the same time.
    I tried WinMFS (winmfs_beta9_3f), but despite using the "administrator" account/UAC disabled (Windows Vista)...the whole works- for some reason the drives weren't being recognized.
    No problem. I'm more comfortable with a command-line anyway, and have a "functional" knowledge of Linux.

    I used the (great) tools @ http://www.mfslive.org/download.htm - (mfslive-1.4), and the nifty "Interactive Command Generator" @ http://www.mfslive.org/cgen.php

    Unfortunately- I didn't select the "Custom Linux Swap Size" checkbox, and my new drive is a WD10EZRX (1T)... so
    clearly I need a swap partition that's greater than ...let's just say 'the default' ;)

    My new 1T drive worked GREAT for a few weeks (see: [media]http://johnl.net/2013101170544-00-img_3716.jpg[/media] [before] and
    [media]http://johnl.net/2013105094350-00-img_3717.jpg[/media] [after]).

    After a few weeks, my TiVo started to 'hang' at boot. Sure enough- I'm using a WD drive (with Intellipark) and
    until yesterday, I hadn't read the various posts in this forum about "wdidle3". So that's mistake #2.
    I've since corrected that mistake, set the Intellipark-idle timeout to "62 minutes", and now my TiVo is able to
    do both a power-on and a 'soft' boot.

    Due to the small swap partition, I'm now stuck in a GSOD loop.
    I've been reading through this post:
    "How to fix your TiVo if it gets stuck on a green screen"
    ...but it's wicked-old, and I think due to its age, mentions Series 1 & 2 TiVo's.

    I'm not too comfortable/confident altering partitions on the drive... especially since this (new) drive is my
    ONLY semi-working drive.

    Last night I tried putting my old/original drive back in -just 'till I get the kinks worked-out with the new WD10EZRX
    drive... but I was greeted with a "Welcome Powering-Up...", then about 5 seconds later.... a GREY screen.
    Nothing more. The old drive sounds like the heads are seeking...but I left it in this state over night- and
    it just doesn't seem to want to boot any more.

    So- if I haven't bored you all yet.. on to my question:

    Is the method described here: "How to fix your TiVo if it gets stuck on a green screen"
    still applicable for a drive copied from a TiVo HD using MFSLive v1.4 (backup/restore) to "fix" the too-small
    swap-partition size mistake ???

    Another approach or thought:
    I'm purchasing another WD10EZRX tomorrow. Rather than mucking around with partition re-numbering, wouldn't it be
    _much_ safer (considering this is my ONLY semi-good drive) to use the same tools from the same MFSLive CD
    and make a copy of my copy? This time- I'll use: backup -qTao - /dev/sda | restore -s 500 -zi - /dev/sdb
    (and, of course, I'll set the wdidle3 correctly on the newest drive too!)

    I appreciate any thoughts and advice you can give me.

  2. lillevig

    lillevig Hot in West Texas

    Dec 6, 2010
    San Angelo, TX
    Can't speak for most of it but when using WinMFS, did you click on the box to "Show mounted drives"? It normally won't show drives that Windows has recognized and mounted. I only use WinMFS and it has a convinient box for setting whatever swap size you want.
  3. jlindema

    jlindema New Member

    Feb 11, 2003
    San Jose, CA
    Thanks for the reply lillevig.
    Yes- I tried everything to get WinMFS to work. No drives ever appeared.
    All the forum posts pointed to a Windows Vista permissions problem... but I was using the "administrator" account itself...not "my" account. The WinMFS executable was marked as "run as administrator" (too).
    I even tried on a WinXP SP3 -system. Same results.
    My USB-to-SATA adapters work perfectly, and correctly detect and read/write to the drives (I did a test before using mfslive to see if there was something wrong with the adapters).
    After several days of testing everything- I gave up on WinMFS and used mfslive (which worked perfectly -aside from my misuse of the -s option)
  4. dianebrat

    dianebrat Uncontrolled Force

    Jul 6, 2002
    In Vista and higher, an "administrator account" even one with administrative privileges is not afforded the same uberpowers as rt-clicking on an item and choosing "run as administrator"
  5. jlindema

    jlindema New Member

    Feb 11, 2003
    San Jose, CA
    After many hours and several changes of strategy- I'm now a little better off, but still not operational.

    Running a "dd_rescue -A /dev/sda /dev/sdb"
    where: /dev/sda is the *original* 160G WD drive (circa 2007 drive) that wouldn't boot any longer when I stuck it
    back in, giving me a grey-screen about 5 sec. after the "Welcome! Powering Up".
    /dev/sdb being a new 1T WD "green" with wdidle3/Intellipark effectively disabled

    ...results in a TiVo that makes it through the entire boot sequence and begins playing the TiVo "introduction"
    video (which can usually be interrupted by pressing any key on the remote, taking you to "TiVo Central").

    But- instead of making it through the introduction clip and getting to "TiVo Central", play 'freezes' at the same
    point every time, then the system reboots.
    Attempts to press buttons on the remote to interrupt and get to TiVo Cental before reaching the point at which it
    frezzes- are ignored. At this stage, the yellow "IR" LED never indicates its receiving, yet I know the remote is
    working- since I am able to use it to enter kickstart command(s). If I use kickstart command 57 to force a file
    system check... I get a GSOD that now lasts much longer than 10-15sec (unlike the symptoms of my prior post).
    And I'm no longer in a GSOD loop. I'm still in a loop, but it progresses much further before rebooting.

    My thoughts:

    -since its able to boot and get to the introduction-clip, the image partition(s), /var, swap, and all is
    [relatively] OK, and _may_ be salvagable?

    -it wouldn't surprise me at all if the MFS partitions (where recordings/streams are stored) is screwed-up...
    but I'm not sure if a file-system check (via kickstart 57) bothers to check the partitions where your
    recordings are stored. TiVo is much more concerned about its own well-being than the well being of your recordings
    (which is understandable).

    -since I think the introductory-clip is located within the software-image itself (vs. the MFS partitions)...the fact that
    it plays to a certain point then locks-up and reboots, tells me the software image itself is corrupted and
    fsck/mfsck isn't able to fix it.

    I guess its time to spend some (more) $$ and get a InstantCake .iso -and read this thread again: http://www.tivocommunity.com/tivo-vb/showthread.php?t=490168

    I'll miss the recordings I had saved -but I'll miss all of my configuration (wishlists, season passes, etc.) even more.
    I know TiVo (the company) offers a Season Pass migration tool...but (last I checked) it doesn't do Wishlists or preserve
    your season pass order/priorities. I wouldn't think it would be _that_ difficult.

    Thanks for listening to my saga.
  6. lillevig

    lillevig Hot in West Texas

    Dec 6, 2010
    San Angelo, TX
    Sent you a PM re: the TCD of your box. I can probably provide a WinMFS image. If not me, then someone else likely has one.
  7. jlindema

    jlindema New Member

    Feb 11, 2003
    San Jose, CA
    Hi everyone!

    Ok..it takes me a while to accept things :)
    I now accept that a complete re-build of my TiVo from a 'stock' image is my only

    However... (you knew that was coming :)
    It kept bugging me that I would lose all of my wishlists, season passes, & the season-pass priorities.
    After all, that kind of stuff is built-up dynamically over many months/years...and it's not easily

    It also kept bugging me that my previous attempt at salvaging my settings (I gave up on salvaging the
    recordings) resulted in a drive that DID boot up..but hung and finally rebooted 1/3 of the way through the
    TiVo introduction clip.
    I figured if I could interrupt that clip-playback, maybe I could get to the menus and see my to-do list and
    other stuff (before it rebooted again).

    My plan was to:
    -hook up the video output to my Series2 TiVo, and start recording. Since I didn't know how much time
    I had 'till the TiVoHD rebooted again, I wasn't going to try to write everything down on paper! ;)

    -since the HD wasn't responding to IR commands from the remote, I figured it *might* respond to
    the bluetooth Slide remote+USB dongle.

    -hopefully the slide remote would be able to interrupt the introductory-clip and prevent a (quick) reboot

    -since the output was being recored, all I had to do was go through the menus and "view" the season passes,
    their priorities, wishlists, to-do, and cable-card settings.


    That plan worked! After boot-up, and while the introductory-clip was playing, I hit TiVo-button on the slide
    remote and got to the TiVo Central menu!! But- instead of interrupting the clip playback, the TiVo menus were
    superimposed over the playback... very weird, but I can live with it to "collect" my settings.

    It took about 4 iterations of this before it dawned on me that since the introductory-clip (which is damaged)
    kept playing 'under' my attempts at traversing the menus, when it reached the damaged part of the clip- it would
    always reboot.
    So- to 'force' it out of this cycle, I went to "Now Playing" (while the intro-clip was still playing...) and
    started playing one of my recordings. That worked, and bought me valuable time- since the TiVo didn't reboot
    at it's regular point in the process.
    I then forwarded to a "blackout" spot in my recording and hit "pause". That gave me a good background with
    high-contrast for viewing the settings.

    I "recorded" my to-do list, season passes, season-pass manager listing, and just for kicks- my now-playing list.
    I couldn't reveal my wishlists-listing -until I did a program-guide update, since this drive-image hadn't been
    "up" since ~Jan. 4th. The connection to the TiVo service went fine, and it was "Loading..." when I went to bed.

    This morning, enough of the program guide had updated for it to allow me to access my wishlists.
    I then "recorded" my scrolling-through that list, all while live TV was playing "underneith" simultaneously!
    Very weird!

    The program-guide update didn't "take" however...and it wanted me to connect to the TiVo service again.
    As I left for work, it was still "up" (overnight) and hadn't rebooted. It's by no means stable, but at least I
    was able to extract a video of my settings, so I can re-set up a re-imaged drive.

    I hope by sharing my long-winded description of this experience, someone who finds themself in the same
    situation, can gleen some ideas for salvaging their settings/season-passes/wishlists/etc. from a damaged drive.

    Again- thanks for listening and giving me advice & support
  8. mattack

    mattack New Member

    Apr 9, 2001
    Wait, if you got it up to Now Playing… you should be able to transfer off shows to another computer or other Tivo.. if they're not copy protected.

    I have a Tivo HD drive that was flaky/rebooting (as far as I can tell afterwards NOT hardware, like I originally thought), but I am able to boot with that drive in and transfer off some shows.. Then I put the 'good' drive back in.
  9. jlindema

    jlindema New Member

    Feb 11, 2003
    San Jose, CA
    You're right mattack. I've been transferring what I can.
    I've also been introduced to a new error message "Unable to playback" -or something like that...for some damaged recordings.
    I'm definitely on borrowed-time.

Share This Page