1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IN Home Streaming Experience - router settings

Discussion in 'TiVo Roamio DVRs' started by DarlingPicky, Oct 25, 2013.

  1. DarlingPicky

    DarlingPicky New Member

    Oct 4, 2013
    I'm sure everyone is exited to try the OOH streaming, but I'm still having issues in home.

    Streaming is generally very high quality (HD), but freezes often. Usually every 5 to 10 seconds. My wifi speed is generally excellent. I have one of the newer Asus AC routers (RT-AC66U).

    The router config is pretty much stock (no QoS enabled or anything). This issue seems to happen regardless of other network traffic.

    Anyone else having this problem or have suggestions on settings? Am I right in suspecting the router is a problem? As it exists not, the streaming is pretty much useless for me.
  2. jimmypowder

    jimmypowder New Member

    Oct 24, 2013
    I run into this as well with my Apple Extreme base Station(new model)

    I have 120 mbps download/20 mbps upload speed! Nothing else i have and I have a lot
    of ethernet connected and wifi devices does this freezing but the Tivo app does.

    The Roamio is ethernet connected.
  3. DeltaOne

    DeltaOne Mount Airy, MD

    Sep 29, 2013
    Our router is the Airport Extreme, streaming in or out of home works fine. I didn't change any router settings.
  4. Dan203

    Dan203 Super Moderator TC Club

    Apr 17, 2000
    How is the Roamio connected to your network? If it's connected via wifi as well then that could be the problem. The Roamio needs to be hard wired to the router, either via Ethernet or MoCa for streaming to be reliable.
  5. DarlingPicky

    DarlingPicky New Member

    Oct 4, 2013
    The roamio is hard wired into the router. I've had no problem streaming in other apps (netflix, hbo go, etc) on the ipad.
  6. shortcut3d

    shortcut3d New Member

    Sep 1, 2013
    LiveTV is more latency sensitive than other streaming services. I know with WMC, there were absolutely no packet retransmission because it used UPnP which is not buffered. I'm not sure how much buffering is allowed on the TiVo Stream.

    I have a Ubiquiti EdgeRouter POE router and UniFi UAP-AC access point and all streaming works fine. The router settings drop all invalid packets and only allow established. Fairly basic rule set that is locked down. Wifi or Internet traffics from the Roamio must always go through the router. Granted I have three drops off the router switch chip. One to the UAP-AC and two to GS108T switches (all devices powered by POE).

    I would map the channels of other Wifi networks in your area. You want to be as far as possible from each channel, no less than 3 from the next strongest network channel. Wireless-AC poses a challenge because at 5GHz VHT 80MHz channel width necessary to reach 1300Gbps only has one true channel regardless of what you manually set. You can reduce your channel width to HT 40Mhz on 5G and 20MHz on 2G. This tends to improve stability and quality.
  7. PCurry57

    PCurry57 Liberal Hippie Chick

    Feb 27, 2012
    I also have an ASUS RT-AC66R, the R being different from the U only in that the R is specifically sold by BestBuy otherwise they are exactly the same and run the same firmware.

    I noticed frequently dropping streaming room to room sudden connection loss, with newer firmwares.

    What follows is the report I've made to ASUS Tech Support

    [Problem Description]
    Currently running {stable}

    I have tried both and and encountered frequent
    wireless drops on 5Ghz AC[80] and freezing of the router. This particularly happens
    with a bridge device in my bedroom connecting the Bedroom PC, TIVO Premiere and
    BluRay. The bridge device I am currently using is a DLink DAP-1522 that has been
    very stable for many years with the preceding router a DLink DIR-825.

    While testing the newer firmware while streaming HD video to the TIVO in the living
    room connected via a wired connection to the RT-AC66R I experience poor
    throughput and frequent dropped connections followed by total lock-up of the web

    I also have an HP Photosmart 7510 connected on the 2.4Ghz WLAN and connect two
    Android devices (Galaxy S4 and a Galaxy Tab 3) via either band and an older PALM
    T|X via 2.4Ghz b and a smart TV's via 5Ghz wlan..

    Again when using the above problems just don't happen. Since I as
    many are am increasingly using mobile devices like smart phones and tablets I
    would greatly appreciate the newer web interface introduced in

    I suggest making your own report they have responded and are working the ticket. The more information we can give may help resolve the issue. In the mean time try firmware
  8. DarlingPicky

    DarlingPicky New Member

    Oct 4, 2013
    SOLVED: Fiddled with the router settings for another hour and eventually reverted back to stock. Upgraded up to version of the firmware, restarted everything, and it's been smooth streaming so far.

    I had just updated the router's firmware a couple weeks ago, so I suspect that I got caught with a buggy firmware update from Asus. Thanks for everyone's tips!

Share This Page