1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HME/VLC video streamer, v1.0 -- watch NASA TV, etc.

Discussion in 'TiVo Home Media Features & TiVoToGo' started by wmcbrine, Aug 23, 2008.

  1. Nov 3, 2008 #81 of 481
    phdeez

    phdeez New Member

    51
    0
    Aug 21, 2003
    In addition, make sure you have the "Home Applications" enabled under the Music, Photos & More Menu [very bottom].

    wmcbrine, it's all good. It certainly isn't a pressing matter... but honestly I'd like any home app to stream subtitles to my Tivo without having to re-encode the video with static subtitles... Like a subtitle "option" just like Closed Captioning is today...

    I will agree with what goodtrips said about audio quality. Comparing pytivo and HME/VLC for just a sample file on my system I find the audio is much different- with the advantage clearly going to pytivo when re-encoding is necessary... maybe the difference is between the encoders...

    Could it be a setting in VLC causing it? Probably...
     
  2. Nov 3, 2008 #82 of 481
    jmemmott

    jmemmott New Member

    393
    0
    Jul 12, 2003
    Santa Cruz, CA
    I don't think you will be able to get away without transcoding although it could be done on the fly. The Tivo does not respond to embedded captions in the streaming media as it does downloaded ones so unless there is a new undiscovered mechanism, hard coded subtitles will be the only path.

    When I have used vlc to stream in other circumstances it always seemed to require something like
    --sout=#transcode{vcodec=...,soverlay} to make this work.
     
  3. Nov 3, 2008 #83 of 481
    wmcbrine

    wmcbrine Ziphead

    10,401
    36
    Aug 2, 2003
    The captions don't have to be embedded. They could be rendered via HME, just like the progress bar, info, etc.

    I just had a look at an .srt file, and it seems ridiculously simple. I'm thinking about how to handle it... I can probably refresh it on resource info events.
     
  4. Nov 3, 2008 #84 of 481
    phdeez

    phdeez New Member

    51
    0
    Aug 21, 2003
    Sorry, I meant "static" subtitles like using a separate application to re-encode the video PRIOR to streaming it with the subtitles permanently overlayed on the video. It would be most beneficial to "decode" a .srt file in the same directory as the .avi/etc on the fly... or something like that.

    Awesome news! Thanks for looking into it!
     
  5. Nov 3, 2008 #85 of 481
    jmemmott

    jmemmott New Member

    393
    0
    Jul 12, 2003
    Santa Cruz, CA
    That would be good if it can be done that way.

    The only concern I had about this approach when it first came up was with respect to synchronization. People who are used to using captions are sensitive to synchronization issues in the same way people are sensitive to audio/video synchronization issues. Good timings are tightly coupled and I did not know how much feedback you can get about what it actually on the screen right now vs what is in the stream buffer. The learning curve to find out seemed too high for me vs the time I had available when it first came up.
     
  6. Nov 3, 2008 #86 of 481
    EightPieceBox

    EightPieceBox New Member

    4
    0
    May 8, 2008
    That is where I'm looking and no new icon shows up for HME/VLC. I must be having a network issue. I tried rebooting my tivo and shutting off my firewall software. Guess I'll try changing the port.
     
  7. Nov 3, 2008 #87 of 481
    wmcbrine

    wmcbrine Ziphead

    10,401
    36
    Aug 2, 2003
    Sounds like it. Worse comes to worst, if you run HME/VLC on port 80, you can try "Manually add a server..." on the TiVo end.
     
  8. Nov 7, 2008 #88 of 481
    KevinG

    KevinG Member

    304
    0
    Sep 3, 2003
    Mt. Laurel, NJ.
    I installed HME/VLC 2.5 last night. I am currently using pyTivo. Since I exclusively watch and then delete, I thought it would be better to stream instead of transfer...

    However, in 2 back to back tests (with ripped DVDs), streaming causes tearing, and macroblocking, whereas transfering (and playing in real-time) yields perfect transfers.

    Is this expected? It didn't matter if I paused either one to allow it to buffer more or less. If I hit 8 second rewind the same tearing was present each time. My tivos are wired, not wireless. Thoughts?

    I also tried tivostream, but I couldn't get that to show up on either of my Tivos...

    Thanks.
    -Kevin
     
  9. Nov 7, 2008 #89 of 481
    wmcbrine

    wmcbrine Ziphead

    10,401
    36
    Aug 2, 2003
    Are you streaming files with names that end in ".mpg" or ".mp4"? If not, they'll be reencoded, so there'll be some quality lost. pyTivo is more sophisticated in how it determines whether or not to reencode -- and when it does, it encodes to MPEG-2. HME/VLC uses MPEG-1.
     
  10. Nov 7, 2008 #90 of 481
    KevinG

    KevinG Member

    304
    0
    Sep 3, 2003
    Mt. Laurel, NJ.
    No. In fact I was trying to find a solution that would explicitly *not* require reencoding. These are VOBs ripped from DVDs, renamed to .mpg.

    And the quality of the video (when not tearing, or macroblocking) is absolutely DVD quality.

    -Kevin
     
  11. Nov 7, 2008 #91 of 481
    moyekj

    moyekj Well-Known Member

    11,253
    72
    Jan 23, 2006
    Mission...
    I found it helpful to run ripped VOBs through VideoRedo Quickstream Fix first before attempting to stream or transfer to Tivos. Otherwise in some cases the stream or transfer would have some issues such as you describe and in some cases the transfer would halt altogether. The Tivo decoder seems to be picky about getting "clean" mpegs.
     
  12. Nov 7, 2008 #92 of 481
    KevinG

    KevinG Member

    304
    0
    Sep 3, 2003
    Mt. Laurel, NJ.
    Yes, that fixed it entirely. Thanks!

    Now I'm bumping up against the fact that streamed movies don't remember where you were if you stop in the middle and plan to come back later... May end up sticking with pyTivo just for this reason alone.

    -Kevin
     
  13. Nov 7, 2008 #93 of 481
    moyekj

    moyekj Well-Known Member

    11,253
    72
    Jan 23, 2006
    Mission...
    tivostream supports resume playback from where you left off for .mpg... too bad you can't seem to get it working.
     
  14. Nov 15, 2008 #94 of 481
    mitchk

    mitchk New Member

    7
    0
    Jul 24, 2007
    Here are two streams for coverage of the Los Angeles area fires. Just add these lines to your config.ini file.

    [ABC-7 Los Angeles]
    url=mms://a352.l5671334351.c56713.n.lm.akamaistream.net/D/352/56713/v0001/reflector:34351
    needs_vlc=True

    [NBC-4 Los Angeles]
    url=http://mfile.akamai.com/12924/live/reflector:30763.asx
    needs_vlc=True
     
  15. Nov 18, 2008 #95 of 481
    dwgsp

    dwgsp New Member

    150
    0
    Aug 27, 2005
    Perinton, NY
    I installed the latest version of HME/VLC and can successfully stream mp4 files from my hard drive (WinXP). However, I cannot stream anything from the web. In fact, I can't even get them to show up in the HME/VLC top level screen on my Tivo HD. I suspect that there is a problem in my config.ini, but I have tried everything that I can think of and still no luck.

    Any ideas? Here's my config.ini. It references a working URL for NASA TV.

    [DEFAULT]
    cnnbase=http://www.cnn.com/video/live/cnnlive_
    cspanbase=http://play.rbn.com/play.asx?url=cspan/cspan/wmlive/cspan

    [hmeserver]
    port=9043
    #datapath=C:\
    apps=hmevlc

    [hmevlc]
    vlcport=9044
    vbitrate=2000
    # not sure what the syntax is for the following line
    vlc=C:\Program Files\VideoLAN\VLC
    #vlc=C:\Program Files\VideoLAN\VLC\vlc.exe


    # this works fine
    [Test]
    dir=C:\Video\TED

    # this does not even show up on the top level Tivo screen.
    [NASA TV]
    url=http://playlist.yahoo.com/makeplaylist.dll?id=1369080
    needs_vlc=True



    Thanks!
    /Don
     
  16. Nov 19, 2008 #96 of 481
    texaslabrat

    texaslabrat New Member

    61
    0
    Oct 24, 2007
    Austin, TX
    Awesome app...I've got it running on my Ubuntu 8.04 server against a Tivo HD..and it works wonderfully.

    I do have one issue..and my apologies if it's been addressed previously..but I've found that one has to be very careful how one exits the HME "environment". If I exit "cleanly" by hitting left arrow multiple times (waiting for each successive menu to be rendered), then everything's great...works as expected.

    However, if I exit by just hitting the Tivo button (and from there doing whatever...standby, live tv, or anything else)...then the app doesn't seem to exit gracefully. In many cases, the VLC process will still be running on the ubuntu box, happily transcoding away (though a netstat -a reveals that there is no remote socket attached to the VLC process, so the Tivo has dropped the connection from its perspective). If I immediately go back to the HME app and select another stream (or even the same one, for that matter), it generally "does its thing" and changes gears successfully as I begin watching content. All seems well and good. However, if I hit the Tivo button/standby and go to bed..and try to access the HME app later on the next day...I get an error trying to open the stream (*any* stream or local file) as the VLC app has either frozen and/or crashed (probably due to some memory leak in the vlc application...been quite a problem over the years it appears from various threads dug up in a quick google search on the topic).

    The HME "control" python process doesn't seem to recognize this fact...and never restarts VLC or attempts to clean up the defunct process. I've also tested with hitting the Tivo button, observing that VLC is still running..and then manually killing the VLC process. Going back into HME has the same problem...it won't start up another VLC process and again errors out when trying to open up a stream or file.

    Killing the start.py and restarting it fixes the issue in all these cases, however I can't but wonder if there's a way to have the HME application sense that something's amiss and "punt" with regards to the VLC process. I took a look at the code, and I see that it's keeping some basic accounting that enumerates clients and kills the VLC when number of clients = 0..and then can subsequently start a fresh VLC process when needed. This is where I think the weakness lies...when one exits with the Tivo button, the HME process doesn't seem to be getting notified that it is disconnecting. Is there a better way to sense a "hang up"? Or perhaps a different approach is needed...one thing I thought of is instead of trying to count clients and killing the VLC process when clients=0, instead actively look at the number of sockets open (via a system call to netstat or some other way) and attached to the VLC process. When THAT number is zero, then kill the VLC process if it's still running. If no one is pulling data from VLC, then that's a sure-fire sign that the VLC process isn't needed and is going to cause problems if it hangs around.

    Anyway, in the mean time I'll try to be careful how I exit the application, and I'll try to train the wife on the particulars on how to avoid the issue as well.

    Thanks again for a wonderful application released for free to the public :)
     
  17. Nov 19, 2008 #97 of 481
    wmcbrine

    wmcbrine Ziphead

    10,401
    36
    Aug 2, 2003
    It's the full path, including the filename, so the second (commented-out) line would be correct. However, that path is already the default, so there's no reason to specify it at all... assuming that you actually have a copy of VLC there.

    It's normal for the "needs_vlc=True" entries not to show up in the menus if the VLC executable isn't present.
     
  18. Nov 19, 2008 #98 of 481
    dwgsp

    dwgsp New Member

    150
    0
    Aug 27, 2005
    Perinton, NY
    I ended up commenting out both of vlc lines, and when that didn;t work in reinstalled the 0.8.6 version of vlc. That worked. Thanks!
     
  19. Nov 20, 2008 #99 of 481
    dwgsp

    dwgsp New Member

    150
    0
    Aug 27, 2005
    Perinton, NY
    Has anyone gotten flash streams to work? It looks like the latest version of VLC supports streaming flash, but previous messages in this thread indicate that the newest VLC is not supported.

    I want to get this working with live streams from the Big Ten Network (for college basketball games).

    http://video.bigtennetwork.com/

    Thanks!
    /Don
     
  20. wmcbrine

    wmcbrine Ziphead

    10,401
    36
    Aug 2, 2003
    VLC 0.8.6 will transcode FLV movies. Whether this is the same as "supporting streaming Flash" is not clear to me.
     

Share This Page