1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with KMTTG Error

Discussion in 'TiVo Home Media Features & TiVoToGo' started by JeffreyF, Aug 27, 2012.

  1. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    I have had great success with KMTTG for downloading and converting .tivo files to the ipad format.

    Something must have changed with my settings as I am not getting an error message. KMTTG successfully transfers the .tivo file to my Windows PC. When it tries to do a decrypt followed by an encode the error message below apperas.

    The Encoding Profile is ff_ipad.

    Pictures enclosed of the settings.

    The error message is as follows:


    Saved 1 queued jobs to file: jobData.dat
    Saved 2 queued jobs to file: jobData.dat
    SKIPPING DECRYPT, FILE ALREADY EXISTS: C:\KMTTG\Output Decode\Relaciones Peligrosas (04_17_2012).mpg
    Saved 1 queued jobs to file: jobData.dat
    2nd try to obtain video file dimensions from file: C:\KMTTG\Output Decode\Relaciones Peligrosas (04_17_2012).mpg
    Failed to determine video dimensions from video file: C:\KMTTG\Output Decode\Relaciones Peligrosas (04_17_2012).mpg
    >> ENCODING WITH PROFILE 'ff_ipad' TO FILE C:\KMTTG\Output iPad\Relaciones Peligrosas (04_17_2012).mp4 ...
    C:\KMTTG\ffmpeg\ffmpeg.exe -y -i "C:\KMTTG\Output Decode\Relaciones Peligrosas (04_17_2012).mpg" -threads 4 -vcodec libx264 -level 31 -subq 6 -me_range 16 -qmin 10 -qmax 50 -g 300 -s 1280xHEIGHT -r 29.97 -b 2500k -maxrate 4000k -acodec aac -ac 2 -ab 160k -ar 48000 -f mp4 "C:\KMTTG\Output iPad\Relaciones Peligrosas (04_17_2012).mp4"
    There are currently no queued jobs to save.
    encoding failed (exit code: 1 ) - check command: C:\KMTTG\ffmpeg\ffmpeg.exe -y -i "C:\KMTTG\Output Decode\Relaciones Peligrosas (04_17_2012).mpg" -threads 4 -vcodec libx264 -level 31 -subq 6 -me_range 16 -qmin 10 -qmax 50 -g 300 -s 1280xHEIGHT -r 29.97 -b 2500k -maxrate 4000k -acodec aac -ac 2 -ab 160k -ar 48000 -f mp4 "C:\KMTTG\Output iPad\Relaciones Peligrosas (04_17_2012).mp4"
    FFmpeg version SVN-r21085, Copyright (c) 2000-2010 Fabrice Bellard, et al.
    built on Jan 8 2010 06:05:02 with gcc 4.2.4
    configuration: --enable-memalign-hack --prefix=/mingw --cross-prefix=i686-mingw32- --cc=ccache-i686-mingw32-gcc --target-os=mingw32 --arch=i686 --cpu=i686 --enable-avisynth --enable-gpl --enable-version3 --enable-zlib --enable-bzlib --enable-libgsm --enable-libfaad --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libmp3lame --enable-libopenjpeg --enable-libxvid --enable-libschroedinger --enable-libx264 --enable-libopencore_amrwb --enable-libopencore_amrnb
    libavutil 50. 7. 0 / 50. 7. 0
    libavcodec 52.45. 0 / 52.45. 0
    libavformat 52.46. 0 / 52.46. 0
    libavdevice 52. 2. 0 / 52. 2. 0
    libswscale 0. 8. 0 / 0. 8. 0
    [NULL @ 0x3e8e10]Format detected only with low score of 1, misdetection possible!
    [mp1 @ 0x3e9f90]Header missing
    Last message repeated 1 times
    [mp3 @ 0x3e8e10]Could not find codec parameters (Audio: mp1, 0 channels, s16)
    [mp3 @ 0x3e8e10]Estimating duration from bitrate, this may be inaccurate
    C:\KMTTG\Output Decode\Relaciones Peligrosas (04_17_2012).mpg: could not find codec parameters

    Your help would be appreciated.

    Jeffrey
     

    Attached Files:

  2. lpwcomp

    lpwcomp Active Member

    8,078
    2
    May 6, 2002
    John's...
    You need to do one of two things. Either delete the .mpg file or check the "Overwrite existing files". Then start over. Also, you didn't by any chance "update" ffmpeg, did you?
     
  3. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    I will try the "overwrite existing files". When the error first appeared I am certain the directory was empty.

    I am not aware of the ffmpeg being updated. The ffmpeg is from the original install of KMTTG.

     
  4. moyekj

    moyekj Well-Known Member

    11,141
    31
    Jan 23, 2006
    Mission...
    Sounds like the .mpg file is empty/corrupted so starting over as suggested is recommended. Also since you are encoding enabling "QS Fix" task is highly recommended else it's likely you'll have A/V sync issues when playing the .mp4.
     
  5. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    I tried another recording that has not been previously converted to ensure there were no duplicate files. I also enables duplicate files to be overwritten. I am still receiving errors. The error for a decrypt and encode using ff_ipad is as follows:

    tivodecode failed (exit code: 10 ) - check command: C:\KMTTG\tivodecode\tivodecode.exe --mak MAK --no-verify --out "C:\KMTTG\Output Decode\La Que No Podía Amar (06_25_2012).mpg" "C:\KMTTG\Output Tivo\La Que No Podía Amar (06_25_2012).TiVo"
    TiVo Private Data : Unmatched Stream ID: No error
    ts_handle_tivo_private_data failed: No error
    processing frame: No error
    Encryption by QUALCOMM ;)

    2nd try to obtain video file dimensions from file: C:\KMTTG\Output Decode\La Que No Podía Amar (06_25_2012).mpg
    Failed to determine video dimensions from video file: C:\KMTTG\Output Decode\La Que No Podía Amar (06_25_2012).mpg
    >> ENCODING WITH PROFILE 'ff_ipad' TO FILE C:\KMTTG\Output iPad\La Que No Podía Amar (06_25_2012).mp4 ...
    C:\KMTTG\ffmpeg\ffmpeg.exe -y -i "C:\KMTTG\Output Decode\La Que No Podía Amar (06_25_2012).mpg" -threads 4 -vcodec libx264 -level 31 -subq 6 -me_range 16 -qmin 10 -qmax 50 -g 300 -s 1280xHEIGHT -r 29.97 -b 2500k -maxrate 4000k -acodec aac -ac 2 -ab 160k -ar 48000 -f mp4 "C:\KMTTG\Output iPad\La Que No Podía Amar (06_25_2012).mp4"
    There are currently no queued jobs to save.
    encoding failed (exit code: 1 ) - check command: C:\KMTTG\ffmpeg\ffmpeg.exe -y -i "C:\KMTTG\Output Decode\La Que No Podía Amar (06_25_2012).mpg" -threads 4 -vcodec libx264 -level 31 -subq 6 -me_range 16 -qmin 10 -qmax 50 -g 300 -s 1280xHEIGHT -r 29.97 -b 2500k -maxrate 4000k -acodec aac -ac 2 -ab 160k -ar 48000 -f mp4 "C:\KMTTG\Output iPad\La Que No Podía Amar (06_25_2012).mp4"
    FFmpeg version SVN-r21085, Copyright (c) 2000-2010 Fabrice Bellard, et al.
    built on Jan 8 2010 06:05:02 with gcc 4.2.4
    configuration: --enable-memalign-hack --prefix=/mingw --cross-prefix=i686-mingw32- --cc=ccache-i686-mingw32-gcc --target-os=mingw32 --arch=i686 --cpu=i686 --enable-avisynth --enable-gpl --enable-version3 --enable-zlib --enable-bzlib --enable-libgsm --enable-libfaad --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libmp3lame --enable-libopenjpeg --enable-libxvid --enable-libschroedinger --enable-libx264 --enable-libopencore_amrwb --enable-libopencore_amrnb
    libavutil 50. 7. 0 / 50. 7. 0
    libavcodec 52.45. 0 / 52.45. 0
    libavformat 52.46. 0 / 52.46. 0
    libavdevice 52. 2. 0 / 52. 2. 0
    libswscale 0. 8. 0 / 0. 8. 0
    [NULL @ 0x1588e00]Format detected only with low score of 1, misdetection possible!
    [mp1 @ 0x1589f90]Header missing
    Last message repeated 1 times
    [mp3 @ 0x1588e00]Could not find codec parameters (Audio: mp1, 0 channels, s16)
    [mp3 @ 0x1588e00]Estimating duration from bitrate, this may be inaccurate
    C:\KMTTG\Output Decode\La Que No Podía Amar (06_25_2012).mpg: could not find codec parameters

    Any insights as to what is causing the error and how I can fix is appreciated.

    Jeffrey

     
  6. moyekj

    moyekj Well-Known Member

    11,141
    31
    Jan 23, 2006
    Mission...
    JeffreyF, the problem is you have "TS Downloads" enabled in kmttg or "Fast Transfers" enabled in TiVo Desktop if that's where the .TiVo file came from. tivodecode does not work properly with TS .TiVo files so you have to turn that off. If downloading with kmttg you have to make sure this setting is off:
    "Download TiVo files in Transport Stream format"

    This has come up many, many times and I'm almost of mind to just get rid of the option completely just to avoid being hassled by it, (though for those with VideoRedo it can decrypt TS .TiVo files and that's what I use for decrypt).
     
  7. lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    As a compromise, perhaps you could put logic in the app that prevents one selecting tivodecode as an option for decrypting if TS transfers are turned on. Or perhaps put in a nag to the effect, "You have Transport Stream transfers turned on. This will prevent your using tividecode to decrypt the files", every time one saves the configuration with TS transfers enabled on any TiVo.
     
  8. JeffreyF

    JeffreyF New Member

    38
    0
    Jan 15, 2012
    I disabled the "Download TiVo files in Transport Stream format" and all works with the features described. Thank you for the help!

     

Share This Page