1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help upgrading to 6.4 I have telnet,tivoweb access

Discussion in 'TiVo Underground' started by tibo, May 19, 2012.

  1. tibo

    tibo New Member

    140
    0
    May 22, 2004
    I am definately getting old, I have not accessed my dvr 80 since 2006... :eek: I tried for a week to get in using win 7 with no luck, so dug up an old laptop with winxp and was able to get access. I have tivoweb 1.3 working, and can telnet in using :
    telnet -t vt100 ipaddy... :cool: but now I am stumped... I have slicer and 6.4a slices in a zip file and did a
    echo mls /SwSystem | tivosh
    results are 6.2 slices there, but no 6.4 so I need to move them up to the tivo with the slicer software... memory not what it used to and 6 years gone by... I am
    drawing a blank... I have the peices... just not sure what to do next...

    ok... alzheimers got the best of me... I bought the slicer and ftp'd it up to var/tmp as suggested... when I run... it fails to download the 6.4a slices... ok... I have them... I ftp'd into same directory...no go... what directory should my slices be in... I have 6.2 and 6.2a updates on the box through "echo mls /SwSystem | tivosh" but what directory should I put my 6.4a slices so I can use the slicer??

    I have read posts for days... and am a little confused on what to do next... any help would be appreciated.
     
  2. 55tbird

    55tbird New Member

    32
    0
    Jun 24, 2007

    If you have "var/packages" in your DTivo search for the wget code from dvrupgr...com.......
    check for your service id and use it in the code. After doing that verify that you have the "getslice" in packages. Then run that file, it'll take 10 min or so but 6.4a will finally showup when you use the echo command sequence you previously mentioned. Then run the slicer.
    All of this should happen "if" your Tivo can connect to the Internet. GL
     
  3. tibo

    tibo New Member

    140
    0
    May 22, 2004
    Thanks 55tbird, here is where I am at

    I bought slicer 1.9 I think is the newest…. followed instructions and hit an error

    ./slicer: /var/packages/update1: Permission denied

    There are no 6.4a-01-2-321 slices on your Tivo, exiting

    I thought slicer was to auto download… but to be sure

    I've tried to get the 6.4a slice by using the following;

    wget -O /var/packages/getslice http://www.dvrupgrade.com/software/update_tool/getslice-6.4a-01-2-321

    but I keep getting the telnet response;

    wget:www.dvrupgrade.com: host name lookup failure

    echo mls /SwSystem | tivosh

    that I currently only have the 6.2a version. so in my frustration and lacking a support response from dvrupgrade

    I put
    http://www.dvrupgrade.com/software/update_tool/getslice-6.4a-01-2-321
    in winexplorer and downloaded getslice direct and ftp'd to /var/packages
    I then went
    cd /var/packages
    ./getslice but I think it should be "sh ./getslice"

    I am missing something.... but damn if I can put my finger on it...

    as an alternative, I downloaded direct... http://www.dvrupgrade.com/software/update_tool/6.4a-01-2-321.slices.tgz
    and Ftp'd to /var, I tried
    gzip -d /var/6.4a-01-2-321.slices.gz
    and
    dbload /var/6.4a-01-2-321 (not sure if it was supposed to include 321.slices or 321.slices.gz)
    but that kicked an error in tvbusy box line 26 (which when I looked up a few posts said it was because I was still zipped.
    so I unzipped everything with winrar... and then ftp'd up to /var/
    and tried dbload again... no error, but then no 6.4a when I rebooted and
    echo mls /SwSystem | tivosh
    still shows only 6.2 and all of the different versions of 6.2a.

    I appreciate any criticism and instructions in my thoughts and process.... hehehe, after six years and not needed to do anything with my box... I see I have forgotten a lot... thanks in advance to any and all
     
  4. 55tbird

    55tbird New Member

    32
    0
    Jun 24, 2007
    .
     
  5. zorro255

    zorro255 New Member

    42
    0
    Apr 7, 2006
    Copied from http://www.tivocommunity.com/tivo-vb/showthread.php?t=485486&page=12
     
  6. sk33t3r

    sk33t3r New Member

    498
    0
    Jul 9, 2003
    Houston, TEXAS
    superpatch_6.4a_crashHD.tcl is the superpatch you used with 64a?

    wget:www.dvrupgrade.com: host name lookup failure

    Its more than likely a dns issue, what do you get when you try a ping dvrupgrade.com?

    If host name lookup failure is the error, then you DNS needs to be corrected, to fix thist do the following

    cd /etc ENTER

    either use JOE or vi to edit resolv.conf
    add the following

    nameserver 8.8.8.8 (yes most docs say to put 4.2.2.2 but google has free dns as well at 8.8.8.8.)

    save and exit NO REBOOT NEEDED (windows would require a reboot)
    now try ping dvtupgrade.com

    if this works then run your wget -O /var/packages/getslice http://www.dvrupgrade.com/software/u...-6.4a-01-2-321

    If editing in VI use this for editing help
     
  7. tibo

    tibo New Member

    140
    0
    May 22, 2004
    wow... thanks guys... I will try working on this again tonight... my first step is to solve the internet which is strongly plausible given that I am sure I have changed routers atleast twice during the past 6 years... and I am sure all of the settings have changed.

    will advise... and thanks again for your input and guidance... much appreciated
     
  8. tibo

    tibo New Member

    140
    0
    May 22, 2004
    well just thought I would provide an update... and say thanks to all.... I finally got it working, once I had internet communication:
    wget:www.dvrupgrade.com: host name lookup failure was no internet connection
    so I went to internet explorer and typed in 192.168.1.100 to access the tivo web and clicked on net config tab.... reset network settings to match the ipconfi /all (my gateway had changed) reboot and full communication...


    echo mls /SwSystem | tivosh
    no slices so

    I ftp'd slicer into /var/tmp and went
    cd /var/tmp
    ./slicer 6.4a-01-2-151 -d (this -d is used only if you DO NOT already have the slices, I did not and only learned afterwords that slicer will download)
    and the slicer executed and then stopped and told me I did not have slices....

    so off to get slices
    wget -O /var/packages/getslice http://www.dvrupgrade.com/software/update_tool/getslice-6.4a-01-2-321
    then
    cd /var/packages
    sh ./getslice
    I got a download successfull and unpacking archive...... this takes a while... 30 min and when complete and confimed that 6.4a is there

    ./slicer 6.4a-01-2-321

    and it errored telling me no slices... $^%@@ fine... so let me try the shortcut
    ./slicer 6.4a-01-2-321... off we go again... download unpacking...and installing all in one, then I remembered that I read of a consolidation of slices for 6.4a... quick search of this forum... and yes 121/321 are the same... so I should of used ./slicer 6.4a-01-2-121 as that is the consolidated slice

    but slices are installed.... and I am waiting for the locals to come back, but I did have a few questions:
    1)slice asked if I want usb drives and hacks copied, I said yes but it gave me a remider to copy any additional hacks I wanted and specifically reminded me to run /enhancements/var-symlinks.sh ???
    2)am supposed to rerun zipper ?
    3)and because I use fakecall... I read that it might not work and I should copy alphawolfs updated or old fakecall from DDB to busybox...

    again thanks alot guys...
     
  9. 55tbird

    55tbird New Member

    32
    0
    Jun 24, 2007
    I have got the locals back after doing the "slicer routine w/ptvupgr...com" but I no longer have the networking options under the phone setup.

    It can connect to the internet as it was able to run "tweak.sh" without any issues but it doesn't show the ip or mac addresses and it doesn't give the "edit phone or network settings" option.

    Is this a normal part of the slicer routine?

    Surely there must be a better way to restore this without pulling the drive and rerunning ptvnet cd.

    I've been searching various forums but haven't been able to find anything on this issue.

    Memories... it seems like it's on tip of my .... if you don't use it you lose it..... damnnn...it...
     
  10. tibo

    tibo New Member

    140
    0
    May 22, 2004
    Now after all this I am no expert,

    still missing channel 4 NBC after 24 hours... so trying to delete programming and todo list to see how that works, but if you have zipper then it installed tivowebplus which I think allows you to change your network info and slicer did not ask me any of that info either, it only asked if I wanted to copy my usb drivers and hacks folder
     
  11. sk33t3r

    sk33t3r New Member

    498
    0
    Jul 9, 2003
    Houston, TEXAS
    try this before your clear and delete even after I did a clear and delete I had to reauthorize my receiver

    https://www.directv.com/DTVAPP/login/login.jsp?_requestid=1058040


    Slicer wont ask for network info, slicer just applies the patches from 6.* to 6.4a your network IP and DNS settings are in

    /etc/rc.d/rc.sysinit.author
     
  12. 55tbird

    55tbird New Member

    32
    0
    Jun 24, 2007
    Is your answer directed at "tibo" or generically towards both of us? I realize that "at" this moment I "do" have internet capability but it doesn't address my chief concern.....

    All that I want to achieve is the restoration of "how" the phone option used to appear, ie, being able to make changes directly @ the Tivo using the remote control. Surely there has to be something that needs to be enabled or edited, especially since the original Ptvnet files should all still be there.
     
  13. tibo

    tibo New Member

    140
    0
    May 22, 2004
    well the clear programming info and todo list, kept my programs, but deleted my season passes and brought back all of the networks, including the missing channel 4...
    "NOTE: 320gb hard drive took 4 hours"

    so now I will re-run the zipper sh tweak.sh and if fakecall does not work, I will have to go get alphawolfs fakecall from DDB, but so far, so good... there is a lot of errors I made, but almost all of them were just a lack of memory and crap I had forgot...

    still not there, the sh tweak.sh recognizes a previous install and when I hit Y, it exits, so there is an issue with zipper that I will have to resolve, the only reason my box is hacked is so it does not call home.... so I really dont know how the phone option works 55tbird, but will let you know if I find out.

    thanks for all the help guys...

    UPDATE: slight issue with the zipper and 6.4a, I had to run the unistall first and then the tweaks... I also had to disable the crlf in my command prompt being that it was win xp... and as a side note... all my season passes appeared today, so I did not have to recreate after a clear programming and todo list... :)... now will wait a day or too to see if fakecall works or if I have to ftp over the one from DDB's alpha's tivotools zip file
     
  14. zorro255

    zorro255 New Member

    42
    0
    Apr 7, 2006
    Yes, but you can also use superpatch-1.2to1.15.diff.txt patch which has superpatch_6.4a_crashHD.tcl in it.
     
  15. sk33t3r

    sk33t3r New Member

    498
    0
    Jul 9, 2003
    Houston, TEXAS
    damn standby is gone after I ran tweak. I tried the advanced and non advanced, i tried modify menus and dont modify menus and standby disappears either way this was before I patched superpatch

    PS this is after a fresh install of 6.4a, not a slicer install
     
  16. tibo

    tibo New Member

    140
    0
    May 22, 2004
    check the other menus, when I re-ran tweak, it gave me the option to move it to the top of the main menu or leave it on messages and settings...
     
  17. sk33t3r

    sk33t3r New Member

    498
    0
    Jul 9, 2003
    Houston, TEXAS
    GONE GONE GONE

    Superpatch67Standby.tcl +tcs
    Current Software Version: 6.4a-01-2-151
    Adding Standby in TiVo (DIRECTV) Central
    Searching for ui/TivoCentral/TivoCentralDocument.brf
    Error: Failed to find ui/TivoCentral/TivoCentralDocument.brf

    Before I ran tweak standby was on the TCS, so in tweak i said dont move, it didnt move it it deleted it.
     
  18. zorro255

    zorro255 New Member

    42
    0
    Apr 7, 2006
    Your running the wrong Standby.tcl. You need to start running 6.4a items not 6.2a. Run Superpatch67Standby-6.4a.tcl.
    Run each menu item one at a time (ignore the errors) then reboot.

    FYI: The bufferhack for 6.4a is bufferhack11j.tcl
     
  19. sk33t3r

    sk33t3r New Member

    498
    0
    Jul 9, 2003
    Houston, TEXAS
    tweak is what runs that superpatch so once its ran i have to start over.
     
  20. zorro255

    zorro255 New Member

    42
    0
    Apr 7, 2006
    You don't need to rerun tweak to run Superpatch67Standby-6.4a.tcl. Just ftp it over to /hacks and run it.

    Tweak is just a script that runs another script that runs alot of patches.
     

Share This Page