1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Breaking News - The sale is back... "Our “once in a lifetime” PLS promotion was such a hit, that we’ve decided to launch it again! The PLS Transfer Sale will be available again for the last 3 days of the month. This will include the BOLT+ 3TB, and 4 refurb units (BOLT 500GB, BOLT 1T, Roamio Pro and the TiVo Mini)." https://www.tivo.com/secondchancelifetimesale#/secondchancelifetimesale

Help Encoding files for GoBack on linux

Discussion in 'TiVo Home Media Features & TiVoToGo' started by sgtstadanko, Sep 15, 2005.

  1. sgtstadanko

    sgtstadanko New Member

    53
    0
    Jan 9, 2005
    Birmingham, AL
    Hey All,

    I am looking for any cli commands on linux to encode files for goback. I cannot seem to get either ffmpeg, vlc, or mencoder to produce a workable file. Please share you command line args as I am wanting to script this, not use a gui.

    Cheers,

    SgtStadanko
     
  2. csitko

    csitko New Member

    2
    0
    Apr 10, 2003
    This ffmpeg command produces files that work fine for me:

    ffmpeg -i input.avi -vcodec mpeg2video -f vob -s 720x480 -r 30000/1001 -b 4000 -aspect 4:3 -ab 128 -bufsize 512 -maxrate 9800 Output.mpg
     
  3. sgtstadanko

    sgtstadanko New Member

    53
    0
    Jan 9, 2005
    Birmingham, AL
    sweet! thanks.
     
  4. Oct 8, 2005 #4 of 10
    tvon

    tvon Destroyer of Worlds

    13
    0
    Jun 28, 2005
    Baltimore, MD
    Thanks for this.

    A few notes after using GoBack for a week:

    1- 720x480 is a bit choppy/jerky on my 540, but at 704x480 everything is smooth and looks great.

    2- For letterbox, use the -padtop and -padbottom options. For example, I had a movie that was 576x240 so I left the size unchanged and added '-padtop 120 -padbottom 120' giving a total size of 576x480 (even though it is not listed as being supported, this played fine).
     
  5. scubabri

    scubabri New Member

    4
    0
    Mar 20, 2002
    When I use ffmpeg with the above options to transcode a VOB, I get audio, and video that is severly pixalated, but tivo accepts it.

    The video is pixalated if I play the mpeg with MediaPlayer, any ideas?

    I am doing this on a Mac running 10.4

    sb
     
  6. csitko

    csitko New Member

    2
    0
    Apr 10, 2003
    You can also change the aspect argument from "4:3" to "16:9" or whatever your videos aspect ratio is rather than padding the video. Also, in my case, setting the aspect ratio to 4:3 for a widescreen video displays the video correctly when expanded on my widescreen TV.
     
  7. tvon

    tvon Destroyer of Worlds

    13
    0
    Jun 28, 2005
    Baltimore, MD
    That doesnt work for me, though from reading some other threads I think it is due to the model of tivo I have (540).

    -Tom
     
  8. Feb 8, 2006 #8 of 10
    electroph4ge

    electroph4ge New Member

    1
    0
    Feb 7, 2006
    Encoding with the above command causes annoying stutters during playback on my SA2 (540) running 7.2.1 The following works beautifully:

    ffmpeg -i input.avi -target ntsc-dvd -s 480x480 -aspect 4:3 -ab 160 output.mpg

    (debian testing with ffmpeg 20060101-0.3 from debian-marillat repository)
     
  9. Jul 7, 2006 #9 of 10
    kb7oeb

    kb7oeb New Member

    490
    0
    Jan 18, 2005
    Phoenix,AZ
  10. EwanG

    EwanG New Member

    228
    0
    Oct 14, 2002
    San Antonio, TX
    What works for me (after a LOT of experimentation) is:

    ffmpeg -i "input.avi" -hq -target ntsc-dvd -acodec mp2 -ab 192 -ac 2 -ar 48000 -b 4096 -r 29.97 -s 720x480 -vcodec mpeg2video "output.mpg"

    FWIW,
    Ewan
     

Share This Page