1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HDMI Connection Not Permitted on Roamio

Discussion in 'TiVo Roamio DVRs' started by TheWizz, Feb 10, 2014.

  1. TheWizz

    TheWizz New Member

    41
    0
    Aug 27, 2013
    I have been having issues with my Roamio and Roamio Pro when connected to a Sony Receiver. On my Pro, I got around the "HDMI Connection Not Permitted" error by connecting the Pro directly to my TV and then digital audio out to the receiver. But my base Roamio was connected to the same model Sony (STR-DN1000) and then a projector. I have to connect to the receiver first. On the base Roamio, I was getting flashing green screens, not the HDMI error. I had another Onkyo receiver that I was able to swapout w/ the Sony and all worked great - for about a week. Now I get this "HDMI Connection Not Permitted" error. The detailed error talks about the TV not supporting HDCP. I have used this TV/Receiver/HDMI cables combo for 7+ years with DTV receivers with no issues or errors. I have tried three different HDMI 1.3 ver cables with no luck. I am at a loss as to what I need to do to get the Roamio to work with the receiver and projector. My only workaround for now is to use one of my Minis in the room to view recordings, but I'd like to get the Roamio, Receiver, Projector combo working again, like it did the first week after connecting it to the Onkyo receiver.

    If anyone has run into this issue on a Roamio and has some ideas, I'd love to hear them. Thanks in advance.
     
  2. ffitzgerald39

    ffitzgerald39 Member

    35
    0
    Apr 17, 2011
    Buffalo...
    I had the same problem between a Roamio Pro, a Sony Bravia TV, and a Sony sound system. I worked with Tivo customer service restarting all the components and checking all the cables, all with no solution. They finally told me to unplug all the HDMI cables, both ends of all cables, and turn everything off. I then plugged in all cables and turned everything back on.

    The tivo came back up on the screen asking to select the output foremat. I choose 1080i and1080p to match the TV. This solved the problem. I later also added the other foremats so the TV was doing all the conversions.

    The key thing seemed to unplugging both ends of the cables before rebooting.
     
  3. celtic pride

    celtic pride Member

    389
    0
    Nov 8, 2005
    That sounds like good advice,I've never had that message,but my screen did go black with no picture or sound. In my case i had to reset my onkyo av receiver ,because it was an hdmi hand shake issue!The next time i'll try removing all my hdmi cables from both ends first and see if that works,because when i reset my av receiver i lose all my sound and picture settings and have to start all over again!
     
  4. eboydog

    eboydog Just TiVo'ing.....

    904
    0
    Mar 23, 2006
    Might try one of these: http://www.amazon.com/dp/B004F9LVXC/ which is a hdmi splitter, it resolves many hdmi negotiation issues, while it's designed to split one hdmi signal to two outputs you don't have to use that second mirrored port. Usually this error occurs with older hdmi displays that don't properly handle HDCP handshake.
     
  5. jwbelcher

    jwbelcher New Member

    489
    0
    Nov 13, 2007
    Orlando, FL
    Its not limited to Roamio. I've also seen it on the Mini when connected to a bravia. I not had the issue after changing the resolution to 1080i fixed.
     
  6. TheWizz

    TheWizz New Member

    41
    0
    Aug 27, 2013
    I've been traveling for a couple of months and just now had to time to try and resolve this. I bought a 4-Port HDMI Selector/Switch at Best Buy that is HDMI 1.4 compliant along with two new HDMI 1.4 cables and it seems to be working OK now.
     
  7. Tanquen

    Tanquen Member

    104
    0
    Jun 1, 2002
    Napa, CA
    HDMI issues can be a pain and companies like to blame others and your cables. Something has changed with the new Roamios though. I had 2 TiVo HDs and a Premier and never ever had this Not Permitted nonsense. Now having swapped them for two Roamios I get these errors all the time. Mostly I get no signal and other times I get a black screen with the HDMI Not Permitted and other time I can see the TiVo menus but if I try to play something I get the error.
     
  8. tomhorsley

    tomhorsley Active Member

    1,172
    4
    Jul 22, 2010
    It is my belief that absolutely no one has ever implemented HDCP correctly :). I try to stick with component outputs when possible to avoid all the nonsense. Even when it "works" HDCP adds extra time to the input switching process while it painfully decides you actually do have the right to look at your own content.
     
  9. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC

    Considering that its only reason for existence is to keep you from watching stuff that they don't want you to be able to watch, they're going to worry about that part working every time it's supposed to a lot more than they're going to worry about it working when it's not supposed to.
     
  10. aaronwt

    aaronwt UHD Addict

    19,190
    25
    Jan 31, 2002
    Northern...
    I see no difference between the Roamios and the S3s I had many years ago. The S3, TiVoHD, Premieres, Minis, and Roamios would all sometimes get the HDMI connection not permitted under the right conditions. I especially had the issue with DVD burners or streamers like Hava and SLingbox when connected to the TiVos. So an HDMI splitter in the mix fixed the issues. Prior to using an HDMI splitter I used a manual two way splitter with one output not connected to anything. So I would switch it to the unused output when recording to eliminate the HDMI connection not permitted. The HDMi splitter was a much better solution since I don't have to mess with anything.
     
  11. nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
    +1 Me too!

    Two Sony Bravia TVs, three Roamios, don't play well together, worse with a switch, though.
    I don't get any errors, I just get complete A/V dropouts while doing anything (Live TV, Recorded TV, Hulu Plus, Netflix, etc).
    I see so many mentions of Sony here, I'm beginning to think this thread is where I belong.
    The 20.4.1 Update hasn't fixed it for me. It seems to have made matters worse.
    I'm sick of hearing how great the HDMI is working for most everybody in the update thread, and most are sick of hearing about my issues.
    The same TVs, switches, and cables worked with HDs and Premieres.
    I've tried multiple cable swaps, new switches, changing all the settings on the Roamios and TVs, and am at wits-end.
    My TVs have built-in Dolby, surround, and have outputs so I can add amplified external speakers, while still using the TV's speakers.
    The loud pops I hear when these dropouts happen are so bad I worry about speaker damage...
     
  12. Tanquen

    Tanquen Member

    104
    0
    Jun 1, 2002
    Napa, CA
    Ok, but I had 2 TiVo HDs and a Premier and never ever had this HDMI Not Permitted message. I had them for years and the HDs more years. Never ever had this message, not once. Then I get two Roamios and bam, I get this message all the time, from both of them.
     
  13. nooneuknow

    nooneuknow TiVo User Since 2007

    3,554
    0
    Feb 5, 2011
    Cox Cable...
    I hear ya...

    TCF is a place where many will place it on the TiVo user to pay more money to buy more items (or different ones), to work-around issues, only happening with TiVos, or a specific model of TiVo, rather than back somebody up and say "I agree, TiVo needs to fix this". Some will at least balance it out. With others, TiVo can do no wrong, and those members seem to spend all their time defending TiVo, while not even offering any workarounds (blame the user, or blame the user's equipment, when TiVo is the only device not playing-well).

    I don't feel it's right, for things to be this way. At the same time, it's pretty clear what the alternatives are. Many of them are just terrible, to say the least.
     

Share This Page