1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hacking your Series 2 DTivo just got a WHOLE lot easier...

Discussion in 'TiVo Underground' started by Gunnyman, Oct 16, 2005.

  1. Sep 15, 2011 #11821 of 11850
    Wil

    Wil Senile Member

    4,115
    32
    Sep 26, 2002
    Image. You have that (I think you said the 6.2 small). Rename it. Put it where it's supposed to be. That's what you asked in the message I responded to with what you call "no help." Sorry. Your problems are apparently deeper and broader than that.

    But you jump around. You ask about system image and then you jump to kernel. Baud rate.

    Do one thing at a time. Deal with THAT. Learn to understand one problem area at a time. If additional problems still remain after you've learned to understand, deal with those in turn one at a time.
     
  2. Sep 15, 2011 #11822 of 11850
    rpweaver

    rpweaver New Member

    23
    0
    Sep 28, 2010
    Problem is that I do jump around (too many forums to remember where you said what). Background... I have 2 TIVO 1s which I expanded many years ago. I have an RCA DVR40 and an RCA DVR80 which I expanded many years ago. The RCA40 HD died at 6.4a upgrade time. I shelved it and DTV sent me a Hughes R15 to replace it for free. I resurrected the DVR40 and put 3.1.1 back on it with a new HD. Now I want to get 6.4a back. Learning lots of stuff now but much of it is as much as 10 years old and it doesn't all fit together well. What I would like to do is suppress the daily call since it doesn't do anything for me and I don't have a land line where it is installed. MFSLive works well for HD upgrade. I was able to buy a Hughes DVR80 on EBAY but the HD is failing. After many attempts I finally got a working 6.4a copy. That runs on both RCA DVR40 and Hughes DVR80, both with new 500G HDs (now that I know about GSOD and Clear and Delete everything) I tried Zipper with 62small. Not much luck, couldn't get zipper to use the iso but would prefer 6.4a anyway. I tried Zipper with 6.4a preloaded. Zipper wants a kernel that works with 6.4a so I can get fakecall to work. That's all I want. I get gibberish in Hyperterminal with a serial cable from after I put in a kernel I found on the Zipper CD (wrong baud rate). Maybe that is correct but it won't get passed Power Up screen. The current Zipper instructions have become dependent on buying all the CDs instead of backups or hacked kernels.The Zipper instructions on the CD are different from the ones online. Yea, I'm frustrated.

    ---
    Went back to the backup I made. In Hyper terminal, I set the baud rate to 115200. Removed the HD and plugged DTIVO in. Got readable text via the serial line and finally asking "What is Password?" Tried "factory" but "What is Password?" repeated.

    Tried editing rc.sysinit to get a BASH prompt - didn't work.

    BTW, it says hdd4 doesn't exist when I try to mount it but hdd7 is fine. (This is a backup from a failing HD, would that happen if the bad sectors were on hdd4?) Might that be why Zipper and I are having trouble? Or is it just me. I'll restore rc.sysinit and try Zipper again. Then I'll try another kernel. I hate groping in the dark unless I have company.

    -----------

    OK, now I'm getting
    Boot failure reason=60
    from the serial line after applying zipper with a zipper kernel.

    Here are the kernels from the zipper files:
    Directory of C:\TIVO\zipper\zipper_tools\custom_kernels

    09/17/2011 12:27 PM <DIR> .
    09/17/2011 12:27 PM <DIR> ..
    03/11/2007 08:21 PM 1,446,400 vmlinux-7.2-Gen04.px
    03/27/2007 01:36 PM 1,434,112 vmlinux-8.1-Gen04.px
    03/27/2007 01:51 PM 1,522,688 vmlinux-Gen05.px
    10/23/2007 03:25 PM 1,533,952 vmlinux-Gen06.px
    03/27/2007 01:42 PM 1,436,160 vmlinux-TGC01.px
    03/27/2007 01:36 PM 1,434,112 vmlinux.px <<<<<<<<<<<<<<<<<<<<<copied and renamed vmlinux-8.1-Gen04.px
    6 File(s) 8,807,424 bytes
    2 Dir(s) 384,249,389,056 bytes free

    I first tried vmlinux-Gen06.px and then vmlinux-8.1-Gen04.px. Both give me the same boot failure error. (renamed to vmlinux.px gzipped and moved to zipper_tools\s2_kernels\3.1.5, where zipper says it can not find a kernel, then create the zipper iso and burn) Any help on what is what? If I need to manually choose one of these, wouldn't it be better to say what they are for, rather than require the user to use trial and error to discover if one or any of these work? Does "custom" == "hacked"? Does the zipper automatically use these and am I using them incorrectly? Wouldn't a readme file help?

    "Just got a whole lot easier" doesn't mean "just got easy."

    Re-downloaded zipper and will try again in case the zipper I had was too old.

    I'm open to ideas. Maybe I'm barking up the wrong tree.....
     
  3. Oct 1, 2011 #11823 of 11850
    rpweaver

    rpweaver New Member

    23
    0
    Sep 28, 2010
    OK, I finally got many of the zipper hacks working. I am still not connected to the network but I am working on that. When I get that going, I will expose that "secret" too.

    First, if you don't have instant cake, 000001 is the mfs file backup. Rename the file you have to this. You can get small versions of 6.2, 6.2a, and 6.4a. It may take some searching and a few nice folks with bit torrent. Keep trying and you will get there. if your file is too large, the iso maker will not create the iso but you can use another tool if you have one. Sorry, I don't have those details.

    Second, the hacked kernel. The ones in Custom kernels are not hacked with killhdinitrd and can not be. There are some links out there for hackable kernels, look around. Beg, You will find them eventually. Get killhdinitrd and run it on your target kernel and put the hacked kernel in the directory that zipper complains about if you don't have one. See the previous post for the path.

    After that, you should be able to follow the zipper instructions.

    If you have a serial cable, you will get lots of messages from your DTivo when booting but no aparent bash prompt. Just hit Enter and the bash prompt will appear. You can use this in place of a network to complete the Zipper process.
     
  4. Oct 1, 2011 #11824 of 11850
    Wil

    Wil Senile Member

    4,115
    32
    Sep 26, 2002
    There are no "secrets." Every question you have asked, every difficulty you have had, is dealt with in this thread.

    You make it very discouraging to try to help you.

    If you were to calm down and adopt a methodical step-by-step approach to the task it might seem painfully slow to you, but you'd get it done in 1/100th of the time.
     
  5. Oct 5, 2011 #11825 of 11850
    Phe0nix

    Phe0nix New Member

    69
    0
    Nov 17, 2005
    I have Tivo Web Plus installed as i choose this when i ran the zipper ver 4.6 on
    my Phillips DSR7000-17 DirecTivo.

    TWP works on my LAN and on gotomydvr.com but i'm unable to access via the internet and i have years ago. I had to reformat the HDD and now started using
    it again.

    1. I left tivoweb.cfg set to port 80 and set a username and pass.

    2. I created an Dynamic DNS Host account with dyndns.com and my hostname is Phe0nix.dyndns.org. I set the service type to "host with ip" using
    my pc WAN IP address.

    3. In my Linksys router i went to single port forwarding and set my external
    port to 1123 and my internal port to match tivoweb.cfg at port 80 as TCP

    4.I also went to the DDNS in my router and set the following :

    DDNS service type -dyndns.org
    username - same as tivoweb.cfg
    password - same as tivoweb.cfg
    hostname - Phe0nix.dyndns.org
    system - dynamic
    backup mx - default of disabled
    wildcard - default of disabled

    internet ip 192.168.2.2 ( reported by router , can't edit )
    status - ddnsm.dyn_good ( reported by router, cant' edit )

    Security tab - made certain " Filter Internet NAT redirection" was disabled

    5. I set my tivo gateway with the zipper during the install
    to 192.168.1.1 which is what my router ip address
    and i'm able to access my routers config page with this address

    6. I went into etc/rc.d and opened file rc.sysinit.author and verified
    that there was a command to open TWP on tivo startup and saw
    the following code :


    # starting Tivowebplus
    export HOSTNAME=Steelers
    /TivoWebPlus/tivoweb


    I am able to connect via LAN and gotomydvr so it must be running. Either way
    at a bash prompt i typed /TivoWebPlus/tivoweb console and it ran allot of code
    and then gave me the "Accepting Connections" message and i still can't get in
    via the internet.




    I sent an email to a friend linking to my tivo as http://Phe0nix.dyndns.org:1123 and the page timed out and didn't ask for a password as it should. I read due to looping you might not be able to access it your own network. When i used this tivo years ago i could get in via the web on my network but not now but i do have a new ISP.

    Anyone know if i maybe setup the free "Dynamic DNS Host" incorrectly or not.
    I fairly sure i have done all i can in the router and that it looks correct ?
     
  6. Oct 6, 2011 #11826 of 11850
    unclemoosh

    unclemoosh I Wish I knew Then..

    368
    0
    Sep 11, 2004
    Gulf South
    Try changing the port in the tivoweb.cfg file to 1123. I was able to ping your url. Some ISP's screw up things to port 80 because they don't want you hosting a server. Even though you're coming in on 1123, give it a try.
     
  7. Oct 6, 2011 #11827 of 11850
    rpweaver

    rpweaver New Member

    23
    0
    Sep 28, 2010
    Yep, all 395 pages of it. Without a thread search function, this is very painful, especially if you are dyslexic. Reading quickly is not my strong suit.

    Who needs to calm down. I am not yelling, just a little frustrated. If you haven't noticed, I AM taking it step by step by step by step by step .............

    I did get the network working by going back to 6.2 and using the 7.2.2-oth-K1 kernel with both wired and wireless. Tivo Web Plus even works. Now I have to get it working on 6.4a and get dhcp working (my current goals but maybe not in that order). Then do it again on the other DTIVOs.
     
  8. Oct 6, 2011 #11828 of 11850
    unclemoosh

    unclemoosh I Wish I knew Then..

    368
    0
    Sep 11, 2004
    Gulf South
    Huh???
    [​IMG]

    Look up and to the right :D
     
  9. Oct 6, 2011 #11829 of 11850
    Phe0nix

    Phe0nix New Member

    69
    0
    Nov 17, 2005
    Let me know if i did what your asking, here is what i have set now:

    External port = 1123 ( unchanged )
    Internal port = 1123 ( changed , was port 80 set to match tivoweb.cfg )

    And changed the port in tivoweb.cfg from port 80 to 1123.

    If i did this right then it didn't work . I noticed sometimes when i use my dyndns address that links to my pc i get a configuration screen that i believe is from my isp.

    Login screen Main Page Dynamic DNS Status Page


    ATTEN : Unclemoosh check your PM

    By the way I also tried using DynSite ver 1.12 as i think i remember i used an application
    like that before my TiVo's HDD died. If i understand this right , a dynamic dns host at dyndns.org points to my WAN IP address and when that address goes into a browser it
    directs the visitor to my TiVo and the router or DynSite then directs that traffic to the correct port there by running TWP. ??

    I have DynSite shutdown at the moment and i'm relying on the Linksys router. I use one or the other .
     
  10. Oct 7, 2011 #11830 of 11850
    rpweaver

    rpweaver New Member

    23
    0
    Sep 28, 2010
    Hey, look at that, how did I miss it. Maybe I'm mixing it up with another forum... Maybe I just don't see everything all the time. :eek:

    Just made a 6.4a Zipper CD and am about to try it, Wish me luck.

    ...

    Nope, stuck in a boot loop.

    ...

    Had to remove the network HW to get it to boot. Then ran sh tweak.sh with the serial line. Reconnected the network HW. Seems DHCP is now working (copied dhclient from 6.2). No time to test now, will test later.
     
  11. Oct 7, 2011 #11831 of 11850
    Phe0nix

    Phe0nix New Member

    69
    0
    Nov 17, 2005
    We'll I have my TiVo Web Plus running from the WAN side of the modem now , it was already running from the LAN side so that told me my router was setup correctly and that the WAN traffic was stopping at the modem and not being sent to the router. My Linksys status page reported my internet IP address
    as a private IP ( 192.168.2.2 ) so any requests coming in even though on the correct port ( that set in tivoweb.cfg ) were ignored as they never made it through the modem.

    I went into the Modem's configuration interface by putting in either my http://mydomainname.dyndns.org or by entering my WAN IP address into
    the browser and under advanced I clicked on WAN > WAN Setup and
    in there i noticed that same IP I saw in the router , the private IP of 192.168.2.2 and that the modem was functioning as a DHCP server and firewall.

    On my routers status page my internet IP should have been the same as my
    WAN IP but it was not. The DHCP in my modem started assigning IP's from
    192.168.2.2 from ... get this an IP client pool of 32 and there is only one ethernet port on the modem so where the other 31 IP's were going to go is and will always be a mystery. Simply disabling the DHCP server will do no good. The modem has it's own IP address,DHCP Server and Firewall and the IP is simply for your ISP to be able to troubleshoot and send any updates to your modem.

    If you have this problem you will need to access your modem's configuration page as you would your routers but with your public IP. If you can do this at all then this IS your problem if you have your port forwarded to your TiVo's IP. Go into the diagnostics page in the modem and click the button to release your IP then click the BRIDGE button and the apply and exit . Now your ISP won't be able to access your modem for trouble shooting anymore
    because your modem is acting as a pass through and has no IP address anymore and go back into your routers status page and do the same, release your IP and then renew your IP and your private IP will now be a public one.

    The modem connects to your wall jack via a phone line and this is called a
    ATM and it then passes through the modem to the ethernet port where this signal is converted into a digital signal hence the term BRIGE. The modem now creates a bridge between the internet and your router.. Problem solved. :cool:

    :up: I must thank unclemoosh for all the time and effort he has put into helping me. He has went beyond the extra mile. If it were not for him confirming I wasn't experiencing the LOOP your hear about, and attempting to access the TiVo remotely from his end I never would have narrowed it down to the modem and would still be focused on the router. I must also say he has located my routers owners manual and read it made suggestions for tivoweb.cfg and even made edits to his file and sent it to me.
    Many thanks for your assistance you kept me troubleshooting and i'm sure i'll get many hours of enjoyment out of my TiVo now. :up:

    Update :

    Wish i would have found this when i was having so much trouble. After you know
    what the problem is information is allot easier to come by I suppose. Here is a
    tutorial with pics for my Sprint/Embarq/Centurylink DSL modem.

    Here is another article for AT&T modems.
     
  12. Oct 8, 2011 #11832 of 11850
    Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    I'll try to give you a hand but I used SApper since I have a stand alone Tivo.

    If Zipper is like SApper you don't need an image. If you don't include an image it will hack the drive as is.

    Custom kernels are built from scratch and don't need initrd killed. That's the point of the custom kernel. You only kill intrird on stock kernels.

    The S2DT had a network adapter installed and SApper added some backport drivers but my network adapter worked after SApper. What kind of adapter do you have?
     
  13. Oct 8, 2011 #11833 of 11850
    Jeff_in_Bklyn

    Jeff_in_Bklyn Member

    185
    0
    Apr 26, 2003
  14. Oct 8, 2011 #11834 of 11850
    unclemoosh

    unclemoosh I Wish I knew Then..

    368
    0
    Sep 11, 2004
    Gulf South
    I used ones that look like that on my HDVR2's with success. I bought them on fleaBay for about that or a little less.
     
  15. Oct 8, 2011 #11835 of 11850
    Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    Can't beat that price. Noting ventured nothing gained when I see a price like that.
     
  16. Oct 9, 2011 #11836 of 11850
    qwertypo

    qwertypo New Member

    45
    0
    Dec 5, 2005
    My G5 Tiger system with TivoTool died... I've upgraded to a system that has Snow Leopard and Tiger... any options for extraction for me? Or do I need to bootcamp and extract in Windows. What are the best windows options?

    Thanks for the years of support!
     
  17. Oct 14, 2011 #11837 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Let me know if you are successful with this particular adapter. I've had mixed luck with different brands of adapters. I posted my results somewhere on TCF.
     
  18. Oct 23, 2011 #11838 of 11850
    PanamaYellow

    PanamaYellow New Member

    19
    0
    Oct 8, 2004
    I have a Series2 hacked using the Zipper. Every day, I get an error message when arriving at 'Now Playing' that says there are SMART error messages in the kernel log file. The details of the supposed error messages have them all occurring on the first day I installed the drive. (it's a new Western Digital 500 GB AV-GP SATA A/V drive)

    Testing the drive with smartctl gives no errors, reports a healthy drive.

    I attempted to clear the kernel log file by deleting /var/log/kernel and then restarting the DTiVo. Looking at /var/log/kernel in VI shows no such messages.

    I'm still seeing the messages.

    Is there someplace else that these error messages are written to?

    Thank you,

    PanamaYellow
     
  19. Oct 26, 2011 #11839 of 11850
    rpweaver

    rpweaver New Member

    23
    0
    Sep 28, 2010
    Just figured out my problem. This only appears if you are logged in. Folks browsing and Googling do not get his option unless or until logged in.
     
  20. Oct 26, 2011 #11840 of 11850
    rpweaver

    rpweaver New Member

    23
    0
    Sep 28, 2010
    Update:
    Not all 6.4a images work with the Zipper.The image that worked for me was saved from a failing DVR80. The minimal 6.4a image available on the web doesn't (6.4a-01-2-101-minimal.mfs). When I use that image, networking doesn't work and /enhancements is gone. Plug in the LinkSYS USB200M adaptor results in Kernel Panic. Without Zipper, the lights light up and blink but I don't know anything else without serial access. Frustrating!
    The reason I did this is that DVR Service was not active and I had to call in to get it Active. Is there another way? Network connection didn't work either. The hacked 6.4a would not connect, unhacked it does. I switched images to be able to save a copy after every success and not take up too much disk space. Now I can't get a Zippered image to work. Is the minimal 6.4a image broken? Is ther a way to get it to work with Zipper?
     

Share This Page