1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hacking your Series 2 DTivo just got a WHOLE lot easier...

Discussion in 'TiVo Underground' started by Gunnyman, Oct 16, 2005.

  1. Nov 13, 2005 #941 of 11850
    texster

    texster New Member

    137
    0
    Mar 10, 2005
    Connecticut
    After five days of zipper bliss, I screwed the pooch - after creating a new subdirectory /var / hack, placing a certain server file in it, I lost networking - usb is powered, but no link (using fa 120).

    I have been monkeying with hyperterminal and a serial cable to see if I can get bash prompt. No joy as of yet. But assuming I can get in - can I remove the offending files and or rerun the zipper files. Or does this sort of thing require pulling the drive and starting over w/ide?
     
  2. Nov 13, 2005 #942 of 11850
    mightyb

    mightyb Tivolutionized!!

    236
    0
    Dec 5, 2003
    Gilbert, AZ

    HA! Once I get the MRV running on our current two, there will be no stopping a 3rd!!! :-D
     
  3. Nov 13, 2005 #943 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    30,825
    28
    Jul 10, 2003
    !Texas
    that depends on what happened. You can try to just rezipper with the HD in your PC if you can't get serial bash, without a re-image and see if just recreating the authorfile fixes things. If not, its re-image time.
     
  4. Nov 13, 2005 #944 of 11850
    owlhooter

    owlhooter New Member

    40
    0
    May 29, 2005

    Oh you mean you have to subscribe to Caller ID? /sarcasm.. I realize that since I didn't specify before there is no way for you to know that yes I do indeed have caller ID service on the line. And when testing NCID in Debug mode it comes up with this:

    RING
    CIDINFO: *LINE*-*RING*1*




    RING
    CIDINFO: *LINE*-*RING*2*




    RING
    CIDINFO: *LINE*-*RING*3*


    CIDINFO: *LINE*-*RING*0*


    Then the cidcall.log file shows this text

    MSG: Started 11/13/2005 20:06
    MSG: Terminated 11/13/2005 20:08



    So it appears that NCID isn't picking up the Caller ID information for some reason or another. It's doing the same on both of my HDVR2's. I was just assuming that maybe the modem in it for whatever reason wasn't CID capable.. But could never find anything saying that, and all I could find is that it should work. But after hours of working with it I still have been unable to get it to pick up the CID info, yet all my phones can pick it up fine.
     
  5. Nov 13, 2005 #945 of 11850
    WhyMe

    WhyMe New Member

    189
    0
    Jul 11, 2005
    I do have caller id on the home phone, what command do I use to look at the ncid.log? Thanks
     
  6. Nov 13, 2005 #946 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    NCID questions are beyond the scope of this thread, which should be reserved for asking questions specifically about the Zipper. It's hard enough for new users to read this thread for Zipper support, without diluting it even further. You'll get more exposure to your questions by starting a new thread in the underground forum. Another alternative is, dare I say?, the search button?
     
  7. Nov 13, 2005 #947 of 11850
    owlhooter

    owlhooter New Member

    40
    0
    May 29, 2005
    I agree, don't want to get this thread too off topic. I have tried the search button but to no avail so I'll go ahead and make a new thread for it. I do want to say that you have done a great job with your scripts, I hacked my 2 pre Zipper but used your enhancement script afterwards.

    Thanks for all your hard work on these to make things easier for the rest of us..
     
  8. Nov 13, 2005 #948 of 11850
    trplblacksnake

    trplblacksnake New Member

    21
    0
    Jul 6, 2005
    Im getting an error while trying to ftp the tweak over to my tivo. Im using filezilla in binary mode. but it comes up as critical transfer error.
     
  9. Nov 13, 2005 #949 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    30,825
    28
    Jul 10, 2003
    !Texas
    snake..
    tweak.sh is already on your tivo
    telnet to th etivo and run it per instructions.
     
  10. Nov 13, 2005 #950 of 11850
    kmclaren

    kmclaren New Member

    2
    0
    Nov 13, 2005
    Hey Guys. Thanks for a great process that is the easiest yet.

    I have just tried the zipper about 100 times and have had no success getting connected to the Tivo after installing the drive. I'm using a Belkin F5D5050 10/100 USB adapter. All the other processes I have used do not light up the activity lights on this thing, but Zipper does show activity.

    However, I cannot Telnet to the machine. After I run zipper using a Cake image the thing pings for about the first minute and then I am unable to ping either. If I sniff the connection, I can see occasional packets coming from the adapter going to port 2190 which appears to be the Tivo broadcast port. However, nothing else works. I also noted that ARP packets come back with a MAC of 00000000 for the IP address of the Tivo. Adding a manual entry in the ARP cache on the PC does not seem to help.

    Anyone have any thoughts on this? I'm thinking that the Belkin adapter may not be a good choice for this application. (I did test on a PC and it does work)

    If I do buy another adapter, is there on that is known to work well?

    Thanks in advance for your help.

    - Keith
     
  11. Nov 13, 2005 #951 of 11850
    clambert11

    clambert11 TV Junkie

    22
    0
    Nov 1, 2005
    East Coast, USA
    I used the same Belkin this weekend when setting up the 3 units I just hacked connected to a Linksys WRT54G.

    What I did notice is that for some reason it didn't use the static IP I initially setup within Zipper. It allowed the router to assign a DHCP IP for some strange reason. I telnetted into the dynamic IP and ran rbautch's script. After that I entered the network settings again and it did indeed make it static.

    All 3 units did the same thing. It's quite possible I made the same mistake 3 times as well. :) At any rate, I figured it out and was able to get things working.

    It doesn't sound like the exact same issue, but you might check it out anyway.

    -- Craig
     
  12. Nov 13, 2005 #952 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Netgear FA-120 is one of the more poplular adapters known to work.
     
  13. Nov 13, 2005 #953 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    If you don't mind, try a test with the latest version 1.3.1 of the Zipper to see if that fixes your issue.
     
  14. Nov 14, 2005 #954 of 11850
    tivoenthused

    tivoenthused New Member

    35
    0
    Sep 21, 2003
    Portland, OR
    Gunny + RBautch

    I was all zippered up for about 2 weeks there. HMO, MRV, etc we're all working beautifully.

    Then for some reason, TiVo Server and TiVo Desktop 2.2 wouldn't start up correctly on my PC. I uninstalled and reinstalled the TiVo desktop software (including manually deleting the common files/tivo folder). When I attempted to reinstall TiVo desktop 2.2, I got the "internal error occurred" message during the "deleting backups" portion of the software install. The install delayed and eventually completed, but now I can't even get TiVo desktop or TivoServer to open.... still getting the "internal error occurred". The network is still up (FTP, MRV, and TivoWeb are all still functional).

    I tried to revert back to TiVo desktop 1.3, but kept getting error messages about how the TiVo Beacon was unavailable (even though it clearly was functioning in the windows task mgr processes report).

    3 questions
    - are there any known issues with the Zipper and TiVo's desktop software
    - is there another method of publishing photos + music to my TiVos without using TiVo Desktop publisher?
    - have any idea where I have gone wrong?

    thanks,

    JL
     
  15. Nov 14, 2005 #955 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    30,825
    28
    Jul 10, 2003
    !Texas
    1) no I've been using tivodesktop for nearly a year (and the zipper is just an automated method for how my systems are hacked)
    2) check out javahmo at javahmo.sourceforge.org
    3) any firewall between you and teh tivo?
     
  16. Nov 14, 2005 #956 of 11850
    adtpete

    adtpete New Member

    1
    0
    Jul 24, 2004
    CT
    Ok, being an FNG to the tivo board, I have a stupid question. My tivo series 2 just started clicking, with the shows slowing and stopping, and on power down reboot, hanging on the tivo restarting screen. Figure the hard drive is dead, and want to replace it rather than hassle with new unit. Just dll the mfstools2.iso. Once I get inside the box, is it really as simple as just rtfi on here? Familiar with pc's and have heard numerous times that hard drive replace/upgrade is simple, but, the oh will beat me if i waste to much time and she can't watch "her" tivo.
    Thanks in advance :)
     
  17. Nov 14, 2005 #957 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    30,825
    28
    Jul 10, 2003
    !Texas
    it's simple if you want to just start fresh with a new HD and no shows.
    Saving shows on a dying HD is tricky.
    Oh and this thread isn't about that.
    Please create a new one. Thanks
     
  18. Nov 14, 2005 #958 of 11850
    trplblacksnake

    trplblacksnake New Member

    21
    0
    Jul 6, 2005
    Ok Ive got everything up and running after making another trip to Staples and getting a different usb 2.0 adapter. I purchased 2 linksys usb200ms one was a V1 the other a V2. Appearantly the drivers arent the same. I hooked the v2 to my laptop and it wouldnt auto load the drivers either. Note dont get the smaller looking usb200m. Now the only problem Im having is getting mrv to work right. I go into my now playing list and it shows all of my recorded programs If I sort the list it wont show my other tivo but if I dont sort the list (no folders and sorted by date instead of alphabetical) it works just fine. Im trying to get tivoweb plus to work now too. Any guides or how tos for twp.
     
  19. Nov 14, 2005 #959 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    30,825
    28
    Jul 10, 2003
    !Texas
    I have my folders turned on and sorted alphabetically and my mrv tivo shows up in the bottom of the list after suggestions.
    for tivowebplus, just put the ip address of your tivo in your browser's address bar.
     
  20. Nov 14, 2005 #960 of 11850
    rmasonjr

    rmasonjr New Member

    19
    0
    Sep 3, 2002
    Hi!
    Sorry for jumping in, but I do have a question. I'm about to take the leap and upgrade both my Tivos and use the Zipper. When I went to get InstantCake, the version says 3.1.1e - I'm running 6.2-01-2-151 I'm assuming the 3.1.1e is the kernel version - correct?
    Thanks!
    Rob
     

Share This Page